Skip to content

Commit

Permalink
Framework: partially sync with upstream
Browse files Browse the repository at this point in the history
Taken from: FreeBSD
  • Loading branch information
fichtner committed Nov 15, 2021
1 parent d8d7d00 commit 3932a1d
Show file tree
Hide file tree
Showing 4 changed files with 69 additions and 2 deletions.
4 changes: 3 additions & 1 deletion Keywords/sample.ucl
Original file line number Diff line number Diff line change
Expand Up @@ -64,6 +64,8 @@ pre-deinstall-lua: <<EOS
if pkg.filecmp(sample_file, target_file) == 0 then
os.remove(target_file)
else
pkg.print_msg("You may need to manually remove " .. target_file .. " if it is no longer needed.")
if not pkg.pkg_upgrade then
pkg.print_msg("You may need to manually remove " .. target_file .. " if it is no longer needed.")
end
end
EOS
2 changes: 1 addition & 1 deletion Mk/Uses/kde.mk
Original file line number Diff line number Diff line change
Expand Up @@ -79,7 +79,7 @@ KDE_PLASMA_VERSION?= 5.23.3
KDE_PLASMA_BRANCH?= stable

# Current KDE frameworks.
KDE_FRAMEWORKS_VERSION?= 5.87.0
KDE_FRAMEWORKS_VERSION?= 5.88.0
KDE_FRAMEWORKS_BRANCH?= stable

# Current KDE applications.
Expand Down
3 changes: 3 additions & 0 deletions Tools/scripts/README
Original file line number Diff line number Diff line change
Expand Up @@ -42,6 +42,9 @@ tindex - script used to build INDEXes for supported FreeBSD branches, which
failure reports on [email protected]
update-patches - generates updated patches.

update_crates - script used to generate an updated Makefile using make cargo-crates
output

----------------------------------------------------------------------

gnomedepends is a script, which analyses pkg/PLIST and gives an advice as to
Expand Down
62 changes: 62 additions & 0 deletions Tools/scripts/update_crates
Original file line number Diff line number Diff line change
@@ -0,0 +1,62 @@
#!/bin/sh
# Copyright (c) 2021 Rodrigo Osorio
# All rights reserved.
#
# Redistribution and use in source and binary forms, with or without
# modification, are permitted provided that the following conditions
# are met:
# 1. Redistributions of source code must retain the above copyright
# notice, this list of conditions and the following disclaimer.
# 2. Redistributions in binary form must reproduce the above copyright
# notice, this list of conditions and the following disclaimer in the
# documentation and/or other materials provided with the distribution.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR AND CONTRIBUTORS ``AS IS'' AND
# ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
# IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
# ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE
# FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
# DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
# OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
# HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
# LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
# OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
# SUCH DAMAGE.
#
# MAINTAINER= [email protected]
#

usage() {
echo "usage: update_crates <makefile>"
echo
exit 1
}

if [ "$#" -ne 1 ]; then
usage
exit 1
fi

newcrates() {
while IFS= read -r nline
do
echo "$nline"
done < "/dev/stdin"
}

infile=$1
incrates=0
while IFS= read -r line <&3
do
match=$(echo "${line}" | grep "^CARGO_CRATES=")
[ -n "${match}" ] && incrates=1
if [ "${incrates}" -eq 1 ]; then
if [ -z "$line" ]; then
incrates=0
newcrates
echo "$line"
fi
else
echo "${line}"
fi
done 3< "$infile"

0 comments on commit 3932a1d

Please sign in to comment.