Skip to content

Commit

Permalink
Framework: partially sync with upstream
Browse files Browse the repository at this point in the history
Taken from: FreeBSD
  • Loading branch information
fichtner committed Dec 13, 2021
1 parent 934f90e commit 7108822
Show file tree
Hide file tree
Showing 5 changed files with 141 additions and 1 deletion.
23 changes: 23 additions & 0 deletions CHANGES
Original file line number Diff line number Diff line change
Expand Up @@ -10,6 +10,29 @@ in the release notes and/or placed into UPDATING.

All ports committers are allowed to commit to this file.

20211211:
AUTHOR: [email protected]

A new USES has been added to depend on ImageMagick.

USES=magick

adds a LIB_DEPENDS on graphics/ImageMagick${IMAGEMAGICK_DEFAULT}.

If a specific version is required, use for example

USES=magick:6 resp. USES=magick:7

If only a build, run or test is required, use for example

USES=magick:build resp. USES=magick:6,build,test

If a dependency on the nox11 flavor is required, use for example

USES=magick:nox11 resp. USES=magick:7,nox11,run,test

See magick.mk for more details on the available flags.

20211122:
AUTHOR: [email protected]

Expand Down
1 change: 1 addition & 0 deletions MOVED
Original file line number Diff line number Diff line change
Expand Up @@ -16612,3 +16612,4 @@ sysutils/bareos17-client-static||2021-12-05|Has expired: Deprecated, no new rele
sysutils/bareos17-server|sysutils/bareos18-server|2021-12-05|Has expired: Deprecated, no new release since 2020
www/bareos17-webui|www/bareos18-webui|2021-12-05|Has expired: Deprecated, no new release since 2020
math/eigen2||2021-12-07|Has expired: No longer available upstream, no consumers in ports
emulators/qemu41||2021-12-10|Has expired: Use emulators/qemu or emulators/qemu-devel
9 changes: 9 additions & 0 deletions Mk/Scripts/qa.sh
Original file line number Diff line number Diff line change
Expand Up @@ -597,6 +597,15 @@ proxydeps_suggest_uses() {
# lua
elif expr ${pkg} : "^lang/lua" > /dev/null; then
warn "you need USES+=lua"
# magick
elif [ ${pkg} = "graphics/ImageMagick6" ] ; then
warn "you need USES=magick:6"
elif [ ${pkg} = "graphics/ImageMagick6-nox11" ] ; then
warn "you need USES=magick:6,nox11"
elif [ ${pkg} = "graphics/ImageMagick7" ] ; then
warn "you need USES=magick:7"
elif [ ${pkg} = "graphics/ImageMagick7-nox11" ] ; then
warn "you need USES=magick:7,nox11"
# motif
elif [ ${pkg} = "x11-toolkits/lesstif" -o ${pkg} = "x11-toolkits/open-motif" ]; then
warn "you need USES+=motif"
Expand Down
93 changes: 93 additions & 0 deletions Mk/Uses/magick.mk
Original file line number Diff line number Diff line change
@@ -0,0 +1,93 @@
# Handle dependency on ImageMagick
#
# Feature: magick
# Usage: USES=magick:ARGS
# Valid ARGS: [version],[kinds],[flavor]
#
# version The chooseable versions are <none>, 6 and 7.
# USES=magick -- depend on ${IMAGEMAGICK_DEFAULT} (default)
# USES=magick:6 -- depend on ImageMagick6
# USES=magick:7 -- depend on ImageMagick7
#
# flavor The flavors are <none> and nox11
# USES=magick -- depend on the default flavor (default)
# USES=magick:nox11 -- depend on the nox11 flavor
#
# kinds The dependency kinds are <none>, lib, build, run and test
# USES=magick -- add a LIB_DEPENDS (default)
# USES=magick:lib -- add a LIB_DEPENDS
# USES=magick:build -- add a BUILD_DEPENDS
# USES=magick:run -- add a RUN_DEPENDS
# USES=magick:test -- add a TEST_DEPENDS
# USES=build,run -- add a BUILD_- and RUN_DEPENDS
#
# In short, on a default ports tree
# USES=magick
# is equivalent to
# USES=magick:7,lib
#
# MAINTAINER: [email protected]
#

.if ! defined(_INCLUDE_USES_MAGICK_MK)
_INCLUDE_USES_MAGICK_MK= YES

#=== Version selection ===
_magick_versions= 6 7

_magick_version= #
. for _ver in ${_magick_versions:O:u}
. if ${magick_ARGS:M${_ver}}
. if empty(_magick_version)
_magick_version= ${_ver}
. else
IGNORE= Incorrect USES=magick:${magick_ARGS} - multiple versions defined
. endif
. endif
. endfor
# Fallback to the default version
.if empty(_magick_version)
_magick_version= ${IMAGEMAGICK_DEFAULT}
.endif

#=== Flavor selection ===
_magick_flavors= nox11
_magick_flavor= #
. for _flavor in ${_magick_flavors:O:u}
. if ${magick_ARGS:M${_flavor}}
. if empty(_magick_flavor)
_magick_flavor= -${_flavor}
. else
IGNORE= Incorrect USES=magick:${magick_ARGS} - multiple flavors defined
. endif
. endif
. endfor

#=== Dependeny selection ===
_magick_depends= lib build run test
_magick_depend= #
. for _depend in ${_magick_depends:O:u}
. if ${magick_ARGS:M${_depend}}
_magick_depend+= ${_depend}
. endif
. endfor
.if empty(_magick_depend)
_magick_depend= lib
.endif

#=== Dependency setup ===
_MAGICK_PORT= graphics/ImageMagick${_magick_version}${_magick_flavor}
_MAGICK_LIB= libMagick++-${_magick_version}.so
_MAGICK_PKG= ImageMagick${_magick_version}${_magick_flavor}

_MAGICK_BUILD_DEPENDS= ${_MAGICK_PKG}>=${_magick_version}:${_MAGICK_PORT}
_MAGICK_LIB_DEPENDS= ${_MAGICK_LIB}:${_MAGICK_PORT}
_MAGICK_RUN_DEPENDS= ${_MAGICK_PKG}>=${_magick_version}:${_MAGICK_PORT}
_MAGICK_TEST_DEPENDS= ${_MAGICK_PKG}>=${_magick_version}:${_MAGICK_PORT}

#=== Actual dependency creation ===
. for _kind in ${_magick_depend}
${_kind:tu}_DEPENDS+= ${_MAGICK_${_kind:tu}_DEPENDS}
. endfor

.endif
16 changes: 15 additions & 1 deletion UPDATING
Original file line number Diff line number Diff line change
Expand Up @@ -5,7 +5,21 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.

20201116:
20211213:
AFFECTS: users of emulators/qemu-utils
AUTHOR: [email protected]

New port emulators/qemu@tools has been introduced which is similar to
emulators/qemu-utils. qemu-utils has also been DEPRECATED in favor for
this as it's MASTER port has also been marked DEPRECATED and set to
expire on 2022-01-09. For updating to qemu-tools please use one of
the following command:

# pkg install qemu-tools
or
# portmaster -o emulators/qemu-utils emulators/qemu@tools

20211116:
AFFECTS: users of emulators/qemu50
AUTHOR: [email protected]

Expand Down

0 comments on commit 7108822

Please sign in to comment.