Skip to content

Commit

Permalink
*/*: sync with upstream
Browse files Browse the repository at this point in the history
Taken from: HardenedBSD
  • Loading branch information
fichtner committed Jul 6, 2017
1 parent 431c1d1 commit 71f67c4
Show file tree
Hide file tree
Showing 90 changed files with 774 additions and 237 deletions.
8 changes: 7 additions & 1 deletion benchmarks/dbs/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -11,6 +11,8 @@ MASTER_SITES= http://www.kusa.ac.jp/~yukio-m/dbs/software1.1.5/ \
MAINTAINER= [email protected]
COMMENT= Distributed network benchmarking system

LICENSE= BSD3CLAUSE

RUN_DEPENDS= gnuplot:math/gnuplot

BROKEN_FreeBSD_12= tcp_debug.h: field has incomplete type 'struct tcpcb'
Expand All @@ -29,7 +31,7 @@ PORTEXAMPLES= *
OPTIONS_DEFINE= DOCS EXAMPLES

pre-build:
cd ${WRKSRC}/src; ${MAKE} dir
cd ${WRKSRC}/src && ${MAKE_CMD} dir

do-install:
.for bin in dbsc dbsd
Expand All @@ -38,10 +40,14 @@ do-install:
.for bin in dbs_view
${INSTALL_SCRIPT} ${WRKSRC}/script/${bin} ${STAGEDIR}${PREFIX}/bin
.endfor

do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for doc in Copyright dbs.man dbs.man.jis dbs_paper.ps
${INSTALL_DATA} ${WRKSRC}/doc/${doc} ${STAGEDIR}${DOCSDIR}
.endfor

do-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
.for ex in TCP2.cmd TCPvsMPEG.cmd
${INSTALL_DATA} ${WRKSRC}/sample/${ex} ${STAGEDIR}${EXAMPLESDIR}
Expand Down
6 changes: 4 additions & 2 deletions benchmarks/stream/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -11,8 +11,6 @@ DIST_SUBDIR= ${PORTNAME}-1.0/${PORTVERSION}
MAINTAINER= [email protected]
COMMENT= Synthetic benchmark program that measures sustainable memory bandwidth

OPTIONS_DEFINE= DOCS

NO_WRKSUBDIR= yes

EXTRACT_CMD= ${CP}
Expand All @@ -22,11 +20,15 @@ EXTRACT_AFTER_ARGS= ${WRKSRC}
PORTDOCS= stream.c
PLIST_FILES= bin/stream_bench

OPTIONS_DEFINE= DOCS

do-build:
(cd ${WRKSRC} && ${CC} ${CFLAGS} -o stream_bench stream.c -lm)

do-install:
(cd ${WRKSRC} && ${INSTALL_PROGRAM} stream_bench ${STAGEDIR}${PREFIX}/bin)

do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
(cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR})

Expand Down
13 changes: 9 additions & 4 deletions benchmarks/webbench/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -9,18 +9,23 @@ MASTER_SITES= SUNSITE/apps/www/servers
MAINTAINER= [email protected]
COMMENT= Simple forking web benchmark

MAKE_ARGS+= CFLAGS="${CPPFLAGS} ${CFLAGS}"
LICENSE= GPLv2

PORTDOCS= copyright changelog
MAKE_ARGS= CFLAGS="${CPPFLAGS} ${CFLAGS}"

PORTDOCS= ChangeLog

PLIST_FILES= bin/webbench \
man/man1/webbench.1.gz

OPTIONS_DEFINE= DOCS

do-install:
${INSTALL_PROGRAM} ${WRKSRC}/webbench ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/webbench.1 ${STAGEDIR}${MAN1PREFIX}/man/man1

do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/debian/copyright ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/debian/changelog ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/ChangeLog ${STAGEDIR}${DOCSDIR}

.include <bsd.port.mk>
2 changes: 2 additions & 0 deletions databases/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -579,6 +579,7 @@
SUBDIR += pgbouncer
SUBDIR += pgdbf
SUBDIR += pgespresso
SUBDIR += pgFormatter
SUBDIR += pgfouine
SUBDIR += pgloader
SUBDIR += pglogical
Expand Down Expand Up @@ -649,6 +650,7 @@
SUBDIR += phpmyadmin
SUBDIR += phppgadmin
SUBDIR += pldebugger
SUBDIR += plpgsql_check
SUBDIR += postgis-jdbc
SUBDIR += postgis20
SUBDIR += postgis21
Expand Down
20 changes: 20 additions & 0 deletions databases/pgFormatter/Makefile
Original file line number Diff line number Diff line change
@@ -0,0 +1,20 @@
# Created by: Jov [email protected]
# $FreeBSD$

PORTNAME= pgFormatter
PORTVERSION= 2.0
DISTVERSIONPREFIX= v
CATEGORIES= databases

MAINTAINER= [email protected]
COMMENT= PostgreSQL SQL syntax beautifier

LICENSE= PostgreSQL
LICENSE_FILE= ${WRKSRC}/LICENSE

USES= perl5
USE_PERL5= configure
USE_GITHUB= yes
GH_ACCOUNT= darold

.include <bsd.port.mk>
3 changes: 3 additions & 0 deletions databases/pgFormatter/distinfo
Original file line number Diff line number Diff line change
@@ -0,0 +1,3 @@
TIMESTAMP = 1496217380
SHA256 (darold-pgFormatter-v2.0_GH0.tar.gz) = ef2f7bc124a694c0384b6bda661582ad2dae7c25b289aba596a23fb17dd5f130
SIZE (darold-pgFormatter-v2.0_GH0.tar.gz) = 52674
8 changes: 8 additions & 0 deletions databases/pgFormatter/pkg-descr
Original file line number Diff line number Diff line change
@@ -0,0 +1,8 @@
This SQL formatter/beautifier supports keywords from SQL-92, SQL-99,
SQL-2003, SQL-2008, SQL-2011 and PostgreSQL specifics keywords. May
works with any other databases too. pgFormatter can work as a console
program or as a CGI. It will automatically detect his environment and
output as text or as HTML following the context. Keywords highlighting
will only be available in CGI context.

WWW: https://github.com/darold/pgFormatter
9 changes: 9 additions & 0 deletions databases/pgFormatter/pkg-plist
Original file line number Diff line number Diff line change
@@ -0,0 +1,9 @@
bin/pg_format
%%PERL5_MAN1%%/pg_format.1.gz
%%PERL5_MAN3%%/pgFormatter::Beautify.3.gz
%%PERL5_MAN3%%/pgFormatter::CGI.3.gz
%%PERL5_MAN3%%/pgFormatter::CLI.3.gz
%%SITE_PERL%%/pgFormatter/Beautify.pm
%%SITE_PERL%%/pgFormatter/CGI.pm
%%SITE_PERL%%/pgFormatter/CLI.pm
%%SITE_PERL%%/regress_test.pl
30 changes: 30 additions & 0 deletions databases/plpgsql_check/Makefile
Original file line number Diff line number Diff line change
@@ -0,0 +1,30 @@
# Created by: Jov <[email protected]>
# $FreeBSD$

PORTNAME= plpgsql_check
PORTVERSION= 1.2.0
DISTVERSIONPREFIX= v
CATEGORIES= databases
PKGNAMEPREFIX= postgresql${PGSQL_VER:S/.//}-

MAINTAINER= [email protected]
COMMENT= PostgreSQL extension to check PL/pgSQL code

LICENSE= UNKNOWN
LICENSE_NAME= postcardware
LICENSE_TEXT= If you like it - send a postcard to address: \
Pavel Stehule \
Skalice 12 \
Benesov u Prahy \
256 01 \
Czech Republic \
Use this code freely on own risk
LICENSE_PERMS= dist-mirror pkg-mirror dist-sell pkg-sell auto-accept

USES= gmake pgsql:9.2+
USE_GITHUB= yes
GH_ACCOUNT= okbob

WANT_PGSQL= server

.include <bsd.port.mk>
3 changes: 3 additions & 0 deletions databases/plpgsql_check/distinfo
Original file line number Diff line number Diff line change
@@ -0,0 +1,3 @@
TIMESTAMP = 1496223426
SHA256 (okbob-plpgsql_check-v1.2.0_GH0.tar.gz) = 370be67e557e91936f05c3697629ce45f1a7855d668359dc147d7fbf125dfcf5
SIZE (okbob-plpgsql_check-v1.2.0_GH0.tar.gz) = 62269
7 changes: 7 additions & 0 deletions databases/plpgsql_check/pkg-descr
Original file line number Diff line number Diff line change
@@ -0,0 +1,7 @@
Plpgsql_check is next generation of plpgsql_lint. It allows to check source
code by explicit call plpgsql_check_function. The SQL statements inside
PL/pgSQL functions are checked by validator for semantic errors. These errors
can be found by plpgsql_check_function. PostgreSQL 9.2 is required, PostgreSQL
9.3, 9.4, 9.5, 9.6 and 10 are supported.

WWW: https://github.com/okbob/plpgsql_check
7 changes: 7 additions & 0 deletions databases/plpgsql_check/pkg-plist
Original file line number Diff line number Diff line change
@@ -0,0 +1,7 @@
lib/postgresql/plpgsql_check.so
share/postgresql/extension/plpgsql_check--1.0--1.1.sql
share/postgresql/extension/plpgsql_check--1.0.sql
share/postgresql/extension/plpgsql_check--1.1--1.2.sql
share/postgresql/extension/plpgsql_check--1.1.sql
share/postgresql/extension/plpgsql_check--1.2.sql
share/postgresql/extension/plpgsql_check.control
2 changes: 1 addition & 1 deletion databases/timescaledb/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -16,7 +16,7 @@ GH_ACCOUNT= timescale
MAKE_ARGS= PG_CONFIG=${LOCALBASE}/bin/pg_config USE_PGXS=1 \
install_bin=/usr/bin/install
USE_LDCONFIG= yes
USES= gmake pgsql:9.6
USES= compiler:c11 gmake pgsql:9.6

PLIST_FILES= lib/postgresql/timescaledb.so \
share/postgresql/extension/timescaledb--0.1.0.sql \
Expand Down
1 change: 1 addition & 0 deletions devel/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -339,6 +339,7 @@
SUBDIR += cpp-hocon
SUBDIR += cpp-netlib
SUBDIR += cppcheck
SUBDIR += cppcheck-gui
SUBDIR += cppi
SUBDIR += cpprestsdk
SUBDIR += cpptest
Expand Down
7 changes: 4 additions & 3 deletions devel/ccache/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -3,15 +3,16 @@

PORTNAME= ccache
PORTVERSION= 3.3.4
PORTREVISION= 3
PORTREVISION= 4
CATEGORIES= devel
MASTER_SITES= http://www.samba.org/ftp/ccache/ \
LOCAL/bdrewery

MAINTAINER= [email protected]
COMMENT= Tool to minimize the compile time of C/C++ programs

LICENSE= GPLv3
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/GPL-3.0.txt

CONFLICTS_INSTALL= ccache-static-[0-9]* ccache-memcached-[0-9]* ccache-memcached-static-[0-9]*

Expand Down Expand Up @@ -75,7 +76,7 @@ PLIST_SUB+= CCLINKDIR="${CCLINKDIR}"
CCACHE_COMPILERS+= icc icpc
.endif

GNU_COMPILERS+= 34 42 43 44 45 46 47 48 49 5 6 7
GNU_COMPILERS+= 34 42 43 44 45 46 47 48 49 5 6 7 8
CCACHE_COMPILERS+= cc c++ CC gcc g++ ${GNU_COMPILERS:S|^|gcc|} ${GNU_COMPILERS:S|^|g++|}

.if ${PORT_OPTIONS:MCLANGLINK}
Expand Down
3 changes: 2 additions & 1 deletion devel/codesearch-py/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -3,6 +3,7 @@

PORTNAME= codesearch-py
PORTVERSION= 0.1
PORTREVISION= 1
CATEGORIES= devel python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}

Expand All @@ -17,7 +18,7 @@ USE_PYTHON= autoplist concurrent distutils

USE_GITHUB= yes
GH_ACCOUNT= chromium
GH_TAGNAME= ec3ad68
GH_TAGNAME= 86cf193

NO_ARCH= yes

Expand Down
6 changes: 3 additions & 3 deletions devel/codesearch-py/distinfo
Original file line number Diff line number Diff line change
@@ -1,3 +1,3 @@
TIMESTAMP = 1498485588
SHA256 (chromium-codesearch-py-0.1-ec3ad68_GH0.tar.gz) = 93c5c3476fafcec52d0bc1f732b31d9ddc700882e5f6755b36da7740f747ef24
SIZE (chromium-codesearch-py-0.1-ec3ad68_GH0.tar.gz) = 335302
TIMESTAMP = 1499190870
SHA256 (chromium-codesearch-py-0.1-86cf193_GH0.tar.gz) = fe0c58fa6e4f2c10e731e7fc96da9c87f2e2448818f626567557de608379230d
SIZE (chromium-codesearch-py-0.1-86cf193_GH0.tar.gz) = 344158
8 changes: 8 additions & 0 deletions devel/cppcheck-gui/Makefile
Original file line number Diff line number Diff line change
@@ -0,0 +1,8 @@
# Created by: Dmitry Marakasov <[email protected]>
# $FreeBSD$

MASTERDIR= ${.CURDIR}/../cppcheck

GUI_ONLY= yes

.include "${MASTERDIR}/Makefile"
31 changes: 23 additions & 8 deletions devel/cppcheck/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -7,28 +7,42 @@ CATEGORIES= devel
MASTER_SITES= SF

MAINTAINER= [email protected]
COMMENT= Static analysis of C/C++ code
COMMENT?= Static analysis of C/C++ code

LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING

BROKEN_powerpc64= fails to compile: analyzerinfo.cpp: 'to_string' is not a member of 'std'

USES= compiler:c++11-lib cmake shebangfix tar:bzip2
SHEBANG_FILES= htmlreport/cppcheck-htmlreport
USES= compiler:c++11-lib cmake tar:bzip2

OPTIONS_DEFINE= RULES GUI HTMLREPORT MANPAGES MATCHCOMPILER TEST
OPTIONS_DEFAULT= RULES GUI HTMLREPORT MANPAGES MATCHCOMPILER
.if defined(GUI_ONLY)
COMMENT= Static analysis of C/C++ code (GUI)

RUN_DEPENDS= cppcheck:devel/cppcheck

CMAKE_ARGS= -DBUILD_GUI=TRUE
USE_QT4= corelib gui xml qmake_build moc_build uic_build rcc_build linguisttools_build

BUILD_WRKSRC= ${WRKSRC}/gui
INSTALL_WRKSRC= ${WRKSRC}/gui

PLIST= ${PKGDIR}/pkg-plist-gui

PKGNAMESUFFIX= -gui
.else
USES+= shebangfix
SHEBANG_FILES= htmlreport/cppcheck-htmlreport

OPTIONS_DEFINE= RULES HTMLREPORT MANPAGES MATCHCOMPILER TEST
OPTIONS_DEFAULT= RULES HTMLREPORT MANPAGES MATCHCOMPILER
OPTIONS_SUB= yes

RULES_DESC= User-defined rule support (requires PCRE)
RULES_CMAKE_BOOL= HAVE_RULES
RULES_LIB_DEPENDS= libpcre.so:devel/pcre
RULES_USES= localbase:ldflags

GUI_CMAKE_BOOL= BUILD_GUI
GUI_USE= QT4=corelib,gui,xml,qmake_build,moc_build,uic_build,rcc_build,linguisttools_build

TEST_CMAKE_BOOL= BUILD_TESTS

HTMLREPORT_DESC= Install cppcheck-htmlreport
Expand Down Expand Up @@ -57,5 +71,6 @@ post-install-MANPAGES-on:

do-test-TEST-on:
cd ${WRKSRC} && ctest
.endif

.include <bsd.port.mk>
16 changes: 0 additions & 16 deletions devel/cppcheck/pkg-plist
Original file line number Diff line number Diff line change
@@ -1,20 +1,7 @@
%%GUI%%bin/cppcheck-gui
bin/cppcheck
%%DATADIR%%/avr.cfg
%%DATADIR%%/gnu.cfg
%%DATADIR%%/gtk.cfg
%%GUI%%%%DATADIR%%/lang/cppcheck_de.qm
%%GUI%%%%DATADIR%%/lang/cppcheck_es.qm
%%GUI%%%%DATADIR%%/lang/cppcheck_fi.qm
%%GUI%%%%DATADIR%%/lang/cppcheck_fr.qm
%%GUI%%%%DATADIR%%/lang/cppcheck_it.qm
%%GUI%%%%DATADIR%%/lang/cppcheck_ja.qm
%%GUI%%%%DATADIR%%/lang/cppcheck_ko.qm
%%GUI%%%%DATADIR%%/lang/cppcheck_nl.qm
%%GUI%%%%DATADIR%%/lang/cppcheck_ru.qm
%%GUI%%%%DATADIR%%/lang/cppcheck_sr.qm
%%GUI%%%%DATADIR%%/lang/cppcheck_sv.qm
%%GUI%%%%DATADIR%%/lang/cppcheck_zh_CN.qm
%%DATADIR%%/microsoft_sal.cfg
%%DATADIR%%/posix.cfg
%%DATADIR%%/qt.cfg
Expand All @@ -24,6 +11,3 @@ bin/cppcheck
%%DATADIR%%/windows.cfg
%%DATADIR%%/wxwidgets.cfg
%%MANPAGES%%man/man1/cppcheck.1.gz
%%GUI%%share/applications/cppcheck-gui.desktop
%%GUI%%share/icons/hicolor/64x64/apps/cppcheck-gui.png
%%GUI%%share/icons/hicolor/scalable/apps/cppcheck-gui.svg
16 changes: 16 additions & 0 deletions devel/cppcheck/pkg-plist-gui
Original file line number Diff line number Diff line change
@@ -0,0 +1,16 @@
bin/cppcheck-gui
share/applications/cppcheck-gui.desktop
%%DATADIR%%/lang/cppcheck_de.qm
%%DATADIR%%/lang/cppcheck_es.qm
%%DATADIR%%/lang/cppcheck_fi.qm
%%DATADIR%%/lang/cppcheck_fr.qm
%%DATADIR%%/lang/cppcheck_it.qm
%%DATADIR%%/lang/cppcheck_ja.qm
%%DATADIR%%/lang/cppcheck_ko.qm
%%DATADIR%%/lang/cppcheck_nl.qm
%%DATADIR%%/lang/cppcheck_ru.qm
%%DATADIR%%/lang/cppcheck_sr.qm
%%DATADIR%%/lang/cppcheck_sv.qm
%%DATADIR%%/lang/cppcheck_zh_CN.qm
share/icons/hicolor/64x64/apps/cppcheck-gui.png
share/icons/hicolor/scalable/apps/cppcheck-gui.svg
Loading

0 comments on commit 71f67c4

Please sign in to comment.