forked from opnsense/ports
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Taken from: HardenedBSD
- Loading branch information
Showing
355 changed files
with
3,819 additions
and
4,060 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,3 @@ | ||
TIMESTAMP = 1499397491 | ||
SHA256 (peazip-6.4.1.src.zip) = 6be126675c83df95b020da6221cf5063aed83510783d55254f4923c29a5245d0 | ||
SIZE (peazip-6.4.1.src.zip) = 4098287 | ||
TIMESTAMP = 1513107866 | ||
SHA256 (peazip-6.5.0.src.zip) = 1c19c7d6c346b511c635c95d6ff0277ee0811873133757d3c06c26fec558e7bf | ||
SIZE (peazip-6.5.0.src.zip) = 4181167 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
SHA256 (Astro-Catalog-4.31.tar.gz) = 12f8e563480432f4bcbd063fef2f391a89c0366708da5cacd8aa1c9a6248eabd | ||
SIZE (Astro-Catalog-4.31.tar.gz) = 272677 | ||
TIMESTAMP = 1517454173 | ||
SHA256 (Astro-Catalog-4.32.tar.gz) = 29e3201cc10171c67b93c0a6d280dc8bb954b3ccca2e94d901ed401005a7f0c1 | ||
SIZE (Astro-Catalog-4.32.tar.gz) = 266033 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,3 @@ | ||
TIMESTAMP = 1511968519 | ||
SHA256 (aipy-2.1.8.tar.gz) = 466619a73885fb2a18e8681f2c8a66848ed9d25fc0ab53e889eb72c5abfc2c94 | ||
SIZE (aipy-2.1.8.tar.gz) = 968382 | ||
TIMESTAMP = 1517354726 | ||
SHA256 (aipy-2.1.9.tar.gz) = fbc20526dac47ec7be8ae5d47ef0c40fcc7349d72ad8b0a48bd21d2c7858fe25 | ||
SIZE (aipy-2.1.9.tar.gz) = 968545 |
47 changes: 47 additions & 0 deletions
47
audio/clementine-player/files/patch-3rdParty_libprojectm_MilkdropPresetFactory_Parser.cpp
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,47 @@ | ||
--- 3rdparty/libprojectm/MilkdropPresetFactory/Parser.cpp.orig 2018-01-31 22:06:57.261592000 +0000 | ||
+++ 3rdparty/libprojectm/MilkdropPresetFactory/Parser.cpp 2018-01-31 22:07:38.081299000 +0000 | ||
@@ -1373,7 +1373,7 @@ | ||
PerFrameEqn * per_frame_eqn; | ||
GenExpr * gen_expr; | ||
|
||
- if (fs == NULL) | ||
+ if (!fs) | ||
return NULL; | ||
if (param_string == NULL) | ||
return NULL; | ||
@@ -1528,7 +1528,7 @@ | ||
|
||
if (preset == NULL) | ||
return NULL; | ||
- if (fs == NULL) | ||
+ if (!fs) | ||
return NULL; | ||
|
||
if ((token = parseToken(fs, name)) != tEq) | ||
@@ -1842,7 +1842,7 @@ | ||
/* Null argument checks */ | ||
if (preset == NULL) | ||
return PROJECTM_FAILURE; | ||
- if (fs == NULL) | ||
+ if (!fs) | ||
return PROJECTM_FAILURE; | ||
if (token == NULL) | ||
return PROJECTM_FAILURE; | ||
@@ -2133,7 +2133,7 @@ | ||
|
||
if (token == NULL) | ||
return PROJECTM_FAILURE; | ||
- if (fs == NULL) | ||
+ if (!fs) | ||
return PROJECTM_FAILURE; | ||
if (preset == NULL) | ||
return PROJECTM_FAILURE; | ||
@@ -2315,7 +2315,7 @@ | ||
if (token == NULL) | ||
|
||
return PROJECTM_FAILURE; | ||
- if (fs == NULL) | ||
+ if (!fs) | ||
return PROJECTM_FAILURE; | ||
if (preset == NULL) | ||
return PROJECTM_FAILURE; |
17 changes: 17 additions & 0 deletions
17
audio/clementine-player/files/patch-3rdParty_libprojectm_Renderer_VideoEcho.cpp
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,17 @@ | ||
--- 3rdparty/libprojectm/Renderer/VideoEcho.cpp.orig 2018-01-31 22:10:05.891427000 +0000 | ||
+++ 3rdparty/libprojectm/Renderer/VideoEcho.cpp 2018-01-31 22:14:31.332885000 +0000 | ||
@@ -77,10 +77,10 @@ | ||
default: flipx=1;flipy=1; break; | ||
} | ||
|
||
- float pointsFlip[4][2] = {{-0.5*flipx, -0.5*flipy}, | ||
- {-0.5*flipx, 0.5*flipy}, | ||
- { 0.5*flipx, 0.5*flipy}, | ||
- { 0.5*flipx, -0.5*flipy}}; | ||
+ float pointsFlip[4][2] = {{static_cast<float>(-0.5)*flipx, static_cast<float>(-0.5)*flipy}, | ||
+ {static_cast<float>(-0.5)*flipx, static_cast<float>(0.5)*flipy}, | ||
+ { static_cast<float>(0.5)*flipx, static_cast<float>(0.5)*flipy}, | ||
+ { static_cast<float>(0.5)*flipx, static_cast<float>(-0.5)*flipy}}; | ||
|
||
glVertexPointer(2,GL_FLOAT,0,pointsFlip); | ||
glDrawArrays(GL_TRIANGLE_FAN,0,4); |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -2,39 +2,22 @@ | |
# $FreeBSD$ | ||
|
||
PORTNAME= emms | ||
PORTVERSION= 4.3 | ||
PORTREVISION= 1 | ||
DISTVERSION= 4.4 | ||
CATEGORIES= audio elisp | ||
MASTER_SITES= GNU | ||
PKGNAMESUFFIX= ${EMACS_PKGNAMESUFFIX} | ||
|
||
MAINTAINER= [email protected] | ||
COMMENT= The Emacs Multi-Media System | ||
COMMENT= Emacs Multi-Media System | ||
|
||
LICENSE= GPLv3 | ||
|
||
USES= gmake makeinfo | ||
USE_EMACS= yes | ||
MAKE_ENV= SITELISP="${PREFIX}/${EMACS_SITE_LISPDIR}/emms" \ | ||
INSTALLINFO="${TRUE}" | ||
# do not depend on base texinfo on 10 | ||
BUILD_DEPENDS= texi2dvi:print/texinfo | ||
|
||
INFO= emms | ||
|
||
.include <bsd.port.pre.mk> | ||
USES= emacs gmake | ||
|
||
.if ${EMACS_PORT_NAME} != "emacs25" | ||
PORTNAMESUFFIX= ${PKGNAMESUFFIX} | ||
.endif | ||
|
||
post-patch: | ||
@${REINPLACE_CMD} -e \ | ||
's|^\(DESTDIR\)=|\1?=| ; \ | ||
s|^\(PREFIX\)=$$(DESTDIR)|\1?=| ; \ | ||
s|^\(INFODIR\)=|\1?=| ; \ | ||
s|^\(MAN1DIR\)=$$(PREFIX)/share|\1?=$$(PREFIX)| ; \ | ||
s|^\(SITELISP\)=|\1?=| ; \ | ||
s|^\(INSTALLINFO\) =|INSTALLINFO ?=| ; \ | ||
s| \($$(SITELISP)\)| $$(DESTDIR)\1|g ; \ | ||
s| \($$(INFODIR)\)| $$(DESTDIR)\1|g ; \ | ||
s| \($$(MAN1DIR)\)| $$(DESTDIR)\1|g' ${WRKSRC}/Makefile | ||
INFO= emms | ||
NO_ARCH= yes | ||
|
||
.include <bsd.port.post.mk> | ||
.include <bsd.port.mk> |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,3 @@ | ||
TIMESTAMP = 1495277936 | ||
SHA256 (emms-4.3.tar.gz) = 00112d631eee0cfee80a85c048bfbf7c2d25886067ee02152376208ae87c2c36 | ||
SIZE (emms-4.3.tar.gz) = 287153 | ||
TIMESTAMP = 1515254365 | ||
SHA256 (emms-4.4.tar.gz) = 10ecc2e9c957ca1f80bbf8d9a0473b9eae552218aaea278dc8b10564215513ac | ||
SIZE (emms-4.4.tar.gz) = 288922 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,18 @@ | ||
--- Makefile.orig 2018-01-06 17:26:53 UTC | ||
+++ Makefile | ||
@@ -10,13 +10,13 @@ ALLCOMPILED=$(wildcard $(LISPDIR)/*.elc) | ||
DESTDIR= | ||
PREFIX=$(DESTDIR)/usr/local | ||
INFODIR=$(PREFIX)/info | ||
-MAN1DIR=$(PREFIX)/share/man/man1 | ||
+MAN1DIR=$(PREFIX)/man/man1 | ||
BINDIR=$(PREFIX)/bin | ||
SITELISP=$(PREFIX)/share/emacs/site-lisp/emms | ||
|
||
GINSTALLINFO = /usr/bin/ginstall-info --info-dir=$(INFODIR) | ||
# For systems without ginstall-info | ||
-INSTALLINFO = /usr/bin/install-info --info-dir=$(INFODIR) | ||
+INSTALLINFO = /usr/local/bin/install-info --info-dir=$(INFODIR) | ||
CHANGELOG_CMD = git log --pretty=medium --no-merges | ||
|
||
# The currently released version of EMMS |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,12 @@ | ||
--- doc/Makefile.orig 2018-01-06 17:09:29 UTC | ||
+++ doc/Makefile | ||
@@ -7,7 +7,7 @@ clean: | ||
rm -f *.info | ||
|
||
%.info: %.texinfo | ||
- makeinfo --no-split $< | ||
+ ${LOCALBASE}/bin/makeinfo --no-split $< | ||
|
||
%.html: %.texinfo | ||
- makeinfo --html --no-split $< | ||
+ ${LOCALBASE}/bin/makeinfo --html --no-split $< |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,11 +1,11 @@ | ||
--- packages/mad/fpmake.pp.orig 2015-11-13 21:15:29 UTC | ||
+++ packages/mad/fpmake.pp | ||
@@ -17,7 +17,7 @@ begin | ||
--- packages/mad/fpmake.pp 2017-09-02 11:48:24.000000000 -0500 | ||
+++ packages/mad/fpmake.pp 2017-12-12 12:22:21.182111000 -0500 | ||
@@ -17,7 +17,7 @@ | ||
P.Directory:=ADirectory; | ||
{$endif ALLPACKAGES} | ||
P.Version:='3.0.2'; | ||
P.Version:='3.0.4'; | ||
- P.OSes := [linux,win32,win64,wii]; | ||
+ P.OSes := [linux,win32,win64,wii,freebsd,dragonfly]; | ||
+ P.OSes := [linux,win32,win64,wii,dragonfly,freebsd]; | ||
P.SourcePath.Add('src'); | ||
|
||
T:=P.Targets.AddUnit('mad.pas'); |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -2,7 +2,7 @@ | |
|
||
PORTNAME= diamond | ||
DISTVERSIONPREFIX= v | ||
DISTVERSION= 0.9.14 | ||
DISTVERSION= 0.9.17 | ||
CATEGORIES= biology | ||
|
||
MAINTAINER= [email protected] | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,3 @@ | ||
TIMESTAMP = 1513181932 | ||
SHA256 (bbuchfink-diamond-v0.9.14_GH0.tar.gz) = de870a7806ac0aa47b97c9b784dd7201e2c8e11a122003bde440d926211b911e | ||
SIZE (bbuchfink-diamond-v0.9.14_GH0.tar.gz) = 389604 | ||
TIMESTAMP = 1517512236 | ||
SHA256 (bbuchfink-diamond-v0.9.17_GH0.tar.gz) = cda79a6c3de73545dc783722edb17ae0828efb2553eac113e0e2c1d354686edc | ||
SIZE (bbuchfink-diamond-v0.9.17_GH0.tar.gz) = 391282 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,3 @@ | ||
TIMESTAMP = 1504443436 | ||
SHA256 (stephaneguindon-phyml-v3.3.20170530_GH0.tar.gz) = f826726cd56b755be75f923abdf29aca8a9951d6af948cddbab40739a8f99f74 | ||
SIZE (stephaneguindon-phyml-v3.3.20170530_GH0.tar.gz) = 2121298 | ||
TIMESTAMP = 1517469692 | ||
SHA256 (stephaneguindon-phyml-3.3.20180129_GH0.tar.gz) = 9fe2158ca6dfdd08269b3890d6f5e35d4cbaef2f7c9be9ed3bd3af8209f4862b | ||
SIZE (stephaneguindon-phyml-3.3.20180129_GH0.tar.gz) = 2459684 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -3,35 +3,32 @@ | |
|
||
PORTNAME= dinotrace | ||
PORTVERSION= 9.4c | ||
PORTREVISION= 5 | ||
PORTREVISION= 6 | ||
CATEGORIES= cad | ||
MASTER_SITES= http://www.veripool.org/ftp/ | ||
PKGNAMESUFFIX= ${EMACS_PKGNAMESUFFIX} | ||
|
||
MAINTAINER= [email protected] | ||
COMMENT= Graphical signal trace waveform viewer | ||
|
||
OPTIONS_DEFINE= EMACS | ||
OPTIONS_DEFAULT= EMACS | ||
EMACS_DESC= Install Emacs supplimentary files | ||
LICENSE= GPLv3+ | ||
|
||
USE_XORG= x11 sm ice xmu xt | ||
USES= gmake motif perl5 tar:tgz | ||
USE_XORG= x11 sm ice xmu xt | ||
USE_PERL5= build | ||
|
||
GNU_CONFIGURE= yes | ||
|
||
INFO= dinotrace | ||
PLIST_FILES= bin/dinotrace | ||
|
||
.include <bsd.port.options.mk> | ||
OPTIONS_DEFINE= EMACS | ||
OPTIONS_DEFAULT= EMACS | ||
EMACS_DESC= Install Emacs supplimentary files | ||
|
||
.if ${PORT_OPTIONS:MEMACS} | ||
RUN_DEPENDS+= verilog-mode.el>0:cad/verilog-mode.el | ||
USE_EMACS= yes | ||
EMACS_NO_BUILD_DEPENDS= yes | ||
.for F in dinotrace.el sim-log.el | ||
PLIST_FILES+= ${EMACS_SITE_LISPDIR}/${F} | ||
.endfor | ||
.endif | ||
EMACS_USES= emacs:run | ||
EMACS_RUN_DEPENDS= verilog-mode.el${EMACS_PKGNAMESUFFIX}>0:cad/verilog-mode.el@${FLAVOR} | ||
EMACS_PLIST_FILES= ${EMACS_SITE_LISPDIR}/dinotrace.el ${EMACS_SITE_LISPDIR}/sim-log.el | ||
|
||
post-patch: | ||
@${REINPLACE_CMD} -e 's|"-O3"|""|' ${WRKSRC}/configure | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Oops, something went wrong.