forked from opnsense/ports
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Taken from: FreeBSD
- Loading branch information
Showing
26 changed files
with
469 additions
and
226 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -10,6 +10,19 @@ in the release notes and/or placed into UPDATING. | |
|
||
All ports committers are allowed to commit to this file. | ||
|
||
20230111: | ||
AUTHOR: [email protected] | ||
|
||
USE_PYTHON=pep517 has been added to facilitate building using the | ||
new format. | ||
|
||
USE_PYTHON=pep517 takes no arguments. Operation is similar to | ||
USE_PYTHON=distutils, although the build backend specified in | ||
pyproject.toml shall be specified in BUILD_DEPENDS. | ||
|
||
A usage guide and implementation primer is available at: | ||
https://wiki.freebsd.org/Python/PEP-517 | ||
|
||
20221217: | ||
AUTHOR: [email protected] | ||
|
||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -9,7 +9,7 @@ LTO_Include_MAINTAINER= [email protected] | |
|
||
. if !defined(LTO_UNSAFE) || defined(LTO_DISABLE_CHECK) | ||
. if "${ARCH}" == "powerpc64" || "${ARCH}" == "riscv64" && !defined(LTO_DISABLE_CHECK) | ||
IGNORE= LTO is currently broken on ${ARCH}, to override set LTO_DISABLE_CHECK=yes | ||
DEV_WARNING+= "LTO is currently broken on powerpc64 and riscv64, to override set LTO_DISABLE_CHECK=yes" | ||
. elif defined(_INCLUDE_USES_CARGO_MK) | ||
CARGO_ENV+= CARGO_PROFILE_RELEASE_LTO="true" \ | ||
CARGO_PROFILE_RELEASE_PANIC="abort" \ | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,90 @@ | ||
# Support for octave based ports | ||
# | ||
# Feature: octave | ||
# Usage: USES=octave | ||
# Valid ARGS: (none), env | ||
# - env : Loads only one environmental variable OCTAVE_VERSION | ||
# MAINTAINER: [email protected] | ||
# | ||
# Common code to install octave-forge packages. | ||
# It is, in effect, a wrapper using the package handling already built | ||
# into math/octave. | ||
|
||
.if !defined(_INCLUDE_USES_OCTAVE_MK) | ||
_INCLUDE_USES_OCTAVE_MK= yes | ||
|
||
_valid_octave_ARGS= env | ||
|
||
# Sanity check | ||
. for arg in ${octave_ARGS} | ||
. if empty(_valid_octave_ARGS:M${arg}) | ||
IGNORE= Incorrect 'USES+= octave:${octave_ARGS}' usage: argument [${arg}] is not recognized | ||
. endif | ||
. endfor | ||
|
||
OCTAVE_VERSION= 7.3.0 | ||
|
||
. if empty(octave_ARGS:Menv) | ||
BUILD_DEPENDS+= octave:math/octave | ||
RUN_DEPENDS+= octave:math/octave \ | ||
${LOCALBASE}/libexec/octave/load-octave-pkg:math/octave-forge-base | ||
LIB_DEPENDS+= libpcre.so:devel/pcre | ||
|
||
. if ! ${USES:Mcompiler} | ||
_USES_POST+= compiler:c++14-lang | ||
. endif | ||
|
||
. if ! ${USES:Mfortran} | ||
_USES_POST+= fortran | ||
. endif | ||
|
||
. if ! ${USES:Mgmake} | ||
_USES_POST+= gmake | ||
. endif | ||
|
||
CXXFLAGS+= -I${LOCALBASE}/include/octave-${OCTAVE_VERSION} | ||
CFLAGS+= -I${LOCALBASE}/include/octave-${OCTAVE_VERSION} | ||
CPPFLAGS+= -I${LOCALBASE}/include/octave-${OCTAVE_VERSION} | ||
|
||
DIST_SUBDIR?= octave-forge | ||
OCTAVE_PKGNAME= ${PORTNAME:S/octave-forge-//} | ||
OCTAVE_DISTNAME= ${OCTAVE_PKGNAME}-${DISTVERSION} | ||
OCTAVE_TARBALLS_DIR= ${LOCALBASE}/share/octave/tarballs | ||
OCTAVE_INSTALL_TARBALLS_DIR= ${STAGEDIR}${PREFIX}/share/octave/tarballs | ||
OCTAVE_SRC?= ${DISTNAME} | ||
WRKSRC?= ${WRKDIR}/${OCTAVE_SRC}/src | ||
|
||
MAKE_ENV+= PACKAGE=${OCTAVE_DISTNAME}.tar.gz | ||
MAKE_ARGS= CC="${CC}" CXX="${CXX}" LD_CXX="${CXX}" DL_LD="${CXX}" MKOCTFILE="${LOCALBASE}/bin/mkoctfile" OCTAVE_VERSION=-${OCTAVE_VERSION} | ||
|
||
LOAD_OCTAVE_PKG_CMD= ${LOCALBASE}/libexec/octave/load-octave-pkg | ||
|
||
. if !target(pre-install) | ||
pre-install: octave-pre-install | ||
. endif # !target(pre-install) | ||
|
||
. if !target(do-install) | ||
do-install: octave-do-install | ||
. endif # !target(do-install) | ||
|
||
. if !target(post-install) | ||
post-install: octave-post-install | ||
. endif # !target(post-install) | ||
|
||
octave-pre-install: | ||
${RM} ${WRKSRC}/Makefile ${WRKSRC}/configure | ||
cd ${WRKDIR} && ${TAR} cfz ${OCTAVE_DISTNAME}.tar.gz ${OCTAVE_SRC} | ||
|
||
octave-do-install: | ||
${MKDIR} ${OCTAVE_INSTALL_TARBALLS_DIR} | ||
${INSTALL_DATA} ${WRKDIR}/${OCTAVE_DISTNAME}.tar.gz ${OCTAVE_INSTALL_TARBALLS_DIR}/. | ||
${LN} -s -f ${OCTAVE_DISTNAME}.tar.gz ${OCTAVE_INSTALL_TARBALLS_DIR}/${OCTAVE_PKGNAME}.tar.gz | ||
|
||
octave-post-install: | ||
@${ECHO_CMD} "share/octave/tarballs/${OCTAVE_DISTNAME}.tar.gz" >> ${TMPPLIST} | ||
@${ECHO_CMD} "share/octave/tarballs/${OCTAVE_PKGNAME}.tar.gz" >> ${TMPPLIST} | ||
@${ECHO_CMD} "@postunexec if [ -x ${LOAD_OCTAVE_PKG_CMD} ]; then ${LOAD_OCTAVE_PKG_CMD}; fi" >> ${TMPPLIST} | ||
@${ECHO_CMD} "@postexec if [ -x ${LOAD_OCTAVE_PKG_CMD} ]; then ${LOAD_OCTAVE_PKG_CMD}; fi" >> ${TMPPLIST} | ||
. endif # empty(octave_ARGS:Menv) | ||
|
||
.endif # !defined(_INCLUDE_USES_OCTAVE_MK) |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Oops, something went wrong.