Skip to content

Commit

Permalink
*/*: sync with upstream
Browse files Browse the repository at this point in the history
Taken from: HardenedBSD
  • Loading branch information
fichtner committed Apr 13, 2018
1 parent 01d7590 commit 8cc80a3
Show file tree
Hide file tree
Showing 215 changed files with 2,111 additions and 693 deletions.
20 changes: 10 additions & 10 deletions astro/libosmium/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -2,16 +2,15 @@
# $FreeBSD$

PORTNAME= libosmium
PORTVERSION= 2.13.1
PORTVERSION= 2.14.0
DISTVERSIONPREFIX= v
PORTREVISION= 4
CATEGORIES= astro geography devel

MAINTAINER= [email protected]
COMMENT= Fast and flexible C++ library for working with OpenStreetMap data

LICENSE= BSL
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
LICENSE_FILE= ${WRKSRC}/LICENSE

BROKEN_powerpc64= fails to compile: types_from_string.hpp: error: 'strtoll' is not a member of 'std'

Expand All @@ -20,21 +19,22 @@ LIB_DEPENDS= libgdal.so:graphics/gdal \
libgeos.so:graphics/geos \
libexpat.so:textproc/expat2
BUILD_DEPENDS= sparsehash>=0:devel/sparsehash \
${LOCALBASE}/include/utf8.h:devel/utf8cpp
RUN_DEPENDS= ${LOCALBASE}/include/utf8.h:devel/utf8cpp
${LOCALBASE}/include/utf8.h:devel/utf8cpp \
${LOCALBASE}/include/protozero/version.hpp:devel/protozero
RUN_DEPENDS= ${LOCALBASE}/include/utf8.h:devel/utf8cpp \
${LOCALBASE}/include/protozero/version.hpp:devel/protozero

USE_GITHUB= yes
GH_ACCOUNT= osmcode

USES= cmake compiler:c++11-lib
CMAKE_ARGS= -DBUILD_EXAMPLES:BOOL=OFF

# if/when corresponding ports appear in the tree, these will need to
# be turned from depends
CMAKE_ARGS+= -DINSTALL_GDALCPP:BOOL=ON \
-DINSTALL_PROTOZERO:BOOL=ON
# if/when corresponding port appears in the tree, this will need to
# be turned into dependency
CMAKE_ARGS+= -DINSTALL_GDALCPP:BOOL=ON

# though it builds tests, the library itself is header-only
# although it builds tests the library itself is header-only
NO_ARCH= yes

PORTDOCS= *
Expand Down
6 changes: 3 additions & 3 deletions astro/libosmium/distinfo
Original file line number Diff line number Diff line change
@@ -1,3 +1,3 @@
TIMESTAMP = 1504088485
SHA256 (osmcode-libosmium-v2.13.1_GH0.tar.gz) = a73cd56838a7438bd9ed208c9ce6794e2d55a1854039c4277a0c160d5071b909
SIZE (osmcode-libosmium-v2.13.1_GH0.tar.gz) = 493918
TIMESTAMP = 1522624701
SHA256 (osmcode-libosmium-v2.14.0_GH0.tar.gz) = ac385c13b1989cf60f9f2e0395a9d8f73ea557fbe8a35cabb0e5f0b74cf43b49
SIZE (osmcode-libosmium-v2.14.0_GH0.tar.gz) = 489137
11 changes: 0 additions & 11 deletions astro/libosmium/files/patch-include_osmium_util_endian.hpp

This file was deleted.

14 changes: 2 additions & 12 deletions astro/libosmium/pkg-plist
Original file line number Diff line number Diff line change
Expand Up @@ -123,6 +123,7 @@ include/osmium/io/pbf_input.hpp
include/osmium/io/pbf_output.hpp
include/osmium/io/reader.hpp
include/osmium/io/reader_iterator.hpp
include/osmium/io/reader_with_progress_bar.hpp
include/osmium/io/writer.hpp
include/osmium/io/writer_options.hpp
include/osmium/io/xml_input.hpp
Expand All @@ -144,6 +145,7 @@ include/osmium/osm/entity.hpp
include/osmium/osm/entity_bits.hpp
include/osmium/osm/item_type.hpp
include/osmium/osm/location.hpp
include/osmium/osm/metadata_options.hpp
include/osmium/osm/node.hpp
include/osmium/osm/node_ref.hpp
include/osmium/osm/node_ref_list.hpp
Expand Down Expand Up @@ -180,7 +182,6 @@ include/osmium/util/config.hpp
include/osmium/util/delta.hpp
include/osmium/util/double.hpp
include/osmium/util/endian.hpp
include/osmium/util/endian.hpp.orig
include/osmium/util/file.hpp
include/osmium/util/iterator.hpp
include/osmium/util/memory.hpp
Expand All @@ -195,14 +196,3 @@ include/osmium/util/timer.hpp
include/osmium/util/verbose_output.hpp
include/osmium/version.hpp
include/osmium/visitor.hpp
include/protozero/byteswap.hpp
include/protozero/config.hpp
include/protozero/exception.hpp
include/protozero/iterators.hpp
include/protozero/pbf_builder.hpp
include/protozero/pbf_message.hpp
include/protozero/pbf_reader.hpp
include/protozero/pbf_writer.hpp
include/protozero/types.hpp
include/protozero/varint.hpp
include/protozero/version.hpp
22 changes: 19 additions & 3 deletions audio/asterisk-espeak/Makefile
Original file line number Diff line number Diff line change
@@ -1,8 +1,9 @@
# $FreeBSD$

PORTNAME= asterisk-espeak
PORTNAME= espeak
PORTVERSION= 4.0
DISTVERSIONPREFIX= v
PORTREVISION= 1
CATEGORIES= audio

MAINTAINER= [email protected]
Expand All @@ -12,8 +13,19 @@ LICENSE= GPLv2

LIB_DEPENDS= libespeak.so:audio/espeak \
libsamplerate.so:audio/libsamplerate
BUILD_DEPENDS= asterisk:net/asterisk13
RUN_DEPENDS= asterisk:net/asterisk13

FLAVORS= asterisk13 asterisk15
FLAVOR?= ${FLAVORS[1]}

asterisk13_PKGNAMEPREFIX= asterisk13-
asterisk13_CONFLICTS_INSTALL= asterisk15-espeak
asterisk13_BUILD_DEPENDS= asterisk:net/asterisk13
asterisk13_RUN_DEPENDS= asterisk:net/asterisk13

asterisk15_PKGNAMEPREFIX= asterisk15-
asterisk15_CONFLICTS_INSTALL= asterisk13-espeak
asterisk15_BUILD_DEPENDS= asterisk:net/asterisk15
asterisk15_RUN_DEPENDS= asterisk:net/asterisk15

USES= compiler gmake localbase
INSTALL_TARGET= install samples
Expand All @@ -28,6 +40,10 @@ GH_PROJECT= Asterisk-eSpeak
CFLAGS+= -fblocks
.endif

post-patch:
@${REINPLACE_CMD} -e '/ASTERISK_REGISTER_FILE/d' \
${WRKSRC}/app_espeak.c

post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/asterisk/modules/app_espeak.so

Expand Down
22 changes: 19 additions & 3 deletions audio/asterisk-flite/Makefile
Original file line number Diff line number Diff line change
@@ -1,8 +1,9 @@
# $FreeBSD$

PORTNAME= asterisk-flite
PORTNAME= flite
PORTVERSION= 3.0
DISTVERSIONPREFIX= v
PORTREVISION= 1
CATEGORIES= audio

MAINTAINER= [email protected]
Expand All @@ -11,8 +12,19 @@ COMMENT= Flite dialplan application for Asterisk
LICENSE= GPLv2

LIB_DEPENDS= libflite.so:audio/flite
BUILD_DEPENDS= asterisk:net/asterisk13
RUN_DEPENDS= asterisk:net/asterisk13

FLAVORS= asterisk13 asterisk15
FLAVOR?= ${FLAVORS[1]}

asterisk13_PKGNAMEPREFIX= asterisk13-
asterisk13_CONFLICTS_INSTALL= asterisk15-flite
asterisk13_BUILD_DEPENDS= asterisk:net/asterisk13
asterisk13_RUN_DEPENDS= asterisk:net/asterisk13

asterisk15_PKGNAMEPREFIX= asterisk15-
asterisk15_CONFLICTS_INSTALL= asterisk13-flite
asterisk15_BUILD_DEPENDS= asterisk:net/asterisk15
asterisk15_RUN_DEPENDS= asterisk:net/asterisk15

USES= compiler gmake localbase
INSTALL_TARGET= install samples
Expand All @@ -27,6 +39,10 @@ GH_PROJECT= Asterisk-Flite
CFLAGS+= -fblocks
.endif

post-patch:
@${REINPLACE_CMD} -e '/ASTERISK_REGISTER_FILE/d' \
${WRKSRC}/app_flite.c

post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/asterisk/modules/app_flite.so

Expand Down
3 changes: 1 addition & 2 deletions audio/ncmpcpp/Makefile
Original file line number Diff line number Diff line change
@@ -1,8 +1,7 @@
# $FreeBSD$

PORTNAME= ncmpcpp
PORTVERSION= 0.8.1
PORTREVISION= 2
DISTVERSION= 0.8.2
CATEGORIES= audio
MASTER_SITES= http://ncmpcpp.rybczak.net/stable/

Expand Down
6 changes: 3 additions & 3 deletions audio/ncmpcpp/distinfo
Original file line number Diff line number Diff line change
@@ -1,3 +1,3 @@
TIMESTAMP = 1510308936
SHA256 (ncmpcpp-0.8.1.tar.bz2) = 4df9570a1db4ba2dc9b759aab88b283c00806fb5d2bce5f5d27a2eb10e6888ff
SIZE (ncmpcpp-0.8.1.tar.bz2) = 464123
TIMESTAMP = 1523589893
SHA256 (ncmpcpp-0.8.2.tar.bz2) = 650ba3e8089624b7ad9e4cc19bc1ac6028edb7523cc111fa1686ea44c0921554
SIZE (ncmpcpp-0.8.2.tar.bz2) = 465713
2 changes: 1 addition & 1 deletion audio/xfce4-pulseaudio-plugin/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -2,7 +2,7 @@
# $FreeBSD$

PORTNAME= xfce4-pulseaudio-plugin
PORTVERSION= 0.4.0
PORTVERSION= 0.4.1
CATEGORIES= audio xfce
MASTER_SITES= XFCE/src/panel-plugins/${PORTNAME}/${PORTVERSION:R}
DIST_SUBDIR= xfce4
Expand Down
6 changes: 3 additions & 3 deletions audio/xfce4-pulseaudio-plugin/distinfo
Original file line number Diff line number Diff line change
@@ -1,3 +1,3 @@
TIMESTAMP = 1521533263
SHA256 (xfce4/xfce4-pulseaudio-plugin-0.4.0.tar.bz2) = aef9ad68a0b604a6aeca4c08146f3eb42bedb4fe1c8b65b82679cec0e2fc1cb3
SIZE (xfce4/xfce4-pulseaudio-plugin-0.4.0.tar.bz2) = 391068
TIMESTAMP = 1523526880
SHA256 (xfce4/xfce4-pulseaudio-plugin-0.4.1.tar.bz2) = 6ca88314dbac3e24c0e1bfc593fad6edb66319766be62e8256c81b0314f049f0
SIZE (xfce4/xfce4-pulseaudio-plugin-0.4.1.tar.bz2) = 391791
1 change: 0 additions & 1 deletion benchmarks/sysbench/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -11,7 +11,6 @@ COMMENT= Scriptable database and system performance benchmark
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING

BUILD_DEPENDS= xxd:editors/vim-console
LIB_DEPENDS= libck.so:devel/concurrencykit \
libluajit-5.1.so:lang/luajit

Expand Down
1 change: 1 addition & 0 deletions databases/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -787,6 +787,7 @@
SUBDIR += py-htsql
SUBDIR += py-htsql-mysql
SUBDIR += py-htsql-pgsql
SUBDIR += py-influxdb
SUBDIR += py-kyotocabinet
SUBDIR += py-leveldb
SUBDIR += py-lmdb
Expand Down
2 changes: 1 addition & 1 deletion databases/cassandra-cpp-driver/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -2,7 +2,7 @@
# $FreeBSD$

PORTNAME= cassandra-cpp-driver
PORTVERSION= 2.8.1
PORTVERSION= 2.9.0
CATEGORIES= databases

MAINTAINER= [email protected]
Expand Down
6 changes: 3 additions & 3 deletions databases/cassandra-cpp-driver/distinfo
Original file line number Diff line number Diff line change
@@ -1,3 +1,3 @@
TIMESTAMP = 1519988768
SHA256 (datastax-cpp-driver-2.8.1_GH0.tar.gz) = c90b1871ee66d2589a9c297c82b3e541ae574c43cce0560f0f253e5023b30413
SIZE (datastax-cpp-driver-2.8.1_GH0.tar.gz) = 1526453
TIMESTAMP = 1523520254
SHA256 (datastax-cpp-driver-2.9.0_GH0.tar.gz) = 9c61e58092b0ffc1b2bf783e66481565bd7c49424e94bd8d4a2a8936488dff25
SIZE (datastax-cpp-driver-2.9.0_GH0.tar.gz) = 9178588
3 changes: 1 addition & 2 deletions databases/pgbouncer/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -2,8 +2,7 @@
# $FreeBSD$

PORTNAME= pgbouncer
PORTVERSION= 1.7.2
PORTREVISION= 3
PORTVERSION= 1.8.1
CATEGORIES= databases
MASTER_SITES= https://pgbouncer.github.io/downloads/files/${PORTVERSION}/ \
http://pgbouncer.github.io/downloads/files/${PORTVERSION}/
Expand Down
5 changes: 3 additions & 2 deletions databases/pgbouncer/distinfo
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
SHA256 (pgbouncer-1.7.2.tar.gz) = de36b318fe4a2f20a5f60d1c5ea62c1ca331f6813d2c484866ecb59265a160ba
SIZE (pgbouncer-1.7.2.tar.gz) = 462374
TIMESTAMP = 1523524075
SHA256 (pgbouncer-1.8.1.tar.gz) = fa8bde2a2d2c8c80d53a859f8e48bc6713cf127e31c77d8f787bbc1d673e8dc8
SIZE (pgbouncer-1.8.1.tar.gz) = 465930
22 changes: 22 additions & 0 deletions databases/py-influxdb/Makefile
Original file line number Diff line number Diff line change
@@ -0,0 +1,22 @@
# $FreeBSD$

PORTNAME= influxdb
PORTVERSION= 5.0.0
CATEGORIES= databases python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}

MAINTAINER= [email protected]
COMMENT= Python Client for InfluxDB

LICENSE= MIT

RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dateutil>0:devel/py-dateutil@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytz>0:devel/py-pytz@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}requests>0:www/py-requests@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${FLAVOR}

USES= python
USE_PYTHON= distutils concurrent autoplist

.include <bsd.port.mk>
3 changes: 3 additions & 0 deletions databases/py-influxdb/distinfo
Original file line number Diff line number Diff line change
@@ -0,0 +1,3 @@
TIMESTAMP = 1521112563
SHA256 (influxdb-5.0.0.tar.gz) = 6adba2ddfd5781a06b5204339e679d66645bf6cc2b7f493eb9d7c8986d714e80
SIZE (influxdb-5.0.0.tar.gz) = 56396
3 changes: 3 additions & 0 deletions databases/py-influxdb/pkg-descr
Original file line number Diff line number Diff line change
@@ -0,0 +1,3 @@
InfluxDB-Python is a client for interacting with InfluxDB.

WWW: https://pypi.python.org/pypi/influxdb
2 changes: 1 addition & 1 deletion deskutils/zim/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -2,7 +2,7 @@
# $FreeBSD$

PORTNAME= zim
PORTVERSION= 0.67
PORTVERSION= 0.68
CATEGORIES= deskutils python
MASTER_SITES= http://www.zim-wiki.org/downloads/

Expand Down
6 changes: 3 additions & 3 deletions deskutils/zim/distinfo
Original file line number Diff line number Diff line change
@@ -1,3 +1,3 @@
TIMESTAMP = 1499768437
SHA256 (zim-0.67.tar.gz) = b37cef3d4906aa263abccb1493929a7ea6b9e8d11a50ed92cd437e8f93ffabbd
SIZE (zim-0.67.tar.gz) = 2034747
TIMESTAMP = 1523480995
SHA256 (zim-0.68.tar.gz) = d91518e010f6a6e951a75314138b5545a4c51151fc99f513aa7768a18858df15
SIZE (zim-0.68.tar.gz) = 2044224
5 changes: 3 additions & 2 deletions devel/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -8,14 +8,14 @@
SUBDIR += ElectricFence
SUBDIR += ORBit2
SUBDIR += ORBit2-reference
SUBDIR += R-cran-abind
SUBDIR += R-cran-BH
SUBDIR += R-cran-Defaults
SUBDIR += R-cran-Hmisc
SUBDIR += R-cran-ModelMetrics
SUBDIR += R-cran-R6
SUBDIR += R-cran-RUnit
SUBDIR += R-cran-Rcpp
SUBDIR += R-cran-abind
SUBDIR += R-cran-bindr
SUBDIR += R-cran-bindrcpp
SUBDIR += R-cran-bit
Expand Down Expand Up @@ -4136,6 +4136,7 @@
SUBDIR += protobuf
SUBDIR += protobuf-c
SUBDIR += protobuf25
SUBDIR += protozero
SUBDIR += pructl
SUBDIR += psptoolchain
SUBDIR += psptoolchain-binutils
Expand Down Expand Up @@ -4975,9 +4976,9 @@
SUBDIR += py-subversion
SUBDIR += py-subvertpy
SUBDIR += py-sure
SUBDIR += py-swagger-spec-validator
SUBDIR += py-sysctl
SUBDIR += py-sysv_ipc
SUBDIR += py-swagger-spec-validator
SUBDIR += py-tables
SUBDIR += py-tabulate
SUBDIR += py-tapi
Expand Down
4 changes: 2 additions & 2 deletions devel/R-cran-lubridate/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -2,14 +2,14 @@
# $FreeBSD$

PORTNAME= lubridate
PORTVERSION= 1.7.3
PORTVERSION= 1.7.4
CATEGORIES= devel
DISTNAME= ${PORTNAME}_${PORTVERSION}

MAINTAINER= [email protected]
COMMENT= Make Dealing with Dates a Little Easier

LICENSE= GPLv2
LICENSE= GPLv2+

CRAN_DEPENDS= R-cran-stringr>0:textproc/R-cran-stringr \
R-cran-Rcpp>=0.12.13:devel/R-cran-Rcpp
Expand Down
6 changes: 3 additions & 3 deletions devel/R-cran-lubridate/distinfo
Original file line number Diff line number Diff line change
@@ -1,3 +1,3 @@
TIMESTAMP = 1520826043
SHA256 (lubridate_1.7.3.tar.gz) = 2cffbf54afce1d068e65241fb876a77b10ee907d5a19d2ffa84d5ba8a2c3f3df
SIZE (lubridate_1.7.3.tar.gz) = 447719
TIMESTAMP = 1523581143
SHA256 (lubridate_1.7.4.tar.gz) = 510ca87bd91631c395655ee5029b291e948b33df09e56f6be5839f43e3104891
SIZE (lubridate_1.7.4.tar.gz) = 449850
Loading

0 comments on commit 8cc80a3

Please sign in to comment.