Skip to content

Commit

Permalink
*/*: sync with upstream
Browse files Browse the repository at this point in the history
Taken from: HardenedBSD
  • Loading branch information
fichtner committed Jun 26, 2017
1 parent ac3af08 commit a423f59
Show file tree
Hide file tree
Showing 437 changed files with 1,481 additions and 2,076 deletions.
2 changes: 1 addition & 1 deletion archivers/lua51-zlib/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -19,7 +19,7 @@ GH_PROJECT= lua-zlib
USES= lua:51

ALL_TARGET= bsd
MAKE_ENV+= LUAPATH="${LOCALBASE}"
MAKE_ENV+= LUAPATH="${LOCALBASE}"
MAKE_ENV+= LUACPATH="${STAGEDIR}${LUA_MODLIBDIR}"
MAKE_ENV+= INCDIR="-I${LUA_INCDIR}"
MAKE_ENV+= LUALIBDIR="-L${LUA_MODLIBDIR}"
Expand Down
2 changes: 1 addition & 1 deletion archivers/lua51-zlib/pkg-descr
Original file line number Diff line number Diff line change
Expand Up @@ -3,4 +3,4 @@ Language. It consists of two functions: inflate and deflate. Both functions
return "stream functions" (takes a buffer of input and returns a buffer
of output).

WWW: https://github.com/brimworks/lua-zlib/
WWW: https://github.com/brimworks/lua-zlib
1 change: 0 additions & 1 deletion archivers/p7zip/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -22,7 +22,6 @@ WRKSRC= ${WRKDIR}/${PORTNAME}_${PORTVERSION}

CFLAGS_aarch64= -fPIC
CFLAGS_amd64= -fPIC
CFLAGS_ia64= -fPIC
CFLAGS_powerpc= -fPIC
CFLAGS_sparc64= -fPIC

Expand Down
3 changes: 2 additions & 1 deletion archivers/par2cmdline-tbb/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -15,7 +15,8 @@ LICENSE= GPLv2

LIB_DEPENDS= libtbb.so:devel/tbb

ONLY_FOR_ARCHS= i386 amd64 ia64
ONLY_FOR_ARCHS= amd64 i386

GNU_CONFIGURE= yes
USES= autoreconf
CPPFLAGS+= -I${LOCALBASE}/include
Expand Down
2 changes: 1 addition & 1 deletion archivers/py-bz2file/pkg-descr
Original file line number Diff line number Diff line change
Expand Up @@ -4,4 +4,4 @@ It contains a drop-in replacement for the file interface in the standard
library's bz2 module, including features from the latest development version
of CPython that are not available in older releases.

WWW: https://github.com/nvawda/bz2file/
WWW: https://github.com/nvawda/bz2file
7 changes: 4 additions & 3 deletions archivers/rar/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -16,6 +16,9 @@ LICENSE_NAME= RAR license
LICENSE_FILE= ${WRKSRC}/license.txt
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept

BROKEN_powerpc= fails to install: File format not recognized
BROKEN_sparc64= fails to install: File format not recognized

RESTRICTED= only unmodified original package can be distributed
NO_BUILD= yes
WRKSRC= ${WRKDIR}/rar
Expand All @@ -29,9 +32,7 @@ SFX_DESC= SFX archive support (implies compat9x on FreeBSD 10 and up)

.include <bsd.port.pre.mk>

.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
BROKEN= fails to install on ia64/powerpc/sparc64: File format not recognized
.elif ${ARCH} == "amd64" || ${ARCH} == "ia64"
.if ${ARCH} == "amd64"
.if !defined(HAVE_COMPAT_IA32_KERN)
HAVE_COMPAT_IA32_KERN!= if ${SYSCTL} -n compat.ia32.maxvmem >/dev/null 2>&1; then ${ECHO_CMD} YES; fi
.endif
Expand Down
2 changes: 1 addition & 1 deletion astro/marble/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -10,7 +10,7 @@ COMMENT= Virtual globe and world atlas for KDE

LIB_DEPENDS= libquazip.so:archivers/quazip

USES= cmake:outsource gmake kde:4 shared-mime-info tar:xz
USES= cmake:outsource kde:4 shared-mime-info tar:xz
USE_KDE= kdelibs automoc4
USE_QT4= corelib dbus declarative designer_build gui network phonon \
qtestlib script sql svg webkit xml \
Expand Down
2 changes: 1 addition & 1 deletion audio/alac/pkg-descr
Original file line number Diff line number Diff line change
Expand Up @@ -9,4 +9,4 @@ encoder and decoder. Also included is an example command line utility, called
alacconvert, to read and write audio data to/from Core Audio Format (CAF) and
WAVE files.

WWW: https://github.com/mikebrady/alac/
WWW: https://github.com/mikebrady/alac
2 changes: 1 addition & 1 deletion audio/boodler/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -45,7 +45,7 @@ OSS_CONFIGURE_ON= --driver oss

.include <bsd.port.pre.mk>

.if ${ARCH} == "amd64" || ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
.if ${ARCH} == "amd64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
CONFIGURE_ARGS+= --PIC
.endif

Expand Down
6 changes: 3 additions & 3 deletions audio/csound/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -21,6 +21,8 @@ BUILD_DEPENDS= swig13>0:devel/swig13 \
gmm++>0:math/gmm++
LIB_DEPENDS= libsndfile.so:audio/libsndfile

BROKEN_powerpc64= Does not build

PORTSCOUT= limit:^5\.

CONFLICTS_INSTALL= outguess-* csound6
Expand Down Expand Up @@ -104,16 +106,14 @@ DOCS_DISTFILES= Csound${PORTVERSION:R}_manual_html.zip:manual

.include <bsd.port.pre.mk>

.if ${ARCH} == amd64 || ${ARCH} == sparc64 || ${ARCH} == ia64
.if ${ARCH} == amd64 || ${ARCH} == sparc64
MAKE_ARGS+= Word64=1
.endif

.if ${OPSYS} == FreeBSD
CXXLIB= c++
.endif

BROKEN_powerpc64= Does not build

post-patch:
@${SED} -e "s|%%LOCALBASE%%|${LOCALBASE}|g; \
s|%%PYTHON_INCLUDEDIR%%|${PYTHON_INCLUDEDIR}|" \
Expand Down
2 changes: 1 addition & 1 deletion audio/csound6/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -23,7 +23,7 @@ BUILD_DEPENDS= boost-libs>0:devel/boost-libs \
LIB_DEPENDS= libsamplerate.so:audio/libsamplerate \
libsndfile.so:audio/libsndfile

USES= alias bison cmake:outsource localbase python:2
USES= alias bison cmake:outsource,noninja localbase python:2
# math/gmm++ requires c++11
USE_CXXSTD= c++11
CMAKE_ARGS= -DBUILD_CSOUNDVST:BOOL=OFF \
Expand Down
2 changes: 1 addition & 1 deletion audio/fluidsynth/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -18,7 +18,7 @@ OPTIONS_DEFINE= JACK ALSA DBUS LADSPA LASH PORTAUDIO PULSEAUDIO READLINE \
OPTIONS_DEFAULT= JACK READLINE

USE_GNOME= glib20
USES= cmake pkgconfig ninja tar:bzip2
USES= cmake pkgconfig tar:bzip2
CMAKE_ARGS= -Denable-ladcca:BOOL=FALSE \
-Denable-midishare:BOOL=FALSE
USE_LDCONFIG= yes
Expand Down
2 changes: 1 addition & 1 deletion audio/gstreamer-plugins-sndio/pkg-descr
Original file line number Diff line number Diff line change
Expand Up @@ -4,4 +4,4 @@ to play and record through sndio.
This includes several games, audio players like Exaile, and audio
editors like Jokosher.

WWW: https://github.com/t6/gstreamer-plugins-sndio/
WWW: https://github.com/t6/gstreamer-plugins-sndio
2 changes: 1 addition & 1 deletion audio/libgme/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -11,7 +11,7 @@ COMMENT= Collection of video game music emulators

LICENSE= LGPL21+

USES= cmake dos2unix ninja tar:bzip2
USES= cmake dos2unix tar:bzip2
USE_LDCONFIG= yes

PORTDOCS= changes.txt design.txt gme.txt readme.txt
Expand Down
2 changes: 1 addition & 1 deletion audio/mps/pkg-descr
Original file line number Diff line number Diff line change
Expand Up @@ -8,4 +8,4 @@ Terminal based MP3 search, playback and download.
- No Python dependencies
- Requires mplayer or mpv

WWW: https://github.com/np1/mps/
WWW: https://github.com/np1/mps
3 changes: 0 additions & 3 deletions audio/openal/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -41,9 +41,6 @@ ALSA_LIB_DEPENDS= libasound.so:audio/alsa-lib
ALSA_CONFIGURE_ENABLE= alsa
ASM_BUILD_DEPENDS= nasm:devel/nasm

NOT_FOR_ARCHS= ia64
NOT_FOR_ARCHS_REASON_ia64= does not compile

post-patch:
@${REINPLACE_CMD} -e 's/x86_64\*/amd64\* | \*ia64\*/g; \
/CPPFLAGS=/ d; s/ \*linux\*)/ \*bsd\*)/' ${WRKSRC}/configure
Expand Down
2 changes: 1 addition & 1 deletion audio/pulseaudio-module-sndio/pkg-descr
Original file line number Diff line number Diff line change
@@ -1,3 +1,3 @@
A module for PulseAudio to support playing to sndio servers.

WWW: https://github.com/t6/pulseaudio-module-sndio/
WWW: https://github.com/t6/pulseaudio-module-sndio
2 changes: 1 addition & 1 deletion audio/py-speechrecognition/pkg-descr
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
SpeechRecognition is a Python library for performing speech recognition,
with support for several engines and APIs, online and offline.

WWW: https://github.com/Uberi/speech_recognition/
WWW: https://github.com/Uberi/speech_recognition
2 changes: 0 additions & 2 deletions audio/spiralsynthmodular/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -24,8 +24,6 @@ LIBS+= -L${LOCALBASE}/lib

WRKSRC= ${WRKDIR}/spiralmodular-0.2.2

BROKEN_ia64= Does not compile on ia64

OPTIONS_DEFINE= OPTIMIZED_CFLAGS

OPTIMIZED_CFLAGS_CFLAGS=-O3 -ffast-math
Expand Down
1 change: 0 additions & 1 deletion audio/xmms-sapplug/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -28,7 +28,6 @@ PLIST_FILES= lib/xmms/Input/libsap.so
OPTIONS_DEFINE= OPTIMIZED_CFLAGS

CFLAGS_amd64= -fpic -DPIC
CFLAGS_ia64= -fpic -DPIC

.include <bsd.port.pre.mk>

Expand Down
2 changes: 1 addition & 1 deletion benchmarks/wrk/pkg-descr
Original file line number Diff line number Diff line change
Expand Up @@ -2,4 +2,4 @@ wrk is a modern HTTP benchmarking tool capable of generating significant
load when run on a single multi-core CPU. It combines a multithreaded
design with scalable event notification systems such as epoll and kqueue.

WWW: https://github.com/wg/wrk/
WWW: https://github.com/wg/wrk
2 changes: 1 addition & 1 deletion biology/hmmer/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -30,7 +30,7 @@ OPTIONS_DEFINE= DOCS EXAMPLES
# HMMER is useless without SSE and any PC in use today should support it
# Should probably also do enable-vmx on Power processors to enable
# Altivec/VMX, but I don't have a machine to test this.
.if ${ARCH} == "amd64" || ${ARCH} == "ia64" || ${ARCH} == "i386"
.if ${ARCH} == "amd64" || ${ARCH} == "i386"
CONFIGURE_ARGS+=--enable-sse
.endif

Expand Down
2 changes: 1 addition & 1 deletion cad/elmerfem/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -28,7 +28,7 @@ CMAKE_ARGS+= -Wno-dev

.include <bsd.port.pre.mk>

.if ${ARCH} == "amd64" || ${ARCH} == "ia64"
.if ${ARCH} == "amd64"
CFLAGS_${ARCH}= -fPIC
CXXFLAGS_${ARCH}= -fPIC
FCFLAGS+= -fPIC
Expand Down
4 changes: 2 additions & 2 deletions cad/gmsh/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -2,8 +2,8 @@
# $FreeBSD$

PORTNAME= gmsh
PORTVERSION= 3.0.2
PORTREVISION= 2
PORTVERSION= 3.0.3
PORTREVISION= 0
CATEGORIES= cad
MASTER_SITES= http://gmsh.info/src/
DISTNAME= ${PORTNAME}-${PORTVERSION}-source
Expand Down
6 changes: 3 additions & 3 deletions cad/gmsh/distinfo
Original file line number Diff line number Diff line change
@@ -1,3 +1,3 @@
TIMESTAMP = 1494863913
SHA256 (gmsh/gmsh-3.0.2-source.tgz) = c0d9fe10f5f65a7b5a364cf9b9c300f42eb6f2c220c7d1ac2cf229deba35189c
SIZE (gmsh/gmsh-3.0.2-source.tgz) = 10872826
TIMESTAMP = 1498315953
SHA256 (gmsh/gmsh-3.0.3-source.tgz) = 4809b4a5c292ff74570b197c0da049aa3af7cd1d5b0950196391b0f20e183fbe
SIZE (gmsh/gmsh-3.0.3-source.tgz) = 10884399
1 change: 1 addition & 0 deletions cad/gmsh/pkg-plist
Original file line number Diff line number Diff line change
Expand Up @@ -250,6 +250,7 @@
%%SHARED%%include/gmsh/partitionFace.h
%%SHARED%%include/gmsh/partitionVertex.h
%%SHARED%%include/gmsh/periodical.h
%%SHARED%%include/gmsh/picojson.h
%%SHARED%%include/gmsh/pointsGenerators.h
%%SHARED%%include/gmsh/polynomialBasis.h
%%SHARED%%include/gmsh/simple3D.h
Expand Down
1 change: 0 additions & 1 deletion cad/kicad-devel/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,6 @@

PORTNAME= kicad
DISTVERSION= r${GIT_SRC_DATE}
PORTREVISION= 3
#PORTREVISION= 1
CATEGORIES= cad
MASTER_SITES= LOCAL/mr
Expand Down
4 changes: 2 additions & 2 deletions cad/kicad-devel/Makefile.git_rev
Original file line number Diff line number Diff line change
@@ -1,2 +1,2 @@
GIT_SRC_HASH= ac9a64a1736617846a479f825e535dcf8f786b38
GIT_SRC_DATE= 20170602115111
GIT_SRC_HASH= 0719b99ad81c16f06e4068c91210230d7703aeec
GIT_SRC_DATE= 20170624104526
6 changes: 3 additions & 3 deletions cad/kicad-devel/distinfo
Original file line number Diff line number Diff line change
@@ -1,3 +1,3 @@
TIMESTAMP = 1496501733
SHA256 (kicad/kicad-r20170602115111.tar.bz2) = 2966419d1b469adc46c3ced313cca584afb9bb279b2ce36bb00d1910df837063
SIZE (kicad/kicad-r20170602115111.tar.bz2) = 239926339
TIMESTAMP = 1498319256
SHA256 (kicad/kicad-r20170624104526.tar.bz2) = 285f97c5eb7537be9be535f74d9836d386723918a38d63bc8830e955a5039e89
SIZE (kicad/kicad-r20170624104526.tar.bz2) = 243515405
Loading

0 comments on commit a423f59

Please sign in to comment.