Skip to content

Commit

Permalink
*/*: sync with upstream
Browse files Browse the repository at this point in the history
Taken from: HardenedBSD
  • Loading branch information
fichtner committed Jan 12, 2018
1 parent bec182b commit a5f7e29
Show file tree
Hide file tree
Showing 341 changed files with 2,835 additions and 1,073 deletions.
19 changes: 9 additions & 10 deletions astro/xmoontool/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -10,26 +10,25 @@ MASTER_SITES= http://www.senax.net/xmoontool/
MAINTAINER= [email protected]
COMMENT= Version of John Walker's classical moontool for X11/Motif

OPTIONS_DEFINE= DOCS LIBNOVA MONOCHROME
OPTIONS_DEFAULT= LIBNOVA
LIBNOVA_DESC= libnova support
MONOCHROME_DESC= Use monochrome display

USES= motif
USE_XORG= x11 xt

PORTDOCS= NOTES
PLIST_FILES= bin/xmoontool man/man1/xmoontool.1.gz
PORTDOCS= NOTES

OPTIONS_DEFINE= DOCS LIBNOVA
OPTIONS_DEFAULT= LIBNOVA

LIBNOVA_DESC= High-accuracy astronomical model (libnova)
LIBNOVA_MAKE_ENV_OFF= WITHOUT_LIBNOVA=yes
LIBNOVA_LIB_DEPENDS= libnova.so:astro/libnova
MONOCHROME_MAKE_ENV= DEFINES=""

do-install:
${INSTALL_PROGRAM} ${WRKSRC}/xmoontool ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/xmoontool.1 ${STAGEDIR}${PREFIX}/man/man1

do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for i in ${PORTDOCS}
${INSTALL_MAN} ${WRKSRC}/${i} ${STAGEDIR}${DOCSDIR}
.endfor
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}

.include <bsd.port.mk>
7 changes: 5 additions & 2 deletions astro/xmoontool/files/patch-Makefile
Original file line number Diff line number Diff line change
@@ -1,8 +1,11 @@
--- Makefile.orig 2006-02-24 22:00:24 UTC
+++ Makefile
@@ -8,9 +8,9 @@ INSTALL?= install
@@ -6,11 +6,11 @@
RMCMD?= rm -f
INSTALL?= install
LOCALBASE?= /usr/local
X11BASE?= /usr/X11R6
-X11BASE?= /usr/X11R6
+X11BASE?= $(LOCALBASE)

-CC= gcc
-CFLAGS= -O2 -Wall
Expand Down
1 change: 0 additions & 1 deletion audio/autozen/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -13,7 +13,6 @@ COMMENT= Adjust brain waves with sound
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING


OPTIONS_DEFINE= DOCS

USES= shebangfix perl5 pkgconfig
Expand Down
10 changes: 6 additions & 4 deletions audio/chordpack/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -13,18 +13,20 @@ COMMENT= Script to convert ChordPro files to HTML, ASCII, and TeX
USES= shebangfix perl5 tar:tgz
SHEBANG_FILES= chordpack
USE_PERL5= run
NO_WRKSUBDIR= true
NO_BUILD= true
NO_WRKSUBDIR= yes
NO_BUILD= yes

OPTIONS_DEFINE= DOCS

do-install:
${INSTALL_SCRIPT} ${WRKSRC}/chordpack ${STAGEDIR}${PREFIX}/bin
@${MKDIR} ${STAGEDIR}${PREFIX}/share/emacs/site-lisp
${INSTALL_DATA} ${WRKSRC}/chordpro-mode.el \
${INSTALL_DATA} ${WRKSRC}/chordpro-mode.el \
${STAGEDIR}${PREFIX}/share/emacs/site-lisp

do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_MAN} ${WRKSRC}/chordpack-documentation.html \
${INSTALL_DATA} ${WRKSRC}/chordpack-documentation.html \
${STAGEDIR}${DOCSDIR}

.include <bsd.port.mk>
35 changes: 17 additions & 18 deletions audio/espeak/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -13,6 +13,15 @@ COMMENT= Software speech synthesizer

LICENSE= GPLv3

CONFLICTS= speak-1.[0-9]

USES= gmake zip
USE_LDCONFIG= yes
CXXFLAGS+= -I${LOCALBASE}/include

BUILD_WRKSRC= ${WRKSRC}/src
INSTALL_WRKSRC= ${WRKSRC}/src

OPTIONS_DEFINE= DOCS
OPTIONS_DEFAULT= PORTAUDIO
OPTIONS_RADIO= AUDIO_SYSTEM
Expand All @@ -34,30 +43,20 @@ PULSEAUDIO_MAKE_ENV= AUDIO="pulseaudio"
PORTAUDIO_MAKE_ENV= AUDIO="portaudio"
RUNTIME_MAKE_ENV= AUDIO="runtime"

CONFLICTS= speak-1.[0-9]

CXXFLAGS+= -I${LOCALBASE}/include
USES= gmake zip
USE_LDCONFIG= yes

WRKSRC= ${WRKDIR}/${DISTNAME}
BUILD_WRKSRC= ${WRKSRC}/src
INSTALL_WRKSRC= ${WRKSRC}/src

REINPLACE_FILES= Makefile speech.h
REINPLACE_ARGS= -i.bak -e "s|%%DATADIR%%|${DATADIR}|g"

BROKEN_sparc64= Does not compile on sparc64

.include <bsd.port.pre.mk>

post-patch:
cd ${BUILD_WRKSRC} && ${REINPLACE_CMD} ${REINPLACE_FILES}
${MV} ${WRKSRC}/src/portaudio19.h ${WRKSRC}/src/portaudio.h
@${REINPLACE_CMD} -e 's|%%DATADIR%%|${DATADIR}|' \
${WRKSRC}/src/Makefile ${WRKSRC}/src/speech.h
@${MV} ${WRKSRC}/src/portaudio19.h ${WRKSRC}/src/portaudio.h
.if ${ARCH} == sparc64 # cf. http://seclists.org/tcpdump/2012/q4/112
@${REINPLACE_CMD} -e 's|-fpic|-fPIC|' ${WRKSRC}/src/Makefile
.endif

post-install:
${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC}/docs && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libespeak.so*

.include <bsd.port.mk>
.include <bsd.port.post.mk>
1 change: 0 additions & 1 deletion audio/ezstream/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -41,7 +41,6 @@ TAGLIB_CONFIGURE_ON= --with-taglib=${LOCALBASE}

.include <bsd.port.options.mk>


post-patch:
@${REINPLACE_CMD} -e '/^SUBDIRS =/s|examples||g ; \
s|: install-dist_docDATA|:|g' ${WRKSRC}/Makefile.in
Expand Down
20 changes: 10 additions & 10 deletions audio/festival-freebsoft-utils/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -9,25 +9,25 @@ MASTER_SITES= http://www.freebsoft.org/pub/projects/${PORTNAME}/
MAINTAINER= [email protected]
COMMENT= Festival utilities focused on interaction with Speech Dispatcher

OPTIONS_DEFINE= DOCS

RUN_DEPENDS= festival:audio/festival \
sox:audio/sox

NO_BUILD= yes
USES= iconv

INFO= ${PORTNAME}
PORTDOCS= ANNOUNCE NEWS README

INFO= ${PORTNAME}
OPTIONS_DEFINE= DOCS

do-install:
${MKDIR} ${STAGEDIR}${PREFIX}/share/festival/lib
cd ${WRKSRC} && ${INSTALL_DATA} *.scm ${STAGEDIR}${PREFIX}/share/festival/lib
cd ${WRKSRC}/doc && ${INSTALL_MAN} ${PORTNAME}.info ${STAGEDIR}${PREFIX}/${INFO_PATH}
${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in ${PORTDOCS}
${INSTALL_MAN} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor
@${MKDIR} ${STAGEDIR}${PREFIX}/share/festival/lib
${INSTALL_DATA} ${WRKSRC}/*.scm ${STAGEDIR}${PREFIX}/share/festival/lib
${INSTALL_DATA} ${WRKSRC}/doc/${PORTNAME}.info \
${STAGEDIR}${PREFIX}/${INFO_PATH}

do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}

.include <bsd.port.mk>
1 change: 0 additions & 1 deletion audio/firefly/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -74,5 +74,4 @@ post-install-DOCS-on:
${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${DOCSDIR}
.endfor


.include <bsd.port.mk>
1 change: 1 addition & 0 deletions audio/polyphone/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -3,6 +3,7 @@
PORTNAME= polyphone
DISTVERSION= 1.8
DISTVERSIONSUFFIX= -src
PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= http://polyphone-soundfonts.com/en/download/file/76-polyphone-1-8-src-zip/latest/download?ae95d968569b61bc77f7b8559a14db4d=1/

Expand Down
4 changes: 2 additions & 2 deletions audio/py-soundcloud/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -8,7 +8,7 @@ MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}

MAINTAINER= [email protected]
COMMENT= A friendly wrapper library for the Soundcloud API
COMMENT= Friendly wrapper library for the Soundcloud API

LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
Expand All @@ -23,7 +23,7 @@ DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}

post-install:
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_MAN} ${WRKSRC}/README.rst ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README.rst ${STAGEDIR}${DOCSDIR}

do-test:
cd ${WRKSRC} ; nosetests --with-doctest
Expand Down
1 change: 0 additions & 1 deletion audio/pytone/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -18,7 +18,6 @@ LIB_DEPENDS= libao.so:audio/libao
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}mutagen>0:audio/py-mutagen@${FLAVOR}


USES= ncurses python:2
USE_PYTHON= autoplist distutils

Expand Down
8 changes: 4 additions & 4 deletions audio/rtmidi/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -2,8 +2,8 @@
# $FreeBSD$

PORTNAME= rtmidi
DISTVERSION= 2.1.1-38
DISTVERSIONSUFFIX= -g907a94c
DISTVERSIONPREFIX= v
DISTVERSION= 3.0.0
CATEGORIES= audio

MAINTAINER= [email protected]
Expand All @@ -13,11 +13,11 @@ LICENSE= MIT

LIB_DEPENDS= libjack.so:audio/jack

USES= autoreconf localbase libtool
USES= autoreconf libtool localbase
GNU_CONFIGURE= yes
USE_GITHUB= yes
GH_ACCOUNT= thestk
CONFIGURE_ARGS= --with-jack
CONFIGURE_ARGS= --with-jack --disable-static
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip

Expand Down
6 changes: 3 additions & 3 deletions audio/rtmidi/distinfo
Original file line number Diff line number Diff line change
@@ -1,3 +1,3 @@
TIMESTAMP = 1503103513
SHA256 (thestk-rtmidi-2.1.1-38-g907a94c_GH0.tar.gz) = 6906d2ac6405eff4a0183307d16c9cf2fd6d9ec1958384d2195e4b47eb309de7
SIZE (thestk-rtmidi-2.1.1-38-g907a94c_GH0.tar.gz) = 80635
TIMESTAMP = 1515648219
SHA256 (thestk-rtmidi-v3.0.0_GH0.tar.gz) = 55cd0fba60321aadcd847481d207bf2b70e783b5bfa1a01037bf916554a7d5c4
SIZE (thestk-rtmidi-v3.0.0_GH0.tar.gz) = 82839
54 changes: 14 additions & 40 deletions audio/rtmidi/files/patch-configure.ac
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
--- configure.ac.orig 2017-04-21 15:27:54 UTC
--- configure.ac.orig 2017-09-01 00:10:07 UTC
+++ configure.ac
@@ -65,7 +65,7 @@ AC_MSG_CHECKING(whether to compile debug
@@ -72,7 +72,7 @@ AC_MSG_CHECKING(whether to compile debug
AC_ARG_ENABLE(debug,
[ --enable-debug = enable various debug output],
[AC_SUBST( cppflag, [-D__RTMIDI_DEBUG__] ) AC_SUBST( cxxflag, [-g] ) AC_SUBST( object_path, [Debug] ) AC_MSG_RESULT(yes)],
Expand All @@ -9,7 +9,7 @@

# Set paths if prefix is defined
if test "x$prefix" != "x" && test "x$prefix" != "xNONE"; then
@@ -78,7 +78,7 @@ CPPFLAGS="$CPPFLAGS $cppflag"
@@ -85,7 +85,7 @@ CPPFLAGS="$CPPFLAGS $cppflag"

# For debugging and optimization ... overwrite default because it has both -g and -O2
#CXXFLAGS="$CXXFLAGS $cxxflag"
Expand All @@ -18,41 +18,15 @@

# Check compiler and use -Wall if gnu.
if [test $GXX = "yes" ;] then
@@ -105,25 +105,25 @@ AC_SUBST( api, [""] )
AC_SUBST( req, [""] )
AC_MSG_CHECKING(for MIDI API)
case $host in
- *-*-linux*)
+ *-*-freebsd*)
AC_ARG_WITH(jack, [ --with-jack = choose JACK server support (mac and linux only)], [
api="$api -D__UNIX_JACK__"
AC_MSG_RESULT(using JACK)
AC_CHECK_LIB(jack, jack_client_open, , AC_MSG_ERROR(JACK support requires the jack library!))], )

# Look for ALSA flag
- AC_ARG_WITH(alsa, [ --with-alsa = choose native ALSA sequencer API support (linux only)], [
- api="$api -D__LINUX_ALSA__"
- req="$req alsa"
- AC_MSG_RESULT(using ALSA)
- AC_CHECK_LIB(asound, snd_seq_open, , AC_MSG_ERROR(ALSA support requires the asound library!))], )
+ #AC_ARG_WITH(alsa, [ --with-alsa = choose native ALSA sequencer API support (linux only)], [
+ # api="$api -D__LINUX_ALSA__"
+ # req="$req alsa"
+ # AC_MSG_RESULT(using ALSA)
+ # AC_CHECK_LIB(asound, snd_seq_open, , AC_MSG_ERROR(ALSA support requires the asound library!))], )

- if [test "$api" == "";] then
- AC_MSG_RESULT(using ALSA)
- AC_SUBST( api, [-D__LINUX_ALSA__] )
- req="$req alsa"
- AC_CHECK_LIB(asound, snd_seq_open, , AC_MSG_ERROR(ALSA sequencer support requires the asound library!))
- fi
+ #if [test "$api" == "";] then
+ # AC_MSG_RESULT(using ALSA)
+ # AC_SUBST( api, [-D__LINUX_ALSA__] )
+ # req="$req alsa"
+ # AC_CHECK_LIB(asound, snd_seq_open, , AC_MSG_ERROR(ALSA sequencer support requires the asound library!))
+ #fi

# Checks for pthread library.
@@ -139,6 +139,11 @@ case $host in
AC_CHECK_LIB(pthread, pthread_create, , AC_MSG_ERROR(RtMidi requires the pthread library!))
;;

+ *-*-freebsd*)
+ # Checks for pthread library.
+ AC_CHECK_LIB(pthread, pthread_create, , AC_MSG_ERROR(RtMidi requires the pthread library!))
+ ;;
+
*-apple*)
# Look for Core flag
AC_ARG_WITH(core, [ --with-core = choose CoreMidi API support (mac only)])
5 changes: 2 additions & 3 deletions audio/rtmidi/pkg-plist
Original file line number Diff line number Diff line change
@@ -1,7 +1,6 @@
include/rtmidi/RtMidi.h
include/rtmidi/rtmidi_c.h
lib/librtmidi.a
lib/librtmidi.so
lib/librtmidi.so.3
lib/librtmidi.so.3.0.0
lib/librtmidi.so.4
lib/librtmidi.so.4.0.0
libdata/pkgconfig/rtmidi.pc
11 changes: 6 additions & 5 deletions benchmarks/httperf/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -19,16 +19,17 @@ MAKE_ARGS= LIBUTIL_OBJS=ssl_writev.o \

PLIST_FILES= bin/httperf \
man/man1/httperf.1.gz
PORTDOCS= ChangeLog NEWS README TODO

OPTIONS_DEFINE= DOCS
PORTDOCS= ChangeLog NEWS README TODO

do-install:
${INSTALL_MAN} ${WRKSRC}/man/${PORTNAME}.1 ${STAGEDIR}${MAN1PREFIX}/man/man1/
${INSTALL_MAN} ${WRKSRC}/man/${PORTNAME}.1 \
${STAGEDIR}${MAN1PREFIX}/man/man1
${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/

do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for file in ${PORTDOCS}
${INSTALL_MAN} ${WRKSRC}/${file} ${STAGEDIR}${DOCSDIR}
.endfor
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}

.include <bsd.port.mk>
6 changes: 4 additions & 2 deletions biology/velvet/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -77,7 +77,9 @@ do-install:
.for f in ${PERLMOD_FILES}
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${PREFIX}/${SITE_PERL_REL}/${f:H:T}/${f:T}
.endfor
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_MAN} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}

do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}

.include <bsd.port.mk>
2 changes: 1 addition & 1 deletion comms/py-bulksms/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -21,6 +21,6 @@ OPTIONS_DEFINE= DOCS

post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
@${INSTALL_MAN} ${WRKSRC}/README.html ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README.html ${STAGEDIR}${DOCSDIR}

.include <bsd.port.mk>
2 changes: 1 addition & 1 deletion comms/sredird/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -23,6 +23,6 @@ do-install:

do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_MAN} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}

.include <bsd.port.mk>
2 changes: 1 addition & 1 deletion comms/tcpser/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -25,6 +25,6 @@ do-install:

do-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_MAN} ${WRKSRC}/README ${WRKSRC}/CHANGES ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${WRKSRC}/CHANGES ${STAGEDIR}${DOCSDIR}

.include <bsd.port.mk>
Loading

0 comments on commit a5f7e29

Please sign in to comment.