forked from opnsense/ports
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Taken from: HardenedBSD
- Loading branch information
Showing
293 changed files
with
14,350 additions
and
22,369 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,40 +1,39 @@ | ||
# Created by: Andrew Pantyukhin <[email protected]> | ||
# $FreeBSD$ | ||
|
||
PORTNAME= exaile | ||
PORTVERSION= 3.4.5 | ||
PORTVERSION= 4.0.0 | ||
PORTREVISION= 1 | ||
CATEGORIES= audio | ||
MASTER_SITES= https://github.com/exaile/exaile/releases/download/${PORTVERSION}/ | ||
|
||
MAINTAINER= [email protected] | ||
COMMENT= Full featured python-based music player for GTK+ | ||
|
||
LICENSE= GPLv2 | ||
LICENSE_FILE= ${WRKSRC}/COPYING | ||
|
||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mutagen>=1.11:audio/py-mutagen@${PY_FLAVOR} | ||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mutagen>0:audio/py-mutagen@${PY_FLAVOR} \ | ||
${PYTHON_PKGNAMEPREFIX}gstreamer1>0:multimedia/py-gstreamer1@${PY_FLAVOR} \ | ||
${PYTHON_PKGNAMEPREFIX}dbus>0:devel/py-dbus@${PY_FLAVOR} \ | ||
${PYTHON_PKGNAMEPREFIX}bsddb3>0:databases/py-bsddb3@${PY_FLAVOR} | ||
|
||
MAKE_ENV+= PYTHON2_CMD=${PYTHON_CMD} XDGCONFDIR=${PREFIX}/etc/xdg | ||
USE_GITHUB= yes | ||
|
||
NO_ARCH= yes | ||
USES= desktop-file-utils gmake gnome python:2.7 | ||
USE_GNOME= pygtk2 librsvg2 | ||
USE_GSTREAMER= good faad python | ||
|
||
OPTIONS_DEFINE= BAD CDDB DBUS HAL NOTIFY NLS SEXY | ||
OPTIONS_DEFAULT= BAD CDDB DBUS HAL NOTIFY SEXY | ||
OPTIONS_SUB= yes | ||
BAD_DESC= Install bad GStreamer plugins | ||
BAD_USE= GSTREAMER=bad | ||
CDDB_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cddb>=1.4:audio/py-cddb@${PY_FLAVOR} | ||
DBUS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dbus>=0.82.1:devel/py-dbus@${PY_FLAVOR} | ||
HAL_LIB_DEPENDS= libhal.so:sysutils/hal | ||
NOTIFY_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}notify>=0.1.1:devel/py-notify@${PY_FLAVOR} | ||
NLS_USES= gettext | ||
USE_GNOME= gtk30 librsvg2 pygobject3 | ||
USE_GSTREAMER1= good faad | ||
OPTIONS_DEFINE= DOCS NLS UDISKS2 CDDB | ||
OPTIONS_SUB= yes | ||
NLS_USES= gettext | ||
NLS_BUILD_DEPENDS= help2man:misc/help2man | ||
NLS_INSTALL_TARGET_OFF= install_no_locale | ||
SEXY_DESC= UI enchancements | ||
SEXY_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sexy>=0.1.9:x11-toolkits/py-sexy@${PY_FLAVOR} | ||
|
||
post-patch: | ||
@${REINPLACE_CMD} -e 's|share/man|man|g' ${WRKSRC}/Makefile | ||
CDDB_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cddb>0:audio/py-cddb@${PY_FLAVOR} | ||
UDISKS2_DESC= UDISKS2 implementation for hardware detection | ||
UDISKS2_RUN_DEPENDS= ${LOCALBASE}bin/bsdisks:sysutils/bsdisks | ||
|
||
MAKE_ENV= EPREFIX=${PREFIX} \ | ||
PYTHON2_CMD=${PYTHON_CMD} \ | ||
XDGCONFDIR=${PREFIX}/etc/xdg \ | ||
MANPREFIX=${PREFIX} | ||
|
||
.include <bsd.port.mk> |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
SHA256 (exaile-3.4.5.tar.gz) = 53149eb7c8d8e126502717bff49832825e5f0e8f83d9983b604207853250007b | ||
SIZE (exaile-3.4.5.tar.gz) = 3734454 | ||
TIMESTAMP = 1577368774 | ||
SHA256 (exaile-exaile-4.0.0_GH0.tar.gz) = 32d3508ee72db0a0ca3a31155e5ef5fb7d3ec4ac0a09268ee37fb85ca0b74dfb | ||
SIZE (exaile-exaile-4.0.0_GH0.tar.gz) = 3578395 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,28 @@ | ||
--- Makefile.orig 2018-02-09 15:54:09 UTC | ||
+++ Makefile | ||
@@ -6,7 +6,7 @@ EPREFIX = $(PREFIX) | ||
|
||
LIBINSTALLDIR = $(EPREFIX)/lib | ||
DATADIR = $(PREFIX)/share | ||
-MANPREFIX = $(PREFIX)/share | ||
+MANPREFIX ?= $(PREFIX)/share | ||
# /etc if PREFIX is /usr, $PREFIX/etc otherwise. | ||
ETCDIR := $(shell [ "$(PREFIX)" = "/usr" ] && echo /etc || echo "$(PREFIX)/etc") | ||
XDGCONFDIR = $(ETCDIR)/xdg | ||
@@ -23,6 +23,7 @@ EXAILELIBDIR = $(DESTDIR)$(LIBINSTALLDIR)/exaile | ||
EXAILESHAREDIR = $(DESTDIR)$(DATADIR)/exaile | ||
EXAILECONFDIR = $(DESTDIR)$(XDGCONFDIR)/exaile | ||
EXAILEMANDIR = $(DESTDIR)$(MANPREFIX)/man | ||
+BASHCOMPDIR = $(ETCDIR)/bash_completion.d | ||
|
||
.PHONY: all all_no_locale builddir compile make-install-dirs uninstall \ | ||
install install_no_locale install-target locale install-locale \ | ||
@@ -206,7 +207,7 @@ po/messages.pot: pot | ||
# dash (Debian's /bin/sh) doesn't support it and exits immediately, so we test it in a subshell. | ||
# The "export LC_ALL=C" disables any locale-dependent sort behavior. | ||
pot: | ||
- ( ( set -o pipefail 2> /dev/null ) && set -o pipefail ; \ | ||
+ ( \ | ||
export LC_ALL=C && cd po && \ | ||
{ find ../xl ../xlgui -name "*.py" | sort && \ | ||
find ../data/ui -name "*.ui" | sort && \ |
Oops, something went wrong.