forked from opnsense/ports
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Taken from: HardenedBSD
- Loading branch information
Showing
490 changed files
with
5,455 additions
and
2,433 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,8 +1,7 @@ | ||
# Created by: Muhammad Moinur Rahman <[email protected]> | ||
|
||
PORTNAME= qmapshack | ||
PORTVERSION= 1.15.2 | ||
PORTREVISION= 1 | ||
PORTVERSION= 1.16.0 | ||
DISTVERSIONPREFIX= V_ | ||
CATEGORIES= astro | ||
|
||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,3 @@ | ||
TIMESTAMP = 1610218166 | ||
SHA256 (Maproom-qmapshack-V_1.15.2_GH0.tar.gz) = 35831d703ef3decc83f168a020144ec89907f484485b242be24fd2e094898857 | ||
SIZE (Maproom-qmapshack-V_1.15.2_GH0.tar.gz) = 46899954 | ||
TIMESTAMP = 1621864013 | ||
SHA256 (Maproom-qmapshack-V_1.16.0_GH0.tar.gz) = 0beae1063fc17c033e6084ea71bc0cc95de505f6fc04da9cf8b70f8003df4302 | ||
SIZE (Maproom-qmapshack-V_1.16.0_GH0.tar.gz) = 54233332 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,26 +1,22 @@ | ||
--- CMakeLists.txt.orig 2020-06-14 10:22:49 UTC | ||
--- CMakeLists.txt.orig 2021-05-24 09:18:08 UTC | ||
+++ CMakeLists.txt | ||
@@ -65,6 +65,7 @@ include(TranslateDesktop) | ||
@@ -47,6 +47,7 @@ include(TranslateDesktop) | ||
include(DefineCMakeDefaults) | ||
include(DefineCompilerFlags) | ||
include(DefineInstallationPaths) | ||
+include(FindPkgConfig) | ||
include(CPackConfig.cmake) | ||
include(ConfigureChecks.cmake) | ||
|
||
@@ -167,10 +168,13 @@ find_package(Qt5WebEngineWidgets REQUIRED) | ||
@@ -151,7 +152,10 @@ find_package(Qt5WebEngineWidgets REQUIRED) | ||
find_package(Qt5Qml REQUIRED) | ||
find_package(Qt5Help REQUIRED) | ||
find_package(GDAL REQUIRED) | ||
-find_package(PROJ4 REQUIRED) | ||
+find_package(PROJ4) | ||
+if (NOT PROJ4_FOUND) | ||
+ pkg_search_module(PROJ4 REQUIRED proj) | ||
-find_package(PROJ REQUIRED) | ||
+find_package(PROJ) | ||
+if (NOT PROJ_FOUND) | ||
+ pkg_search_module(PROJ REQUIRED proj) | ||
+endif() | ||
find_package(JPEG REQUIRED) | ||
find_package(ROUTINO REQUIRED) | ||
-find_package(QuaZip5 REQUIRED) | ||
+find_package(QuaZip-Qt5 REQUIRED) | ||
find_package(ALGLIB ) # optional as we can use our local version | ||
|
||
|
||
find_package(QuaZip-Qt5 REQUIRED) |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,25 +1,11 @@ | ||
--- src/qmapshack/CMakeLists.txt.orig 2020-06-14 10:22:49 UTC | ||
--- src/qmapshack/CMakeLists.txt.orig 2021-05-24 14:06:57 UTC | ||
+++ src/qmapshack/CMakeLists.txt | ||
@@ -897,7 +897,6 @@ include_directories( | ||
${PROJ4_INCLUDE_DIRS} | ||
${ROUTINO_INCLUDE_DIRS} | ||
${ALGLIB_INCLUDE_DIRS} | ||
- ${QUAZIP_INCLUDE_DIRS} | ||
) | ||
|
||
if(APPLE) | ||
@@ -941,12 +940,12 @@ target_link_libraries(${APPLICATION_NAME} | ||
Qt5::Qml | ||
Qt5::Positioning | ||
@@ -971,7 +971,7 @@ target_link_libraries(${APPLICATION_NAME} | ||
Qt5::Help | ||
+ QuaZip::QuaZip | ||
${DBUS_LIB} | ||
${GDAL_LIBRARIES} | ||
- ${PROJ4_LIBRARIES} | ||
+ ${PROJ4_LDFLAGS} ${PROJ4_LIBRARIES} | ||
- ${PROJ_LIBRARIES} | ||
+ ${PROJ_LDFLAGS} ${PROJ_LIBRARIES} | ||
${ROUTINO_LIBRARIES} | ||
${ALGLIB_LIBRARIES} | ||
- ${QUAZIP_LIBRARIES} | ||
) | ||
|
||
if(APPLE) | ||
QuaZip::QuaZip |
4 changes: 2 additions & 2 deletions
4
astro/qmapshack/files/patch-src_qmapshack_device_CDeviceWatcherLinux.cpp
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
8 changes: 4 additions & 4 deletions
8
.../qmapshack/files/patch-src_qmapshack_gis_rte_router_brouter_CRouterBRouterSetupWizard.cpp
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,11 +1,11 @@ | ||
--- src/qmapshack/gis/rte/router/brouter/CRouterBRouterSetupWizard.cpp.orig 2020-11-08 17:59:37 UTC | ||
--- src/qmapshack/gis/rte/router/brouter/CRouterBRouterSetupWizard.cpp.orig 2021-05-24 09:18:08 UTC | ||
+++ src/qmapshack/gis/rte/router/brouter/CRouterBRouterSetupWizard.cpp | ||
@@ -22,7 +22,7 @@ | ||
#include "gis/rte/router/brouter/CRouterBRouterSetupWizard.h" | ||
@@ -24,7 +24,7 @@ | ||
#include "helpers/CWebPage.h" | ||
#include "setup/IAppSetup.h" | ||
|
||
-#include <JlCompress.h> | ||
+#include <quazip/JlCompress.h> | ||
#include <proj_api.h> | ||
#include <QFileDialog> | ||
#include <QMessageBox> | ||
#include <QNetworkReply> |
6 changes: 3 additions & 3 deletions
6
astro/qmapshack/files/patch-src_qmapshack_gis_wpt_CGisItemWpt.cpp
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
8 changes: 4 additions & 4 deletions
8
astro/qmapshack/files/patch-src_qmapshack_mouse_IMouseSelect.cpp
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,10 +1,10 @@ | ||
--- src/qmapshack/mouse/IMouseSelect.cpp.orig 2020-05-21 11:11:11 UTC | ||
--- src/qmapshack/mouse/IMouseSelect.cpp.orig 2021-05-24 09:18:08 UTC | ||
+++ src/qmapshack/mouse/IMouseSelect.cpp | ||
@@ -23,6 +23,7 @@ | ||
#include "mouse/IScrOpt.h" | ||
@@ -24,6 +24,7 @@ | ||
|
||
#include <QPainterPath> | ||
#include <QtWidgets> | ||
+#include <QPainterPath> | ||
|
||
IMouseSelect::IMouseSelect(CGisDraw *gis, CCanvas *canvas, CMouseAdapter *mouse) | ||
IMouseSelect::IMouseSelect(CGisDraw* gis, CCanvas* canvas, CMouseAdapter* mouse) | ||
: IMouse(gis, canvas, mouse) |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,11 +1,11 @@ | ||
--- src/qmaptool/CMakeLists.txt.orig 2020-03-27 08:07:31 UTC | ||
--- src/qmaptool/CMakeLists.txt.orig 2021-05-24 09:18:08 UTC | ||
+++ src/qmaptool/CMakeLists.txt | ||
@@ -254,7 +254,7 @@ target_link_libraries(${APPLICATION_NAME} | ||
@@ -259,7 +259,7 @@ target_link_libraries(${APPLICATION_NAME} | ||
Qt5::Network | ||
Qt5::Help | ||
${GDAL_LIBRARIES} | ||
- ${PROJ4_LIBRARIES} | ||
+ ${PROJ4_LDFLAGS} ${PROJ4_LIBRARIES} | ||
- ${PROJ_LIBRARIES} | ||
+ ${PROJ_LDFLAGS} ${PROJ_LIBRARIES} | ||
) | ||
|
||
if(APPLE) |
16 changes: 8 additions & 8 deletions
16
astro/qmapshack/files/patch-src_qmt__map2jnx_CMakeLists.txt
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,11 +1,11 @@ | ||
--- src/qmt_map2jnx/CMakeLists.txt.orig 2020-03-27 08:07:31 UTC | ||
--- src/qmt_map2jnx/CMakeLists.txt.orig 2021-05-24 09:18:08 UTC | ||
+++ src/qmt_map2jnx/CMakeLists.txt | ||
@@ -48,7 +48,7 @@ IF(WIN32) | ||
ADD_DEFINITIONS(-D_CRT_SECURE_NO_DEPRECATE) | ||
ENDIF(WIN32) | ||
|
||
-TARGET_LINK_LIBRARIES(${APPLICATION_NAME} ${GDAL_LIBRARIES} ${PROJ4_LIBRARIES} ${JPEG_LIBRARIES}) | ||
+TARGET_LINK_LIBRARIES(${APPLICATION_NAME} ${GDAL_LIBRARIES} ${PROJ4_LDFLAGS} ${PROJ4_LIBRARIES} ${JPEG_LIBRARIES}) | ||
@@ -53,7 +53,7 @@ TARGET_LINK_LIBRARIES(${APPLICATION_NAME} | ||
Qt5::Core | ||
Qt5::Gui | ||
${GDAL_LIBRARIES} | ||
- ${PROJ_LIBRARIES} | ||
+ ${PROJ_LDFLAGS} ${PROJ_LIBRARIES} | ||
${JPEG_LIBRARIES}) | ||
|
||
install( | ||
TARGETS ${APPLICATION_NAME} DESTINATION ${BIN_INSTALL_DIR} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,11 +1,11 @@ | ||
--- src/qmt_rgb2pct/CMakeLists.txt.orig 2020-03-27 08:07:31 UTC | ||
--- src/qmt_rgb2pct/CMakeLists.txt.orig 2021-05-24 09:18:08 UTC | ||
+++ src/qmt_rgb2pct/CMakeLists.txt | ||
@@ -92,7 +92,7 @@ target_compile_definitions(${APPLICATION_NAME} PUBLIC | ||
target_link_libraries(${APPLICATION_NAME} | ||
Qt5::Core | ||
${GDAL_LIBRARIES} | ||
- ${PROJ4_LIBRARIES} | ||
+ ${PROJ4_LDFLAGS} ${PROJ4_LIBRARIES} | ||
- ${PROJ_LIBRARIES} | ||
+ ${PROJ_LDFLAGS} ${PROJ_LIBRARIES} | ||
) | ||
|
||
if(APPLE) |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,11 +1,11 @@ | ||
PORTNAME= Carla | ||
DISTVERSIONPREFIX= v | ||
DISTVERSION= 2.2.0 | ||
PORTREVISION= 6 | ||
DISTVERSION= 2.3.0 | ||
PORTREVISION= 1 | ||
CATEGORIES= audio | ||
|
||
MAINTAINER= [email protected] | ||
COMMENT= Audio LV2 plugin host for Jack and PulseAudio | ||
COMMENT= Audio plugin host for Jack and PulseAudio | ||
|
||
LICENSE= GPLv2 | ||
LICENSE_FILE= ${WRKSRC}/doc/GPL.txt | ||
|
@@ -19,16 +19,17 @@ CONFLICTS_BUILD= rtaudio-* rtmidi-* | |
USES= compiler:c++11-lib desktop-file-utils gl gmake gnome localbase \ | ||
pkgconfig pyqt:5 python:3.4+ qt:5 shared-mime-info shebangfix \ | ||
tar:bz2 xorg | ||
USE_GITHUB= yes | ||
GH_ACCOUNT= falkTX | ||
USE_PYQT= core_run gui_run sip svg_run widgets_run xml_build # "sip" should be "sip_build", but "import PyQt5.QtCore" wants "sip". See bug#225040 | ||
USE_GNOME= gtk20 gtk30 | ||
USE_QT= core gui widgets buildtools_build | ||
USE_GL= gl | ||
USE_XORG= x11 | ||
USE_LDCONFIG= ${PREFIX}/lib/carla | ||
|
||
SHEBANG_FILES= data/carla-single data/carla-bridge-lv2-modgui source/native-plugins/resources/* source/frontend/* | ||
|
||
USE_GITHUB= yes | ||
GH_ACCOUNT= falkTX | ||
|
||
MAKE_ARGS= HAVE_QT4=false \ | ||
EXTERNAL_PLUGINS=false \ | ||
# Give the Makefile the proper versioned binaries of PyQt | ||
|
@@ -42,15 +43,21 @@ OPTIONS_DEFAULT= FFMPEG FLUIDSYNTH JACK LINUXSAMPLER | |
OPTIONS_MULTI= BACKEND | ||
OPTIONS_MULTI_BACKEND= JACK PULSEAUDIO | ||
BACKEND_DESC= Audio backend | ||
LINUXSAMPLER_DESC= Use LinuxSampler: a software audio sampler | ||
|
||
FFMPEG_LIB_DEPENDS= libavutil.so:multimedia/ffmpeg | ||
FFMPEG_MAKE_ARGS_OFF= HAVE_FFMPEG=false | ||
|
||
FLUIDSYNTH_LIB_DEPENDS= libfluidsynth.so:audio/fluidsynth | ||
FLUIDSYNTH_MAKE_ARGS_OFF= HAVE_FLUIDSYNTH=false | ||
|
||
LINUXSAMPLER_DESC= Use LinuxSampler: a software audio sampler | ||
LINUXSAMPLER_LIB_DEPENDS= liblinuxsampler.so:audio/linuxsampler | ||
LINUXSAMPLER_MAKE_ARGS_OFF= HAVE_LINUXSAMPLER=false | ||
|
||
JACK_BUILD_DEPENDS= jackit>0:audio/jack | ||
JACK_RUN_DEPENDS= ${LOCALBASE}/lib/libjack.so:audio/jack | ||
JACK_MAKE_ARGS_OFF= HAVE_JACK=false | ||
|
||
PULSEAUDIO_LIB_DEPENDS= libpulse-simple.so:audio/pulseaudio | ||
PULSEAUDIO_MAKE_ARGS_OFF= HAVE_PULSEAUDIO=false | ||
|
||
|
@@ -59,6 +66,7 @@ post-install: | |
s|^PYTHON=.*|PYTHON=${PYTHON_CMD}|; \ | ||
s|#!/bin/bash|#!/bin/sh|' \ | ||
${STAGEDIR}${PREFIX}/bin/carla* | ||
${RMDIR} ${STAGEDIR}${PREFIX}/share/carla/resources/translations | ||
|
||
devel-features: patch | ||
@${ECHO} "Developer command: show build features" | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,3 @@ | ||
TIMESTAMP = 1601438699 | ||
SHA256 (falkTX-Carla-v2.2.0_GH0.tar.gz) = 4bf08511257db88979eccc002f10c153ff2a14f5143291c2be39cadd69ce10e1 | ||
SIZE (falkTX-Carla-v2.2.0_GH0.tar.gz) = 9844747 | ||
TIMESTAMP = 1621894202 | ||
SHA256 (falkTX-Carla-v2.3.0_GH0.tar.gz) = 27def29cc408d5c74926e8d0ef3a77fd76fee1e4f2797f840e999e6376a5be03 | ||
SIZE (falkTX-Carla-v2.3.0_GH0.tar.gz) = 10014487 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,46 @@ | ||
--- source/modules/AppConfig.h.orig 2021-03-21 01:16:46 UTC | ||
+++ source/modules/AppConfig.h | ||
@@ -29,13 +29,15 @@ | ||
# define APPCONFIG_OS_MAC | ||
#elif defined(__linux__) || defined(__linux) | ||
# define APPCONFIG_OS_LINUX | ||
+#elif defined(__FreeBSD__) | ||
+# define APPCONFIG_OS_FREEBSD | ||
#else | ||
# error Unsupported platform! | ||
#endif | ||
|
||
#if defined(APPCONFIG_OS_WIN32) || defined(APPCONFIG_OS_WIN64) | ||
# define APPCONFIG_OS_WIN | ||
-#elif defined(APPCONFIG_OS_LINUX) || defined(APPCONFIG_OS_MAC) | ||
+#elif defined(APPCONFIG_OS_LINUX) || defined(APPCONFIG_OS_FREEBSD) || defined(APPCONFIG_OS_MAC) | ||
# define APPCONFIG_OS_UNIX | ||
#endif | ||
|
||
@@ -81,7 +83,7 @@ | ||
#define JUCE_STRING_UTF_TYPE 8 | ||
#define JUCE_USE_VFORK 1 | ||
|
||
-#ifdef APPCONFIG_OS_LINUX | ||
+#if defined(APPCONFIG_OS_LINUX) || defined(APPCONFIG_OS_FREEBSD) | ||
# define JUCE_DISABLE_NATIVE_FILECHOOSERS 1 | ||
# define JUCE_MODAL_LOOPS_PERMITTED 0 | ||
// # define JUCE_AUDIOPROCESSOR_NO_GUI 1 | ||
@@ -145,7 +147,7 @@ | ||
/** Config: JUCE_JACK | ||
Enables JACK audio devices (Linux only). | ||
*/ | ||
-#ifdef APPCONFIG_OS_LINUX | ||
+#if defined(APPCONFIG_OS_LINUX) || defined(APPCONFIG_OS_FREEBSD) | ||
#define JUCE_JACK 1 | ||
#define JUCE_JACK_CLIENT_NAME "Carla" | ||
#else | ||
@@ -227,7 +229,7 @@ | ||
|
||
@see VSTPluginFormat, VST3PluginFormat, AudioPluginFormat, AudioPluginFormatManager, JUCE_PLUGINHOST_VST, JUCE_PLUGINHOST_AU | ||
*/ | ||
-#if defined(APPCONFIG_OS_LINUX) || defined(APPCONFIG_OS_MAC) || defined(APPCONFIG_OS_WIN) | ||
+#if defined(APPCONFIG_OS_LINUX) || defined(APPCONFIG_OS_FREEBSD) || defined(APPCONFIG_OS_MAC) || defined(APPCONFIG_OS_WIN) | ||
# define JUCE_PLUGINHOST_VST3 1 | ||
#else | ||
# define JUCE_PLUGINHOST_VST3 0 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Oops, something went wrong.