Skip to content

Commit

Permalink
*/*: sync with upstream
Browse files Browse the repository at this point in the history
Taken from: HardenedBSD
  • Loading branch information
fichtner committed Dec 15, 2017
1 parent c2a8dfb commit bc8f8c5
Show file tree
Hide file tree
Showing 55 changed files with 13,525 additions and 795 deletions.
35 changes: 35 additions & 0 deletions audio/GxSwitchlessWah-lv2/Makefile
Original file line number Diff line number Diff line change
@@ -0,0 +1,35 @@
# $FreeBSD$

PORTNAME= GxSwitchlessWah
DISTVERSION= g20171206
CATEGORIES= audio
PKGNAMESUFFIX= -lv2

MAINTAINER= [email protected]
COMMENT= Analog wah emulation with switchless activation

LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE

BUILD_DEPENDS= lv2>0:audio/lv2

USES= gmake localbase
USE_GITHUB= yes
GH_ACCOUNT= brummer10
GH_PROJECT= ${PORTNAME}.lv2
GH_TAGNAME= 6977568

SSE_FLAGS_i386= "-msse -mfpmath=sse"
SSE_FLAGS_amd64= "-msse2 -mfpmath=sse"
SSE_FLAGS_armv7= "-march=armv7 -mfpu=vfpv3"

MAKE_ARGS= SSE_CFLAGS=${SSE_FLAGS_${ARCH}}

PLIST_FILES= lib/lv2/GxSwitchlessWah.lv2/gx_switchless_wah.so \
lib/lv2/GxSwitchlessWah.lv2/gx_switchless_wah.ttl \
lib/lv2/GxSwitchlessWah.lv2/manifest.ttl

post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/lv2/GxSwitchlessWah.lv2/gx_switchless_wah.so

.include <bsd.port.mk>
3 changes: 3 additions & 0 deletions audio/GxSwitchlessWah-lv2/distinfo
Original file line number Diff line number Diff line change
@@ -0,0 +1,3 @@
TIMESTAMP = 1512578914
SHA256 (brummer10-GxSwitchlessWah.lv2-g20171206-6977568_GH0.tar.gz) = 5d7a67c58fd44848e317a55496a1421183ac1654eb703ebd8618d2b03ce0a831
SIZE (brummer10-GxSwitchlessWah.lv2-g20171206-6977568_GH0.tar.gz) = 17415
47 changes: 47 additions & 0 deletions audio/GxSwitchlessWah-lv2/files/patch-Makefile
Original file line number Diff line number Diff line change
@@ -0,0 +1,47 @@
--- Makefile.orig 2017-12-08 06:25:07 UTC
+++ Makefile
@@ -8,25 +8,25 @@
endif

# check CPU and supported optimization flags
- ifneq ($(shell cat /proc/cpuinfo | grep sse3 ) , )
- SSE_CFLAGS = -msse3 -mfpmath=sse
- else ifneq ($(shell cat /proc/cpuinfo | grep sse2 ) , )
- SSE_CFLAGS = -msse2 -mfpmath=sse
- else ifneq ($(shell cat /proc/cpuinfo | grep sse ) , )
- SSE_CFLAGS = -msse -mfpmath=sse
- else ifneq ($(shell cat /proc/cpuinfo | grep ARM ) , )
- ifneq ($(shell cat /proc/cpuinfo | grep ARMv7 ) , )
- ifneq ($(shell cat /proc/cpuinfo | grep vfpd32 ) , )
- SSE_CFLAGS = -march=armv7 -mfpu=vfpv3
- else ifneq ($(shell cat /proc/cpuinfo | grep vfpv3 ) , )
- SSE_CFLAGS = -march=armv7 -mfpu=vfpv3
- endif
- else
- ARMCPU = "YES"
- endif
- else
- SSE_CFLAGS =
- endif
+ #ifneq ($(shell cat /proc/cpuinfo | grep sse3 ) , )
+ # SSE_CFLAGS = -msse3 -mfpmath=sse
+ #else ifneq ($(shell cat /proc/cpuinfo | grep sse2 ) , )
+ # SSE_CFLAGS = -msse2 -mfpmath=sse
+ #else ifneq ($(shell cat /proc/cpuinfo | grep sse ) , )
+ # SSE_CFLAGS = -msse -mfpmath=sse
+ # else ifneq ($(shell cat /proc/cpuinfo | grep ARM ) , )
+ # ifneq ($(shell cat /proc/cpuinfo | grep ARMv7 ) , )
+ # ifneq ($(shell cat /proc/cpuinfo | grep vfpd32 ) , )
+ # SSE_CFLAGS = -march=armv7 -mfpu=vfpv3
+ # else ifneq ($(shell cat /proc/cpuinfo | grep vfpv3 ) , )
+ # SSE_CFLAGS = -march=armv7 -mfpu=vfpv3
+ # endif
+ # else
+ # ARMCPU = "YES"
+ # endif
+ #else
+ # SSE_CFLAGS =
+ #endif

# set bundle name
NAME = gx_switchless_wah
7 changes: 7 additions & 0 deletions audio/GxSwitchlessWah-lv2/pkg-descr
Original file line number Diff line number Diff line change
@@ -0,0 +1,7 @@
Analog wah emulator allowing to alter sound in a way to create a distinctive
sound, mimicking the human voice saying the onomatopoeic name "wah-wah".

See the corresponding article on Wikipedia:
https://en.wikipedia.org/wiki/Wah-wah_pedal

WWW: https://github.com/brummer10/GxSwitchlessWah.lv2
1 change: 1 addition & 0 deletions audio/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -3,6 +3,7 @@

COMMENT = Audio tools

SUBDIR += GxSwitchlessWah-lv2
SUBDIR += HVSC-Update
SUBDIR += Maaate
SUBDIR += aacgain
Expand Down
1 change: 1 addition & 0 deletions audio/cmus/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -46,6 +46,7 @@ _CMUS_CONFIGURE_OPTS= AAC ALSA AO ARTS CDDB CDIO COREAUDIO CUE DISCID \
CONFIGURE_ARGS+= CONFIG_${opt}=n
.endfor

OPTIONS_DEFINE= EXAMPLES
OPTIONS_DEFAULT= AAC FFMPEG FLAC MAD MODPLUG MP4 OPUS OSS SNDIO VORBIS WAV
OPTIONS_SUB= yes

Expand Down
2 changes: 1 addition & 1 deletion converters/rubygem-json-ld/pkg-descr
Original file line number Diff line number Diff line change
Expand Up @@ -3,4 +3,4 @@ compaction and framing API interfaces. It can now be used to create a context
from an RDFS/OWL definition, and optionally include a JSON-LD representation of
the ontology itself.

WWW: http://github.com/ruby-rdf/json-ld
WWW: https://github.com/ruby-rdf/json-ld
26 changes: 4 additions & 22 deletions databases/galera/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -56,32 +56,14 @@ OPTIONS_DEFINE= BOOSTPOOL BPOSTATIC DEBUG
BOOSTPOOL_DESC= Use boost pool allocator
BPOSTATIC_DESC= Use static boost_program_options

.include <bsd.port.pre.mk>

# Clang is available on FreeBSD 9.x but the default
# compiler (e.g. /usr/bin/cc) is GCC. Force the usage of Clang.
.if ${OSVERSION} < 1000024
CC= clang
CXX= clang++
CPP= clang-cpp
.endif

.if ${PORT_OPTIONS:MBOOSTPOOL}
MAKE_ARGS+= boost_pool=1
.endif

.if ${PORT_OPTIONS:MBPOSTATIC}
MAKE_ARGS+= bpostatic=${LOCALBASE}/lib/libboost_program_options.a
.endif

.if ${PORT_OPTIONS:MDEBUG}
MAKE_ARGS+= debug=0
.endif
BOOSTPOOL_MAKE_ARGS= boost_pool=1
BPOSTATIC_MAKE_ARGS= bpostatic=${LOCALBASE}/lib/libboost_program_options.a
DEBUG_MAKE_ARGS= debug=0

do-install:
${INSTALL_PROGRAM} ${WRKSRC}/garb/garbd ${STAGEDIR}${PREFIX}/bin/
${INSTALL_LIB} ${WRKSRC}/libgalera_smm.so ${STAGEDIR}${PREFIX}/lib/
@(cd ${STAGEDIR}${PREFIX}/lib && ${LN} -sf libgalera_smm.so \
libgalera.so)

.include <bsd.port.post.mk>
.include <bsd.port.mk>
2 changes: 1 addition & 1 deletion databases/galera/pkg-descr
Original file line number Diff line number Diff line change
Expand Up @@ -2,4 +2,4 @@ Galera wsrep provider library for Galera Cluster for MySQL, an easy-to-use
high-availability solution with high system up-time, no data loss,
and scalability for future growth.

WWW: http://galeracluster.com
WWW: http://galeracluster.com/
9 changes: 8 additions & 1 deletion databases/ruby-gdbm/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -28,8 +28,15 @@ MAKE_ARGS= sitelibdir='$$(rubylibdir)' \
INSTALL_PROG="${INSTALL_PROGRAM}" \
INSTALL_DATA="${INSTALL_DATA}"

.include <bsd.port.pre.mk>

.if ${RUBY_VER} >= 2.4
post-patch:
@${REINPLACE_CMD} -e '/\/include\/ruby.h/d' ${WRKSRC}/depend
.endif

do-extract:
${MKDIR} ${WRKDIR}
${LN} -sf `cd ${PORTSDIR}/${RUBY_PORT}; ${MAKE} -V WRKDIR`/${PORTNAME} ${WRKDIR}/

.include <bsd.port.mk>
.include <bsd.port.post.mk>
5 changes: 3 additions & 2 deletions deskutils/pypanel/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -33,8 +33,9 @@ post-patch:
s|/usr/bin/imlib2-config|${LOCALBASE}/bin/imlib2-config|; \
s|/usr/X11R6/include|${LOCALBASE}/include|; \
s|"COPYING", "README", ||' ${WRKSRC}/setup.py
@${REINPLACE_CMD} -e 's|sysconfig\.get_python_lib()|"${PREFIX}/share"|' \
${WRKSRC}/setup.py ${WRKSRC}/pypanel
@${REINPLACE_CMD} -e \
's|sysconfig\.get_python_lib()|"${PREFIX}/share"|' \
${WRKSRC}/setup.py ${WRKSRC}/pypanel
@${REINPLACE_CMD} -e \
's|/usr/lib/libImlib2.so.1|${LOCALBASE}/lib/libImlib2.so|' \
${WRKSRC}/setup.py ${WRKSRC}/ppmodule.c
Expand Down
4 changes: 2 additions & 2 deletions devel/cppcheck/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -44,7 +44,7 @@ RULES_USES= localbase:ldflags
TEST_CMAKE_BOOL= BUILD_TESTS

HTMLREPORT_DESC= Install cppcheck-htmlreport
HTMLREPORT_USES= python:2,${PYUSE:C/ /,/W}
HTMLREPORT_USES= python:${PYUSE:C/ /,/W}
HTMLREPORT_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pygments>0:textproc/py-pygments@${PY_FLAVOR}
HTMLREPORT_PLIST_FILES= bin/cppcheck-htmlreport
HTMLREPORT_VARS= PYUSE+=run
Expand All @@ -54,7 +54,7 @@ MANPAGES_BUILD_DEPENDS= xsltproc:textproc/libxslt \

MATCHCOMPILER_DESC= Build-time optimizations via Python
MATCHCOMPILER_CMAKE_BOOL= USE_MATCHCOMPILER
MATCHCOMPILER_USES= python:2,${PYUSE:C/ /,/W}
MATCHCOMPILER_USES= python:${PYUSE:C/ /,/W}
MATCHCOMPILER_VARS= PYUSE+=build

post-install-HTMLREPORT-on:
Expand Down
2 changes: 1 addition & 1 deletion devel/grpc/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -2,7 +2,7 @@
# $FreeBSD$

PORTNAME= grpc
PORTVERSION= 1.8.0
PORTVERSION= 1.8.1
DISTVERSIONPREFIX= v
CATEGORIES= devel

Expand Down
6 changes: 3 additions & 3 deletions devel/grpc/distinfo
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
TIMESTAMP = 1513174933
SHA256 (grpc-grpc-v1.8.0_GH0.tar.gz) = 7d1c646c2012bdd0af275215c3fc882c598a1eb664c1012a49a81e4faf27a504
SIZE (grpc-grpc-v1.8.0_GH0.tar.gz) = 4636987
TIMESTAMP = 1513345089
SHA256 (grpc-grpc-v1.8.1_GH0.tar.gz) = ae34c8255ea0aa4f893b9b2cb9f02d8e13bd9d7f2a90d1c39d56a5d6143a9f44
SIZE (grpc-grpc-v1.8.1_GH0.tar.gz) = 4636161
SHA256 (google-benchmark-v1.3.0_GH0.tar.gz) = f19559475a592cbd5ac48b61f6b9cedf87f0b6775d1443de54cfe8f53940b28d
SIZE (google-benchmark-v1.3.0_GH0.tar.gz) = 105485
2 changes: 1 addition & 1 deletion devel/pecl-grpc/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -2,7 +2,7 @@
# $FreeBSD$

PORTNAME= grpc
PORTVERSION= 1.7.0
PORTVERSION= 1.8.0
CATEGORIES= devel net

MAINTAINER= [email protected]
Expand Down
6 changes: 3 additions & 3 deletions devel/pecl-grpc/distinfo
Original file line number Diff line number Diff line change
@@ -1,3 +1,3 @@
TIMESTAMP = 1510723140
SHA256 (PECL/grpc-1.7.0.tgz) = 0583129a618f186c90ec81b41d3d259e195fbd7f0979a74a8b13f46a64b96686
SIZE (PECL/grpc-1.7.0.tgz) = 2326462
TIMESTAMP = 1513349287
SHA256 (PECL/grpc-1.8.0.tgz) = cec11452d2938da8d7c5a5b11bc7df6c11469ece18c0954fd12edd34a3321dab
SIZE (PECL/grpc-1.8.0.tgz) = 2304860

This file was deleted.

Original file line number Diff line number Diff line change
@@ -0,0 +1,11 @@
--- src/core/tsi/ssl_transport_security.cc.orig 2017-12-15 14:58:10 UTC
+++ src/core/tsi/ssl_transport_security.cc
@@ -19,7 +19,7 @@
#include "src/core/tsi/ssl_transport_security.h"

#include <grpc/support/port_platform.h>
-
+#include <sys/socket.h>
#include <limits.h>
#include <string.h>

4 changes: 2 additions & 2 deletions devel/pycharm-ce/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -2,7 +2,7 @@
# $FreeBSD$

PORTNAME= pycharm-ce
PORTVERSION= 2017.2.4
PORTVERSION= 2017.3
CATEGORIES= devel java python
MASTER_SITES= https://download.jetbrains.com/python/ \
http://download.jetbrains.com/python/
Expand Down Expand Up @@ -41,7 +41,7 @@ do-install:
@${RM} -r ${STAGEDIR}${DATADIR}/jre64
@${RM} -r ${STAGEDIR}${DATADIR}/helpers/pydev/pydevd_attach_to_process
@${RM} ${STAGEDIR}${DATADIR}/lib/pty4j-0.5.jar
${INSTALL_SCRIPT} ${WRKDIR}/pycharm ${STAGEDIR}${PREFIX}/bin/
${INSTALL_SCRIPT} ${WRKDIR}/pycharm ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
${INSTALL_DATA} ${WRKDIR}/${PORTNAME}.desktop ${STAGEDIR}${PREFIX}/share/applications/
#cd ${WRKSRC}/lib && ${JAVA_HOME}/bin/jar xf icons.jar
# TODO: Remove and enable fsnotifier when devel/libinotify is fixed
Expand Down
6 changes: 3 additions & 3 deletions devel/pycharm-ce/distinfo
Original file line number Diff line number Diff line change
@@ -1,3 +1,3 @@
TIMESTAMP = 1509539301
SHA256 (pycharm-community-2017.2.4.tar.gz) = a72045c348981640a12fb9739e04d4985163248006150d4fd3b3c09d34216ea4
SIZE (pycharm-community-2017.2.4.tar.gz) = 200392450
TIMESTAMP = 1513173904
SHA256 (pycharm-community-2017.3.tar.gz) = b973581cb3de0f0f5a203231f67b21a45b7dd58968393cef49d48403cb1b8ad1
SIZE (pycharm-community-2017.3.tar.gz) = 282451011
Loading

0 comments on commit bc8f8c5

Please sign in to comment.