forked from opnsense/ports
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Taken from: HardenedBSD
- Loading branch information
Showing
55 changed files
with
13,525 additions
and
795 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,35 @@ | ||
# $FreeBSD$ | ||
|
||
PORTNAME= GxSwitchlessWah | ||
DISTVERSION= g20171206 | ||
CATEGORIES= audio | ||
PKGNAMESUFFIX= -lv2 | ||
|
||
MAINTAINER= [email protected] | ||
COMMENT= Analog wah emulation with switchless activation | ||
|
||
LICENSE= GPLv3 | ||
LICENSE_FILE= ${WRKSRC}/LICENSE | ||
|
||
BUILD_DEPENDS= lv2>0:audio/lv2 | ||
|
||
USES= gmake localbase | ||
USE_GITHUB= yes | ||
GH_ACCOUNT= brummer10 | ||
GH_PROJECT= ${PORTNAME}.lv2 | ||
GH_TAGNAME= 6977568 | ||
|
||
SSE_FLAGS_i386= "-msse -mfpmath=sse" | ||
SSE_FLAGS_amd64= "-msse2 -mfpmath=sse" | ||
SSE_FLAGS_armv7= "-march=armv7 -mfpu=vfpv3" | ||
|
||
MAKE_ARGS= SSE_CFLAGS=${SSE_FLAGS_${ARCH}} | ||
|
||
PLIST_FILES= lib/lv2/GxSwitchlessWah.lv2/gx_switchless_wah.so \ | ||
lib/lv2/GxSwitchlessWah.lv2/gx_switchless_wah.ttl \ | ||
lib/lv2/GxSwitchlessWah.lv2/manifest.ttl | ||
|
||
post-install: | ||
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/lv2/GxSwitchlessWah.lv2/gx_switchless_wah.so | ||
|
||
.include <bsd.port.mk> |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,3 @@ | ||
TIMESTAMP = 1512578914 | ||
SHA256 (brummer10-GxSwitchlessWah.lv2-g20171206-6977568_GH0.tar.gz) = 5d7a67c58fd44848e317a55496a1421183ac1654eb703ebd8618d2b03ce0a831 | ||
SIZE (brummer10-GxSwitchlessWah.lv2-g20171206-6977568_GH0.tar.gz) = 17415 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,47 @@ | ||
--- Makefile.orig 2017-12-08 06:25:07 UTC | ||
+++ Makefile | ||
@@ -8,25 +8,25 @@ | ||
endif | ||
|
||
# check CPU and supported optimization flags | ||
- ifneq ($(shell cat /proc/cpuinfo | grep sse3 ) , ) | ||
- SSE_CFLAGS = -msse3 -mfpmath=sse | ||
- else ifneq ($(shell cat /proc/cpuinfo | grep sse2 ) , ) | ||
- SSE_CFLAGS = -msse2 -mfpmath=sse | ||
- else ifneq ($(shell cat /proc/cpuinfo | grep sse ) , ) | ||
- SSE_CFLAGS = -msse -mfpmath=sse | ||
- else ifneq ($(shell cat /proc/cpuinfo | grep ARM ) , ) | ||
- ifneq ($(shell cat /proc/cpuinfo | grep ARMv7 ) , ) | ||
- ifneq ($(shell cat /proc/cpuinfo | grep vfpd32 ) , ) | ||
- SSE_CFLAGS = -march=armv7 -mfpu=vfpv3 | ||
- else ifneq ($(shell cat /proc/cpuinfo | grep vfpv3 ) , ) | ||
- SSE_CFLAGS = -march=armv7 -mfpu=vfpv3 | ||
- endif | ||
- else | ||
- ARMCPU = "YES" | ||
- endif | ||
- else | ||
- SSE_CFLAGS = | ||
- endif | ||
+ #ifneq ($(shell cat /proc/cpuinfo | grep sse3 ) , ) | ||
+ # SSE_CFLAGS = -msse3 -mfpmath=sse | ||
+ #else ifneq ($(shell cat /proc/cpuinfo | grep sse2 ) , ) | ||
+ # SSE_CFLAGS = -msse2 -mfpmath=sse | ||
+ #else ifneq ($(shell cat /proc/cpuinfo | grep sse ) , ) | ||
+ # SSE_CFLAGS = -msse -mfpmath=sse | ||
+ # else ifneq ($(shell cat /proc/cpuinfo | grep ARM ) , ) | ||
+ # ifneq ($(shell cat /proc/cpuinfo | grep ARMv7 ) , ) | ||
+ # ifneq ($(shell cat /proc/cpuinfo | grep vfpd32 ) , ) | ||
+ # SSE_CFLAGS = -march=armv7 -mfpu=vfpv3 | ||
+ # else ifneq ($(shell cat /proc/cpuinfo | grep vfpv3 ) , ) | ||
+ # SSE_CFLAGS = -march=armv7 -mfpu=vfpv3 | ||
+ # endif | ||
+ # else | ||
+ # ARMCPU = "YES" | ||
+ # endif | ||
+ #else | ||
+ # SSE_CFLAGS = | ||
+ #endif | ||
|
||
# set bundle name | ||
NAME = gx_switchless_wah |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,7 @@ | ||
Analog wah emulator allowing to alter sound in a way to create a distinctive | ||
sound, mimicking the human voice saying the onomatopoeic name "wah-wah". | ||
|
||
See the corresponding article on Wikipedia: | ||
https://en.wikipedia.org/wiki/Wah-wah_pedal | ||
|
||
WWW: https://github.com/brummer10/GxSwitchlessWah.lv2 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,5 +1,5 @@ | ||
TIMESTAMP = 1513174933 | ||
SHA256 (grpc-grpc-v1.8.0_GH0.tar.gz) = 7d1c646c2012bdd0af275215c3fc882c598a1eb664c1012a49a81e4faf27a504 | ||
SIZE (grpc-grpc-v1.8.0_GH0.tar.gz) = 4636987 | ||
TIMESTAMP = 1513345089 | ||
SHA256 (grpc-grpc-v1.8.1_GH0.tar.gz) = ae34c8255ea0aa4f893b9b2cb9f02d8e13bd9d7f2a90d1c39d56a5d6143a9f44 | ||
SIZE (grpc-grpc-v1.8.1_GH0.tar.gz) = 4636161 | ||
SHA256 (google-benchmark-v1.3.0_GH0.tar.gz) = f19559475a592cbd5ac48b61f6b9cedf87f0b6775d1443de54cfe8f53940b28d | ||
SIZE (google-benchmark-v1.3.0_GH0.tar.gz) = 105485 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -2,7 +2,7 @@ | |
# $FreeBSD$ | ||
|
||
PORTNAME= grpc | ||
PORTVERSION= 1.7.0 | ||
PORTVERSION= 1.8.0 | ||
CATEGORIES= devel net | ||
|
||
MAINTAINER= [email protected] | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,3 @@ | ||
TIMESTAMP = 1510723140 | ||
SHA256 (PECL/grpc-1.7.0.tgz) = 0583129a618f186c90ec81b41d3d259e195fbd7f0979a74a8b13f46a64b96686 | ||
SIZE (PECL/grpc-1.7.0.tgz) = 2326462 | ||
TIMESTAMP = 1513349287 | ||
SHA256 (PECL/grpc-1.8.0.tgz) = cec11452d2938da8d7c5a5b11bc7df6c11469ece18c0954fd12edd34a3321dab | ||
SIZE (PECL/grpc-1.8.0.tgz) = 2304860 |
10 changes: 0 additions & 10 deletions
10
devel/pecl-grpc/files/patch-src_core_tsi_ssl__transport__security.c
This file was deleted.
Oops, something went wrong.
11 changes: 11 additions & 0 deletions
11
devel/pecl-grpc/files/patch-src_core_tsi_ssl__transport__security.cc
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,11 @@ | ||
--- src/core/tsi/ssl_transport_security.cc.orig 2017-12-15 14:58:10 UTC | ||
+++ src/core/tsi/ssl_transport_security.cc | ||
@@ -19,7 +19,7 @@ | ||
#include "src/core/tsi/ssl_transport_security.h" | ||
|
||
#include <grpc/support/port_platform.h> | ||
- | ||
+#include <sys/socket.h> | ||
#include <limits.h> | ||
#include <string.h> | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,3 @@ | ||
TIMESTAMP = 1509539301 | ||
SHA256 (pycharm-community-2017.2.4.tar.gz) = a72045c348981640a12fb9739e04d4985163248006150d4fd3b3c09d34216ea4 | ||
SIZE (pycharm-community-2017.2.4.tar.gz) = 200392450 | ||
TIMESTAMP = 1513173904 | ||
SHA256 (pycharm-community-2017.3.tar.gz) = b973581cb3de0f0f5a203231f67b21a45b7dd58968393cef49d48403cb1b8ad1 | ||
SIZE (pycharm-community-2017.3.tar.gz) = 282451011 |
Oops, something went wrong.