Skip to content

Commit

Permalink
*/*: sync with upstream
Browse files Browse the repository at this point in the history
Taken from: HardenedBSD
  • Loading branch information
fichtner committed Aug 28, 2019
1 parent 56ab9cd commit e7f30ee
Show file tree
Hide file tree
Showing 158 changed files with 10,107 additions and 1,426 deletions.
2 changes: 1 addition & 1 deletion audio/cmus/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -4,7 +4,7 @@
PORTNAME= cmus
DISTVERSIONPREFIX= v
DISTVERSION= 2.8.0
PORTREVISION= 2
PORTREVISION= 3
CATEGORIES= audio

MAINTAINER= [email protected]
Expand Down
2 changes: 1 addition & 1 deletion audio/decibel-audio-player/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,7 @@

PORTNAME= decibel-audio-player
PORTVERSION= 1.08
PORTREVISION= 6
PORTREVISION= 7
CATEGORIES= audio multimedia gnome python
MASTER_SITES= http://decibel.silent-blade.org/uploads/Main/

Expand Down
2 changes: 1 addition & 1 deletion audio/kid3-qt5/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -2,7 +2,7 @@

PORTNAME= kid3
PORTVERSION= 3.7.1
PORTREVISION?= 3
PORTREVISION?= 4
CATEGORIES= audio kde
MASTER_SITES= SF
PKGNAMESUFFIX= -${SLAVE}
Expand Down
1 change: 1 addition & 0 deletions audio/mixxx/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -4,6 +4,7 @@
PORTNAME= mixxx
DISTVERSIONPREFIX= release-
DISTVERSION= 2.2.2
PORTREVISION= 1
CATEGORIES= audio

MAINTAINER= [email protected]
Expand Down
2 changes: 1 addition & 1 deletion audio/mixxx21/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -4,7 +4,7 @@
PORTNAME= mixxx
DISTVERSIONPREFIX= release-
DISTVERSION= 2.1.8
PORTREVISION= 4
PORTREVISION= 5
CATEGORIES= audio
PKGNAMESUFFIX= 21

Expand Down
2 changes: 1 addition & 1 deletion audio/mous/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -4,7 +4,7 @@
PORTNAME= mous
DISTVERSIONPREFIX= v
DISTVERSION= 2.0.1
PORTREVISION= 2
PORTREVISION= 3
CATEGORIES= audio

MAINTAINER= [email protected]
Expand Down
1 change: 1 addition & 0 deletions comms/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -110,6 +110,7 @@
SUBDIR += obexapp
SUBDIR += openobex
SUBDIR += openzwave
SUBDIR += openzwave-devel
SUBDIR += owfs
SUBDIR += p5-Cisco-UCS
SUBDIR += p5-Device-Gsm
Expand Down
44 changes: 44 additions & 0 deletions comms/openzwave-devel/Makefile
Original file line number Diff line number Diff line change
@@ -0,0 +1,44 @@
# Created by: Johan Strom <[email protected]>
# $FreeBSD$

PORTNAME= openzwave
PORTVERSION= 1.6.${VERSION_REV}
CATEGORIES= comms
PKGNAMESUFFIX= -devel

MAINTAINER= [email protected]
COMMENT= Open-zwave - An open-source interface to Z-Wave networks

LICENSE= LGPL20

USES= gmake tar:bz2 iconv pkgconfig

# Manually update this when makefile is updated
# echo $(git describe --long --tags --dirty 2>/dev/null | sed s/^v//) | awk '{split($$0,a,"-"); print a[2]}'
VERSION_REV= 897

USE_LDCONFIG= yes
USE_GITHUB= yes
GH_ACCOUNT= OpenZWave
GH_PROJECT= open-zwave
GH_TAGNAME= 1e2d123c
MAKE_ARGS= VERSION_REV=${VERSION_REV} LIBDIR=${WRKSRC} docdir=${DOCSDIR}

OPTIONS_DEFINE= DOXYGEN
OPTIONS_DEFAULT=
OPTIONS_SUB= yes

PLIST_SUB= PORTVERSION=${PORTVERSION}

DOXYGEN_DESCR= Build docs (requires doxygen + graphviz)
DOXYGEN_BUILD_DEPENDS= doxygen:${PORTSDIR}/devel/doxygen dot:${PORTSDIR}/graphics/graphviz
DOXYGEN_PORTDOCS= api/* default.htm general/* images+css/*

post-install:
${STRIP_CMD} ${STAGEDIR}${LOCALBASE}/lib/libopenzwave.so.1.6
${STRIP_CMD} ${STAGEDIR}${LOCALBASE}/bin/MinOZW

post-install-DOXYGEN-on:
${RM} ${STAGEDIR}${DOCSDIR}/Doxyfile.in

.include <bsd.port.mk>
3 changes: 3 additions & 0 deletions comms/openzwave-devel/distinfo
Original file line number Diff line number Diff line change
@@ -0,0 +1,3 @@
TIMESTAMP = 1566889355
SHA256 (OpenZWave-open-zwave-1.6.897-1e2d123c_GH0.tar.gz) = 6608e9961b8439841fce3d64f562f7c4140345d57b841c943bb6418bf939c60d
SIZE (OpenZWave-open-zwave-1.6.897-1e2d123c_GH0.tar.gz) = 12048208
13 changes: 13 additions & 0 deletions comms/openzwave-devel/files/patch-cpp_build_Makefile
Original file line number Diff line number Diff line change
@@ -0,0 +1,13 @@
--- cpp/build/Makefile.orig 2019-08-26 02:51:02 UTC
+++ cpp/build/Makefile
@@ -280,8 +280,8 @@ install: $(LIBDIR)/$(SHARED_LIB_NAME) doc $(top_buildd
@cp -r $(top_srcdir)/docs/* $(DESTDIR)/$(docdir)
@if [ -d "$(top_builddir)/docs/html/" ]; then cp -r $(top_builddir)/docs/html/* $(DESTDIR)/$(docdir); fi
@echo "Installing Pkg-config Files"
- @install -d $(DESTDIR)/$(pkgconfigdir)
- @cp $(top_builddir)/libopenzwave.pc $(DESTDIR)/$(pkgconfigdir)
+ @install -d $(DESTDIR)/$(PREFIX)/libdata/pkgconfig
+ @cp $(top_builddir)/libopenzwave.pc $(DESTDIR)/$(PREFIX)/libdata/pkgconfig
@install -d $(DESTDIR)/$(PREFIX)/bin/
@cp $(top_builddir)/ozw_config $(DESTDIR)/$(PREFIX)/bin/ozw_config
@chmod 755 $(DESTDIR)/$(PREFIX)/bin/ozw_config
13 changes: 13 additions & 0 deletions comms/openzwave-devel/files/patch-cpp_build_support.mk
Original file line number Diff line number Diff line change
@@ -0,0 +1,13 @@
--- cpp/build/support.mk.orig 2019-08-26 02:51:02 UTC
+++ cpp/build/support.mk
@@ -46,8 +46,8 @@ VERSION_REV ?= 0
else
GITVERSION := $(shell $(GIT) --git-dir $(top_srcdir)/.git describe --long --tags --dirty 2>/dev/null | sed s/^v//)
ifeq ($(GITVERSION),)
-GITVERSION := $(VERSION_MAJ).$(VERSION_MIN).-1
-VERSION_REV := 0
+GITVERSION := $(VERSION_MAJ).$(VERSION_MIN).$(VERSION_REV)
+#VERSION_REV := 0
else
VERSION_REV ?= $(shell echo $(GITVERSION) | awk '{split($$0,a,"-"); print a[2]}')
endif
6 changes: 6 additions & 0 deletions comms/openzwave-devel/pkg-descr
Original file line number Diff line number Diff line change
@@ -0,0 +1,6 @@
Free software library that interfaces with selected Z-Wave PC controllers,
allowing anyone to create applications that manipulate and respond to
devices on a Z-Wave network, without requiring in-depth knowledge of the
Z-Wave protocol.

WWW: http://www.openzwave.net/
Loading

0 comments on commit e7f30ee

Please sign in to comment.