Skip to content

Commit

Permalink
*/*: sync with upstream
Browse files Browse the repository at this point in the history
Taken from: FreeBSD
  • Loading branch information
fichtner committed Sep 18, 2016
1 parent 6275b78 commit ec630fc
Show file tree
Hide file tree
Showing 402 changed files with 6,838 additions and 6,083 deletions.
2 changes: 1 addition & 1 deletion archivers/pecl-snappy/pkg-descr
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
Provides the API to PHP for the snappy compression algorithm by
Google.

WWW: http://code.google.com/p/php-snappy/
WWW: https://github.com/kjdev/php-ext-snappy
4 changes: 2 additions & 2 deletions archivers/quazip-qt5/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
# $FreeBSD$

PORTNAME= quazip
PORTVERSION= 0.7.1
PORTVERSION= 0.7.2
CATEGORIES= archivers
MASTER_SITES= SF
PKGNAMESUFFIX= -qt5
Expand All @@ -12,7 +12,7 @@ COMMENT= Qt/C++ wrapper for ZIP/UNZIP package
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/COPYING

USES= cmake
USES= cmake:outsource
USE_LDCONFIG= yes
USE_QT5= core buildtools_build qmake_build

Expand Down
5 changes: 3 additions & 2 deletions archivers/quazip-qt5/distinfo
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
SHA256 (quazip-0.7.1.tar.gz) = 78c984103555c51e6f7ef52e3a2128e2beb9896871b2cc4d4dbd4d64bff132de
SIZE (quazip-0.7.1.tar.gz) = 390629
TIMESTAMP = 1472674423
SHA256 (quazip-0.7.2.tar.gz) = 91d827fbcafd099ae814cc18a8dd3bb709da6b8a27c918ee1c6c03b3f29440f4
SIZE (quazip-0.7.2.tar.gz) = 466915
106 changes: 0 additions & 106 deletions archivers/quazip-qt5/files/patch-coinstallable_with_qt4_version

This file was deleted.

27 changes: 27 additions & 0 deletions archivers/quazip-qt5/files/patch-quazip_CMakeLists.txt
Original file line number Diff line number Diff line change
@@ -0,0 +1,27 @@
Properly link quazip_static against its dependencies

From the looks of r256, it appears that the target_link_libraries() call in
quazip/CMakeLists.txt was modified with the intention of linking both
${QUAZIP_LIB_TARGET_NAME} and quazip_static against all required libraries.
However, target_link_libraries()'s syntax is such that the first argument is
the library that all other arguments will be linked against. In other words,
libquazip(5).so will link against quazip_static, which is not what is desired.

Creator: Raphael Kubo da Costa

https://sourceforge.net/p/quazip/patches/28/

Index: quazip/CMakeLists.txt
===================================================================
--- quazip/CMakeLists.txt.orig 2016-01-03 06:01:40 UTC
+++ quazip/CMakeLists.txt
@@ -25,7 +25,8 @@ endif ()

set_target_properties(${QUAZIP_LIB_TARGET_NAME} quazip_static PROPERTIES VERSION 1.0.0 SOVERSION 1 DEBUG_POSTFIX d)
# Link against ZLIB_LIBRARIES if needed (on Windows this variable is empty)
-target_link_libraries(${QUAZIP_LIB_TARGET_NAME} quazip_static ${QT_QTMAIN_LIBRARY} ${QTCORE_LIBRARIES} ${ZLIB_LIBRARIES})
+target_link_libraries(quazip_static ${QT_QTMAIN_LIBRARY} ${QTCORE_LIBRARIES} ${ZLIB_LIBRARIES})
+target_link_libraries(${QUAZIP_LIB_TARGET_NAME} ${QT_QTMAIN_LIBRARY} ${QTCORE_LIBRARIES} ${ZLIB_LIBRARIES})

install(FILES ${PUBLIC_HEADERS} DESTINATION include/quazip${QUAZIP_LIB_VERSION_SUFFIX})
install(TARGETS ${QUAZIP_LIB_TARGET_NAME} quazip_static LIBRARY DESTINATION ${LIB_DESTINATION} ARCHIVE DESTINATION ${LIB_DESTINATION} RUNTIME DESTINATION ${LIB_DESTINATION})
1 change: 1 addition & 0 deletions archivers/quazip-qt5/pkg-plist
Original file line number Diff line number Diff line change
Expand Up @@ -14,6 +14,7 @@ include/quazip5/quazipfileinfo.h
include/quazip5/quazipnewinfo.h
include/quazip5/unzip.h
include/quazip5/zip.h
lib/libquazip5.a
lib/libquazip5.so
lib/libquazip5.so.1
lib/libquazip5.so.1.0.0
Expand Down
2 changes: 1 addition & 1 deletion archivers/quazip/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -2,7 +2,7 @@
# $FreeBSD$

PORTNAME= quazip
PORTVERSION= 0.7.1
PORTVERSION= 0.7.2
CATEGORIES= archivers
MASTER_SITES= SF

Expand Down
5 changes: 3 additions & 2 deletions archivers/quazip/distinfo
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
SHA256 (quazip-0.7.1.tar.gz) = 78c984103555c51e6f7ef52e3a2128e2beb9896871b2cc4d4dbd4d64bff132de
SIZE (quazip-0.7.1.tar.gz) = 390629
TIMESTAMP = 1472674368
SHA256 (quazip-0.7.2.tar.gz) = 91d827fbcafd099ae814cc18a8dd3bb709da6b8a27c918ee1c6c03b3f29440f4
SIZE (quazip-0.7.2.tar.gz) = 466915
8 changes: 4 additions & 4 deletions archivers/quazip/files/patch-qztest_qztest.pro
Original file line number Diff line number Diff line change
@@ -1,9 +1,9 @@
--- qztest/qztest.pro.orig 2014-02-10 18:04:08 UTC
--- qztest/qztest.pro.orig 2016-03-01 15:20:57 UTC
+++ qztest/qztest.pro
@@ -40,7 +40,10 @@ MOC_DIR = .moc

@@ -43,7 +43,10 @@ MOC_DIR = .moc
win32:CONFIG(release, debug|release): LIBS += -L$$OUT_PWD/../quazip/release/ -lquazip
else:win32:CONFIG(debug, debug|release): LIBS += -L$$OUT_PWD/../quazip/debug/ -lquazip
else:win32:CONFIG(debug, debug|release): LIBS += -L$$OUT_PWD/../quazip/debug/ -lquazipd
else:mac:CONFIG(debug, debug|release): LIBS += -L$$OUT_PWD/../quazip/debug/ -lquazip_debug
-else:unix: LIBS += -L$$OUT_PWD/../quazip/ -lquazip
+else:unix: LIBS += -L$$OUT_PWD/../quazip/ -lquazip $$join(QMAKE_LIBDIR, " -L", -L) -L$$QMAKE_LIBDIR_QT
+
Expand Down
6 changes: 3 additions & 3 deletions archivers/unrar/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -2,12 +2,12 @@
# $FreeBSD$

PORTNAME= unrar
PORTVERSION= 5.31
PORTVERSION= 5.40
PORTEPOCH= 5
CATEGORIES+= archivers
MASTER_SITES= http://www.rarlab.com/rar/ \
LOCAL/sunpoet
DISTNAME= unrarsrc-5.3.11
DISTNAME= unrarsrc-5.4.5

MAINTAINER?= [email protected]
COMMENT= Extract, view & test RAR archives
Expand All @@ -31,7 +31,7 @@ SLAVEDIRS= archivers/unrar-iconv chinese/unrar

OPENSSL_AES_CPPFLAGS= -DOPENSSL_AES -I${OPENSSLINC}
OPENSSL_AES_LDFLAGS= -L${OPENSSLLIB} -lcrypto
OPENSSL_AES_USE= OPENSSL=yes
OPENSSL_AES_USES= ssl

do-install:
${INSTALL_PROGRAM} ${WRKSRC}/unrar ${STAGEDIR}${PREFIX}/bin/
Expand Down
5 changes: 3 additions & 2 deletions archivers/unrar/distinfo
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
SHA256 (unrarsrc-5.3.11.tar.gz) = 77b87af4b2976ef7c6b0c79e071284c2c1b035a9543273ec925f9d92f73b8763
SIZE (unrarsrc-5.3.11.tar.gz) = 223663
TIMESTAMP = 1472916114
SHA256 (unrarsrc-5.4.5.tar.gz) = e470c584332422893fb52e049f2cbd99e24dc6c6da971008b4e2ae4284f8796c
SIZE (unrarsrc-5.4.5.tar.gz) = 226320
2 changes: 1 addition & 1 deletion astro/josm/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -2,7 +2,7 @@
# $FreeBSD$

PORTNAME= josm
PORTVERSION= 10786
PORTVERSION= 10966
CATEGORIES= astro java
MASTER_SITES= http://josm.openstreetmap.de/download/ \
http://mirror.amdmi3.ru/distfiles/
Expand Down
6 changes: 3 additions & 3 deletions astro/josm/distinfo
Original file line number Diff line number Diff line change
@@ -1,3 +1,3 @@
TIMESTAMP = 1471300532
SHA256 (josm-snapshot-10786.jar) = f6cafd5be7689d00e4ecd1f528fe5079daa6f54eb7781ca1beb145c4ed188bb6
SIZE (josm-snapshot-10786.jar) = 10703670
TIMESTAMP = 1474055562
SHA256 (josm-snapshot-10966.jar) = 211ddb977b40c6c47ffdc183301d7d9f370053a7ad8519b158c49eec308df13d
SIZE (josm-snapshot-10966.jar) = 10750990
5 changes: 2 additions & 3 deletions audio/dir2ogg/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -2,10 +2,9 @@
# $FreeBSD$

PORTNAME= dir2ogg
PORTVERSION= 0.11.8
PORTREVISION= 4
PORTVERSION= 0.12
CATEGORIES= audio
MASTER_SITES= http://jak-linux.org/projects/dir2ogg/${PORTVERSION:R}/
MASTER_SITES= http://jak-linux.org/projects/dir2ogg/${PORTVERSION}/

MAINTAINER= [email protected]
COMMENT= Command-line {wav,mp3,m4a} to ogg converter
Expand Down
5 changes: 3 additions & 2 deletions audio/dir2ogg/distinfo
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
SHA256 (dir2ogg-0.11.8.tar.gz) = 0b6fd089fc1eb20cc92b7901c947ff6033ce04c897f9af9f962fa421a67ba7e0
SIZE (dir2ogg-0.11.8.tar.gz) = 21145
TIMESTAMP = 1473878764
SHA256 (dir2ogg-0.12.tar.gz) = 2876db3926415f40d728122f5836532253a25db1bc4877505e77ebcbc0cb5fea
SIZE (dir2ogg-0.12.tar.gz) = 19608
8 changes: 1 addition & 7 deletions audio/osd-lyrics/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -5,26 +5,20 @@ PORTNAME= osdlyrics
PORTVERSION= 0.4.3
PORTREVISION= 4
CATEGORIES= audio deskutils
MASTER_SITES= GOOGLE_CODE
PROJECTHOST= osd-lyrics
MASTER_SITES= https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/osd-lyrics/

MAINTAINER= [email protected]
COMMENT= On-screen lyrics display program for various media players

LICENSE= GPLv3

BROKEN= Unfetchable (google code has gone away)

LIB_DEPENDS= libnotify.so:devel/libnotify \
libdbus-glib-1.so:devel/dbus-glib \
libcurl.so:ftp/curl

USES= desktop-file-utils gettext gmake iconv localbase pkgconfig sqlite
USE_GNOME= gtk20 intltool
GNU_CONFIGURE= yes
# Cannot enable -Werror yet: Clang does not like the code `printf(_("..."))',
# see this bug for details: http://llvm.org/bugs/show_bug.cgi?id=3814
#CONFIGURE_ARGS= --with-werror
INSTALLS_ICONS= yes

PORTDOCS= AUTHORS ChangeLog NEWS README
Expand Down
1 change: 0 additions & 1 deletion audio/ruby-mp3tag/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -20,7 +20,6 @@ OPTIONS_DEFINE= DOCS EXAMPLES
NO_ARCH= yes
NO_BUILD= yes
USE_RUBY= yes
USE_RUBY_RDOC= yes

post-patch:
@${REINPLACE_CMD} -E \
Expand Down
2 changes: 1 addition & 1 deletion benchmarks/fio/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -2,7 +2,7 @@
# $FreeBSD$

PORTNAME= fio
PORTVERSION= 2.13
PORTVERSION= 2.14
CATEGORIES= benchmarks
MASTER_SITES= http://brick.kernel.dk/snaps/

Expand Down
6 changes: 3 additions & 3 deletions benchmarks/fio/distinfo
Original file line number Diff line number Diff line change
@@ -1,3 +1,3 @@
TIMESTAMP = 1469294180
SHA256 (fio-2.13.tar.bz2) = e03f3c7477ebab152edea3c08988e83cb57a53865439f377a9aa223dbf4c7681
SIZE (fio-2.13.tar.bz2) = 530845
TIMESTAMP = 1474138756
SHA256 (fio-2.14.tar.bz2) = 9156f784ab96a90150984ba92ddbd677b53605e70debf30f64bbbd438787e819
SIZE (fio-2.14.tar.bz2) = 543963
2 changes: 2 additions & 0 deletions benchmarks/fio/pkg-plist
Original file line number Diff line number Diff line change
Expand Up @@ -4,6 +4,8 @@ man/man1/fio.1.gz
man/man1/fio_generate_plots.1.gz
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/1mbs_clients.fio
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/aio-read.fio
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/backwards-read.fio
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/basic-verify.fio
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cpuio.fio
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/disk-zone-profile.fio
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/e4defrag.fio
Expand Down
2 changes: 1 addition & 1 deletion cad/irsim/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -2,7 +2,7 @@
# $FreeBSD$

PORTNAME= irsim
PORTVERSION= 9.7.94
PORTVERSION= 9.7.95
CATEGORIES= cad
MASTER_SITES= http://opencircuitdesign.com/irsim/archive/

Expand Down
6 changes: 3 additions & 3 deletions cad/irsim/distinfo
Original file line number Diff line number Diff line change
@@ -1,3 +1,3 @@
TIMESTAMP = 1469365797
SHA256 (irsim-9.7.94.tgz) = 09d40c9e0d7c63157f60eb012baa45f3ed51c7d094a74a229d325f1fe4e8e6aa
SIZE (irsim-9.7.94.tgz) = 466212
TIMESTAMP = 1474206660
SHA256 (irsim-9.7.95.tgz) = 5569d483f680fd812813b451fe93d5efd57a1609bfe2b7022bcea65b0c18b8c6
SIZE (irsim-9.7.95.tgz) = 466223
7 changes: 3 additions & 4 deletions cad/openvsp/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -2,10 +2,9 @@
# $FreeBSD$

PORTNAME= openvsp
PORTVERSION= 3.9.0
PORTVERSION= 3.9.1
DISTVERSIONPREFIX= ${GH_PROJECT}_
CATEGORIES= cad
MASTER_SITES= GH

MAINTAINER= [email protected]
COMMENT= Create a 3D model of an aircraft defined by engineering parameters
Expand Down Expand Up @@ -60,8 +59,8 @@ BUILD_PREFIX= OpenVSP-prefix/src/OpenVSP-build/_CPack_Packages/FreeBSD/ZIP/OpenV

do-install:
${INSTALL_PROGRAM} ${BUILD_WRKSRC}/${BUILD_PREFIX}/vsp* ${STAGEDIR}${PREFIX}/bin
${STRIP_CMD} ${STAGEDIR}/${PREFIX}/vsp*
${MKDIR} ${STAGEDIR}${DATADIR}
@${STRIP_CMD} ${STAGEDIR}/${PREFIX}/vsp*
@${MKDIR} ${STAGEDIR}${DATADIR}
.for d in CustomScripts airfoil matlab scripts textures
(cd ${BUILD_WRKSRC}/${BUILD_PREFIX}/${d} && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR})
.endfor
Expand Down
6 changes: 3 additions & 3 deletions cad/openvsp/distinfo
Original file line number Diff line number Diff line change
@@ -1,3 +1,3 @@
TIMESTAMP = 1472060174
SHA256 (OpenVSP-OpenVSP-OpenVSP_3.9.0_GH0.tar.gz) = 582efa843ecd46543950a8faac9c4c1274f0d897d31eef0bef887795d91142d3
SIZE (OpenVSP-OpenVSP-OpenVSP_3.9.0_GH0.tar.gz) = 32750881
TIMESTAMP = 1473160974
SHA256 (OpenVSP-OpenVSP-OpenVSP_3.9.1_GH0.tar.gz) = 3c9607a4f1574a6a2c85acc1f3c5e20e392f1ad7f9e8fbebd3cfd548a97a65fa
SIZE (OpenVSP-OpenVSP-OpenVSP_3.9.1_GH0.tar.gz) = 32752113
11 changes: 0 additions & 11 deletions cad/openvsp/files/patch-src_vsp__aero_viewer_ContourLevel.fl

This file was deleted.

11 changes: 0 additions & 11 deletions cad/openvsp/files/patch-src_vsp__aero_viewer_CuttingPlane.fl

This file was deleted.

Loading

0 comments on commit ec630fc

Please sign in to comment.