Skip to content

Commit

Permalink
Framework: sync with upstream
Browse files Browse the repository at this point in the history
Taken from: HardenedBSD
  • Loading branch information
fichtner committed Apr 22, 2021
1 parent 7d825b8 commit ee8b055
Show file tree
Hide file tree
Showing 4 changed files with 14 additions and 13 deletions.
1 change: 1 addition & 0 deletions MOVED
Original file line number Diff line number Diff line change
Expand Up @@ -16293,3 +16293,4 @@ x11-toolkits/qt5-gtkplatform||2021-04-17|Has expired: Archived upstream
textproc/py-markdown3|textproc/py-markdown|2021-04-20|markdown3 confilicts with too many ports
security/fbopenssl||2021-04-20|Unmaintained, abandoned, does not build with recent OS versions
devel/gearmand-devel||2021-04-20|Unmaintained, abandoned, has not built for over half a year
textproc/bsdsort||2021-04-21|Old version of sort(1)
12 changes: 6 additions & 6 deletions Mk/Uses/cabal.mk
Original file line number Diff line number Diff line change
Expand Up @@ -189,14 +189,14 @@ do-install:
${INSTALL_PROGRAM} \
$$(find ${WRKSRC}/dist-newstyle -name ${exe} -type f -perm +111) \
${STAGEDIR}${PREFIX}/${CABAL_LIBEXEC}/${exe}
${ECHO} '#!/bin/sh' > ${STAGEDIR}${PREFIX}/bin/${exe}
${ECHO} '' >> ${STAGEDIR}${PREFIX}/bin/${exe}
${ECHO} 'export ${exe:S/-/_/}_datadir=${DATADIR}' >> ${STAGEDIR}${PREFIX}/bin/${exe}
${ECHO_CMD} '#!/bin/sh' > ${STAGEDIR}${PREFIX}/bin/${exe}
${ECHO_CMD} '' >> ${STAGEDIR}${PREFIX}/bin/${exe}
${ECHO_CMD} 'export ${exe:S/-/_/}_datadir=${DATADIR}' >> ${STAGEDIR}${PREFIX}/bin/${exe}
. for dep in ${${exe}_DATADIR_VARS}
${ECHO} 'export ${dep:S/-/_/}_datadir=${DATADIR}' >> ${STAGEDIR}${PREFIX}/bin/${exe}
${ECHO_CMD} 'export ${dep:S/-/_/}_datadir=${DATADIR}' >> ${STAGEDIR}${PREFIX}/bin/${exe}
. endfor
${ECHO} '' >> ${STAGEDIR}${PREFIX}/bin/${exe}
${ECHO} '${PREFIX}/${CABAL_LIBEXEC}/${exe} "$$@"' >> ${STAGEDIR}${PREFIX}/bin/${exe}
${ECHO_CMD} '' >> ${STAGEDIR}${PREFIX}/bin/${exe}
${ECHO_CMD} 'exec ${PREFIX}/${CABAL_LIBEXEC}/${exe} "$$@"' >> ${STAGEDIR}${PREFIX}/bin/${exe}
${CHMOD} +x ${STAGEDIR}${PREFIX}/bin/${exe}
. endfor
. endif
Expand Down
4 changes: 2 additions & 2 deletions Mk/bsd.options.mk
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
# These variables are used in port makefiles to define the options for a port.
#
# OPTIONS_DEFINE - List of options this ports accept
# OPTIONS_DEFINE_${ARCH} - List of options this ports accept and are
# OPTIONS_DEFINE - List of options this port accepts
# OPTIONS_DEFINE_${ARCH} - List of options this port accepts and are
# specific to ${ARCH}
# OPTIONS_DEFAULT - List of options activated by default
# OPTIONS_DEFAULT_${ARCH} - List of options activated by default for a
Expand Down
10 changes: 5 additions & 5 deletions Tools/scripts/rmport
Original file line number Diff line number Diff line change
Expand Up @@ -51,7 +51,7 @@ if [ -n "$(command -v git 2>/dev/null)" ]; then
GIT=git
else
echo "git(1) not found. Please install devel/git."
exit 1
exit 66
fi

log()
Expand Down Expand Up @@ -103,7 +103,7 @@ find_catport()
echo ${category}/${port}
else
echo "What do you mean by '${arg}'?" >&2
exit 1
exit 64
fi
}

Expand Down Expand Up @@ -213,7 +213,7 @@ get_PRs()

if [ -z "${raw}" ] ; then
log "${catport}: empty result from URL: ${url}"
exit 1
exit 67
fi

printf "%s" "${raw}" \
Expand Down Expand Up @@ -378,11 +378,11 @@ usage()

if ! ${GIT} diff --exit-code remotes/origin/main ; then
echo "you have local commits, exiting" >&2
exit
exit 65
fi
if [ ! -r ${INDEX} ] ; then
echo "${INDEX} not readable, exiting" >&2
exit
exit 66
fi

git_dir="$(${GIT} rev-parse --git-dir)"
Expand Down

0 comments on commit ee8b055

Please sign in to comment.