Skip to content

Commit

Permalink
*/*: sync with upstream
Browse files Browse the repository at this point in the history
Taken from: FreeBSD
  • Loading branch information
fichtner committed Dec 28, 2016
1 parent 1ecb5bd commit eed7de3
Show file tree
Hide file tree
Showing 887 changed files with 34,333 additions and 4,203 deletions.
2 changes: 2 additions & 0 deletions accessibility/speech-dispatcher/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -90,6 +90,8 @@ post-install:

.else

PORTSCOUT= ignore:1

NO_ARCH= yes
USES+= python:3.3+
LIB_DEPENDS+= libspeechd.so:accessibility/speech-dispatcher
Expand Down
4 changes: 3 additions & 1 deletion archivers/freeze/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -12,6 +12,8 @@ MASTER_SITES= ftp://ftp.warwick.ac.uk/pub/compression/ \
MAINTAINER= [email protected]
COMMENT= Compression program - often used in QNX

LICENSE= NONE

CONFLICTS_INSTALL= mlt-[0-9]*
GNU_CONFIGURE= yes
ALL_TARGET= prog
Expand All @@ -22,7 +24,7 @@ PORTDOCS= README

OPTIONS_DEFINE= DOCS

post-install:
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}

Expand Down
1 change: 0 additions & 1 deletion archivers/innoextract/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -19,7 +19,6 @@ LIB_DEPENDS= libboost_iostreams.so:devel/boost-libs \
libboost_program_options.so:devel/boost-libs

USES= cmake iconv
CMAKE_ARGS= -DCMAKE_INSTALL_MANDIR=man

PLIST_FILES= bin/innoextract \
man/man1/innoextract.1.gz
Expand Down
3 changes: 3 additions & 0 deletions archivers/ruby-lha/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -25,6 +25,9 @@ SHEBANG_FILES= ${EXAMPLES}

OPTIONS_DEFINE= DOCS

DEPRECATED= Upstream no longer active
EXPIRATION_DATE= 2017-01-28

# We don't have executables in this package, but rake uses
# INSTALL_PROG for shared libraries:
MAKE_ARGS= INSTALL_PROG="${INSTALL_LIB}"
Expand Down
2 changes: 1 addition & 1 deletion archivers/rubygem-archive-zip/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -2,7 +2,7 @@
# $FreeBSD$

PORTNAME= archive-zip
PORTVERSION= 0.8.0
PORTVERSION= 0.9.0
CATEGORIES= archivers rubygems
MASTER_SITES= RG

Expand Down
5 changes: 3 additions & 2 deletions archivers/rubygem-archive-zip/distinfo
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
SHA256 (rubygem/archive-zip-0.8.0.gem) = c7ef7b7b7d97ab4ee9f70b4fe2d4973728634b3ba8fa8a483eb144c71ce3f67b
SIZE (rubygem/archive-zip-0.8.0.gem) = 57856
TIMESTAMP = 1482857412
SHA256 (rubygem/archive-zip-0.9.0.gem) = 3a21b9970e12b0d6a8e97da477360930fab3939be0c013c32e01e23cc4ac98af
SIZE (rubygem/archive-zip-0.9.0.gem) = 58368
2 changes: 1 addition & 1 deletion archivers/snzip/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
# $FreeBSD$

PORTNAME= snzip
PORTVERSION= 1.0.2
PORTVERSION= 1.0.4
CATEGORIES= archivers

MAINTAINER= [email protected]
Expand Down
5 changes: 3 additions & 2 deletions archivers/snzip/distinfo
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
SHA256 (kubo-snzip-1.0.2_GH0.tar.gz) = ec2763e15ca42455a32a53c8eefb92d7a4b8ea2f518a6e04c0f11f86c4924847
SIZE (kubo-snzip-1.0.2_GH0.tar.gz) = 1754963
TIMESTAMP = 1482759478
SHA256 (kubo-snzip-1.0.4_GH0.tar.gz) = e2f03856d8d232fe4e49b8a3b713ea92057c526f0ba2e028588b9b9570e5199a
SIZE (kubo-snzip-1.0.4_GH0.tar.gz) = 2373756
40 changes: 19 additions & 21 deletions astro/boinc-astropulse/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -31,25 +31,12 @@ BOINC_CLIENT_USER?= boinc
BOINC_CLIENT_GROUP?= boinc
BOINC_CLIENT_HOME?= /var/db/boinc

OPTIONS_DEFINE= X11
X11_DESC= Build screensaver (requires net/boinc-client with X11)

OPTIONS_SUB= yes

X11_BUILD_DEPENDS= ${LOCALBASE}/lib/libboinc_graphics2.a:net/boinc-client
X11_USES= jpeg
X11_USE= GL=gl,glu,glut \
XORG=ice,sm,x11,xau,xcb,xext,xi,xdamage,xdmcp,xfixes,xmu,xt,xxf86vm
X11_CONFIGURE_ENABLE= graphics

X11_BUILD_DEPENDS_OFF= ${LOCALBASE}/include/boinc/std_fixes.h:net/boinc-client

SETI_WORK!= cd ${.CURDIR}/../boinc-setiathome-v7 && ${MAKE} -V WRKSRC
CONFIGURE_ENV+= BOINCDIR="${NONEXISTENT}" \
CONFIGURE_ENV= BOINCDIR="${NONEXISTENT}" \
BOINC_DIR="${NONEXISTENT}" \
SETI_BOINC_DIR="${SETI_WORK}"
CONFIGURE_ARGS+= --disable-static-client \
--with-boinc-platform=${ARCH}-portbld-freebsd
CONFIGURE_ARGS= --disable-static-client \
--with-boinc-platform=${ARCH}-portbld-freebsd

SETI_SITE= setiathome.berkeley.edu
AP_BINARY= astropulse-${PORTVERSION:S/.0/./}.${ARCH}-portbld-freebsd
Expand All @@ -61,19 +48,30 @@ SUB_LIST= AP_BINARY=${AP_BINARY} \
BOINC_CLIENT_HOME=${BOINC_CLIENT_HOME} \
BOINC_CLIENT_USER=${BOINC_CLIENT_USER} \
BOINC_CLIENT_GROUP=${BOINC_CLIENT_GROUP}
PLIST_SUB+= AP_BINARY=${AP_BINARY} \
PLIST_SUB= AP_BINARY=${AP_BINARY} \
SETI_SITE=${SETI_SITE} \
BOINC_CLIENT_HOME=${BOINC_CLIENT_HOME} \
BOINC_CLIENT_USER=${BOINC_CLIENT_USER} \
BOINC_CLIENT_GROUP=${BOINC_CLIENT_GROUP}

OPTIONS_DEFINE= X11
OPTIONS_SUB= yes

X11_DESC= Build screensaver (requires net/boinc-client with X11)
X11_BUILD_DEPENDS= ${LOCALBASE}/lib/libboinc_graphics2.a:net/boinc-client
X11_USES= jpeg
X11_USE= GL=gl,glu,glut \
XORG=ice,sm,x11,xau,xcb,xext,xi,xdamage,xdmcp,xfixes,xmu,xt,xxf86vm
X11_CONFIGURE_ENABLE= graphics
X11_BUILD_DEPENDS_OFF= ${LOCALBASE}/include/boinc/std_fixes.h:net/boinc-client

do-install:
${INSTALL} -d ${STAGEDIR}${BOINC_CLIENT_HOME}/projects
${INSTALL} -d ${STAGEDIR}${BOINC_CLIENT_HOME}/projects/${SETI_SITE}
@${MKDIR} ${STAGEDIR}${BOINC_CLIENT_HOME}/projects/${SETI_SITE}
${INSTALL_PROGRAM} ${WRKSRC}/${AP_BINARY} \
${STAGEDIR}${BOINC_CLIENT_HOME}/projects/${SETI_SITE}/
${STAGEDIR}${BOINC_CLIENT_HOME}/projects/${SETI_SITE}/

do-install-X11-on:
${INSTALL_PROGRAM} ${WRKSRC}/ap_graphics \
${STAGEDIR}${BOINC_CLIENT_HOME}/projects/${SETI_SITE}/
${STAGEDIR}${BOINC_CLIENT_HOME}/projects/${SETI_SITE}/

.include <bsd.port.mk>
11 changes: 11 additions & 0 deletions astro/boinc-astropulse/files/patch-ap__client__main.cpp
Original file line number Diff line number Diff line change
@@ -1,5 +1,16 @@
--- ap_client_main.cpp.orig 2012-08-14 00:07:20 UTC
+++ ap_client_main.cpp
@@ -241,7 +241,7 @@ int detect_hit(float *arr, float& total)
* calls to this function.
*/
void updatecputime() {
- int cputicksinterval = abs(clock() - lastcputicks);
+ int cputicksinterval = abs((long)clock() - (long)lastcputicks);
lastcputicks = clock();
maxcputicksinterval = (maxcputicksinterval > cputicksinterval)?maxcputicksinterval:cputicksinterval;
cputime += ((float)cputicksinterval / (float)CLOCKS_PER_SEC);
--- ap_client_main.cpp.orig 2012-08-14 00:07:20 UTC
+++ ap_client_main.cpp
@@ -1288,7 +1288,6 @@ void Science::mainloop() {
* used to inform the core client GUI of the % complete.
*/
Expand Down
11 changes: 8 additions & 3 deletions astro/libosmium/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -4,6 +4,7 @@
PORTNAME= libosmium
PORTVERSION= 2.10.3
DISTVERSIONPREFIX= v
PORTREVISION= 1
CATEGORIES= astro geography devel

MAINTAINER= [email protected]
Expand All @@ -16,7 +17,9 @@ LIB_DEPENDS= libgdal.so:graphics/gdal \
libboost_regex.so:devel/boost-libs \
libgeos.so:graphics/geos \
libexpat.so:textproc/expat2
BUILD_DEPENDS= sparsehash>=0:devel/sparsehash
BUILD_DEPENDS= sparsehash>=0:devel/sparsehash \
${LOCALBASE}/include/utf8.h:devel/utf8cpp
RUN_DEPENDS= ${LOCALBASE}/include/utf8.h:devel/utf8cpp

BROKEN_FreeBSD_9= does not build (lack of c++11 support)

Expand All @@ -29,8 +32,7 @@ CMAKE_ARGS= -DBUILD_EXAMPLES:BOOL=OFF
# if/when corresponding ports appear in the tree, these will need to
# be turned from depends
CMAKE_ARGS+= -DINSTALL_GDALCPP:BOOL=ON \
-DINSTALL_PROTOZERO:BOOL=ON \
-DINSTALL_UTFCPP:BOOL=ON
-DINSTALL_PROTOZERO:BOOL=ON

# though it builds tests, the library itself is header-only
NO_ARCH= yes
Expand All @@ -42,6 +44,9 @@ OPTIONS_DEFAULT= TEST
TEST_TEST_TARGET= test
TEST_CMAKE_BOOL= BUILD_TESTING

post-extract:
@${RM} -rf ${WRKSRC}/include/utf8*

post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/CHANGELOG.md ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}
Expand Down
4 changes: 0 additions & 4 deletions astro/libosmium/pkg-plist
Original file line number Diff line number Diff line change
Expand Up @@ -187,7 +187,3 @@ include/protozero/pbf_writer.hpp
include/protozero/types.hpp
include/protozero/varint.hpp
include/protozero/version.hpp
include/utf8.h
include/utf8/checked.h
include/utf8/core.h
include/utf8/unchecked.h
5 changes: 1 addition & 4 deletions astro/stellarium/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -2,8 +2,7 @@
# $FreeBSD$

PORTNAME= stellarium
PORTVERSION= 0.15.0
PORTREVISION= 1
PORTVERSION= 0.15.1
CATEGORIES= astro
MASTER_SITES= SF/${PORTNAME}/Stellarium-sources/${PORTVERSION}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
Expand Down Expand Up @@ -71,8 +70,6 @@ post-extract-DOCS-on:

post-patch:
@${REINPLACE_CMD} -e 's, -Wno-unused-result,,' ${WRKSRC}/CMakeLists.txt
@${REINPLACE_CMD} -e 's,-Testscene,&_ground,' \
${WRKSRC}/scenery3d/Testscene/TX_Stellarium-Testscene_ground/CMakeLists.txt

post-install-MORE_STARS-on:
${INSTALL_DATA} ${DISTDIR}/stars_[45678]_[12]v0_1.cat \
Expand Down
5 changes: 3 additions & 2 deletions astro/stellarium/distinfo
Original file line number Diff line number Diff line change
@@ -1,5 +1,6 @@
SHA256 (stellarium-0.15.0.tar.gz) = 74d0e3a69fcbaf1c6278f601a44497fd3e9f2de7dfa11a60197d3afb68288746
SIZE (stellarium-0.15.0.tar.gz) = 147160785
TIMESTAMP = 1482657338
SHA256 (stellarium-0.15.1.tar.gz) = 0fe52fc496c11d92728742ae6d71bac116746dca7885d34d17b1a288fe8b5b11
SIZE (stellarium-0.15.1.tar.gz) = 155860125
SHA256 (stellarium_user_guide-0.15.0-1.pdf) = 264d437a1afc0742f5bbadf37115d8cd2b41ac462daf1516657c091955c9217e
SIZE (stellarium_user_guide-0.15.0-1.pdf) = 16155822
SHA256 (stars_4_1v0_1.cat) = 7a2084e5e45610bbffae9448d9552d8a8dd191e5b1a07b0e47d27622fab4a979
Expand Down
13 changes: 0 additions & 13 deletions astro/stellarium/files/patch-CMakeLists.txt

This file was deleted.

Loading

0 comments on commit eed7de3

Please sign in to comment.