forked from opnsense/ports
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Taken from: FreeBSD
- Loading branch information
Showing
592 changed files
with
6,581 additions
and
5,559 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -5,7 +5,8 @@ CATEGORIES= archivers www pear | |
MAINTAINER= [email protected] | ||
COMMENT= Horde Fast Compression Library | ||
|
||
USES= horde | ||
USES= cpe horde | ||
USE_HORDE_RUN= Horde_Exception | ||
CPE_VENDOR= horde | ||
|
||
.include <bsd.port.mk> |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -5,8 +5,9 @@ CATEGORIES= archivers www pear | |
MAINTAINER= [email protected] | ||
COMMENT= Horde Pack Utility | ||
|
||
USES= horde | ||
USES= cpe horde | ||
USE_HORDE_RUN= Horde_Compress_Fast \ | ||
Horde_Exception | ||
CPE_VENDOR= horde | ||
|
||
.include <bsd.port.mk> |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,6 +1,6 @@ | ||
PORTNAME= indiwebmanagerapp | ||
DISTVERSION= 1.6 | ||
PORTREVISION= 1 | ||
PORTREVISION= 2 | ||
CATEGORIES= astro | ||
|
||
MAINTAINER= [email protected] | ||
|
@@ -21,4 +21,10 @@ USE_GITHUB= yes | |
GH_ACCOUNT= rlancaste | ||
GH_PROJECT= INDIWebManagerApp | ||
|
||
post-patch: | ||
${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' -e \ | ||
's|python3|${PYTHON_VERSION}|g' ${WRKSRC}/src/mainwindow.cpp | ||
${REINPLACE_CMD} -e 's|On Linux|On Linux\/FreeBSD|g' \ | ||
${WRKSRC}/src/opsconfiguration.cpp | ||
|
||
.include <bsd.port.mk> |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,55 @@ | ||
--- src/mainwindow.cpp 2021-09-04 23:55:40.427687000 -0500 | ||
+++ src/mainwindow.cpp 2021-09-05 00:10:09.774435000 -0500 | ||
@@ -295,6 +295,8 @@ | ||
#ifdef Q_OS_OSX | ||
//Note this is the Path where python3 gets symlinked by homebrew. | ||
return "/usr/local/opt/python/libexec/bin"; | ||
+ #elif defined(Q_OS_FREEBSD) | ||
+ return "%%LOCALBASE%%/bin"; | ||
#endif | ||
if (flat.isEmpty() == false) | ||
return flat + "/bin/"; | ||
@@ -307,6 +309,8 @@ | ||
{ | ||
#ifdef Q_OS_OSX | ||
return "/usr/local/bin/indi-web"; | ||
+ #elif defined(Q_OS_FREEBSD) | ||
+ return "%%LOCALBASE%%/bin/indi-web"; | ||
#endif | ||
return QDir::homePath() + "/.local/bin/indi-web"; | ||
} | ||
@@ -316,6 +320,8 @@ | ||
{ | ||
#ifdef Q_OS_OSX | ||
return QStandardPaths::locate(QStandardPaths::GenericDataLocation, QString(), QStandardPaths::LocateDirectory) + "INDIWebManagerApp/gsc"; | ||
+ #elif defined(Q_OS_FREEBSD) | ||
+ return "%%LOCALBASE%%/share/gsc"; | ||
#endif | ||
if (flat.isEmpty() == false) | ||
return flat + "/share/GSC"; | ||
@@ -339,6 +345,8 @@ | ||
#ifdef Q_OS_OSX | ||
QString appPath = QCoreApplication::applicationDirPath(); | ||
return QDir(appPath + "/indi").absolutePath(); | ||
+ #elif defined(Q_OS_FREEBSD) | ||
+ return "%%LOCALBASE%%/bin/"; | ||
#endif | ||
if (flat.isEmpty() == false) | ||
return flat + "/bin/"; | ||
@@ -352,6 +360,8 @@ | ||
#ifdef Q_OS_OSX | ||
QString appPath = QCoreApplication::applicationDirPath(); | ||
return QDir(appPath + "/../Resources/DriverSupport").absolutePath(); | ||
+ #elif defined(Q_OS_FREEBSD) | ||
+ return "%%LOCALBASE%%/share/indi"; | ||
#elif defined(Q_OS_LINUX) | ||
if (flat.isEmpty() == false) | ||
return flat + "/share/indi"; | ||
@@ -544,7 +554,6 @@ | ||
*/ | ||
bool MainWindow::pythonInstalled(QString pythonExecFolder) | ||
{ | ||
- | ||
return QFileInfo(pythonExecFolder + "/python").exists() || QFileInfo(pythonExecFolder + "/python2").exists() || QFileInfo(pythonExecFolder + "/python3").exists(); | ||
} | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,7 +1,7 @@ | ||
# Created by: Gleb Smirnoff <[email protected]> | ||
|
||
PORTNAME= josm | ||
PORTVERSION= 18191 | ||
PORTVERSION= 18193 | ||
CATEGORIES= astro java | ||
MASTER_SITES= https://josm.openstreetmap.de/download/ \ | ||
https://mirror.amdmi3.ru/distfiles/ | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,3 @@ | ||
TIMESTAMP = 1630604074 | ||
SHA256 (josm-snapshot-18191.jar) = 39fbc934feed0f1c8c844270dc83274dffc417e80dc6073443d0d59bf35876eb | ||
SIZE (josm-snapshot-18191.jar) = 16013739 | ||
TIMESTAMP = 1630938120 | ||
SHA256 (josm-snapshot-18193.jar) = e7996b3ce950431d6b9a6233049e76db34a26bb46654d4de1ee136d2f13577a0 | ||
SIZE (josm-snapshot-18193.jar) = 16013832 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,7 +1,6 @@ | ||
PORTNAME= phd2 | ||
DISTVERSIONPREFIX=v | ||
DISTVERSION= 2.6.9dev5 | ||
PORTREVISION= 3 | ||
DISTVERSION= 2.6.10 | ||
CATEGORIES= astro | ||
|
||
MAINTAINER= [email protected] | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,3 @@ | ||
TIMESTAMP = 1621752833 | ||
SHA256 (OpenPHDGuiding-phd2-v2.6.9dev5_GH0.tar.gz) = 93028d3a8b8d04276db886505176daa5192a21238d0801f2b251905ad4e0a9f7 | ||
SIZE (OpenPHDGuiding-phd2-v2.6.9dev5_GH0.tar.gz) = 110229487 | ||
TIMESTAMP = 1630823115 | ||
SHA256 (OpenPHDGuiding-phd2-v2.6.10_GH0.tar.gz) = f330ae45dfe3c0166b509adcac11a28403dc101e97020ab5f09d8e681e11cd5d | ||
SIZE (OpenPHDGuiding-phd2-v2.6.10_GH0.tar.gz) = 117658264 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,11 @@ | ||
--- indiweb/driver.py 2021-09-05 00:47:09.163136000 -0500 | ||
+++ indiweb/driver.py 2021-09-05 00:47:30.642233000 -0500 | ||
@@ -5,7 +5,7 @@ | ||
import xml.etree.ElementTree as ET | ||
|
||
# Default INDI data directory | ||
-INDI_DATA_DIR = "/usr/share/indi/" | ||
+INDI_DATA_DIR = "%%LOCALBASE%%/share/indi/" | ||
|
||
|
||
class DeviceDriver: |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,6 +1,5 @@ | ||
PORTNAME= stellarsolver | ||
DISTVERSION= 1.5 | ||
PORTREVISION= 1 | ||
DISTVERSION= 1.8 | ||
CATEGORIES= astro | ||
|
||
MAINTAINER= [email protected] | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,3 @@ | ||
TIMESTAMP = 1621530559 | ||
SHA256 (rlancaste-stellarsolver-1.5_GH0.tar.gz) = 62ce99c066a205c9f7c5cbace1678504750ceeb99cb12bacd4e4a329c4f512bc | ||
SIZE (rlancaste-stellarsolver-1.5_GH0.tar.gz) = 9113711 | ||
TIMESTAMP = 1630876435 | ||
SHA256 (rlancaste-stellarsolver-1.8_GH0.tar.gz) = 4f0009dfa76b153848abd9bcbea52b8dc27159133cf6a1db165b16e5c7b04841 | ||
SIZE (rlancaste-stellarsolver-1.8_GH0.tar.gz) = 9117094 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -3,8 +3,12 @@ | |
PORTNAME= fasttracker2 | ||
DISTVERSIONPREFIX= v | ||
DISTVERSION= 1.47 | ||
PORTREVISION= 1 | ||
CATEGORIES= audio | ||
|
||
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/ | ||
PATCHFILES+= 14013d2165f6.patch:-p1 # https://github.com/8bitbubsy/ft2-clone/issues/21 | ||
|
||
MAINTAINER= [email protected] | ||
COMMENT= Fasttracker II clone | ||
|
||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,5 @@ | ||
TIMESTAMP = 1621948797 | ||
TIMESTAMP = 1630666288 | ||
SHA256 (8bitbubsy-ft2-clone-v1.47_GH0.tar.gz) = a011c6c13aff8788daa6df5e8c6d44d2e1ce6d470618e41d9ede45c37ce79f5b | ||
SIZE (8bitbubsy-ft2-clone-v1.47_GH0.tar.gz) = 5234480 | ||
SHA256 (14013d2165f6.patch) = d0a03e33b679a39daf2acd55cf8c91402abc1318779b0fcc42e8318279baa105 | ||
SIZE (14013d2165f6.patch) = 1033 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,7 +1,7 @@ | ||
# Created by: <[email protected]> | ||
|
||
PORTNAME= libsamplerate | ||
DISTVERSION= 0.2.1 | ||
DISTVERSION= 0.2.2 | ||
CATEGORIES= audio | ||
MASTER_SITES= https://github.com/libsndfile/${PORTNAME}/releases/download/${DISTVERSION}/ | ||
|
||
|
@@ -11,7 +11,7 @@ COMMENT= Secret Rabbit Code: a Sample Rate Converter for audio | |
LICENSE= BSD2CLAUSE | ||
LICENSE_FILE= ${WRKSRC}/COPYING | ||
|
||
USES= cmake cpe pkgconfig tar:bz2 | ||
USES= cmake cpe pkgconfig tar:xz | ||
|
||
CPE_VENDOR= ${CPE_PRODUCT}_project | ||
|
||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,3 @@ | ||
TIMESTAMP = 1611794308 | ||
SHA256 (libsamplerate-0.2.1.tar.bz2) = f6323b5e234753579d70a0af27796dde4ebeddf58aae4be598e39b3cee00c90a | ||
SIZE (libsamplerate-0.2.1.tar.bz2) = 3747188 | ||
TIMESTAMP = 1630910419 | ||
SHA256 (libsamplerate-0.2.2.tar.xz) = 3258da280511d24b49d6b08615bbe824d0cacc9842b0e4caf11c52cf2b043893 | ||
SIZE (libsamplerate-0.2.2.tar.xz) = 3319468 |
Oops, something went wrong.