Skip to content

Commit

Permalink
ath79: replace patches
Browse files Browse the repository at this point in the history
replace our downstream version of the patches with the ones
that were sent upstream.

Signed-off-by: John Crispin <[email protected]>
  • Loading branch information
blogic committed Aug 28, 2018
1 parent af6e901 commit 9300eda
Show file tree
Hide file tree
Showing 35 changed files with 1,332 additions and 1,322 deletions.
Original file line number Diff line number Diff line change
@@ -1,14 +1,14 @@
From cb376159800b9b44be76949c3aee89eb06d29faa Mon Sep 17 00:00:00 2001
From f3eacff2310a60348a755c50a8da6fc251fc8587 Mon Sep 17 00:00:00 2001
From: John Crispin <[email protected]>
Date: Tue, 6 Mar 2018 09:55:13 +0100
Subject: [PATCH 07/27] irqchip/irq-ath79-intc: add irq cascade driver for
Subject: [PATCH 07/33] irqchip/irq-ath79-intc: add irq cascade driver for
QCA9556 SoCs

Signed-off-by: John Crispin <[email protected]>
---
drivers/irqchip/Makefile | 1 +
drivers/irqchip/irq-ath79-intc.c | 104 +++++++++++++++++++++++++++++++++++++++
2 files changed, 105 insertions(+)
drivers/irqchip/irq-ath79-intc.c | 142 +++++++++++++++++++++++++++++++++++++++
2 files changed, 143 insertions(+)
create mode 100644 drivers/irqchip/irq-ath79-intc.c

--- a/drivers/irqchip/Makefile
Expand Down
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
From f711421eb5f6f790f1ebc09a13ae4aed8ba5f67b Mon Sep 17 00:00:00 2001
From e029f998594f151008ecbfa024e2957edd2a5189 Mon Sep 17 00:00:00 2001
From: John Crispin <[email protected]>
Date: Tue, 6 Mar 2018 09:58:19 +0100
Subject: [PATCH 08/27] irqchip/irq-ath79-cpu: drop !OF init helper
Subject: [PATCH 08/33] irqchip/irq-ath79-cpu: drop !OF init helper

Signed-off-by: John Crispin <[email protected]>
---
Expand Down
Original file line number Diff line number Diff line change
@@ -1,12 +1,21 @@
From 3ea2bff4ed3ce74dc4303aa20f5e906e78352f6b Mon Sep 17 00:00:00 2001
From: John Crispin <john@phrozen.org>
From e93fe20529aeb8738b87533f66c46e2c21524530 Mon Sep 17 00:00:00 2001
From: Gabor Juhos <juhosg@openwrt.org>
Date: Tue, 6 Mar 2018 10:06:10 +0100
Subject: [PATCH 09/27] MIPS: ath79: add lots of missing registers
Subject: [PATCH 09/33] MIPS: ath79: add lots of missing registers

This patch adds many new registers for various QCA MIPS SoCs. The patch is
an aggragate of many contributions made to OpenWrt.

Signed-off-by: Gabor Juhos <[email protected]>
Signed-off-by: Henryk Heisig <[email protected]>
Signed-off-by: Matthias Schiffer <[email protected]>
Signed-off-by: Weijie Gao <[email protected]>
Signed-off-by: Felix Fietkau <[email protected]>
Signed-off-by: Julien Dusser <[email protected]>
Signed-off-by: John Crispin <[email protected]>
---
arch/mips/include/asm/mach-ath79/ar71xx_regs.h | 773 ++++++++++++++++++++++++-
1 file changed, 771 insertions(+), 2 deletions(-)
arch/mips/include/asm/mach-ath79/ar71xx_regs.h | 771 ++++++++++++++++++++++++-
1 file changed, 770 insertions(+), 1 deletion(-)

--- a/arch/mips/include/asm/mach-ath79/ar71xx_regs.h
+++ b/arch/mips/include/asm/mach-ath79/ar71xx_regs.h
Expand Down Expand Up @@ -650,7 +659,7 @@ Signed-off-by: John Crispin <[email protected]>

/*
* SRIF block
@@ -552,4 +1007,322 @@
@@ -552,4 +1007,318 @@
#define AR934X_SRIF_DPLL2_OUTDIV_SHIFT 13
#define AR934X_SRIF_DPLL2_OUTDIV_MASK 0x7

Expand Down Expand Up @@ -876,10 +885,6 @@ Signed-off-by: John Crispin <[email protected]>
+#define AR934X_ETH_CFG_RDV_DELAY BIT(16)
+#define AR934X_ETH_CFG_RDV_DELAY_MASK 0x3
+#define AR934X_ETH_CFG_RDV_DELAY_SHIFT 16
+#define AR934X_ETH_CFG_TXD_DELAY_MASK 0x3
+#define AR934X_ETH_CFG_TXD_DELAY_SHIFT 18
+#define AR934X_ETH_CFG_TXE_DELAY_MASK 0x3
+#define AR934X_ETH_CFG_TXE_DELAY_SHIFT 20
+
+/*
+ * QCA953X GMAC Interface
Expand Down
Loading

0 comments on commit 9300eda

Please sign in to comment.