Skip to content

Commit

Permalink
archrelease: copy trunk to testing-any
Browse files Browse the repository at this point in the history
git-svn-id: file:///srv/repos/svn-packages/svn@404969 eb2447ed-0c53-47e4-bac8-5bc4a241df78
  • Loading branch information
allan committed Dec 24, 2020
1 parent 515cd7e commit 513720d
Show file tree
Hide file tree
Showing 5 changed files with 183 additions and 0 deletions.
Original file line number Diff line number Diff line change
@@ -0,0 +1,28 @@
From e5654a5591884b92633c7785f325626711e7f7aa Mon Sep 17 00:00:00 2001
From: Paul Eggert <[email protected]>
Date: Tue, 29 Jan 2013 13:46:48 -0800
Subject: [PATCH] autoscan: port to perl 5.17

* bin/autoscan.in (scan_sh_file): Escape '{'. This avoids a
feature that is deprecated in Perl 5.17. Reported by Ray Lauff in
<http://lists.gnu.org/archive/html/bug-autoconf/2013-01/msg00059.html>.
---
bin/autoscan.in | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/bin/autoscan.in b/bin/autoscan.in
index 993a750..db1df79 100644
--- a/bin/autoscan.in
+++ b/bin/autoscan.in
@@ -358,7 +358,7 @@ sub scan_sh_file ($)
{
# Strip out comments and variable references.
s/#.*//;
- s/\${[^\}]*}//g;
+ s/\$\{[^\}]*}//g;
s/@[^@]*@//g;

# Tokens in the code.
--
2.1.0

25 changes: 25 additions & 0 deletions autoconf/repos/testing-any/0002-autoconf-2.69-perl-5.28.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,25 @@
From dfb0659b205e03af62542cd318a9f3253e28c40a Mon Sep 17 00:00:00 2001
From: Daniel Colascione <[email protected]>
Date: Sun, 4 Mar 2018 13:36:55 -0800
Subject: [PATCH] Fix test suite with modern Perl

---
tests/tools.at | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/tests/tools.at b/tests/tools.at
index a4a7dd7..e9a6240 100644
--- a/tests/tools.at
+++ b/tests/tools.at
@@ -1386,7 +1386,7 @@ do
funny=`func_sanitize_file_name "$funny"`
file=" file $funny"
dir=`func_sanitize_dir_name " dir $funny"`
- TMPDIR=" tmp$dir"
+ TMPDIR="./ tmp$dir"
export TMPDIR

# skip if we cannot create such a file or directory
--
1.9.1

Original file line number Diff line number Diff line change
@@ -0,0 +1,27 @@
From 247b02e5a5bb79ca6666e91de02ae2d3cb0cd325 Mon Sep 17 00:00:00 2001
From: Gary V. Vaughan <[email protected]>
Date: Mon, 03 Nov 2014 06:25:03 +0000
Subject: tests: avoid spurious test failure with libtool 2.4.3

Based on a report by Bruce Dubbs.

* tests/foreign.at (Libtool): Be tolerant of 'quote' replacing the
older `quote'.

Signed-off-by: Eric Blake <[email protected]>
---
diff --git a/tests/foreign.at b/tests/foreign.at
index a9dc33c..d4702cd 100644
--- a/tests/foreign.at
+++ b/tests/foreign.at
@@ -57,7 +57,7 @@ AT_CHECK([./config.guess || exit 77], [], [ignore], [ignore])
# Make sure at-path contains something valid, and let the test suite
# display it when verbose. And fail, skipping would too easily hide
# problems.
-AT_CHECK([sed -n ["s,^.*\`\\(/[^']*\\)'.*,\\1,p"] stdout], [0], [stdout])
+AT_CHECK([sed -n ["s,^[^']*[\`']\\(/[^']*\\)'.*,\\1,p"] stdout], [0], [stdout])
AT_CHECK([test -f "`sed -n 1p stdout`"])

# Older libtoolize installed everything but install-sh...
--
cgit v0.9.0.2
60 changes: 60 additions & 0 deletions autoconf/repos/testing-any/0004-Port-tests-to-Bash-5.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,60 @@
From 5b9db67786a428164abafe626ab11a2754aad528 Mon Sep 17 00:00:00 2001
From: Ondrej Dubaj <[email protected]>
Date: Wed, 28 Aug 2019 07:39:50 +0200
Subject: [PATCH] Port tests to Bash 5

* tests/local.at (AT_CHECK_ENV, AT_CONFIG_CMP):
Add BASH_ARGC, BASH_ARGV to list of variables to be ignored when
comparing variable space dumps.
(AT_CONFIG_CMP): Also ignore LINENO.
* tests/m4sh.at: Also unset LINENO in 'reference' and 'test/test-1'.
---
tests/local.at | 5 ++++-
tests/m4sh.at | 4 ++--
2 files changed, 6 insertions(+), 3 deletions(-)

diff --git a/tests/local.at b/tests/local.at
index a22958c..852be28 100644
--- a/tests/local.at
+++ b/tests/local.at
@@ -325,7 +325,7 @@ if test -f state-env.before && test -f state-env.after; then
[AWK|LEX|LEXLIB|LEX_OUTPUT_ROOT|LN_S|M4|MKDIR_P|RANLIB|SET_MAKE|YACC],
[GREP|[EF]GREP|SED],
[[_@]|.[*#?$].],
- [argv|ARGC|LINENO|OLDPWD|PIPESTATUS|RANDOM|SECONDS]))=' \
+ [argv|ARGC|LINENO|BASH_ARGC|BASH_ARGV|OLDPWD|PIPESTATUS|RANDOM|SECONDS]))=' \
$act_file ||
test $? -eq 1 || echo failed >&2
) 2>stderr-$act_file |
@@ -382,6 +382,9 @@ do
/'\'\\\$\''=/ d
/^argv=/ d
/^ARGC=/ d
+ /^BASH_ARGC=/ d
+ /^BASH_ARGV=/ d
+ /^LINENO=/ d
' $act_file >at_config_vars-$act_file
done
AT_CMP([at_config_vars-$1], [at_config_vars-$2])[]dnl
diff --git a/tests/m4sh.at b/tests/m4sh.at
index e9d70b0..cbdfcb6 100644
--- a/tests/m4sh.at
+++ b/tests/m4sh.at
@@ -254,7 +254,7 @@ AT_CHECK([autom4te -l m4sh $1.as -o $1])
# `_oline_', once processed and ran, produces our reference.
# We check that we find ourselves by looking at a string which is
# available only in the original script: `_oline_'.
-AT_DATA_LINENO([reference], [false], [__OLINE__], [_oline__])
+AT_DATA_LINENO([reference], [true], [__OLINE__], [_oline__])
AT_CHECK([./reference], 0, [stdout])

# The reference:
@@ -264,7 +264,7 @@ mv stdout expout
# Be sure to be out of the PATH.
AT_CHECK([mkdir test || exit 77])

-AT_DATA_LINENO([test/test-1], [false], [__LINENO__], [LINENO])
+AT_DATA_LINENO([test/test-1], [true], [__LINENO__], [LINENO])
AT_CHECK([./test/test-1], 0, [expout])
AT_CHECK([(PATH=test$PATH_SEPARATOR$PATH; export PATH; exec test-1)],
0, [expout])
43 changes: 43 additions & 0 deletions autoconf/repos/testing-any/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,43 @@
# Maintainer: Lukas Fleischer <[email protected]>
# Contributor: Allan McRae <[email protected]>
# Contributor: Andreas Radke <[email protected]>

pkgname=autoconf
pkgver=2.70
pkgrel=1
pkgdesc="A GNU tool for automatically configuring source code"
arch=('any')
license=('GPL2' 'GPL3' 'custom')
url="https://www.gnu.org/software/autoconf"
groups=('base-devel')
depends=('awk' 'm4' 'diffutils' 'perl' 'sh')
checkdepends=('gcc-fortran')
source=("https://ftp.gnu.org/pub/gnu/${pkgname}/${pkgname}-${pkgver}.tar.xz"{,.sig})
md5sums=('e4453011b18da194b565bf282948f997'
'SKIP')
validpgpkeys=('82F854F3CE73174B8B63174091FCC32B6769AA64') # Zack Weinberg


build() {
cd "${pkgname}-${pkgver}"
./configure --prefix=/usr
make
}

check() {
cd "${srcdir}/${pkgname}-${pkgver}"

# test 309 is a false positive due to warning outputted with our build flags
make check || true
}

package() {
cd "${srcdir}/${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" install

# license exception
install -Dm644 COPYING.EXCEPTION "$pkgdir"/usr/share/licenses/autoconf/COPYING.EXCEPTION

# remove unwanted file
rm -f "$pkgdir"/usr/share/info/standards.info
}

0 comments on commit 513720d

Please sign in to comment.