Skip to content

Commit

Permalink
Add proper quoting to paths
Browse files Browse the repository at this point in the history
git-svn-id: file:///srv/repos/svn-packages/svn@369437 eb2447ed-0c53-47e4-bac8-5bc4a241df78
  • Loading branch information
lfleischer committed Nov 19, 2019
1 parent a0b8fea commit 61f4a3d
Showing 1 changed file with 22 additions and 22 deletions.
44 changes: 22 additions & 22 deletions autoconf/trunk/PKGBUILD
Original file line number Diff line number Diff line change
@@ -1,4 +1,5 @@
# Maintainer: Allan McRae <[email protected]>
# Maintainer: Lukas Fleischer <[email protected]>
# Contributor: Allan McRae <[email protected]>
# Contributor: Andreas Radke <[email protected]>

pkgname=autoconf
Expand All @@ -12,7 +13,7 @@ groups=('base-devel')
depends=('awk' 'm4' 'diffutils' 'sh')
makedepends=('help2man') # needed while perl patch is present
checkdepends=('gcc-fortran')
source=(https://ftp.gnu.org/pub/gnu/${pkgname}/${pkgname}-${pkgver}.tar.xz{,.sig}
source=("https://ftp.gnu.org/pub/gnu/${pkgname}/${pkgname}-${pkgver}.tar.xz"{,.sig}
'0001-autoconf-2.69-perl-5.22-autoscan.patch'
'0002-autoconf-2.69-perl-5.28.patch'
'0003-autoconf-2.69-libtool-compatibility.patch'
Expand All @@ -27,37 +28,36 @@ validpgpkeys=('71C2CC22B1C4602927D2F3AAA7A16B4A2527436A')


prepare() {
cd ${pkgname}-${pkgver}
cd "${pkgname}-${pkgver}"

# fix incompatibility with recent perl
patch -p1 -i $srcdir/0001-autoconf-2.69-perl-5.22-autoscan.patch
patch -p1 -i $srcdir/0002-autoconf-2.69-perl-5.28.patch
# fix incompatibility with recent perl
patch -p1 -i "$srcdir"/0001-autoconf-2.69-perl-5.22-autoscan.patch
patch -p1 -i "$srcdir"/0002-autoconf-2.69-perl-5.28.patch

# fix tesetsuite failures with recent libtool
patch -p1 -i $srcdir/0003-autoconf-2.69-libtool-compatibility.patch
# fix tesetsuite failures with recent libtool
patch -p1 -i "$srcdir"/0003-autoconf-2.69-libtool-compatibility.patch

patch -p1 -i $srcdir/0004-Port-tests-to-Bash-5.patch
patch -p1 -i "$srcdir"/0004-Port-tests-to-Bash-5.patch
}

build() {
cd ${pkgname}-${pkgver}
./configure --prefix=/usr
make
cd "${pkgname}-${pkgver}"
./configure --prefix=/usr
make
}

check() {
cd ${srcdir}/${pkgname}-${pkgver}
make check
cd "${srcdir}/${pkgname}-${pkgver}"
make check
}

package() {
cd ${srcdir}/${pkgname}-${pkgver}
make DESTDIR=${pkgdir} install
cd "${srcdir}/${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" install

# license exception
install -Dm644 COPYING.EXCEPTION \
$pkgdir/usr/share/licenses/autoconf/COPYING.EXCEPTION
# license exception
install -Dm644 COPYING.EXCEPTION "$pkgdir"/usr/share/licenses/autoconf/COPYING.EXCEPTION

# remove unwanted file
rm -f ${pkgdir}/usr/share/info/standards.info
# remove unwanted file
rm -f "$pkgdir"/usr/share/info/standards.info
}

0 comments on commit 61f4a3d

Please sign in to comment.