Skip to content

Commit

Permalink
archrelease: copy trunk to testing-i686, testing-x86_64
Browse files Browse the repository at this point in the history
git-svn-id: file:///srv/repos/svn-packages/svn@215528 eb2447ed-0c53-47e4-bac8-5bc4a241df78
  • Loading branch information
anatolik committed Jun 28, 2014
1 parent cb03eb3 commit 6dcb25c
Show file tree
Hide file tree
Showing 2 changed files with 100 additions and 0 deletions.
50 changes: 50 additions & 0 deletions libpng/repos/testing-i686/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,50 @@
# $Id$
# Maintainer: Jan de Groot <[email protected]>
# Contributor: dorphell <[email protected]>
# Contributor: Travis Willard <[email protected]>
# Contributor: Douglas Soares de Andrade <[email protected]>

pkgname=libpng
pkgver=1.6.12
_apngver=1.6.12
pkgrel=1
pkgdesc="A collection of routines used to create PNG format graphics files"
arch=('i686' 'x86_64')
url="http://www.libpng.org/pub/png/libpng.html"
license=('custom')
depends=('zlib' 'sh')
source=(http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.xz{,.asc}
http://downloads.sourceforge.net/sourceforge/libpng-apng/libpng-$_apngver-apng.patch.gz)
md5sums=('ee752da8aa75076500e4cf31318e636e'
'SKIP'
'f959e8b1cb9876ce946a2701e8aca519')

prepare() {
cd $pkgname-$pkgver

# Add animated PNG (apng) support. Required by Firefox
# see http://sourceforge.net/projects/libpng-apng/
patch -Np1 -i ../libpng-$_apngver-apng.patch
}

build() {
cd $pkgname-$pkgver

./configure --prefix=/usr --disable-static
make
}

check() {
cd $pkgname-$pkgver
make check
}

package() {
cd $pkgname-$pkgver
make DESTDIR="$pkgdir" install

cd contrib/pngminus
make PNGLIB="-L$pkgdir/usr/lib -lpng" -f makefile.std png2pnm pnm2png
install -m755 png2pnm pnm2png "$pkgdir/usr/bin/"
install -D -m644 ../../LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
50 changes: 50 additions & 0 deletions libpng/repos/testing-x86_64/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,50 @@
# $Id$
# Maintainer: Jan de Groot <[email protected]>
# Contributor: dorphell <[email protected]>
# Contributor: Travis Willard <[email protected]>
# Contributor: Douglas Soares de Andrade <[email protected]>

pkgname=libpng
pkgver=1.6.12
_apngver=1.6.12
pkgrel=1
pkgdesc="A collection of routines used to create PNG format graphics files"
arch=('i686' 'x86_64')
url="http://www.libpng.org/pub/png/libpng.html"
license=('custom')
depends=('zlib' 'sh')
source=(http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.xz{,.asc}
http://downloads.sourceforge.net/sourceforge/libpng-apng/libpng-$_apngver-apng.patch.gz)
md5sums=('ee752da8aa75076500e4cf31318e636e'
'SKIP'
'f959e8b1cb9876ce946a2701e8aca519')

prepare() {
cd $pkgname-$pkgver

# Add animated PNG (apng) support. Required by Firefox
# see http://sourceforge.net/projects/libpng-apng/
patch -Np1 -i ../libpng-$_apngver-apng.patch
}

build() {
cd $pkgname-$pkgver

./configure --prefix=/usr --disable-static
make
}

check() {
cd $pkgname-$pkgver
make check
}

package() {
cd $pkgname-$pkgver
make DESTDIR="$pkgdir" install

cd contrib/pngminus
make PNGLIB="-L$pkgdir/usr/lib -lpng" -f makefile.std png2pnm pnm2png
install -m755 png2pnm pnm2png "$pkgdir/usr/bin/"
install -D -m644 ../../LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}

0 comments on commit 6dcb25c

Please sign in to comment.