Skip to content

Commit

Permalink
archrelease: copy trunk to staging-x86_64
Browse files Browse the repository at this point in the history
git-svn-id: file:///srv/repos/svn-packages/svn@428678 eb2447ed-0c53-47e4-bac8-5bc4a241df78
  • Loading branch information
svenstaro committed Nov 20, 2021
1 parent 3c4e38a commit 7117f8a
Showing 1 changed file with 37 additions and 0 deletions.
37 changes: 37 additions & 0 deletions assimp/repos/staging-x86_64/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,37 @@
# Maintainer: Sven-Hendrik Haase <[email protected]>
# Contributor: jepaan <jepaan at hotmail dot com>

pkgname=assimp
pkgver=5.1.0
pkgrel=1
pkgdesc="Library to import various well-known 3D model formats in an uniform manner"
arch=('x86_64')
license=('BSD')
depends=('zlib' 'gcc-libs')
makedepends=('cmake' 'ninja')
url='https://assimp.org/'
source=("$pkgname-$pkgver.tar.gz::https://github.com/assimp/assimp/archive/v${pkgver}.tar.gz")
sha512sums=('b0445c048173720bccdfb64d5beb4637bd58021c29bdb5ccc2ca3e5b1189c0c46a03dd93da59e254e70b159e4918f4b7d2bd82f2390e9b45faf2361d450cad80')

build() {
cd ${pkgname}-${pkgver}

cmake . \
-Bbuild \
-GNinja \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release \
-DASSIMP_BUILD_SAMPLES=OFF
ninja -C build
}

package() {
cd ${pkgname}-${pkgver}

DESTDIR="$pkgdir" ninja -C build install
install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE

# Remove this in release > 5.0.1
# https://bugs.archlinux.org/task/67735
sed -i "s|includedir=.*|includedir=/usr/include/assimp|" "${pkgdir}"/usr/lib/pkgconfig/assimp.pc
}

0 comments on commit 7117f8a

Please sign in to comment.