Skip to content

Commit

Permalink
ath79: add support for ON Networks N150R
Browse files Browse the repository at this point in the history
This is a rebranded Netgear WNR612v2, specs are the same.

 - Atheros AR7240 (Python) @400Mhz
 - flash 4MB
 - ram 32MB
 - ethernet 10/100: 1xwan + 2xlan (only two)
 - radio AR9285

Signed-off-by: Zoltan HERPAI <[email protected]>
  • Loading branch information
wigyori authored and blogic committed Jun 26, 2018
1 parent 51dd8ec commit 31c26ce
Show file tree
Hide file tree
Showing 5 changed files with 32 additions and 2 deletions.
3 changes: 2 additions & 1 deletion target/linux/ath79/base-files/etc/board.d/01_leds
Original file line number Diff line number Diff line change
Expand Up @@ -22,7 +22,8 @@ case "$board" in
ucidef_set_led_oneshot "modbus" "Modbus" "$boardname:red:modbus" "100" "33"
ucidef_set_led_default "etactica" "etactica" "$boardname:red:etactica" "ignore"
;;
"netgear,wnr612-v2")
"netgear,wnr612-v2"|\
"on,n150r")
ucidef_set_led_netdev "wan" "WAN" "netgear:green:wan" "eth0"
ucidef_set_led_switch "lan1" "LAN1" "netgear:green:lan1" "switch0" "0x02" "0x0f"
ucidef_set_led_switch "lan2" "LAN2" "netgear:green:lan2" "switch0" "0x04" "0x0f"
Expand Down
3 changes: 2 additions & 1 deletion target/linux/ath79/base-files/etc/board.d/02_network
Original file line number Diff line number Diff line change
Expand Up @@ -33,7 +33,8 @@ ath79_setup_interfaces()
ucidef_set_interfaces_lan_wan "eth1" "eth0"
;;

"netgear,wnr612-v2")
"netgear,wnr612-v2"|\
"on,n150r")
ucidef_set_interfaces_lan_wan "eth1.1" "eth0"
ucidef_add_switch "switch0" \
"0@eth1" "1:lan" "2:lan" "3:lan:3" "4:lan:4"
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -55,6 +55,7 @@ case "$FIRMWARE" in
ath9k_eeprom_extract "art" 20480 1088
;;
"netgear,wnr612-v2"|\
"on,n150r"|\
"tplink,tl-wr740n-v2"|\
"ubnt,unifi")
ath9k_eeprom_extract "art" 4096 2048
Expand Down
10 changes: 10 additions & 0 deletions target/linux/ath79/dts/ar7240_on_n150r.dts
Original file line number Diff line number Diff line change
@@ -0,0 +1,10 @@
// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
/dts-v1/;

#include "ar7240_netgear_wnr612-v2.dtsi"

/ {
model = "ON Network N150R";
compatible = "on,n150r";
};

17 changes: 17 additions & 0 deletions target/linux/ath79/image/tiny-netgear.mk
Original file line number Diff line number Diff line change
Expand Up @@ -17,3 +17,20 @@ define Device/netgear_wnr612-v2
SUPPORTED_DEVICES := netgear,wnr612-v2 wnr612-v2
endef
TARGET_DEVICES += netgear_wnr612-v2

define Device/n150r
ATH_SOC := ar7240
DEVICE_TITLE := ON Network N150R
DEVICE_DTS := ar7240_on_n150r
NETGEAR_KERNEL_MAGIC := 0x32303631
KERNEL := kernel-bin | append-dtb | lzma -d20 | netgear-uImage lzma
KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma -d20 | netgear-uImage lzma
NETGEAR_BOARD_ID := N150R
IMAGE_SIZE := 3904k
IMAGES := sysupgrade.bin factory.img
IMAGE/default := append-kernel | pad-to $$$$(BLOCKSIZE) | netgear-squashfs | append-rootfs | pad-rootfs
IMAGE/sysupgrade.bin := $$(IMAGE/default) | append-metadata | check-size $$$$(IMAGE_SIZE)
IMAGE/factory.img := $$(IMAGE/default) | netgear-dni | check-size $$$$(IMAGE_SIZE)
SUPPORTED_DEVICES := on,n150r n150r
endef
TARGET_DEVICES += n150r

0 comments on commit 31c26ce

Please sign in to comment.