Skip to content

Commit

Permalink
build: remove package preconfig feature
Browse files Browse the repository at this point in the history
This feature has been unused for years, and its scope is too limited to be
actually useful.

Signed-off-by: Matthias Schiffer <[email protected]>
  • Loading branch information
neocturne committed Jan 13, 2018
1 parent 423ec18 commit 3abf663
Show file tree
Hide file tree
Showing 4 changed files with 2 additions and 73 deletions.
16 changes: 1 addition & 15 deletions include/package-dumpinfo.mk
Original file line number Diff line number Diff line change
Expand Up @@ -9,19 +9,6 @@ ifneq ($(DUMP),)

dumpinfo: FORCE

define Config/template
Preconfig: $(1)
Preconfig-Type: $(2)
Preconfig-Default: $(3)
Preconfig-Label: $(4)

endef

define Config
Preconfig/$(1) = $$(call Config/template,$(1),$(2),$(3),$(4))
preconfig_$$(1) += $(1)
endef

define Dumpinfo/Package
$(info Package: $(1)
$(if $(MENU),Menu: $(MENU)
Expand Down Expand Up @@ -59,8 +46,7 @@ $(if $(URL),$(URL)
$(if $(Package/$(1)/config),Config:
$(Package/$(1)/config)
@@
)$(foreach pc,$(preconfig_$(1)),
$(Preconfig/$(pc))))
))
endef

define Feature/Default
Expand Down
3 changes: 0 additions & 3 deletions package/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -72,7 +72,6 @@ $(curdir)/install: $(TMP_DIR)/.build $(curdir)/merge $(if $(CONFIG_TARGET_PER_DE
$(call opkg,$(TARGET_DIR)) flag $$flag `cat $$file`; \
done; \
done || true
@-$(MAKE) package/preconfig

$(CP) $(TARGET_DIR) $(TARGET_DIR_ORIG)

Expand All @@ -96,8 +95,6 @@ ifdef CONFIG_SIGNED_PACKAGES
); done
endif

$(curdir)/preconfig:

$(curdir)/flags-install:= -j1

$(eval $(call stampfile,$(curdir),package,prereq,.config))
Expand Down
20 changes: 1 addition & 19 deletions scripts/metadata.pm
Original file line number Diff line number Diff line change
Expand Up @@ -2,10 +2,9 @@ package metadata;
use base 'Exporter';
use strict;
use warnings;
our @EXPORT = qw(%package %srcpackage %category %preconfig %features %overrides clear_packages parse_package_metadata parse_target_metadata get_multiline @ignore %usernames %groupnames);
our @EXPORT = qw(%package %srcpackage %category %features %overrides clear_packages parse_package_metadata parse_target_metadata get_multiline @ignore %usernames %groupnames);

our %package;
our %preconfig;
our %srcpackage;
our %category;
our %features;
Expand Down Expand Up @@ -177,7 +176,6 @@ sub parse_target_metadata($) {
}

sub clear_packages() {
%preconfig = ();
%package = ();
%srcpackage = ();
%category = ();
Expand All @@ -191,7 +189,6 @@ sub parse_package_metadata($) {
my $file = shift;
my $pkg;
my $feature;
my $preconfig;
my $src;
my $override;
my %ignore = map { $_ => 1 } @ignore;
Expand Down Expand Up @@ -299,21 +296,6 @@ sub parse_package_metadata($) {
};
/^Config:\s*(.*)\s*$/ and $pkg->{config} = "$1\n".get_multiline(*FILE, "\t");
/^Prereq-Check:/ and $pkg->{prereq} = 1;
/^Preconfig:\s*(.+)\s*$/ and do {
my $pkgname = $pkg->{name};
$preconfig{$pkgname} or $preconfig{$pkgname} = {};
if (exists $preconfig{$pkgname}->{$1}) {
$preconfig = $preconfig{$pkgname}->{$1};
} else {
$preconfig = {
id => $1
};
$preconfig{$pkgname}{$1} = $preconfig unless $src->{ignore};
}
};
/^Preconfig-Type:\s*(.*?)\s*$/ and $preconfig->{type} = $1;
/^Preconfig-Label:\s*(.*?)\s*$/ and $preconfig->{label} = $1;
/^Preconfig-Default:\s*(.*?)\s*$/ and $preconfig->{default} = $1;
/^Require-User:\s*(.*?)\s*$/ and do {
my @ugspecs = split /\s+/, $1;

Expand Down
36 changes: 0 additions & 36 deletions scripts/package-metadata.pl
Original file line number Diff line number Diff line change
Expand Up @@ -372,19 +372,6 @@ ()
sub gen_package_config() {
parse_package_metadata($ARGV[0]) or exit 1;
print "menuconfig IMAGEOPT\n\tbool \"Image configuration\"\n\tdefault n\n";
foreach my $preconfig (keys %preconfig) {
foreach my $cfg (keys %{$preconfig{$preconfig}}) {
my $conf = $preconfig{$preconfig}->{$cfg}->{id};
$conf =~ tr/\.-/__/;
print <<EOF
config UCI_PRECONFIG_$conf
string "$preconfig{$preconfig}->{$cfg}->{label}" if IMAGEOPT
depends on PACKAGE_$preconfig
default "$preconfig{$preconfig}->{$cfg}->{default}"
EOF
}
}
print "source \"package/*/image-config.in\"\n";
if (scalar glob "package/feeds/*/*/image-config.in") {
print "source \"package/feeds/*/*/image-config.in\"\n";
Expand Down Expand Up @@ -579,29 +566,6 @@ ()
if ($line ne "") {
print "\n$line";
}
foreach my $preconfig (keys %preconfig) {
my $cmds;
foreach my $cfg (keys %{$preconfig{$preconfig}}) {
my $conf = $preconfig{$preconfig}->{$cfg}->{id};
$conf =~ tr/\.-/__/;
$cmds .= "\techo \"uci set '$preconfig{$preconfig}->{$cfg}->{id}=\$(subst \",,\$(CONFIG_UCI_PRECONFIG_$conf))'\"; \\\n";
}
next unless $cmds;
print <<EOF
ifndef DUMP_TARGET_DB
\$(TARGET_DIR)/etc/uci-defaults/$preconfig: FORCE
( \\
$cmds \\
) > \$@
ifneq (\$(IMAGEOPT)\$(CONFIG_IMAGEOPT),)
package/preconfig: \$(TARGET_DIR)/etc/uci-defaults/$preconfig
endif
endif
EOF
}
}

sub gen_package_source() {
Expand Down

0 comments on commit 3abf663

Please sign in to comment.