forked from openwrt/openwrt
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Signed-off-by: Alex Maclean <[email protected]>
- Loading branch information
Showing
8 changed files
with
120 additions
and
79 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,84 @@ | ||
DEVICE_VARS += TPLINK_HWID TPLINK_HWREV TPLINK_FLASHLAYOUT TPLINK_HEADER_VERSION TPLINK_BOARD_NAME | ||
|
||
define rootfs_align | ||
$(patsubst %-256k,0x40000,$(patsubst %-128k,0x20000,$(patsubst %-64k,0x10000,$(patsubst squashfs%,0x4,$(patsubst root.%,%,$(1)))))) | ||
endef | ||
|
||
# combine kernel and rootfs into one image | ||
# mktplinkfw <type> <optional extra arguments to mktplinkfw binary> | ||
# <type> is "sysupgrade" or "factory" | ||
# | ||
# -a align the rootfs start on an <align> bytes boundary | ||
# -j add jffs2 end-of-filesystem markers | ||
# -s strip padding from end of the image | ||
# -X reserve <size> bytes in the firmware image (hexval prefixed with 0x) | ||
define Build/mktplinkfw | ||
-$(STAGING_DIR_HOST)/bin/mktplinkfw \ | ||
-H $(TPLINK_HWID) -W $(TPLINK_HWREV) -F $(TPLINK_FLASHLAYOUT) -N OpenWrt -V $(REVISION) \ | ||
-m $(TPLINK_HEADER_VERSION) \ | ||
-k $(IMAGE_KERNEL) \ | ||
-r $@ \ | ||
-o $@.new \ | ||
-j -X 0x40000 \ | ||
-a $(call rootfs_align,$(FILESYSTEM)) \ | ||
$(wordlist 2,$(words $(1)),$(1)) \ | ||
$(if $(findstring sysupgrade,$(word 1,$(1))),-s) && mv $@.new $@ || rm -f $@ | ||
endef | ||
|
||
# mktplinkfw-combined | ||
# | ||
# -c combined image | ||
define Build/mktplinkfw-combined | ||
$(STAGING_DIR_HOST)/bin/mktplinkfw \ | ||
-H $(TPLINK_HWID) -W $(TPLINK_HWREV) -F $(TPLINK_FLASHLAYOUT) -N OpenWrt -V $(REVISION) $(1) \ | ||
-m $(TPLINK_HEADER_VERSION) \ | ||
-k $@ \ | ||
-o $@.new \ | ||
-s -S \ | ||
-c | ||
@mv $@.new $@ | ||
endef | ||
|
||
define Device/tplink | ||
TPLINK_HWREV := 0x1 | ||
TPLINK_HEADER_VERSION := 1 | ||
LOADER_TYPE := gz | ||
KERNEL := kernel-bin | append-dtb | lzma | ||
KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma | tplink-v1-header | ||
IMAGES := sysupgrade.bin factory.bin | ||
IMAGE/sysupgrade.bin := append-rootfs | mktplinkfw sysupgrade | append-metadata | ||
IMAGE/factory.bin := append-rootfs | mktplinkfw factory | ||
endef | ||
|
||
define Device/tplink-nolzma | ||
$(Device/tplink) | ||
LOADER_FLASH_OFFS := 0x22000 | ||
COMPILE := loader-$(1).gz | ||
COMPILE/loader-$(1).gz := loader-okli-compile | ||
KERNEL := kernel-bin | append-dtb | lzma | uImage lzma -M 0x4f4b4c49 | loader-okli $(1) | ||
KERNEL_INITRAMFS := kernel-bin | append-dtb | gzip | tplink-v1-header | ||
endef | ||
|
||
define Device/tplink-4m | ||
$(Device/tplink-nolzma) | ||
TPLINK_FLASHLAYOUT := 4M | ||
IMAGE_SIZE := 3904k | ||
endef | ||
|
||
define Device/tplink-4mlzma | ||
$(Device/tplink) | ||
TPLINK_FLASHLAYOUT := 4Mlzma | ||
IMAGE_SIZE := 3904k | ||
endef | ||
|
||
define Device/tplink-8m | ||
$(Device/tplink-nolzma) | ||
TPLINK_FLASHLAYOUT := 8M | ||
IMAGE_SIZE := 7936k | ||
endef | ||
|
||
define Device/tplink-8mlzma | ||
$(Device/tplink) | ||
TPLINK_FLASHLAYOUT := 8Mlzma | ||
IMAGE_SIZE := 7936k | ||
endef |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,2 @@ | ||
include ./common-tp-link.mk | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,14 @@ | ||
CONFIG_BLK_MQ_PCI=y | ||
CONFIG_LEDS_RESET=y | ||
CONFIG_OF_ADDRESS_PCI=y | ||
CONFIG_OF_PCI=y | ||
CONFIG_OF_PCI_IRQ=y | ||
CONFIG_PCI=y | ||
CONFIG_PCI_AR71XX=y | ||
CONFIG_PCI_AR724X=y | ||
CONFIG_PCI_DISABLE_COMMON_QUIRKS=y | ||
CONFIG_PCI_DOMAINS=y | ||
CONFIG_PHY_AR7100_USB=y | ||
CONFIG_PHY_AR7200_USB=y | ||
CONFIG_REGULATOR=y | ||
CONFIG_REGULATOR_FIXED_VOLTAGE=y |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,9 @@ | ||
define Profile/Default | ||
NAME:=Default Profile (all drivers) | ||
PRIORITY := 1 | ||
endef | ||
|
||
define Profile/Default/Description | ||
Default package set compatible with most boards. | ||
endef | ||
$(eval $(call Profile,Default)) |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,6 @@ | ||
BOARDNAME:=Devices with small flash | ||
FEATURES += squashfs small_flash | ||
|
||
define Target/Description | ||
Build firmware images for Atheros AR71xx/AR913x/AR934x based boards with small flash | ||
endef |