Skip to content

Commit

Permalink
Update to 20.12 beta
Browse files Browse the repository at this point in the history
git-svn-id: file:///srv/repos/svn-packages/svn@400773 eb2447ed-0c53-47e4-bac8-5bc4a241df78
  • Loading branch information
antonio-rojas committed Nov 13, 2020
1 parent 7b6bf75 commit 342be35
Show file tree
Hide file tree
Showing 223 changed files with 7,521 additions and 0 deletions.
28 changes: 28 additions & 0 deletions akonadi-calendar-tools/kde-unstable/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,28 @@
# Maintainer: Antonio Rojas <[email protected]>
# Maintainer: Felix Yan <[email protected]>

pkgname=akonadi-calendar-tools
pkgver=20.11.80
pkgrel=1
pkgdesc="CLI tools to manage akonadi calendars"
arch=(x86_64)
url="https://kontact.kde.org"
license=(GPL2)
depends=(calendarsupport)
makedepends=(extra-cmake-modules kdoctools boost)
groups=(kde-applications kdepim)
source=("https://download.kde.org/unstable/release-service/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig})
sha256sums=('5be97379d1d63272639258fd2608bb5a15cd03324d35148f5923483e0d1253d8'
'SKIP')
validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7 # Albert Astals Cid <[email protected]>
F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87) # Christoph Feck <[email protected]>

build() {
cmake -B build -S $pkgname-$pkgver \
-DBUILD_TESTING=OFF
cmake --build build
}

package() {
DESTDIR="$pkgdir" cmake --install build
}
26 changes: 26 additions & 0 deletions akonadi-calendar/kde-unstable/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,26 @@
# Maintainer: Antonio Rojas <[email protected]>

pkgname=akonadi-calendar
pkgver=20.11.80
pkgrel=1
pkgdesc="Akonadi calendar integration"
arch=(x86_64)
url="https://kontact.kde.org"
license=(LGPL)
depends=(kmailtransport kcalutils akonadi-contacts)
makedepends=(extra-cmake-modules boost)
source=("https://download.kde.org/unstable/release-service/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig})
sha256sums=('ec1956b652233d90b462e9e02a09f1d0dd15eee2ec2f4a457b0ffbfe5b2fa647'
'SKIP')
validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7 # Albert Astals Cid <[email protected]>
F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87) # Christoph Feck <[email protected]>

build() {
cmake -B build -S $pkgname-$pkgver \
-DBUILD_TESTING=OFF
cmake --build build
}

package() {
DESTDIR="$pkgdir" cmake --install build
}
26 changes: 26 additions & 0 deletions akonadi-contacts/kde-unstable/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,26 @@
# Maintainer: Antonio Rojas <[email protected]>

pkgname=akonadi-contacts
pkgver=20.11.80
pkgrel=1
pkgdesc="Libraries and daemons to implement Contact Management in Akonadi"
arch=(x86_64)
url="https://kontact.kde.org"
license=(LGPL)
depends=(libakonadi kcontacts kmime prison grantleetheme libkleo)
makedepends=(extra-cmake-modules boost)
source=("https://download.kde.org/unstable/release-service/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig})
sha256sums=('717165c77e42b5593677073762242730373b38db351c8819ae8f983550242fb4'
'SKIP')
validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7 # Albert Astals Cid <[email protected]>
F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87) # Christoph Feck <[email protected]>

build() {
cmake -B build -S $pkgname-$pkgver \
-DBUILD_TESTING=OFF
cmake --build build
}

package() {
DESTDIR="$pkgdir" cmake --install build
}
29 changes: 29 additions & 0 deletions akonadi-import-wizard/kde-unstable/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,29 @@
# Maintainer: Antonio Rojas <[email protected]>
# Maintainer: Felix Yan <[email protected]>

pkgname=akonadi-import-wizard
pkgver=20.11.80
pkgrel=1
pkgdesc="Import data from other mail clients to KMail"
arch=(x86_64)
url="https://kontact.kde.org"
license=(GPL2)
depends=(mailcommon)
makedepends=(extra-cmake-modules boost kdoctools)
optdepends=('kdepim-addons: additional import plugins')
groups=(kde-applications kdepim)
source=("https://download.kde.org/unstable/release-service/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig})
sha256sums=('d55c2486012a55e284caab347591f9394aaa01d6dbaeeaccd7445bb659a73452'
'SKIP')
validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7 # Albert Astals Cid <[email protected]>
F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87) # Christoph Feck <[email protected]>

build() {
cmake -B build -S $pkgname-$pkgver \
-DBUILD_TESTING=OFF
cmake --build build
}

package() {
DESTDIR="$pkgdir" cmake --install build
}
26 changes: 26 additions & 0 deletions akonadi-mime/kde-unstable/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,26 @@
# Maintainer: Antonio Rojas <[email protected]>

pkgname=akonadi-mime
pkgver=20.11.80
pkgrel=1
pkgdesc="Libraries and daemons to implement basic email handling"
arch=(x86_64)
url="https://kontact.kde.org"
license=(LGPL)
depends=(libakonadi kmime)
makedepends=(extra-cmake-modules kdoctools boost)
source=("https://download.kde.org/unstable/release-service/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig})
sha256sums=('3be26bff989aeedcaa13db72744005cd732892045be978ebd05bc50a4272cb67'
'SKIP')
validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7 # Albert Astals Cid <[email protected]>
F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87) # Christoph Feck <[email protected]>

build() {
cmake -B build -S $pkgname-$pkgver \
-DBUILD_TESTING=OFF
cmake --build build
}

package() {
DESTDIR="$pkgdir" cmake --install build
}
26 changes: 26 additions & 0 deletions akonadi-notes/kde-unstable/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,26 @@
# Maintainer: Antonio Rojas <[email protected]>

pkgname=akonadi-notes
pkgver=20.11.80
pkgrel=1
pkgdesc="Libraries and daemons to implement management of notes in Akonadi"
arch=(x86_64)
url="https://kontact.kde.org"
license=(LGPL)
depends=(kmime)
makedepends=(extra-cmake-modules)
source=("https://download.kde.org/unstable/release-service/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig})
sha256sums=('c212492e909d6c687af29d43884ca28ffdaa9d4530ffffcc96b63b83c84e30ae'
'SKIP')
validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7 # Albert Astals Cid <[email protected]>
F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87) # Christoph Feck <[email protected]>

build() {
cmake -B build -S $pkgname-$pkgver \
-DBUILD_TESTING=OFF
cmake --build build
}

package() {
DESTDIR="$pkgdir" cmake --install build
}
27 changes: 27 additions & 0 deletions akonadi-search/kde-unstable/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,27 @@
# Maintainer: Antonio Rojas <[email protected]>
# Contributor: Gustavo Alvarez <[email protected]>

pkgname=akonadi-search
pkgver=20.11.80
pkgrel=1
pkgdesc="Libraries and daemons to implement searching in Akonadi"
url='https://kontact.kde.org'
arch=(x86_64)
license=(GPL LGPL FDL)
depends=(xapian-core akonadi-mime kcontacts kcalendarcore krunner)
makedepends=(extra-cmake-modules boost)
source=("https://download.kde.org/unstable/release-service/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig})
sha256sums=('36f960fbd9dea8718374370fab3a008e81827741a0e3771545b68f0f529beed1'
'SKIP')
validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7 # Albert Astals Cid <[email protected]>
F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87) # Christoph Feck <[email protected]>

build() {
cmake -B build -S $pkgname-$pkgver \
-DBUILD_TESTING=OFF
cmake --build build
}

package() {
DESTDIR="$pkgdir" cmake --install build
}
41 changes: 41 additions & 0 deletions akonadi/kde-unstable/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,41 @@
# Maintainer: Antonio Rojas <[email protected]>
# Maintainer: Felix Yan <[email protected]>
# Contributor: Andrea Scarpino <[email protected]>
# Contributor: Pierre Schmitz <[email protected]>

pkgbase=akonadi
pkgname=(akonadi libakonadi)
pkgver=20.11.80
pkgrel=1
pkgdesc="PIM layer, which provides an asynchronous API to access all kind of PIM data"
arch=(x86_64)
url='https://kontact.kde.org'
license=(LGPL)
makedepends=(extra-cmake-modules postgresql qt5-tools boost kitemmodels kaccounts-integration)
source=("https://download.kde.org/unstable/release-service/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig})
sha256sums=('05b7fa5cc8f919c0f7b7d2db4747b27e4365348851109d84d51c58ba9df3a45b'
'SKIP')
validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7 # Albert Astals Cid <[email protected]>
F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87) # Christoph Feck <[email protected]>

build() {
cmake -B build -S $pkgname-$pkgver \
-DBUILD_TESTING=OFF
cmake --build build
}

package_libakonadi() {
pkgdesc='Libraries used by applications based on Akonadi'
depends=(kitemmodels kaccounts-integration)

DESTDIR="$pkgdir" cmake --install build
rm -r "$pkgdir"/usr/bin # Provided by akonadi
}

package_akonadi() {
depends=(libakonadi mariadb)
optdepends=('postgresql: PostgreSQL backend')

DESTDIR="$pkgdir" cmake --install build
rm -r "$pkgdir"/{etc,usr/{include,lib,share}} # Provided by libakonadi
}
28 changes: 28 additions & 0 deletions akonadiconsole/kde-unstable/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,28 @@
# Maintainer: Antonio Rojas <[email protected]>
# Maintainer: Felix Yan <[email protected]>

pkgname=akonadiconsole
pkgver=20.11.80
pkgrel=1
pkgdesc="Akonadi management and debugging console"
arch=(x86_64)
url="https://kontact.kde.org"
license=(GPL2)
depends=(calendarsupport messagelib)
makedepends=(extra-cmake-modules kdoctools boost)
groups=(kde-applications kdepim)
source=("https://download.kde.org/unstable/release-service/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig})
sha256sums=('270a4c88876255eec31c6732d1889282212edf1aae851b1fa41a24bfbf621144'
'SKIP')
validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7 # Albert Astals Cid <[email protected]>
F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87) # Christoph Feck <[email protected]>

build() {
cmake -B build -S $pkgname-$pkgver \
-DBUILD_TESTING=OFF
cmake --build build
}

package() {
DESTDIR="$pkgdir" cmake --install build
}
29 changes: 29 additions & 0 deletions akregator/kde-unstable/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,29 @@
# Maintainer: Antonio Rojas <[email protected]>
# Maintainer: Felix Yan <[email protected]>

pkgname=akregator
pkgver=20.11.80
pkgrel=1
pkgdesc="A Feed Reader by KDE"
arch=(x86_64)
url="https://kontact.kde.org"
license=(GPL2)
depends=(kontactinterface messagelib knotifyconfig ktexteditor syndication kuserfeedback)
makedepends=(extra-cmake-modules boost kdoctools)
optdepends=('kdepim-addons: additional plugins')
groups=(kde-applications kdepim)
source=("https://download.kde.org/unstable/release-service/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig})
sha256sums=('ca11e8ed0392abaa70a9d3ac55a0c54e493fbbf937e04970807b42b3471269ce'
'SKIP')
validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7 # Albert Astals Cid <[email protected]>
F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87) # Christoph Feck <[email protected]>

build() {
cmake -B build -S $pkgname-$pkgver \
-DBUILD_TESTING=OFF
cmake --build build
}

package() {
DESTDIR="$pkgdir" cmake --install build
}
28 changes: 28 additions & 0 deletions analitza/kde-unstable/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,28 @@
# Maintainer: Felix Yan <[email protected]>
# Maintainer: Antonio Rojas <[email protected]>
# Contributor: Andrea Scarpino <[email protected]>

pkgname=analitza
pkgver=20.11.80
pkgrel=1
pkgdesc="A library to add mathematical features to your program"
url="https://edu.kde.org/"
arch=(x86_64)
license=(GPL LGPL FDL)
depends=(qt5-svg qt5-declarative)
makedepends=(extra-cmake-modules kdoctools eigen qt5-tools)
source=("https://download.kde.org/unstable/release-service/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig})
sha256sums=('67c3e9c2d3dcee098adfda0c4d31a9f8870294c1fe48dbf18a29351e5c18cbf7'
'SKIP')
validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7 # Albert Astals Cid <[email protected]>
F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87) # Christoph Feck <[email protected]>

build() {
cmake -B build -S $pkgname-$pkgver \
-DBUILD_TESTING=OFF
cmake --build build
}

package() {
DESTDIR="$pkgdir" cmake --install build
}
32 changes: 32 additions & 0 deletions ark/kde-unstable/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,32 @@
# Maintainer: Antonio Rojas <[email protected]>
# Maintainer: Felix Yan <[email protected]>
# Contributor: Andrea Scarpino <[email protected]>

pkgname=ark
pkgver=20.11.80
pkgrel=1
pkgdesc='Archiving Tool'
arch=(x86_64)
url='https://kde.org/applications/utilities/ark/'
license=(GPL)
depends=(kparts kpty libarchive libzip kitemmodels hicolor-icon-theme)
makedepends=(extra-cmake-modules kdoctools)
optdepends=('p7zip: 7Z format support' 'unrar: RAR decompression support' 'unarchiver: RAR format support'
'lzop: LZO format support' 'lrzip: LRZ format support')
groups=(kde-applications kde-utilities)
source=("https://download.kde.org/unstable/release-service/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig})
sha256sums=('87d7d72f8f8d85f6a3f9353ff5740f971a715b3dfc988a146e7f001f6ce326f0'
'SKIP')
validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7 # Albert Astals Cid <[email protected]>
F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87) # Christoph Feck <[email protected]>

build() {
cmake -B build -S $pkgname-$pkgver \
-DBUILD_TESTING=OFF
cmake --build build
}

package() {
DESTDIR="$pkgdir" cmake --install build
}

29 changes: 29 additions & 0 deletions artikulate/kde-unstable/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,29 @@
# Maintainer: Felix Yan <[email protected]>
# Maintainer: Antonio Rojas <[email protected]>
# Contributor: Andrea Scarpino <[email protected]>

pkgname=artikulate
pkgver=20.11.80
pkgrel=1
pkgdesc="Improve your pronunciation by listening to native speakers"
url="https://edu.kde.org/applications/s/artikulate"
arch=(x86_64)
license=(GPL LGPL FDL)
groups=(kde-applications kde-education)
depends=(hicolor-icon-theme kdeclarative knewstuff kirigami2 qt5-xmlpatterns)
makedepends=(extra-cmake-modules kdoctools boost)
source=("https://download.kde.org/unstable/release-service/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig})
sha256sums=('83e0a5588327a4b05812fdab8dff077af149345b2be4883f34d29ecc9934e101'
'SKIP')
validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7 # Albert Astals Cid <[email protected]>
F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87) # Christoph Feck <[email protected]>

build() {
cmake -B build -S $pkgname-$pkgver \
-DBUILD_TESTING=OFF
cmake --build build
}

package() {
DESTDIR="$pkgdir" cmake --install build
}
Loading

0 comments on commit 342be35

Please sign in to comment.