Skip to content

Commit

Permalink
archrelease: copy trunk to staging-x86_64
Browse files Browse the repository at this point in the history
git-svn-id: file:///srv/repos/svn-packages/svn@361128 eb2447ed-0c53-47e4-bac8-5bc4a241df78
  • Loading branch information
foutrelis committed Aug 24, 2019
1 parent c6e2bf0 commit 6dc1901
Show file tree
Hide file tree
Showing 6 changed files with 434 additions and 0 deletions.
86 changes: 86 additions & 0 deletions calligra/repos/staging-x86_64/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,86 @@
# Maintainer: Felix Yan <[email protected]>
# Maintainer: Antonio Rojas <[email protected]>
# Contributor: Andrea Scarpino <[email protected]>
# Contributor: Ronald van Haren <ronald.archlinux.org>

pkgname=calligra
pkgdesc="A set of applications for productivity and creative usage"
pkgver=3.1.0
pkgrel=22
arch=(x86_64)
url='https://www.calligra-suite.org/'
license=(FDL1.2 GPL2 LGPL)
depends=(kcmutils knotifyconfig kross kactivities kdiagram libspnav kdelibs4support
gsl openexr kcontacts qca-qt5 poppler-qt5 libodfgen qt5-webkit cauchy khtml)
makedepends=(extra-cmake-modules kdoctools kdesignerplugin boost openjpeg akonadi-contacts
libwpg okular eigen marble-common pstoedit libvisio libetonyek libwps vc libgit2)
optdepends=('libwpg: Corel WordPerfect Graphics image importer'
'libwps: Microsoft Works file word processor format import'
'libvisio: Microsoft Visio import filter'
'libetonyek: Apple Keynote import filter'
'pstoedit: EPS to SVG filter'
'poppler: PDF to SVG filter'
'openjpeg: PDF to SVG filer'
'libgit2: Calligra Gemini git plugin'
'kirigami2: for Calligra Gemini'
'qt5-quickcontrols: for Calligra Gemini'
'qt5-webengine: for Calligra Gemini')
conflicts=(calligra-devtools calligra-extras calligra-filters calligra-karbon karbon calligra-libs
calligra-plugins calligra-sheets calligra-stage calligra-words calligra-l10n calligra-meta
calligra-flow calligra-braindump calligra-gemini calligra-handbook)
replaces=(calligra-devtools calligra-extras calligra-filters calligra-karbon karbon calligra-libs
calligra-plugins calligra-sheets calligra-stage calligra-words calligra-l10n calligra-meta)
for _lang in bs ca ca@valencia cs da de el en_gb es et fi fr gl hu it ja kk nb nl \
pl pt pt_br ru sk sv uk zh_cn zh_tw; do
conflicts+=(calligra-l10n-$_lang)
replaces+=(calligra-l10n-$_lang)
done
source=("https://download.kde.org/stable/$pkgname/$pkgver/$pkgname-$pkgver.tar.xz"{,.sig}
calligra-qt5.11.patch
calligra-qt5.13.patch
calligra-poppler-0.69.patch::"https://cgit.kde.org/calligra.git/patch/?id=a6157182"
calligra-poppler-0.71.patch
calligra-poppler-0.72.patch
calligra-poppler-0.73.patch)
sha256sums=('6818cd6e64136321be217eb57cc7d6ac7c7035191fdb1ee336ebe60bc114e870'
'SKIP'
'40ac9fabed8e13c31f6f243bd7e9083c3ec322568991ba84987106b982ffc10a'
'd32a9cda1343f224f5a0cfa2b8122c5571a0dbb09c9948414d6770d9c3814f4d'
'127cc5e0946fbf741279306b4e9d592f5f901a7fab09039fcfc6c7e60193fa80'
'052adc4ea812d7667812ff7867e703327dbe7c1ecad86094fd6772dc09782d87'
'87a09710b9e7e825a46344ddec08eb98b3454d6d067b0177d284733b2342cece'
'ef95f49f69c9f2a5b530e416003f2d6d106bb3c85e8458ae27494c64c8b474a8')
validpgpkeys=(05D00A8B73A686789E0A156858B9596C722EA3BD # Boudewijn Rempt <[email protected]>
42A60D06F449E895F40F09C01638B8A616108B8A) # Dag Andersen <[email protected]>

prepare() {
mkdir -p build

cd $pkgname-$pkgver
# Fix build with Qt 5.11
patch -p1 -i ../calligra-qt5.11.patch
# Fix build with Qt 5.13
patch -p1 -i ../calligra-qt5.13.patch
# Fix build with poppler 0.69
patch -p1 -i ../calligra-poppler-0.69.patch
# Fix build with poppler 0.71
patch -p1 -i ../calligra-poppler-0.71.patch
# Fix build with poppler 0.72
patch -p1 -i ../calligra-poppler-0.72.patch
# Fix build with poppler 0.73
patch -p1 -i ../calligra-poppler-0.73.patch
}

build() {
cd build
cmake ../$pkgbase-$pkgver \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_TESTING=OFF
make
}

package() {
cd build
make DESTDIR="$pkgdir" install
}
131 changes: 131 additions & 0 deletions calligra/repos/staging-x86_64/calligra-poppler-0.71.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,131 @@
diff --git a/filters/karbon/pdf/PdfImport.cpp b/filters/karbon/pdf/PdfImport.cpp
index 48b08dfa32d..e910dae0756 100644
--- a/filters/karbon/pdf/PdfImport.cpp
+++ b/filters/karbon/pdf/PdfImport.cpp
@@ -88,9 +88,9 @@ KoFilter::ConversionStatus PdfImport::convert(const QByteArray& from, const QByt
SvgOutputDev * dev = new SvgOutputDev(m_chain->outputFile());
if (dev->isOk()) {
int rotate = 0;
- GBool useMediaBox = gTrue;
- GBool crop = gFalse;
- GBool printing = gFalse;
+ bool useMediaBox = true;
+ bool crop = false;
+ bool printing = false;
pdfDoc->displayPages(dev, firstPage, lastPage, hDPI, vDPI, rotate, useMediaBox, crop, printing);
dev->dumpContent();
}
diff --git a/filters/karbon/pdf/SvgOutputDev.cpp b/filters/karbon/pdf/SvgOutputDev.cpp
index 5692824bc45..43205170991 100644
--- a/filters/karbon/pdf/SvgOutputDev.cpp
+++ b/filters/karbon/pdf/SvgOutputDev.cpp
@@ -39,7 +39,7 @@ class SvgOutputDev::Private
{
public:
Private(const QString &fname)
- : svgFile(fname), defs(0), body(0), state(gTrue)
+ : svgFile(fname), defs(0), body(0), state(true)
, brush(Qt::SolidPattern) {}

~Private() {
@@ -52,7 +52,7 @@ public:
QString defsData;
QTextStream * defs;
QTextStream * body;
- GBool state;
+ bool state;
QSizeF pageSize;
QPen pen;
QBrush brush;
@@ -62,7 +62,7 @@ SvgOutputDev::SvgOutputDev(const QString &fileName)
: d(new Private(fileName))
{
if (! d->svgFile.open(QIODevice::WriteOnly)) {
- d->state = gFalse;
+ d->state = false;
return;
}

@@ -75,24 +75,24 @@ SvgOutputDev::~SvgOutputDev()
delete d;
}

-GBool SvgOutputDev::isOk()
+bool SvgOutputDev::isOk()
{
return d->state;
}

-GBool SvgOutputDev::upsideDown()
+bool SvgOutputDev::upsideDown()
{
- return gTrue;
+ return true;
}

-GBool SvgOutputDev::useDrawChar()
+bool SvgOutputDev::useDrawChar()
{
- return gFalse;
+ return false;
}

-GBool SvgOutputDev::interpretType3Chars()
+bool SvgOutputDev::interpretType3Chars()
{
- return gFalse;
+ return false;
}

void SvgOutputDev::startPage(int pageNum, GfxState *state, XRef */*xref*/)
@@ -480,7 +480,7 @@ void SvgOutputDev::drawString(GfxState * state, GooString * s)

void SvgOutputDev::drawImage(GfxState *state, Object */*ref*/, Stream *str,
int width, int height, GfxImageColorMap *colorMap,
- int *maskColors, GBool /*inlineImg*/)
+ int *maskColors, bool /*inlineImg*/)
{
ImageStream * imgStr = new ImageStream(str, width, colorMap->getNumPixelComps(), colorMap->getBits());
imgStr->reset();
@@ -549,7 +549,7 @@ void SvgOutputDev::drawImage(GfxState *state, Object */*ref*/, Stream *str,

void SvgOutputDev::drawImage(GfxState *state, Object *ref, Stream *str,
int width, int height, GfxImageColorMap *colorMap,
- GBool /*interpolate*/, int *maskColors, GBool inlineImg)
+ bool /*interpolate*/, int *maskColors, bool inlineImg)
{
drawImage(state, ref, str, width, height, colorMap, maskColors, inlineImg);
}
diff --git a/filters/karbon/pdf/SvgOutputDev.h b/filters/karbon/pdf/SvgOutputDev.h
index 2a4490848bf..cdb1d4e43b1 100644
--- a/filters/karbon/pdf/SvgOutputDev.h
+++ b/filters/karbon/pdf/SvgOutputDev.h
@@ -44,11 +44,11 @@ public:
explicit SvgOutputDev(const QString &fileName);
virtual ~SvgOutputDev();

- GBool isOk();
+ bool isOk();

- virtual GBool upsideDown();
- virtual GBool useDrawChar();
- virtual GBool interpretType3Chars();
+ virtual bool upsideDown();
+ virtual bool useDrawChar();
+ virtual bool interpretType3Chars();
virtual void startPage(int pageNum, GfxState *state, XRef *xref);
virtual void endPage();

@@ -63,10 +63,10 @@ public:
// images
virtual void drawImage(GfxState *state, Object *ref, Stream *str,
int width, int height, GfxImageColorMap *colorMap,
- int *maskColors, GBool inlineImg);
+ int *maskColors, bool inlineImg);
virtual void drawImage(GfxState *state, Object *ref, Stream *str,
int width, int height, GfxImageColorMap *colorMap,
- GBool interpolate, int *maskColors, GBool inlineImg);
+ bool interpolate, int *maskColors, bool inlineImg);

// styles
virtual void updateAll(GfxState *state);
29 changes: 29 additions & 0 deletions calligra/repos/staging-x86_64/calligra-poppler-0.72.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,29 @@
diff --git a/filters/karbon/pdf/SvgOutputDev.cpp b/filters/karbon/pdf/SvgOutputDev.cpp
index 80f01a5f76f..ea69228dbc1 100644
--- a/filters/karbon/pdf/SvgOutputDev.cpp
+++ b/filters/karbon/pdf/SvgOutputDev.cpp
@@ -407,7 +407,7 @@ void SvgOutputDev::drawString(GfxState * state, const GooString * s)

QString str;

- const char * p = s->getCString();
+ const char * p = s->c_str();
int len = s->getLength();
CharCode code;
Unicode *u = nullptr;
@@ -459,11 +459,11 @@ void SvgOutputDev::drawString(GfxState * state, const GooString * s)
*d->body << " y=\"" << y << "px\"";

if (font && font->getFamily()) {
- *d->body << " font-family=\"" << QString::fromLatin1(font->getFamily()->getCString()) << "\"";
- //debugPdf << "font family:" << QString::fromLatin1( font->getFamily()->getCString() );
+ *d->body << " font-family=\"" << QString::fromLatin1(font->getFamily()->c_str()) << "\"";
+ //debugPdf << "font family:" << QString::fromLatin1( font->getFamily()->c_str() );
} else if (font && font->getName()) {
- *d->body << " font-family=\"" << QString::fromLatin1(font->getName()->getCString()) << "\"";
- //debugPdf << "font name:" << QString::fromLatin1( font->getName()->getCString() );
+ *d->body << " font-family=\"" << QString::fromLatin1(font->getName()->c_str()) << "\"";
+ //debugPdf << "font name:" << QString::fromLatin1( font->getName()->c_str() );
}
*d->body << " font-size=\"" << qMax(state->getFontSize(), state->getTransformedFontSize()) << "px\"";

32 changes: 32 additions & 0 deletions calligra/repos/staging-x86_64/calligra-poppler-0.73.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,32 @@
From a1ddd91e6c354e8f0dda40f8a522053c3fa19c39 Mon Sep 17 00:00:00 2001
From: Albert Astals Cid <[email protected]>
Date: Tue, 15 Jan 2019 22:24:08 +0100
Subject: [PATCH] Guchar -> unsigned char

It was just a typdef and it's now gone
---
filters/karbon/pdf/SvgOutputDev.cpp | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/filters/karbon/pdf/SvgOutputDev.cpp b/filters/karbon/pdf/SvgOutputDev.cpp
index 80f01a5f76f..1a5aa30bc40 100644
--- a/filters/karbon/pdf/SvgOutputDev.cpp
+++ b/filters/karbon/pdf/SvgOutputDev.cpp
@@ -496,7 +496,7 @@ void SvgOutputDev::drawImage(GfxState *state, Object *ref, Stream *str,
if (maskColors) {
for (int y = 0; y < height; y++) {
dest = (unsigned int *)(buffer + y * 4 * width);
- Guchar * pix = imgStr->getLine();
+ unsigned char * pix = imgStr->getLine();
colorMap->getRGBLine(pix, dest, width);

for (int x = 0; x < width; x++) {
@@ -515,7 +515,7 @@ void SvgOutputDev::drawImage(GfxState *state, Object *ref, Stream *str,
} else {
for (int y = 0; y < height; y++) {
dest = (unsigned int *)(buffer + y * 4 * width);
- Guchar * pix = imgStr->getLine();
+ unsigned char * pix = imgStr->getLine();
colorMap->getRGBLine(pix, dest, width);
}

Loading

0 comments on commit 6dc1901

Please sign in to comment.