forked from openwrt/packages
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Backport a commit from upstream curl to fix a problem in configure with wolfssl. checking size of time_t... configure: error: cannot determine a size for time_t Signed-off-by: Hauke Mehrtens <[email protected]>
- Loading branch information
Showing
1 changed file
with
31 additions
and
0 deletions.
There are no files selected for viewing
31 changes: 31 additions & 0 deletions
31
net/curl/patches/100-configure-fix-pkg-config-detecting-wolfssl.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,31 @@ | ||
From 510d98157f21dee5793c4e975fde3317b6139267 Mon Sep 17 00:00:00 2001 | ||
From: Daniel Stenberg <[email protected]> | ||
Date: Mon, 24 Aug 2020 16:28:34 +0200 | ||
Subject: [PATCH] configure: fix pkg-config detecting wolfssl | ||
|
||
When amending the include path with "/wolfssl", this now properly strips | ||
off all whitespace from the path variable! Previously this would lead to | ||
pkg-config builds creating bad command lines. | ||
|
||
Closes #5848 | ||
--- | ||
configure.ac | 8 ++++++-- | ||
1 file changed, 6 insertions(+), 2 deletions(-) | ||
|
||
--- a/configure.ac | ||
+++ b/configure.ac | ||
@@ -2474,8 +2474,12 @@ if test -z "$ssl_backends" -o "x$OPT_WOL | ||
AC_DEFINE(HAVE_WOLFSSL_DES_ECB_ENCRYPT, 1, | ||
[if you have wolfSSL_DES_ecb_encrypt]) | ||
if test -n "$addcflags"; then | ||
- CPPFLAGS="$addcflags/wolfssl $CPPFLAGS" | ||
- AC_MSG_NOTICE([Add $addcflags/wolfssl to CPPFLAGS]) | ||
+ dnl use a for loop to strip off whitespace | ||
+ for f in $addcflags; do | ||
+ CPPFLAGS="$f/wolfssl $CPPFLAGS" | ||
+ AC_MSG_NOTICE([Add $f/wolfssl to CPPFLAGS]) | ||
+ break | ||
+ done | ||
else | ||
dnl user didn't give a path, so guess/hope they installed wolfssl | ||
dnl headers to system default location |