forked from archlinux/svntogit-packages
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
archrelease: copy trunk to staging-x86_64
git-svn-id: file:///srv/repos/svn-packages/svn@366658 eb2447ed-0c53-47e4-bac8-5bc4a241df78
- Loading branch information
1 parent
af51793
commit 79ba500
Showing
1 changed file
with
66 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,66 @@ | ||
# Maintainer: Andreas Radke <[email protected]> | ||
# Contributor: Harley Laue <[email protected]> | ||
|
||
pkgbase=anjuta | ||
pkgname=('libanjuta' 'anjuta') | ||
pkgver=3.34.0 | ||
pkgrel=2 | ||
pkgdesc="GNOME Integrated Development Environment (IDE)" | ||
arch=(x86_64) | ||
license=(GPL) | ||
makedepends=(gdl vte3 autogen devhelp glade libgda subversion neon vala dconf gtk-doc yelp-tools gnome-common intltool gobject-introspection itstool gjs git python) | ||
url="http://www.anjuta.org/" | ||
options=('!emptydirs') | ||
_commit=aaadfafe19450d8524400af9ae09d5187b2d627a # master | ||
source=(https://download.gnome.org/sources/$pkgbase/${pkgver:0:4}/$pkgbase-$pkgver.tar.xz) | ||
sha256sums=('42a93130ed3ee02d064a7094e94e1ffae2032b3f35a87bf441e37fc3bb3a148f') | ||
|
||
prepare() { | ||
cd $pkgbase-$pkgver | ||
|
||
# vala 0.46 | ||
sed -i '/m4_foreach/s/0\.44/0.46/' configure.ac | ||
|
||
AUTOPOINT="intltoolize" autoreconf -fvi | ||
} | ||
|
||
|
||
build() { | ||
cd $pkgbase-$pkgver | ||
|
||
./configure --prefix=/usr --sysconfdir=/etc \ | ||
--localstatedir=/var \ | ||
--disable-compile-warnings \ | ||
--disable-schemas-compile \ | ||
--disable-silent-rules \ | ||
--disable-static \ | ||
--enable-introspection \ | ||
--enable-plugin-devhelp \ | ||
--enable-plugin-glade \ | ||
--enable-plugin-subversion \ | ||
--enable-glade-catalog --enable-gtk-doc | ||
sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool | ||
make | ||
} | ||
|
||
package_libanjuta(){ | ||
pkgdesc="Anjuta runtime library" | ||
depends=(gdl) | ||
conflicts=('anjuta<3.4.4') | ||
|
||
cd $pkgbase-$pkgver/libanjuta | ||
|
||
# j1: Race during linking | ||
make -j1 DESTDIR="$pkgdir" install | ||
} | ||
|
||
package_anjuta(){ | ||
pkgdesc="GNOME Integrated Development Environment (IDE)" | ||
depends=(libanjuta vte3 autogen devhelp glade libgda subversion neon vala dconf) | ||
|
||
cd $pkgbase-$pkgver | ||
make -j1 DESTDIR="$pkgdir" install | ||
|
||
cd libanjuta | ||
make -j1 DESTDIR="$pkgdir" uninstall | ||
} |