Skip to content

Commit

Permalink
uboot-mvebu: update to v2020.10
Browse files Browse the repository at this point in the history
Remove merged patches and update the emmc set.

Signed-off-by: Andre Heider <[email protected]>
  • Loading branch information
dhewg authored and hauke committed Oct 11, 2020
1 parent 4d6ade2 commit ed20d4c
Show file tree
Hide file tree
Showing 8 changed files with 40 additions and 186 deletions.
4 changes: 2 additions & 2 deletions package/boot/uboot-mvebu/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -8,10 +8,10 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk

PKG_VERSION:=2020.10-rc4
PKG_VERSION:=2020.10
PKG_RELEASE:=1

PKG_HASH:=0a7bdd2c7df2c14daf2730fcf3277fd917aadfaae935529e29c7412314bbf260
PKG_HASH:=0d481bbdc05c0ee74908ec2f56a6daa53166cc6a78a0e4fac2ac5d025770a622

include $(INCLUDE_DIR)/u-boot.mk
include $(INCLUDE_DIR)/package.mk
Expand Down

This file was deleted.

This file was deleted.

This file was deleted.

Original file line number Diff line number Diff line change
@@ -1,14 +1,16 @@
From 753947e2c374820dcbc9c86626812aeb7d460653 Mon Sep 17 00:00:00 2001
From cdcfd9211c805624a702b6ff81b9bd9515344749 Mon Sep 17 00:00:00 2001
From: Andre Heider <[email protected]>
Date: Fri, 4 Sep 2020 16:34:22 +0200
Subject: [PATCH] arm64: dts: armada-3720-espressobin: use Linux
model/compatible strings

Fix the actual board vendor and ease synching dts files from Linux.

Signed-off-by: Andre Heider <[email protected]>
---
arch/arm/dts/armada-3720-espressobin.dts | 4 ++--
board/Marvell/mvebu_armada-37xx/board.c | 4 ++--
2 files changed, 4 insertions(+), 4 deletions(-)
board/Marvell/mvebu_armada-37xx/board.c | 8 ++++----
2 files changed, 6 insertions(+), 6 deletions(-)

--- a/arch/arm/dts/armada-3720-espressobin.dts
+++ b/arch/arm/dts/armada-3720-espressobin.dts
Expand All @@ -25,7 +27,24 @@ Fix the actual board vendor and ease synching dts files from Linux.
stdout-path = "serial0:115200n8";
--- a/board/Marvell/mvebu_armada-37xx/board.c
+++ b/board/Marvell/mvebu_armada-37xx/board.c
@@ -201,7 +201,7 @@ static int mii_multi_chip_mode_write(str
@@ -88,14 +88,14 @@ int board_late_init(void)
if (env_get("fdtfile"))
return 0;

- if (!of_machine_is_compatible("marvell,armada-3720-espressobin"))
+ if (!of_machine_is_compatible("globalscale,espressobin"))
return 0;

/* If the memory controller has been configured for DDR4, we're running on v7 */
ddr4 = ((readl(A3700_CH0_MC_CTRL2_REG) >> A3700_MC_CTRL2_SDRAM_TYPE_OFFS)
& A3700_MC_CTRL2_SDRAM_TYPE_MASK) == A3700_MC_CTRL2_SDRAM_TYPE_DDR4;

- emmc = of_machine_is_compatible("marvell,armada-3720-espressobin-emmc");
+ emmc = of_machine_is_compatible("globalscale,espressobin-emmc");

if (ddr4 && emmc)
env_set("fdtfile", "marvell/armada-3720-espressobin-v7-emmc.dtb");
@@ -248,7 +248,7 @@ static int mii_multi_chip_mode_write(str
/* Bring-up board-specific network stuff */
int board_network_enable(struct mii_dev *bus)
{
Expand All @@ -34,7 +53,7 @@ Fix the actual board vendor and ease synching dts files from Linux.
return 0;

/*
@@ -253,7 +253,7 @@ int ft_board_setup(void *blob, struct bd
@@ -300,7 +300,7 @@ int ft_board_setup(void *blob, struct bd
int part_off;

/* Fill SPI MTD partitions for Linux kernel on Espressobin */
Expand Down
Original file line number Diff line number Diff line change
@@ -1,21 +1,20 @@
From ee59573dd531df96de0d9dc8e79b34ed3716c864 Mon Sep 17 00:00:00 2001
From a9ac1dd46a4fd11880be80227e1eb102e3c61dd8 Mon Sep 17 00:00:00 2001
From: Andre Heider <[email protected]>
Date: Fri, 4 Sep 2020 15:38:58 +0200
Subject: [PATCH] arm64: dts: armada-3720-espressobin: split common parts to
.dtsi
Subject: [PATCH] arm64: dts: armada-3720-espressobin: split common parts
to .dtsi

Move most of the dts to the new common
arch/arm/dts/armada-3720-espressobin.dtsi file, just like Linux has.
Move most of the dts to the new common armada-3720-espressobin.dtsi
file, just like Linux, but keep the current, downstream based, version.

The dts itself is imported from Linux.

Signed-off-by: Andre Heider <[email protected]>
---
arch/arm/dts/armada-3720-espressobin.dts | 190 ++----------------
...sobin.dts => armada-3720-espressobin.dtsi} | 3 -
2 files changed, 20 insertions(+), 173 deletions(-)
rewrite arch/arm/dts/armada-3720-espressobin.dts (95%)
copy arch/arm/dts/{armada-3720-espressobin.dts => armada-3720-espressobin.dtsi} (96%)
arch/arm/dts/armada-3720-espressobin.dts | 164 +--------------------
arch/arm/dts/armada-3720-espressobin.dtsi | 167 ++++++++++++++++++++++
2 files changed, 174 insertions(+), 157 deletions(-)
create mode 100644 arch/arm/dts/armada-3720-espressobin.dtsi

--- a/arch/arm/dts/armada-3720-espressobin.dts
+++ b/arch/arm/dts/armada-3720-espressobin.dts
Expand Down
Original file line number Diff line number Diff line change
@@ -1,10 +1,12 @@
From 83908b6e2e5a7d7b0f4d040ffb4bf3ce6807b8fe Mon Sep 17 00:00:00 2001
From 408bba2fb84ad0b02c3f9529065126b40899e256 Mon Sep 17 00:00:00 2001
From: Andre Heider <[email protected]>
Date: Fri, 4 Sep 2020 15:44:41 +0200
Subject: [PATCH] arm64: dts: a3720: add support for boards with populated emmc
Subject: [PATCH] arm64: dts: a3720: add support for espressobin with
populated emmc

Import armada-3720-espressobin-emmc.dts from Linux, but use sdhc1 for
emmc, since sdhc0 is used for the sd card.
emmc, since our dtsi is still based on downstream and sdhc0 is used for
the sd card.

Signed-off-by: Andre Heider <[email protected]>
---
Expand Down

This file was deleted.

0 comments on commit ed20d4c

Please sign in to comment.