Skip to content

Commit

Permalink
net/rsyslog: add new package
Browse files Browse the repository at this point in the history
Signed-off-by: Dov Murik <[email protected]>
  • Loading branch information
dubek committed Nov 11, 2015
1 parent 964835b commit 7c0b1e0
Show file tree
Hide file tree
Showing 3 changed files with 87 additions and 0 deletions.
57 changes: 57 additions & 0 deletions net/rsyslog/Makefile
Original file line number Diff line number Diff line change
@@ -0,0 +1,57 @@
#
# Copyright (C) 2006-2014 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#

include $(TOPDIR)/rules.mk

PKG_NAME:=rsyslog
PKG_VERSION:=8.14.0
PKG_RELEASE:=1

PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.rsyslog.com/files/download/rsyslog/
PKG_MD5SUM:=9862b08fd8d13753c13d7f9d86ec8f4e

PKG_MAINTAINER:=Dov Murik <[email protected]>
PKG_LICENSE:=GPL-3.0
PKG_LICENSE_FILES:=COPYING

PKG_INSTALL:=1
PKG_FIXUP:=autoreconf

include $(INCLUDE_DIR)/package.mk

define Package/rsyslog
SECTION:=net
CATEGORY:=Network
TITLE:=Enhanced system logging and kernel message trapping daemons
URL:=http://www.rsyslog.com/
DEPENDS:=+libestr +libjson-c +libuuid +zlib
endef

define Package/rsyslog/conffiles
/etc/rsyslog.conf
endef

CONFIGURE_ARGS+= \
--disable-libgcrypt \
--disable-liblogging-stdlog

TARGET_CFLAGS += \
-std=c99

define Package/rsyslog/install
$(INSTALL_DIR) $(1)/usr/sbin
$(CP) $(PKG_INSTALL_DIR)/usr/sbin/rsyslogd $(1)/usr/sbin/
$(INSTALL_DIR) $(1)/usr/lib/rsyslog
$(CP) $(PKG_INSTALL_DIR)/usr/lib/rsyslog/* $(1)/usr/lib/rsyslog/
$(INSTALL_DIR) $(1)/etc
$(INSTALL_CONF) ./files/rsyslog.conf $(1)/etc
$(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_BIN) ./files/rsyslog.init $(1)/etc/init.d/rsyslog
endef

$(eval $(call BuildPackage,rsyslog))
18 changes: 18 additions & 0 deletions net/rsyslog/files/rsyslog.conf
Original file line number Diff line number Diff line change
@@ -0,0 +1,18 @@
module(load="imuxsock")
module(load="imklog")
module(load="imudp")
input(type="imudp" port="514")
#module(load="imtcp")
#input(type="imtcp" port="514")

$ActionFileDefaultTemplate RSYSLOG_TraditionalFileFormat

*.info;mail.none;authpriv.none;cron.none /var/log/messages

authpriv.* /var/log/secure

mail.* /var/log/maillog

cron.* /var/log/cron

local7.* /var/log/boot.log
12 changes: 12 additions & 0 deletions net/rsyslog/files/rsyslog.init
Original file line number Diff line number Diff line change
@@ -0,0 +1,12 @@
#!/bin/sh /etc/rc.common
# Copyright (C) 2014 OpenWrt.org

START=20

USE_PROCD=1

start_service() {
procd_open_instance
procd_set_param command /usr/sbin/rsyslogd
procd_close_instance
}

0 comments on commit 7c0b1e0

Please sign in to comment.