Skip to content

Commit

Permalink
*/*: sync with upstream
Browse files Browse the repository at this point in the history
Taken from: FreeBSD
  • Loading branch information
fichtner committed Oct 19, 2015
1 parent 8ee79a8 commit 094ca6a
Show file tree
Hide file tree
Showing 117 changed files with 2,653 additions and 2,803 deletions.
15 changes: 6 additions & 9 deletions arabic/arabtex/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -14,22 +14,19 @@ COMMENT= TeX/LaTeX package to generate Arabic writing

LICENSE= LPPL10

ARABTEXDIRS= fonts tex

MKTEXLSR= ${LOCALBASE}/bin/mktexlsr
USE_TEX= base texmf

NO_WRKSUBDIR= yes
NO_BUILD= yes

OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDOCS}
ARABTEXDIRS+= doc
.endif
ARABTEXDIRS= fonts tex
MKTEXLSR= ${LOCALBASE}/bin/mktexlsr

PLIST_SUB= MKTEXLSR=${MKTEXLSR}

USE_TEX= base texmf
OPTIONS_DEFINE= DOCS

DOCS_VARS= ARABTEXDIRS+=doc

do-install:
.for dir in ${ARABTEXDIRS}
Expand Down
67 changes: 29 additions & 38 deletions audio/audiere/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -26,58 +26,49 @@ PORTDOCS= changelog.txt cvs.txt dependencies.txt faq.txt glossary.txt \
license.txt overview.txt readme.txt release-howto.txt \
tutorial.txt

CONFIGURE_REPLACES='s|wx_config|no_&|'

OPTIONS_DEFINE= DUMB CDAUDIO VORBIS SPEEX DOCS
OPTIONS_DEFAULT= DUMB CDAUDIO VORBIS SPEEX

DUMB_DESC= DUMB support
CDAUDIO_DESC= libcdaudio support

.include <bsd.port.options.mk>
# since dumb is a static lib and it depends on ogg, we should
# link audiere with ogg as well
DUMB_IMPLIES= VORBIS

# Broken with recent FLAC
#.if !defined(WITHOUT_FLAC)
#LIB_DEPENDS+= FLAC:${PORTSDIR}/audio/flac
#.else
CONFIGURE_REPLACES+='/AC_CHECK_LIB/ s|FLAC|no_&|'
#.endif
DUMB_BUILD_DEPENDS= ${LOCALBASE}/lib/libdumb.a:${PORTSDIR}/audio/dumb
CDAUDIO_LIB_DEPENDS= libcdaudio.so:${PORTSDIR}/audio/libcdaudio
VORBIS_LIB_DEPENDS= libvorbis.so:${PORTSDIR}/audio/libvorbis \
libogg.so:${PORTSDIR}/audio/libogg
SPEEX_LIB_DEPENDS= libspeex.so:${PORTSDIR}/audio/speex

.if ${PORT_OPTIONS:MDUMB}
BUILD_DEPENDS+= ${LOCALBASE}/lib/libdumb.a:${PORTSDIR}/audio/dumb
.else
CONFIGURE_REPLACES+='/AC_CHECK_LIB/ s|dumb|no_&|'
.endif
post-patch:
# could be an option, but build is broken with recent FLAC
@${REINPLACE_CMD} -e '/AC_CHECK_LIB/ s|FLAC|no_&|; \
s|wx_config|no_&|' \
${WRKSRC}/configure.in

.if ${PORT_OPTIONS:MCDAUDIO}
LIB_DEPENDS+= libcdaudio.so:${PORTSDIR}/audio/libcdaudio
.else
CONFIGURE_REPLACES+='/AC_CHECK_LIB/ s|cdaudio|no_&|'
.endif
post-patch-DUMB-off:
@${REINPLACE_CMD} -e '/AC_CHECK_LIB/ s|dumb|no_&|' \
${WRKSRC}/configure.in

# since dumb is a static lib and it depends on ogg, we should
# link audiere with ogg as well
.if ${PORT_OPTIONS:MVORBIS} || ${PORT_OPTIONS:MDUMB}
LIB_DEPENDS+= libvorbis.so:${PORTSDIR}/audio/libvorbis \
libogg.so:${PORTSDIR}/audio/libogg
.else
CONFIGURE_REPLACES+='/AC_CHECK_HEADER/ s|vorbis|no_&|'
.endif

.if ${PORT_OPTIONS:MSPEEX}
LIB_DEPENDS+= libspeex.so:${PORTSDIR}/audio/speex
.else
CONFIGURE_REPLACES+='/AC_CHECK_HEADER/ s|speex|no_&|'
.endif
post-patch-CDAUDIO-off:
@${REINPLACE_CMD} -e '/AC_CHECK_LIB/ s|cdaudio|no_&|' \
${WRKSRC}/configure.in

post-patch:
@${REINPLACE_CMD} ${CONFIGURE_REPLACES:C/.*/-e &/} \
-e 's|-lpthread|-pthread|' \
post-patch-VORBIS-off:
@${REINPLACE_CMD} -e '/AC_CHECK_HEADER/ s|vorbis|no_&|' \
${WRKSRC}/configure.in

post-patch-SPEEX-off:
@${REINPLACE_CMD} -e '/AC_CHECK_HEADER/ s|speex|no_&|' \
${WRKSRC}/configure.in

post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libaudiere.so
${MKDIR} ${STAGEDIR}${DOCSDIR}
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libaudiere.so

post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/doc/${f} ${STAGEDIR}${DOCSDIR}
.endfor
Expand Down
27 changes: 20 additions & 7 deletions audio/deadbeef/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -17,7 +17,7 @@ GNU_CONFIGURE= yes
USES= desktop-file-utils execinfo gettext gmake iconv libtool \
pkgconfig shebangfix tar:bzip2
USE_LDCONFIG= yes
CONFIGURE_ARGS= --disable-alsa --disable-nullout --disable-gtk3 --disable-static
CONFIGURE_ARGS= --disable-alsa --disable-nullout --disable-static
CPPFLAGS+= -I../dumb/dumb-kode54/include -I../../plugins/libmp4ff \
-I../../plugins/gme/game-music-emu-0.6pre \
-I${LOCALBASE}/include
Expand All @@ -32,13 +32,13 @@ OPTIONS_DEFINE= MAD PULSEAUDIO GUI VFS LASTFM ART SUPEREQ SID FFAP VTX \
MUSEPACK WILDMIDI TTA DCA AAC MMS SHN AO SHELLEXEC NLS M3U \
PSF ADPLUG DSP MONO2STEREO CONVERTER VFS_ZIP ALAC PLTBROWSER \
WMA
OPTIONS_DEFAULT= MAD GUI VFS LASTFM ART SUPEREQ SID FFAP VTX HOSTKEYS \
OPTIONS_DEFAULT= MAD GTK2 VFS LASTFM ART SUPEREQ SID FFAP VTX HOSTKEYS \
OGG FLAC SNDFILE WAVPACK CDDA GME DUMB NOTIFY MUSEPACK \
WILDMIDI TTA DCA AAC MMS SHN AO SHELLEXEC M3U PSF ADPLUG DSP \
MONO2STEREO CONVERTER VFS_ZIP HOTKEYS ALAC PLTBROWSER WMA

PULSEAUDIO_DESC= PulseAudio output plugin (unsupported)
GUI_DESC= Standard GTK+2 user interface plugin
GUI_DESC= Standard GUI plugin
VFS_DESC= HTTP streaming VFS plugin
LASTFM_DESC= Last.fm/Libre.fm scrobbler plugin
ART_DESC= Cover artwork loader plugin
Expand All @@ -63,17 +63,30 @@ CONVERTER_DESC= Plugin for converting files from/to any formats
VFS_ZIP_DESC= Play files directly from ZIP archives
PLTBROWSER_DESC= Playlist browser GUI plugin

OPTIONS_SUB= yes
OPTIONS_SUB= yes
OPTIONS_RADIO+= GUI
OPTIONS_RADIO_GUI= GTK2 GTK3
GUI_IMPLIES= CONVERTER

MAD_LIB_DEPENDS= libmad.so:${PORTSDIR}/audio/libmad
MAD_CONFIGURE_OFF= --disable-mad

PULSEAUDIO_LIB_DEPENDS= libpulse.so:${PORTSDIR}/audio/pulseaudio
PULSEAUDIO_CONFIGURE_OFF= --disable-pulse

GUI_USE= gnome=gtk20,glib20
GUI_CONFIGURE_OFF= --disable-gtkui --disable-gtk3
GUI_IMPLIES= CONVERTER
GTK2_USE= gnome=gtk20,glib20
GTK2_CONFIGURE_OFF= --disable-gtk2
GTK2_CONFIGURE_ON= --enable-gtk2
GTK2_VARS= GTK_VER=2

GTK3_USE= gnome=gtk30
GTK3_CONFIGURE_OFF= --disable-gtk3
GTK3_CONFIGURE_ON= --enable-gtk3
GTK3_VARS= GTK_VER=3

PLIST_SUB+= GTK_VER=${GTK_VER}

GUI_CONFIGURE_OFF= --disable-gtk2 --disable-gtk3

VFS_LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
VFS_CONFIGURE_OFF= --disable-vfs-curl
Expand Down
8 changes: 4 additions & 4 deletions audio/deadbeef/pkg-plist
Original file line number Diff line number Diff line change
Expand Up @@ -23,7 +23,7 @@ lib/deadbeef/oss.so
%%MMS%%lib/deadbeef/mms.so
%%SHN%%lib/deadbeef/ddb_shn.so
%%SHELLEXEC%%lib/deadbeef/shellexec.so
%%SHELLEXEC%%lib/deadbeef/shellexecui_gtk2.so
%%SHELLEXEC%%lib/deadbeef/shellexecui_gtk%%GTK_VER%%.so
%%LASTFM%%lib/deadbeef/lastfm.so
%%ART%%lib/deadbeef/artwork.so
%%SID%%lib/deadbeef/sid.so
Expand All @@ -44,13 +44,13 @@ share/applications/deadbeef.desktop
%%DOCSDIR%%/translators.txt
%%DOCSDIR%%/help.ru.txt
%%DOCSDIR%%/help.pt_BR.txt
%%GUI%%lib/deadbeef/ddb_gui_GTK2.so
%%GUI%%lib/deadbeef/ddb_gui_GTK%%GTK_VER%%.so
%%DSP%%lib/deadbeef/dsp_libsrc.so
%%MONO2STEREO%%lib/deadbeef/ddb_mono2stereo.so
%%M3U%%lib/deadbeef/m3u.so
%%PSF%%lib/deadbeef/ddb_ao.so
%%CONVERTER%%lib/deadbeef/converter.so
%%CONVERTER%%lib/deadbeef/converter_gtk2.so
%%CONVERTER%%lib/deadbeef/converter_gtk%%GTK_VER%%.so
%%CONVERTER%%lib/deadbeef/convpresets/AAC_(Nero_FAAC).txt
%%CONVERTER%%lib/deadbeef/convpresets/ALAC.txt
%%CONVERTER%%lib/deadbeef/convpresets/FLAC_(compression_level_5).txt
Expand All @@ -65,7 +65,7 @@ share/applications/deadbeef.desktop
%%CONVERTER%%lib/deadbeef/convpresets/WavPack.txt
%%VFS_ZIP%%lib/deadbeef/vfs_zip.so
%%ALAC%%lib/deadbeef/alac.so
%%PLTBROWSER%%lib/deadbeef/pltbrowser_gtk2.so
%%PLTBROWSER%%lib/deadbeef/pltbrowser_gtk%%GTK_VER%%.so
%%WMA%%lib/deadbeef/wma.so
%%NLS%%share/locale/be/LC_MESSAGES/deadbeef.mo
%%NLS%%share/locale/tr/LC_MESSAGES/deadbeef.mo
Expand Down
27 changes: 11 additions & 16 deletions devel/drpython/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,7 @@

PORTNAME= drpython
PORTVERSION= 3.11.4
PORTREVISION= 5
PORTREVISION= 6
CATEGORIES= devel python
MASTER_SITES= SF/${PORTNAME}/DrPython%20%283.x%29/${PORTVERSION}
PKGNAMESUFFIX= ${PYTHON_PKGNAMESUFFIX}
Expand All @@ -14,14 +14,17 @@ COMMENT= Highly customizable cross-platform ide to aid programming in Python

LICENSE= GPLv2

# fails to build in presence if installed self
CONFLICTS_BUILD= ${PORTNAME}${PYTHON_PKGNAMESUFFIX}-[0-9]*

BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>0:${PORTSDIR}/textproc/py-sphinx
RUN_DEPENDS= xdg-open:${PORTSDIR}/devel/xdg-utils

NO_ARCH= yes
WRKSRC= ${WRKDIR}/${PORTNAME}

USES= compiler:c++11-lib python zip
USE_PYTHON= distutils autoplist
USE_PYTHON= autoplist distutils
USE_WX= 3.0+
WX_COMPS= python:lib

Expand All @@ -43,31 +46,23 @@ post-patch:
@${RM} ${WRKSRC}/setup.cfg
@${REINPLACE_CMD} -e \
's|firefox|xdg-open|' ${WRKSRC}/drPreferences.py
@${REINPLACE_CMD} -e 's|%%PYTHON%%|${PYTHON_CMD}|' ${WRKSRC}/drpython.lin

pre-build:
@(cd ${WRKSRC}/docsrc && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} html)
@(cd ${WRKSRC}/docsrc/_build/html && ${CP} -f *.html *.js \
${WRKSRC}/documentation)

post-build:
@${MKDIR} ${WRKDIR}/wrappers
@${ECHO_CMD} -n \
>> ${WRKDIR}/wrappers/drpython
@${ECHO_CMD} '#!/bin/sh' \
>> ${WRKDIR}/wrappers/drpython
@${ECHO_CMD} '#!/bin/sh' > ${WRKDIR}/drpython.sh
.if ${OPSYS} == FreeBSD && ${CHOSEN_COMPILER_TYPE} == gcc
@${ECHO_CMD} 'LD_LIBRARY_PATH="${LOCALBASE}/lib/${CC}:$$LD_LIBRARY_PATH"' \
>> ${WRKDIR}/wrappers/drpython
@${ECHO_CMD} 'export LD_LIBRARY_PATH' \
>> ${WRKDIR}/wrappers/drpython
@${ECHO_CMD} \
>> ${WRKDIR}/wrappers/drpython
>> ${WRKDIR}/drpython.sh
@${ECHO_CMD} 'export LD_LIBRARY_PATH' >> ${WRKDIR}/drpython.sh
.endif
@${ECHO_CMD} 'exec ${PYTHON_CMD} -m drpython.drpython' \
>> ${WRKDIR}/wrappers/drpython
@${ECHO_CMD} 'exec ${PYTHON_CMD} -m drpython.drpython' >> ${WRKDIR}/drpython.sh

post-install:
(cd ${WRKDIR}/wrappers && ${INSTALL_SCRIPT} drpython \
${STAGEDIR}${PREFIX}/bin)
${INSTALL_SCRIPT} ${WRKDIR}/drpython.sh ${STAGEDIR}${PREFIX}/bin/${PORTNAME}

.include <bsd.port.post.mk>
4 changes: 2 additions & 2 deletions devel/drpython/files/patch-drToolBarDialog.py
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
--- drToolBarDialog.py.orig
--- drToolBarDialog.py.orig 2014-04-20 17:50:40 UTC
+++ drToolBarDialog.py
@@ -36,7 +36,7 @@
@@ -36,7 +36,7 @@ def GetToolBarLabels(filename, frame):
text = f.read()
f.close()
except:
Expand Down
7 changes: 7 additions & 0 deletions devel/drpython/files/patch-drpython.lin
Original file line number Diff line number Diff line change
@@ -0,0 +1,7 @@
--- drpython.lin.orig 2014-04-20 17:50:40 UTC
+++ drpython.lin
@@ -1,2 +1,2 @@
-#!/bin/bash
-python ${0%/*}/drpython.pyw
+#!/bin/sh
+%%PYTHON%% ${0%/*}/drpython.pyw
2 changes: 1 addition & 1 deletion devel/gdb/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,7 @@

PORTNAME= gdb
PORTVERSION= 7.10
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= GNU

Expand Down
4 changes: 3 additions & 1 deletion devel/gdb/files/fbsd-threads.c
Original file line number Diff line number Diff line change
Expand Up @@ -764,7 +764,9 @@ fbsd_thread_wait (struct target_ops *ops,
td_thrinfo_t ti;

ret = beneath->to_wait (beneath, ptid, ourstatus, options);
if (GET_PID(ret) >= 0 && ourstatus->kind == TARGET_WAITKIND_STOPPED)
if (GET_PID(ret) >= 0 &&
( ourstatus->kind == TARGET_WAITKIND_STOPPED ||
ourstatus->kind == TARGET_WAITKIND_FORKED ) )
{
lwp = get_current_lwp (GET_PID(ret));
ret = thread_from_lwp (BUILD_LWP(lwp, GET_PID(ret)),
Expand Down
4 changes: 2 additions & 2 deletions devel/lcov/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -2,12 +2,12 @@
# $FreeBSD$

PORTNAME= lcov
PORTVERSION= 1.10
PORTVERSION= 1.12
CATEGORIES= devel
MASTER_SITES= SF/ltp/Coverage%20Analysis/LCOV-${PORTVERSION}

MAINTAINER= [email protected]
COMMENT= The Linux Test Project GCOV extension
COMMENT= Linux Test Project GCOV extension

LICENSE= GPLv1

Expand Down
4 changes: 2 additions & 2 deletions devel/lcov/distinfo
Original file line number Diff line number Diff line change
@@ -1,2 +1,2 @@
SHA256 (lcov-1.10.tar.gz) = 8a4661becc95fafad7875786672f7f29b080437825c3ff31d55a49492c15b88f
SIZE (lcov-1.10.tar.gz) = 150174
SHA256 (lcov-1.12.tar.gz) = b474e49c6c962754063b3be97a757a2ba9e7a455f0aea612863bf67e9b8b8ea7
SIZE (lcov-1.12.tar.gz) = 153009
2 changes: 1 addition & 1 deletion devel/lcov/pkg-descr
Original file line number Diff line number Diff line change
Expand Up @@ -3,4 +3,4 @@ gcov data for multiple source files and creates HTML pages containing the
source code annotated with coverage information. It also adds overview pages
for easy navigation within the file structure.

WWW: http://ltp.sourceforge.net/coverage/lcov.php
WWW: http://ltp.sourceforge.net/coverage/lcov.php
32 changes: 17 additions & 15 deletions devel/mongo-c-driver/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -2,30 +2,32 @@
# $FreeBSD$

PORTNAME= mongo-c-driver
PORTVERSION= 0.7.1
DISTVERSIONPREFIX= v
PORTVERSION= 1.1.9
CATEGORIES= devel
PKGNAMESUFFIX= -devel

MAINTAINER= [email protected]
COMMENT= C Driver for MongoDB

LICENSE= APACHE20

BUILD_DEPENDS= ${LOCALBASE}/lib/libbson-1.0.so:${PORTSDIR}/devel/libbson
LIB_DEPENDS+= libsasl2.so:${PORTSDIR}/security/cyrus-sasl2

USE_GITHUB= yes
GH_ACCOUNT= mongodb

USES= gmake

USES= autoreconf gmake libtool pkgconfig
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
LDFLAGS+= -pthread

MAKE_ARGS= pkgconfigdir="${PREFIX}/libdata/pkgconfig" V=1

pre-configure:
cd ${WRKSRC} && ./autogen.sh

PLIST_FILES= include/mongo.h \
include/bson.h \
lib/libmongoc.a \
lib/libmongoc.so.0.7 \
lib/libmongoc.so.0.7.1 \
lib/libmongoc.so \
lib/libbson.a \
lib/libbson.so.0.7.1 \
lib/libbson.so.0.7 \
lib/libbson.so
post-stage:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libmongoc-priv.so.0.0.0
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libmongoc-1.0.so.0.0.0

.include <bsd.port.mk>
4 changes: 2 additions & 2 deletions devel/mongo-c-driver/distinfo
Original file line number Diff line number Diff line change
@@ -1,2 +1,2 @@
SHA256 (mongodb-mongo-c-driver-v0.7.1_GH0.tar.gz) = 8338f851cb1202353db83c26bfab85eb3e3fb976b58bf990862dbfe0a20a308f
SIZE (mongodb-mongo-c-driver-v0.7.1_GH0.tar.gz) = 108524
SHA256 (mongodb-mongo-c-driver-1.1.9_GH0.tar.gz) = a025131105807ae2c176f1da5b8128c998d334c7c8d96be42c7da227dd0985c8
SIZE (mongodb-mongo-c-driver-1.1.9_GH0.tar.gz) = 347463
Loading

0 comments on commit 094ca6a

Please sign in to comment.