forked from opnsense/ports
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Taken from: FreeBSD
- Loading branch information
Showing
575 changed files
with
28,416 additions
and
7,630 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,41 @@ | ||
# Created by: Thomas Hurst <[email protected]> | ||
# $FreeBSD$ | ||
|
||
PORTNAME= attic | ||
PORTVERSION= 0.16 | ||
CATEGORIES= archivers python | ||
MASTER_SITES= CHEESESHOP | ||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX} | ||
DISTNAME= Attic-${PORTVERSION} | ||
|
||
MAINTAINER= [email protected] | ||
COMMENT= Deduplicating backup program | ||
|
||
LICENSE= BSD3CLAUSE | ||
LICENSE_FILE= ${WRKSRC}/LICENSE | ||
|
||
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}msgpack>=0.1.10:${PORTSDIR}/devel/py-msgpack | ||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}msgpack>=0.1.10:${PORTSDIR}/devel/py-msgpack | ||
|
||
USES= python:3.2+ | ||
USE_PYTHON= autoplist distutils | ||
USE_OPENSSL= yes | ||
|
||
STRIP_FILES= hashindex.so platform_freebsd.so chunker.so crypto.so | ||
PYDISTUTILS_BUILDPATH=${BUILD_WRKSRC}/build/lib.${OPSYS:tl}-${UNAMER}-${ARCH}-${PYTHON_VER} | ||
|
||
.include <bsd.port.pre.mk> | ||
|
||
.if ${OSVERSION} < 1000015 | ||
BUILD_DEPENDS+= openssl>=1.0:${PORTSDIR}/security/openssl | ||
RUN_DEPENDS+= openssl>=1.0:${PORTSDIR}/security/openssl | ||
.endif | ||
|
||
regression-test: build | ||
${SETENV} PYTHONPATH="${PYDISTUTILS_BUILDPATH}:${PYTHONPATH}" \ | ||
${PYTHON_CMD} -m attic.testsuite.run | ||
|
||
post-install: | ||
${STRIP_CMD} ${STRIP_FILES:S,^,${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/attic/,} | ||
|
||
.include <bsd.port.post.mk> |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,2 @@ | ||
SHA256 (Attic-0.16.tar.gz) = 6650cd28072101c2e05941e77b93a62f91da6179785e4e4b4880916c469bba2c | ||
SIZE (Attic-0.16.tar.gz) = 232455 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,6 @@ | ||
Attic is a deduplicating backup program written in Python. The main goal of | ||
Attic is to provide an efficient and secure way to backup data. The data | ||
deduplication technique used makes Attic suitable for daily backups since only | ||
the changes are stored. | ||
|
||
WWW: https://attic-backup.org |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -3,13 +3,15 @@ | |
|
||
PORTNAME= unmakeself | ||
PORTVERSION= 1.1 | ||
PORTREVISION= 1 | ||
CATEGORIES= archivers | ||
DISTFILES= | ||
|
||
MAINTAINER= [email protected] | ||
COMMENT= Extract Makeself archives | ||
|
||
LDFLAGS+= -larchive -lbz2 -lz -lcrypto -lmd | ||
USES= libarchive | ||
LDFLAGS+= -larchive | ||
NO_WRKSUBDIR= yes | ||
|
||
PLIST_FILES= bin/unmakeself | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -6,16 +6,16 @@ PORTVERSION= 0.82 | |
PORTREVISION= 4 | ||
PORTEPOCH= 1 | ||
CATEGORIES= audio | ||
MASTER_SITES= http://cvsup.theplanet.com/distfiles/ \ | ||
http://mark.foster.cc/pub/freebsd/ports/distfiles/ | ||
MASTER_SITES= http://mark.foster.cc/pub/freebsd/ports/distfiles/ \ | ||
LOCAL/feld | ||
MASTER_SITES= LOCAL/feld | ||
|
||
MAINTAINER= [email protected] | ||
COMMENT= Easy to use CD Ripping and MP3 Encoding tool | ||
|
||
RUN_DEPENDS= lame:${PORTSDIR}/audio/lame \ | ||
dagrab:${PORTSDIR}/audio/dagrab | ||
|
||
BROKEN= Fails to fetch | ||
USES= perl5 shebangfix | ||
USE_PERL5= run | ||
SHEBANG_FILES= cd2mp3 | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -2,71 +2,53 @@ | |
# $FreeBSD$ | ||
|
||
PORTNAME= tomahawk | ||
PORTVERSION= 0.7.0 | ||
PORTREVISION= 4 | ||
PORTVERSION= 0.8.4 | ||
CATEGORIES= audio | ||
|
||
MAINTAINER= [email protected] | ||
COMMENT= Multi-source, social, and smart music player | ||
|
||
LICENSE= GPLv3 | ||
|
||
BUILD_DEPENDS= google-sparsehash>=2.0.2:${PORTSDIR}/devel/google-sparsehash \ | ||
websocketpp>=0.4.0:${PORTSDIR}/devel/websocketpp | ||
RUN_DEPENDS= phonon-vlc>=0.6.1:${PORTSDIR}/multimedia/phonon-vlc | ||
LIB_DEPENDS= libattica.so:${PORTSDIR}/x11-toolkits/attica \ | ||
libclucene-core.so:${PORTSDIR}/textproc/clucene \ | ||
liblucene++.so:${PORTSDIR}/textproc/luceneplusplus \ | ||
libboost_thread.so:${PORTSDIR}/devel/boost-libs \ | ||
libechonest.so:${PORTSDIR}/audio/libechonest \ | ||
libgnutls.so:${PORTSDIR}/security/gnutls \ | ||
libjreen.so:${PORTSDIR}/net-im/libjreen \ | ||
liblastfm.so:${PORTSDIR}/audio/liblastfm \ | ||
libqca.so:${PORTSDIR}/devel/qca \ | ||
libqjson.so:${PORTSDIR}/devel/qjson \ | ||
libqtkeychain.so:${PORTSDIR}/security/qtkeychain-qt4 \ | ||
libquazip.so:${PORTSDIR}/archivers/quazip \ | ||
libtag.so:${PORTSDIR}/audio/taglib | ||
|
||
CMAKE_ARGS+= -DWITH_BREAKPAD:BOOL="OFF" \ | ||
-DCLUCENE_CONFIG_PATH:PATH="${LOCALBASE}/share/clucene" | ||
CXXFLAGS+= -Wno-cast-align | ||
CMAKE_ARGS= -DBUILD_RELEASE="ON" | ||
CXXFLAGS+= -Wno-cast-align -I${LOCALBASE}/include | ||
|
||
GH_ACCOUNT= tomahawk-player | ||
|
||
TELEPATHY_LIB_DEPENDS= libtelepathy-qt4.so:${PORTSDIR}/net-im/telepathy-qt4 | ||
TELEPATHY_DESC= Configure Telepathy Settings | ||
TELEPATHY_USE_KDE4= kdelibs automoc4 | ||
|
||
INSTALLS_ICONS= yes | ||
|
||
OPTIONS_DEFINE= QTWEETLIB | ||
OPTIONS_DEFAULT= GSTREAMER QTWEETLIB | ||
OPTIONS_RADIO= PHONON | ||
OPTIONS_RADIO_PHONON= GSTREAMER VLC XINE | ||
OPTIONS_DEFAULT= | ||
OPTIONS_DEFINE= TELEPATHY | ||
OPTIONS_SUB= yes | ||
QTWEETLIB_DESC= Enable Twitter SIP plugin | ||
VLC_DESC= Multimedia support for VLC | ||
|
||
PLIST_SUB+= DESKTOPDIR=${DESKTOPDIR:S,^${PREFIX}/,,} \ | ||
PORTVERSION=${PORTVERSION} | ||
|
||
USES= cmake pkgconfig desktop-file-utils | ||
USES= cmake desktop-file-utils pkgconfig | ||
USE_GITHUB= yes | ||
USE_LDCONFIG= yes | ||
|
||
USE_QT4= dbus designer gui linguist_build moc_build \ | ||
network phonon qmake_build qtestlib rcc_build \ | ||
sql-sqlite2 svg uic_build xml | ||
|
||
.include <bsd.port.options.mk> | ||
|
||
.if ${PORT_OPTIONS:MQTWEETLIB} | ||
LIB_DEPENDS+= libQTweetLib.so:${PORTSDIR}/net/qtweetlib | ||
.else | ||
CMAKE_ARGS+= -DWITH_QTweetLib:BOOL="OFF" | ||
.endif | ||
|
||
.if ${PORT_OPTIONS:MGSTREAMER} | ||
RUN_DEPENDS+= phonon-gstreamer>=4.6.3:${PORTSDIR}/multimedia/phonon-gstreamer | ||
.endif | ||
|
||
.if ${PORT_OPTIONS:MVLC} | ||
RUN_DEPENDS+= phonon-vlc>=0.6.1:${PORTSDIR}/multimedia/phonon-vlc | ||
.endif | ||
|
||
.if ${PORT_OPTIONS:MXINE} | ||
RUN_DEPENDS+= phonon-xine>=4.4.4_5:${PORTSDIR}/multimedia/phonon-xine | ||
.endif | ||
|
||
.include <bsd.port.mk> |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,2 @@ | ||
SHA256 (tomahawk-player-tomahawk-0.7.0_GH0.tar.gz) = 5bc9f10537c03e2f79cca5afab71dd76617ed9c0b4bd9a2025424c94bfc37d61 | ||
SIZE (tomahawk-player-tomahawk-0.7.0_GH0.tar.gz) = 6519964 | ||
SHA256 (tomahawk-player-tomahawk-0.8.4_GH0.tar.gz) = c61089cda8af780015cf3c7c9d0d2a704fb7ee756c228ab3fd7808f264756236 | ||
SIZE (tomahawk-player-tomahawk-0.8.4_GH0.tar.gz) = 9699629 |
22 changes: 0 additions & 22 deletions
22
audio/tomahawk/files/patch-CMakeModules__FindCLucene.cmake
This file was deleted.
Oops, something went wrong.
8 changes: 4 additions & 4 deletions
8
audio/tomahawk/files/patch-src__libtomahawk__sip__PeerInfo.cpp
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
6 changes: 3 additions & 3 deletions
6
audio/tomahawk/files/patch-src__libtomahawk__utils__Closure.h
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file was deleted.
Oops, something went wrong.
20 changes: 20 additions & 0 deletions
20
audio/tomahawk/files/patch-src_libtomahawk_utils_TomahawkUtils.cpp
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,20 @@ | ||
--- src/libtomahawk/utils/TomahawkUtils.cpp.orig 2014-11-20 00:17:56 UTC | ||
+++ src/libtomahawk/utils/TomahawkUtils.cpp | ||
@@ -19,6 +19,8 @@ | ||
* along with Tomahawk. If not, see <http://www.gnu.org/licenses/>. | ||
*/ | ||
|
||
+#include <unistd.h> | ||
+ | ||
#include "utils/TomahawkUtils.h" | ||
|
||
#include "config.h" | ||
@@ -183,7 +185,7 @@ appDataDir() | ||
} | ||
#elif defined(Q_OS_MAC) | ||
path = appSupportFolderPath(); | ||
- #elif defined(Q_OS_LINUX) | ||
+ #elif defined(Q_OS_LINUX) || defined(Q_OS_FREEBSD) | ||
path = QDir::home().filePath( ".local/share" ); | ||
#else | ||
path = QCoreApplication::applicationDirPath(); |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,2 @@ | ||
ATTENTION! | ||
Tomahawk currently does not work if multimedia/phonon-gstreamer is installed. |
Oops, something went wrong.