Skip to content

Commit

Permalink
*/*: sync with upstream
Browse files Browse the repository at this point in the history
Taken from: FreeBSD
  • Loading branch information
fichtner committed Jul 20, 2015
1 parent f8bf717 commit 0c80e35
Show file tree
Hide file tree
Showing 575 changed files with 28,416 additions and 7,630 deletions.
1 change: 1 addition & 0 deletions archivers/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -159,6 +159,7 @@
SUBDIR += ppmd-7z
SUBDIR += ppunpack
SUBDIR += pxz
SUBDIR += py-attic
SUBDIR += py-liblzma
SUBDIR += py-librtfcomp
SUBDIR += py-lz4
Expand Down
3 changes: 2 additions & 1 deletion archivers/ark/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -3,6 +3,7 @@

PORTNAME= ark
PORTVERSION= ${KDE4_VERSION}
PORTREVISION= 1
CATEGORIES= archivers kde
MASTER_SITES= KDE/${KDE4_BRANCH}/${PORTVERSION}/src
DIST_SUBDIR= KDE/${PORTVERSION}
Expand All @@ -13,7 +14,7 @@ COMMENT= Archiving tool for KDE
LIB_DEPENDS= libqjson.so:${PORTSDIR}/devel/qjson

USE_KDE4= kdeprefix automoc4 kdelibs libkonq
USES= cmake:outsource cpe tar:xz
USES= cmake:outsource libarchive cpe tar:xz
CPE_VENDOR= kde
USE_QT4= qtestlib qmake_build moc_build rcc_build uic_build
USE_LDCONFIG= yes
Expand Down
3 changes: 2 additions & 1 deletion archivers/file-roller/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -5,6 +5,7 @@
PORTNAME= file-roller
PORTVERSION= 3.14.2
PORTEPOCH= 1
PORTREVISION= 1
CATEGORIES= archivers gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome3
Expand All @@ -16,7 +17,7 @@ BUILD_DEPENDS= itstool:${PORTSDIR}/textproc/itstool
RUN_DEPENDS= gtar:${PORTSDIR}/archivers/gtar \
unzip:${PORTSDIR}/archivers/unzip

USES= desktop-file-utils gettext gmake libtool \
USES= desktop-file-utils gettext gmake libtool libarchive \
pathfix pkgconfig tar:xz
USE_GNOME= gnomeprefix gtk30 intlhack introspection:build
USE_XORG= sm
Expand Down
4 changes: 2 additions & 2 deletions archivers/p5-Archive-Extract-Libarchive/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,7 @@

PORTNAME= Archive-Extract-Libarchive
PORTVERSION= 0.38
PORTREVISION= 3
PORTREVISION= 4
CATEGORIES= archivers perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
Expand All @@ -21,7 +21,7 @@ TEST_DEPENDS= p5-File-Slurp>=0:${PORTSDIR}/devel/p5-File-Slurp \
p5-Test-Pod>=1.04:${PORTSDIR}/devel/p5-Test-Pod

USE_PERL5= modbuild
USES= perl5
USES= perl5 libarchive

post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Archive/Extract/Libarchive/Libarchive.so
Expand Down
2 changes: 1 addition & 1 deletion archivers/pixz/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE

SUB_FILES= Makefile
PLIST_FILES= bin/${PORTNAME} man/man1/pixz.1.gz
USES= uidfix
USES= uidfix libarchive

post-extract: apply-slist
${INSTALL_DATA} ${WRKDIR}/Makefile ${WRKSRC}
Expand Down
41 changes: 41 additions & 0 deletions archivers/py-attic/Makefile
Original file line number Diff line number Diff line change
@@ -0,0 +1,41 @@
# Created by: Thomas Hurst <[email protected]>
# $FreeBSD$

PORTNAME= attic
PORTVERSION= 0.16
CATEGORIES= archivers python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= Attic-${PORTVERSION}

MAINTAINER= [email protected]
COMMENT= Deduplicating backup program

LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE

BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}msgpack>=0.1.10:${PORTSDIR}/devel/py-msgpack
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}msgpack>=0.1.10:${PORTSDIR}/devel/py-msgpack

USES= python:3.2+
USE_PYTHON= autoplist distutils
USE_OPENSSL= yes

STRIP_FILES= hashindex.so platform_freebsd.so chunker.so crypto.so
PYDISTUTILS_BUILDPATH=${BUILD_WRKSRC}/build/lib.${OPSYS:tl}-${UNAMER}-${ARCH}-${PYTHON_VER}

.include <bsd.port.pre.mk>

.if ${OSVERSION} < 1000015
BUILD_DEPENDS+= openssl>=1.0:${PORTSDIR}/security/openssl
RUN_DEPENDS+= openssl>=1.0:${PORTSDIR}/security/openssl
.endif

regression-test: build
${SETENV} PYTHONPATH="${PYDISTUTILS_BUILDPATH}:${PYTHONPATH}" \
${PYTHON_CMD} -m attic.testsuite.run

post-install:
${STRIP_CMD} ${STRIP_FILES:S,^,${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/attic/,}

.include <bsd.port.post.mk>
2 changes: 2 additions & 0 deletions archivers/py-attic/distinfo
Original file line number Diff line number Diff line change
@@ -0,0 +1,2 @@
SHA256 (Attic-0.16.tar.gz) = 6650cd28072101c2e05941e77b93a62f91da6179785e4e4b4880916c469bba2c
SIZE (Attic-0.16.tar.gz) = 232455
6 changes: 6 additions & 0 deletions archivers/py-attic/pkg-descr
Original file line number Diff line number Diff line change
@@ -0,0 +1,6 @@
Attic is a deduplicating backup program written in Python. The main goal of
Attic is to provide an efficient and secure way to backup data. The data
deduplication technique used makes Attic suitable for daily backups since only
the changes are stored.

WWW: https://attic-backup.org
12 changes: 3 additions & 9 deletions archivers/rpm4/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -27,8 +27,8 @@ NLS_USES= gettext
NLS_LIBS= -lintl
PORTDOCS= *

USES= alias gmake libtool lua:51 pathfix pkgconfig shebangfix \
tar:bzip2
USES= alias gmake libarchive libtool lua:51 pathfix pkgconfig \
shebangfix tar:bzip2
USE_BDB= 46+
INVALID_BDB_VER=51
GNU_CONFIGURE= yes
Expand Down Expand Up @@ -59,12 +59,6 @@ CONFIGURE_ENV+= LUA_CFLAGS=-I${LUA_INCDIR} \
LUA_LIBS="-L${LUA_LIBDIR} -llua-${LUA_VER} -lm"
PLIST_SUB+= VERSION=${PORTVERSION}

.include <bsd.port.pre.mk>

.if ${OSVERSION} < 1000000
LIB_DEPENDS+= libarchive.so.13:${PORTSDIR}/archivers/libarchive
.endif

post-patch:
${REINPLACE_CMD} -e 's:\.\./\.\./bin/::' ${WRKSRC}/Makefile.in
${REINPLACE_CMD} -e 's/(hpux)/& || defined(__FreeBSD__)/' \
Expand All @@ -77,4 +71,4 @@ post-install:
${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC}/doc && ${COPYTREE_SHARE} librpm/html ${STAGEDIR}${DOCSDIR}

.include <bsd.port.post.mk>
.include <bsd.port.mk>
3 changes: 2 additions & 1 deletion archivers/rubygem-libarchive/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -3,6 +3,7 @@

PORTNAME= libarchive
PORTVERSION= 0.1.2
PORTREVISION= 1
CATEGORIES= archivers rubygems
MASTER_SITES= RG

Expand All @@ -11,7 +12,7 @@ COMMENT= Ruby bindings for libarchive

LICENSE= BSD3CLAUSE

USES= dos2unix
USES= dos2unix libarchive
USE_RUBY= yes
USE_RUBYGEMS= yes
RUBYGEM_AUTOPLIST= yes
Expand Down
4 changes: 3 additions & 1 deletion archivers/unmakeself/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -3,13 +3,15 @@

PORTNAME= unmakeself
PORTVERSION= 1.1
PORTREVISION= 1
CATEGORIES= archivers
DISTFILES=

MAINTAINER= [email protected]
COMMENT= Extract Makeself archives

LDFLAGS+= -larchive -lbz2 -lz -lcrypto -lmd
USES= libarchive
LDFLAGS+= -larchive
NO_WRKSUBDIR= yes

PLIST_FILES= bin/unmakeself
Expand Down
6 changes: 3 additions & 3 deletions audio/cd2mp3/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -6,16 +6,16 @@ PORTVERSION= 0.82
PORTREVISION= 4
PORTEPOCH= 1
CATEGORIES= audio
MASTER_SITES= http://cvsup.theplanet.com/distfiles/ \
http://mark.foster.cc/pub/freebsd/ports/distfiles/
MASTER_SITES= http://mark.foster.cc/pub/freebsd/ports/distfiles/ \
LOCAL/feld
MASTER_SITES= LOCAL/feld

MAINTAINER= [email protected]
COMMENT= Easy to use CD Ripping and MP3 Encoding tool

RUN_DEPENDS= lame:${PORTSDIR}/audio/lame \
dagrab:${PORTSDIR}/audio/dagrab

BROKEN= Fails to fetch
USES= perl5 shebangfix
USE_PERL5= run
SHEBANG_FILES= cd2mp3
Expand Down
2 changes: 1 addition & 1 deletion audio/hydrogen-devel/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -59,7 +59,7 @@ LASH_LIB_DEPENDS= liblash.so:${PORTSDIR}/audio/lash
LIBARCHIVE_DESC= LibArchive support
LIBARCHIVE_CMAKE_ON= -DWANT_LIBARCHIVE:BOOL=ON
LIBARCHIVE_CMAKE_OFF= -DWANT_LIBARCHIVE:BOOL=OFF
LIBARCHIVE_LIB_DEPENDS= libarchive.so:${PORTSDIR}/archivers/libarchive
LIBARCHIVE_USES= libarchive

OSS_CMAKE_ON= -DWANT_OSS:BOOL=ON
OSS_CMAKE_OFF= -DWANT_OSS:BOOL=OFF
Expand Down
50 changes: 16 additions & 34 deletions audio/tomahawk/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -2,71 +2,53 @@
# $FreeBSD$

PORTNAME= tomahawk
PORTVERSION= 0.7.0
PORTREVISION= 4
PORTVERSION= 0.8.4
CATEGORIES= audio

MAINTAINER= [email protected]
COMMENT= Multi-source, social, and smart music player

LICENSE= GPLv3

BUILD_DEPENDS= google-sparsehash>=2.0.2:${PORTSDIR}/devel/google-sparsehash \
websocketpp>=0.4.0:${PORTSDIR}/devel/websocketpp
RUN_DEPENDS= phonon-vlc>=0.6.1:${PORTSDIR}/multimedia/phonon-vlc
LIB_DEPENDS= libattica.so:${PORTSDIR}/x11-toolkits/attica \
libclucene-core.so:${PORTSDIR}/textproc/clucene \
liblucene++.so:${PORTSDIR}/textproc/luceneplusplus \
libboost_thread.so:${PORTSDIR}/devel/boost-libs \
libechonest.so:${PORTSDIR}/audio/libechonest \
libgnutls.so:${PORTSDIR}/security/gnutls \
libjreen.so:${PORTSDIR}/net-im/libjreen \
liblastfm.so:${PORTSDIR}/audio/liblastfm \
libqca.so:${PORTSDIR}/devel/qca \
libqjson.so:${PORTSDIR}/devel/qjson \
libqtkeychain.so:${PORTSDIR}/security/qtkeychain-qt4 \
libquazip.so:${PORTSDIR}/archivers/quazip \
libtag.so:${PORTSDIR}/audio/taglib

CMAKE_ARGS+= -DWITH_BREAKPAD:BOOL="OFF" \
-DCLUCENE_CONFIG_PATH:PATH="${LOCALBASE}/share/clucene"
CXXFLAGS+= -Wno-cast-align
CMAKE_ARGS= -DBUILD_RELEASE="ON"
CXXFLAGS+= -Wno-cast-align -I${LOCALBASE}/include

GH_ACCOUNT= tomahawk-player

TELEPATHY_LIB_DEPENDS= libtelepathy-qt4.so:${PORTSDIR}/net-im/telepathy-qt4
TELEPATHY_DESC= Configure Telepathy Settings
TELEPATHY_USE_KDE4= kdelibs automoc4

INSTALLS_ICONS= yes

OPTIONS_DEFINE= QTWEETLIB
OPTIONS_DEFAULT= GSTREAMER QTWEETLIB
OPTIONS_RADIO= PHONON
OPTIONS_RADIO_PHONON= GSTREAMER VLC XINE
OPTIONS_DEFAULT=
OPTIONS_DEFINE= TELEPATHY
OPTIONS_SUB= yes
QTWEETLIB_DESC= Enable Twitter SIP plugin
VLC_DESC= Multimedia support for VLC

PLIST_SUB+= DESKTOPDIR=${DESKTOPDIR:S,^${PREFIX}/,,} \
PORTVERSION=${PORTVERSION}

USES= cmake pkgconfig desktop-file-utils
USES= cmake desktop-file-utils pkgconfig
USE_GITHUB= yes
USE_LDCONFIG= yes

USE_QT4= dbus designer gui linguist_build moc_build \
network phonon qmake_build qtestlib rcc_build \
sql-sqlite2 svg uic_build xml

.include <bsd.port.options.mk>

.if ${PORT_OPTIONS:MQTWEETLIB}
LIB_DEPENDS+= libQTweetLib.so:${PORTSDIR}/net/qtweetlib
.else
CMAKE_ARGS+= -DWITH_QTweetLib:BOOL="OFF"
.endif

.if ${PORT_OPTIONS:MGSTREAMER}
RUN_DEPENDS+= phonon-gstreamer>=4.6.3:${PORTSDIR}/multimedia/phonon-gstreamer
.endif

.if ${PORT_OPTIONS:MVLC}
RUN_DEPENDS+= phonon-vlc>=0.6.1:${PORTSDIR}/multimedia/phonon-vlc
.endif

.if ${PORT_OPTIONS:MXINE}
RUN_DEPENDS+= phonon-xine>=4.4.4_5:${PORTSDIR}/multimedia/phonon-xine
.endif

.include <bsd.port.mk>
4 changes: 2 additions & 2 deletions audio/tomahawk/distinfo
Original file line number Diff line number Diff line change
@@ -1,2 +1,2 @@
SHA256 (tomahawk-player-tomahawk-0.7.0_GH0.tar.gz) = 5bc9f10537c03e2f79cca5afab71dd76617ed9c0b4bd9a2025424c94bfc37d61
SIZE (tomahawk-player-tomahawk-0.7.0_GH0.tar.gz) = 6519964
SHA256 (tomahawk-player-tomahawk-0.8.4_GH0.tar.gz) = c61089cda8af780015cf3c7c9d0d2a704fb7ee756c228ab3fd7808f264756236
SIZE (tomahawk-player-tomahawk-0.8.4_GH0.tar.gz) = 9699629
22 changes: 0 additions & 22 deletions audio/tomahawk/files/patch-CMakeModules__FindCLucene.cmake

This file was deleted.

Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
--- ./src/libtomahawk/sip/PeerInfo.cpp.orig 2013-06-28 17:01:55.000000000 +0200
+++ ./src/libtomahawk/sip/PeerInfo.cpp 2013-06-28 17:02:45.000000000 +0200
@@ -312,7 +312,7 @@
m_fancyAvatar = 0;
--- src/libtomahawk/sip/PeerInfo.cpp.orig 2014-11-20 00:17:56 UTC
+++ src/libtomahawk/sip/PeerInfo.cpp
@@ -333,7 +333,7 @@ PeerInfo::setAvatar( const QPixmap& avat
d->fancyAvatar.reset();

Q_ASSERT( !contactId().isEmpty() );
- TomahawkUtils::Cache::instance()->putData( "Sources", 7776000000 /* 90 days */, contactId(), ba );
Expand Down
6 changes: 3 additions & 3 deletions audio/tomahawk/files/patch-src__libtomahawk__utils__Closure.h
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
--- src/libtomahawk/utils/Closure.h.orig 2014-08-15 16:48:25.000000000 +0200
+++ src/libtomahawk/utils/Closure.h 2014-08-15 16:49:47.000000000 +0200
@@ -30,6 +30,10 @@
--- src/libtomahawk/utils/Closure.h.orig 2014-11-20 00:17:56 UTC
+++ src/libtomahawk/utils/Closure.h
@@ -40,6 +40,10 @@ using std::tr1::function;
#include <boost/noncopyable.hpp>
#include <boost/scoped_ptr.hpp>

Expand Down
13 changes: 0 additions & 13 deletions audio/tomahawk/files/patch-src__main.cpp

This file was deleted.

20 changes: 20 additions & 0 deletions audio/tomahawk/files/patch-src_libtomahawk_utils_TomahawkUtils.cpp
Original file line number Diff line number Diff line change
@@ -0,0 +1,20 @@
--- src/libtomahawk/utils/TomahawkUtils.cpp.orig 2014-11-20 00:17:56 UTC
+++ src/libtomahawk/utils/TomahawkUtils.cpp
@@ -19,6 +19,8 @@
* along with Tomahawk. If not, see <http://www.gnu.org/licenses/>.
*/

+#include <unistd.h>
+
#include "utils/TomahawkUtils.h"

#include "config.h"
@@ -183,7 +185,7 @@ appDataDir()
}
#elif defined(Q_OS_MAC)
path = appSupportFolderPath();
- #elif defined(Q_OS_LINUX)
+ #elif defined(Q_OS_LINUX) || defined(Q_OS_FREEBSD)
path = QDir::home().filePath( ".local/share" );
#else
path = QCoreApplication::applicationDirPath();
2 changes: 2 additions & 0 deletions audio/tomahawk/pkg-message
Original file line number Diff line number Diff line change
@@ -0,0 +1,2 @@
ATTENTION!
Tomahawk currently does not work if multimedia/phonon-gstreamer is installed.
Loading

0 comments on commit 0c80e35

Please sign in to comment.