forked from opnsense/ports
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Taken from: FreeBSD
- Loading branch information
Showing
79 changed files
with
884 additions
and
684 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -3,6 +3,7 @@ | |
|
||
PORTNAME= gogglesmm | ||
PORTVERSION= 1.1.7 | ||
PORTREVISION= 1 | ||
CATEGORIES= audio | ||
|
||
MAINTAINER= [email protected] | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -3,6 +3,7 @@ | |
|
||
PORTNAME= hamlib | ||
PORTVERSION= 3.1 | ||
PORTREVISION= 1 | ||
CATEGORIES= comms hamradio | ||
MASTER_SITES= SF | ||
|
||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,177 @@ | ||
--- dummy/netrigctl.c.orig 2017-04-16 02:56:42 UTC | ||
+++ dummy/netrigctl.c | ||
@@ -54,7 +54,7 @@ static int netrigctl_transaction(RIG *ri | ||
if (ret != RIG_OK) | ||
return ret; | ||
|
||
- ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", sizeof("\n")); | ||
+ ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", 1); | ||
if (ret < 0) | ||
return ret; | ||
|
||
@@ -87,18 +87,18 @@ static int netrigctl_open(RIG *rig) | ||
if (prot_ver < RIGCTLD_PROT_VER) | ||
return -RIG_EPROTO; | ||
|
||
- ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", sizeof("\n")); | ||
+ ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", 1); | ||
if (ret <= 0) | ||
return (ret < 0) ? ret : -RIG_EPROTO; | ||
|
||
- ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", sizeof("\n")); | ||
+ ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", 1); | ||
if (ret <= 0) | ||
return (ret < 0) ? ret : -RIG_EPROTO; | ||
|
||
rs->itu_region = atoi(buf); | ||
|
||
for (i=0; i<FRQRANGESIZ; i++) { | ||
- ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", sizeof("\n")); | ||
+ ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", 1); | ||
if (ret <= 0) | ||
return (ret < 0) ? ret : -RIG_EPROTO; | ||
|
||
@@ -117,7 +117,7 @@ static int netrigctl_open(RIG *rig) | ||
break; | ||
} | ||
for (i=0; i<FRQRANGESIZ; i++) { | ||
- ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", sizeof("\n")); | ||
+ ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", 1); | ||
if (ret <= 0) | ||
return (ret < 0) ? ret : -RIG_EPROTO; | ||
|
||
@@ -136,7 +136,7 @@ static int netrigctl_open(RIG *rig) | ||
break; | ||
} | ||
for (i=0; i<TSLSTSIZ; i++) { | ||
- ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", sizeof("\n")); | ||
+ ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", 1); | ||
if (ret <= 0) | ||
return (ret < 0) ? ret : -RIG_EPROTO; | ||
|
||
@@ -150,7 +150,7 @@ static int netrigctl_open(RIG *rig) | ||
} | ||
|
||
for (i=0; i<FLTLSTSIZ; i++) { | ||
- ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", sizeof("\n")); | ||
+ ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", 1); | ||
if (ret <= 0) | ||
return (ret < 0) ? ret : -RIG_EPROTO; | ||
|
||
@@ -168,31 +168,31 @@ static int netrigctl_open(RIG *rig) | ||
chan_t chan_list[CHANLSTSIZ]; /*!< Channel list, zero ended */ | ||
#endif | ||
|
||
- ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", sizeof("\n")); | ||
+ ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", 1); | ||
if (ret <= 0) | ||
return (ret < 0) ? ret : -RIG_EPROTO; | ||
|
||
rs->max_rit = atol(buf); | ||
|
||
- ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", sizeof("\n")); | ||
+ ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", 1); | ||
if (ret <= 0) | ||
return (ret < 0) ? ret : -RIG_EPROTO; | ||
|
||
rs->max_xit = atol(buf); | ||
|
||
- ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", sizeof("\n")); | ||
+ ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", 1); | ||
if (ret <= 0) | ||
return (ret < 0) ? ret : -RIG_EPROTO; | ||
|
||
rs->max_ifshift = atol(buf); | ||
|
||
- ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", sizeof("\n")); | ||
+ ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", 1); | ||
if (ret <= 0) | ||
return (ret < 0) ? ret : -RIG_EPROTO; | ||
|
||
rs->announces = atoi(buf); | ||
|
||
- ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", sizeof("\n")); | ||
+ ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", 1); | ||
if (ret <= 0) | ||
return (ret < 0) ? ret : -RIG_EPROTO; | ||
|
||
@@ -205,7 +205,7 @@ chan_t chan_list[CHANLSTSIZ]; /*!< Chann | ||
ret = 0; | ||
rs->preamp[ret] = RIG_DBLST_END; | ||
- ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", sizeof("\n")); | ||
+ ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", 1); | ||
if (ret <= 0) | ||
return (ret < 0) ? ret : -RIG_EPROTO; | ||
@@ -218,37 +218,37 @@ chan_t chan_list[CHANLSTSIZ]; /*!< Chann | ||
ret = 0; | ||
rs->attenuator[ret] = RIG_DBLST_END; | ||
- ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", sizeof("\n")); | ||
+ ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", 1); | ||
if (ret <= 0) | ||
return (ret < 0) ? ret : -RIG_EPROTO; | ||
rs->has_get_func = strtol(buf, NULL, 0); | ||
- ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", sizeof("\n")); | ||
+ ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", 1); | ||
if (ret <= 0) | ||
return (ret < 0) ? ret : -RIG_EPROTO; | ||
rs->has_set_func = strtol(buf, NULL, 0); | ||
- ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", sizeof("\n")); | ||
+ ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", 1); | ||
if (ret <= 0) | ||
return (ret < 0) ? ret : -RIG_EPROTO; | ||
rs->has_get_level = strtol(buf, NULL, 0); | ||
- ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", sizeof("\n")); | ||
+ ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", 1); | ||
if (ret <= 0) | ||
return (ret < 0) ? ret : -RIG_EPROTO; | ||
rs->has_set_level = strtol(buf, NULL, 0); | ||
- ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", sizeof("\n")); | ||
+ ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", 1); | ||
if (ret <= 0) | ||
return (ret < 0) ? ret : -RIG_EPROTO; | ||
rs->has_get_parm = strtol(buf, NULL, 0); | ||
- ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", sizeof("\n")); | ||
+ ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", 1); | ||
if (ret <= 0) | ||
return (ret < 0) ? ret : -RIG_EPROTO; | ||
@@ -354,7 +354,7 @@ static int netrigctl_get_mode(RIG *rig, | ||
if (ret > 0 && buf[ret-1]=='\n') buf[ret-1] = '\0'; /* chomp */ | ||
*mode = rig_parse_mode(buf); | ||
|
||
- ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", sizeof("\n")); | ||
+ ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", 1); | ||
if (ret <= 0) | ||
return (ret < 0) ? ret : -RIG_EPROTO; | ||
|
||
@@ -761,7 +761,7 @@ static int netrigctl_get_split_mode(RIG | ||
if (ret > 0 && buf[ret-1]=='\n') buf[ret-1] = '\0'; /* chomp */ | ||
*tx_mode = rig_parse_mode(buf); | ||
|
||
- ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", sizeof("\n")); | ||
+ ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", 1); | ||
if (ret <= 0) | ||
return (ret < 0) ? ret : -RIG_EPROTO; | ||
|
||
@@ -804,7 +804,7 @@ static int netrigctl_get_split_vfo(RIG * | ||
|
||
*split = atoi(buf); | ||
|
||
- ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", sizeof("\n")); | ||
+ ret = read_string(&rig->state.rigport, buf, BUF_MAX, "\n", 1); | ||
if (ret <= 0) | ||
return (ret < 0) ? ret : -RIG_EPROTO; | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,29 @@ | ||
--- src/network.c.orig 2016-12-31 20:01:25 UTC | ||
+++ src/network.c | ||
@@ -48,6 +48,7 @@ | ||
|
||
#ifdef HAVE_NETINET_IN_H | ||
#include <netinet/in.h> | ||
+#include <netinet/tcp.h> | ||
#endif | ||
#if HAVE_NETDB_H | ||
#include <netdb.h> | ||
@@ -117,6 +118,7 @@ int network_open(hamlib_port_t *rp, int | ||
{ | ||
int fd; /* File descriptor for the port */ | ||
int status; | ||
+ int flag; | ||
struct addrinfo hints, *res, *saved_res; | ||
char *hoststr = NULL, *portstr = NULL, *bracketstr1, *bracketstr2; | ||
char hostname[FILPATHLEN]; | ||
@@ -202,6 +204,10 @@ int network_open(hamlib_port_t *rp, int | ||
return -RIG_EIO; | ||
} | ||
|
||
+ /* Disable Nagle */ | ||
+ flag = 1; | ||
+ setsockopt(fd, IPPROTO_TCP, TCP_NODELAY, &flag, sizeof(flag)); | ||
+ | ||
if ((status = connect(fd, res->ai_addr, res->ai_addrlen)) == 0) | ||
{ | ||
break; |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,3 @@ | ||
TIMESTAMP = 1489825304 | ||
SHA256 (calibre-2.82.0.tar.xz) = 137995abe467fcb951c1d42583305ebec7b8ca403c44895e70f82a2d6156711c | ||
SIZE (calibre-2.82.0.tar.xz) = 38823912 | ||
TIMESTAMP = 1492289630 | ||
SHA256 (calibre-2.83.0.tar.xz) = 96166e8c74047cfbae9289c38ab5e2f661168048e568cd187f908242d98426ab | ||
SIZE (calibre-2.83.0.tar.xz) = 38875672 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,10 @@ | ||
--- gcc/system.h.orig 2014-01-02 22:23:26 UTC | ||
+++ gcc/system.h | ||
@@ -203,6 +203,7 @@ extern int errno; | ||
|
||
#ifdef __cplusplus | ||
# include <cstring> | ||
+# include <new> | ||
#endif | ||
|
||
/* Some of glibc's string inlines cause warnings. Plus we'd rather |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,3 @@ | ||
TIMESTAMP = 1488992499 | ||
SHA256 (meson-0.39.0.tar.gz) = e582b040038d6ae7c44e64eda05bc24e0a9328629a82c3e4c2bfb983eade7592 | ||
SIZE (meson-0.39.0.tar.gz) = 557134 | ||
TIMESTAMP = 1492266393 | ||
SHA256 (meson-0.39.1.tar.gz) = 44885ccfef94d3d4afb1053fa6673ed130d3093fc9e9f6624d08161d8a385220 | ||
SIZE (meson-0.39.1.tar.gz) = 558914 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,3 @@ | ||
TIMESTAMP = 1486361589 | ||
SHA256 (Params-ValidationCompiler-0.23.tar.gz) = e357b63e28950519f227a5b45e4ac1c487cbc6c1bb67c09a8d3698ee9f289230 | ||
SIZE (Params-ValidationCompiler-0.23.tar.gz) = 43078 | ||
TIMESTAMP = 1492335035 | ||
SHA256 (Params-ValidationCompiler-0.24.tar.gz) = a8963747bae618c2b96ec1918ef2b6ea7dd7ff3dbcebc9de6124b2771a4f4287 | ||
SIZE (Params-ValidationCompiler-0.24.tar.gz) = 43439 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -2,18 +2,29 @@ | |
# $FreeBSD$ | ||
|
||
PORTNAME= PHP_Timer | ||
PORTVERSION= 1.0.4 | ||
PORTVERSION= 1.0.9 | ||
CATEGORIES= devel pear | ||
MASTER_SITES= http://pear.phpunit.de/get/ | ||
PKGNAMEPREFIX= pear- | ||
|
||
MAINTAINER= [email protected] | ||
COMMENT= Utility class for timing | ||
|
||
BUILD_DEPENDS= ${PEARDIR}/.channels/pear.phpunit.de.reg:devel/pear-channel-phpunit | ||
RUN_DEPENDS= ${PEARDIR}/.channels/pear.phpunit.de.reg:devel/pear-channel-phpunit | ||
LICENSE= BSD3CLAUSE | ||
LICENSE_FILE= ${WRKSRC}/LICENSE | ||
|
||
USES= pear | ||
PEAR_CHANNEL= phpunit | ||
USE_GITHUB= yes | ||
GH_ACCOUNT= sebastianbergmann | ||
GH_PROJECT= php-timer | ||
|
||
NO_BUILD= yes | ||
|
||
PHP_DIR= share/PHP | ||
|
||
PLIST_FILES= ${PHP_DIR}/${PORTNAME}/Timer.php | ||
|
||
do-install: | ||
${MKDIR} ${STAGEDIR}${PREFIX}/${PHP_DIR}/${PORTNAME} | ||
${INSTALL_SCRIPT} ${WRKSRC}/src/Timer.php \ | ||
${STAGEDIR}${PREFIX}/${PHP_DIR}/${PORTNAME} | ||
|
||
.include <bsd.port.mk> |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
SHA256 (PEAR/PHP_Timer-1.0.4.tgz) = f51965eea8ec722843f0a10cd4b9c35aaecf0a816ac80929dbab87c8a6d8692b | ||
SIZE (PEAR/PHP_Timer-1.0.4.tgz) = 3694 | ||
TIMESTAMP = 1492020404 | ||
SHA256 (sebastianbergmann-php-timer-1.0.9_GH0.tar.gz) = db90226fe9c5e3d72f49780d6df430b4f305b55639544fdfb9b22927d581670c | ||
SIZE (sebastianbergmann-php-timer-1.0.9_GH0.tar.gz) = 3740 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,3 @@ | ||
TIMESTAMP = 1485141324 | ||
SHA256 (astroid-1.4.9.tar.gz) = a483e7891ce3a06dadfc6cb9095b0938aca58940d43576d72e4502b480c085d7 | ||
SIZE (astroid-1.4.9.tar.gz) = 189315 | ||
TIMESTAMP = 1492309285 | ||
SHA256 (astroid-1.5.1.tar.gz) = b1d87cbb3dbcca64f8fb8252d2a6650c3bf7b1fc6516831c1b63462d965f2af7 | ||
SIZE (astroid-1.5.1.tar.gz) = 239345 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
SHA256 (tables-3.2.2.tar.gz) = 3564b351a71ec1737b503b001eb7ceae1f65d5d6e3ffe1ea75aafba10f37fa84 | ||
SIZE (tables-3.2.2.tar.gz) = 7008045 | ||
TIMESTAMP = 1492270029 | ||
SHA256 (tables-3.4.1.tar.gz) = 1587337593133b169d73bc68729b2cb736a3494f93a54188b8cc26f52cd51c67 | ||
SIZE (tables-3.4.1.tar.gz) = 7592051 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,13 +1,13 @@ | ||
--- setup.py.orig 2015-09-22 03:02:05 UTC | ||
--- setup.py.orig 2017-04-12 12:02:34 UTC | ||
+++ setup.py | ||
@@ -127,8 +127,8 @@ VERSION = open('VERSION').read().strip() | ||
@@ -115,8 +115,8 @@ with open('VERSION') as fd: | ||
debug = '--debug' in sys.argv | ||
|
||
# Global variables | ||
-lib_dirs = [] | ||
-inc_dirs = ['c-blosc/hdf5'] | ||
+lib_dirs = ['/usr/local/lib'] | ||
+inc_dirs = ['c-blosc/hdf5','/usr/local/include'] | ||
-inc_dirs = [os.path.join('hdf5-blosc', 'src')] | ||
+lib_dirs = ['%%LOCALBASE%%/lib'] | ||
+inc_dirs = [os.path.join('hdf5-blosc', 'src'),'%%LOCALBASE%%/include'] | ||
optional_libs = [] | ||
data_files = [] # list of data files to add to packages (mainly for DLL's) | ||
|
Oops, something went wrong.