forked from opnsense/ports
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Taken from: FreeBSD
- Loading branch information
Showing
401 changed files
with
854 additions
and
1,211 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,31 @@ | ||
# $FreeBSD$ | ||
|
||
PORTNAME= multimon-ng | ||
PORTVERSION= 1.1.0 | ||
CATEGORIES= comms hamradio | ||
|
||
MAINTAINER= [email protected] | ||
COMMENT= Digital transmission decoder | ||
|
||
LICENSE= GPLv2 | ||
LICENSE_FILE= ${WRKSRC}/COPYING | ||
|
||
USE_GITHUB= yes | ||
GH_ACCOUNT= EliasOenal | ||
|
||
USES= cmake | ||
|
||
OPTIONS_DEFINE= PULSEAUDIO X11 | ||
|
||
PULSEAUDIO_LIB_DEPENDS= libpulse.so:audio/pulseaudio | ||
PULSEAUDIO_CMAKE_BOOL= PULSE_AUDIO_SUPPORT | ||
|
||
X11_USE= XORG=ice,sm,x11,xext | ||
X11_CMAKE_BOOL= X11_SUPPORT | ||
|
||
PLIST_FILES= bin/multimon-ng | ||
|
||
do-install: | ||
${INSTALL_PROGRAM} ${WRKSRC}/multimon-ng ${STAGEDIR}${PREFIX}/bin | ||
|
||
.include <bsd.port.mk> |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,3 @@ | ||
TIMESTAMP = 1489583557 | ||
SHA256 (EliasOenal-multimon-ng-1.1.0_GH0.tar.gz) = 378209bce0111ec496a8bf1878d43b8d42d67921958c8fbef4aedde2ea416c43 | ||
SIZE (EliasOenal-multimon-ng-1.1.0_GH0.tar.gz) = 2420682 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,12 @@ | ||
--- CMakeLists.txt.orig 2015-11-09 12:57:23 UTC | ||
+++ CMakeLists.txt | ||
@@ -48,7 +48,8 @@ endif( X11_SUPPORT ) | ||
|
||
if( PULSE_AUDIO_SUPPORT ) | ||
include_directories( ${PULSEAUDIO_INCLUDE_DIR} ) | ||
- link_libraries( ${PULSEAUDIO_LIBRARY} "-lpulse-simple" ) | ||
+ find_library( PULSE_SIMPLE NAMES pulse-simple REQUIRED ) | ||
+ link_libraries( ${PULSEAUDIO_LIBRARY} ${PULSE_SIMPLE} ) | ||
add_definitions( "-DPULSE_AUDIO" ) | ||
else( PULSE_AUDIO_SUPPORT ) | ||
add_definitions( "-DDUMMY_AUDIO" ) |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,18 @@ | ||
multimon-ng a fork of multimon. | ||
It decodes the following digital transmission modes: | ||
|
||
- POCSAG512 POCSAG1200 POCSAG2400 | ||
- FLEX | ||
- EAS | ||
- UFSK1200 CLIPFSK AFSK1200 AFSK2400 AFSK2400_2 AFSK2400_3 | ||
- HAPN4800 | ||
- FSK9600 | ||
- DTMF | ||
- ZVEI1 ZVEI2 ZVEI3 DZVEI PZVEI | ||
- EEA EIA CCIR | ||
- MORSE CW | ||
|
||
As an example it can be used with rtl_sdr to decode radio amateurs packets: | ||
rtl_fm -f 144.390M -s 22050 | multimon-ng -v 10 -t raw -A - | ||
|
||
WWW: https://github.com/EliasOenal/multimon-ng/ |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,20 +1,20 @@ | ||
# $FreeBSD$ | ||
|
||
PORTNAME= pg_rman | ||
PORTVERSION= 1.2.3 | ||
PORTREVISION= 2 | ||
PORTVERSION= 1.3.3 | ||
CATEGORIES= databases | ||
MASTER_SITES= http://pg-rman.googlecode.com/files/ | ||
|
||
MAINTAINER= [email protected] | ||
COMMENT= Online backup and restore tool for PostgreSQL | ||
|
||
BROKEN= Unfetchable (google code has gone away) | ||
DEPRECATED= Unfetchable for more than six months (google code has gone away) | ||
EXPIRATION_DATE= 2017-04-30 | ||
LICENSE= BSD3CLAUSE | ||
|
||
USES= gmake pgsql:9.2 | ||
USES= gettext-runtime gmake pgsql | ||
USE_GITHUB= yes | ||
PG_TAG_VERSION= ${PGSQL_DEFAULT:S/./_/} | ||
GH_TUPLE= ossc-db:pg_rman:REL${PG_TAG_VERSION}_STABLE | ||
WANT_PGSQL= client server | ||
WANT_PGSQL_VER= 91+ | ||
MAKE_ARGS= USE_PGXS=1 | ||
PLIST_FILES= bin/pg_rman | ||
|
||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,11 @@ | ||
SHA256 (pg_rman-1.2.3.tar.gz) = ea1a4cd44bef716bc3c3f5a7d592f730730b666873a84f5bdee814b586b809bb | ||
SIZE (pg_rman-1.2.3.tar.gz) = 97390 | ||
TIMESTAMP = 1489635538 | ||
SHA256 (ossc-db-pg_rman-1.3.3-REL9_2_STABLE_GH0.tar.gz) = 5f93549370fd6857ebf137019ff04ac9c689d81b47dc5454ffc4c7d1b0d6d5e6 | ||
SIZE (ossc-db-pg_rman-1.3.3-REL9_2_STABLE_GH0.tar.gz) = 111789 | ||
SHA256 (ossc-db-pg_rman-1.3.3-REL9_3_STABLE_GH0.tar.gz) = d4a0801141091b92c06a1511ccdc694846bb67fede5a8dde43ce303374c0bbd2 | ||
SIZE (ossc-db-pg_rman-1.3.3-REL9_3_STABLE_GH0.tar.gz) = 112483 | ||
SHA256 (ossc-db-pg_rman-1.3.3-REL9_4_STABLE_GH0.tar.gz) = c5882f4ed8991e3f725aaa38193db8f5713b79561786cb103e0a6536e04d3f57 | ||
SIZE (ossc-db-pg_rman-1.3.3-REL9_4_STABLE_GH0.tar.gz) = 112320 | ||
SHA256 (ossc-db-pg_rman-1.3.3-REL9_5_STABLE_GH0.tar.gz) = e3c4fa00f5404693e6caa5eedff4d6e61fb62b84c5c403e40b3053df0759d54a | ||
SIZE (ossc-db-pg_rman-1.3.3-REL9_5_STABLE_GH0.tar.gz) = 112373 | ||
SHA256 (ossc-db-pg_rman-1.3.3-REL9_6_STABLE_GH0.tar.gz) = b44bac870ce21f1e928fe8a4c53592ce6cb4cf038216033d0f884ebe8c0b525c | ||
SIZE (ossc-db-pg_rman-1.3.3-REL9_6_STABLE_GH0.tar.gz) = 112113 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Oops, something went wrong.