Skip to content

Commit

Permalink
*/*: sync with upstream
Browse files Browse the repository at this point in the history
Taken from: FreeBSD
  • Loading branch information
fichtner committed Apr 14, 2016
1 parent bd502b6 commit 37baa0b
Show file tree
Hide file tree
Showing 423 changed files with 6,418 additions and 2,886 deletions.
8 changes: 5 additions & 3 deletions archivers/xarchiver/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -2,10 +2,8 @@
# $FreeBSD$

PORTNAME= xarchiver
PORTVERSION= 0.5.4
PORTREVISION= 1
PORTVERSION= 0.5.4.6
CATEGORIES= archivers
MASTER_SITES= SF/${PORTNAME:tl}

MAINTAINER= [email protected]
COMMENT= Desktop-agnostic GTK+2 frontend to various archiving tools
Expand All @@ -17,6 +15,10 @@ RUN_DEPENDS= xdg-open:devel/xdg-utils \
zip:archivers/zip \
zipinfo:archivers/unzip

USE_GITHUB= yes
GH_ACCOUNT= ib
GH_TAGNAME= bb5fce0

USES= desktop-file-utils gmake pkgconfig tar:bzip2
USE_GNOME= glib20 gtk20 intltool
GNU_CONFIGURE= yes
Expand Down
4 changes: 2 additions & 2 deletions archivers/xarchiver/distinfo
Original file line number Diff line number Diff line change
@@ -1,2 +1,2 @@
SHA256 (xarchiver-0.5.4.tar.bz2) = e63fa73979fcc56efe8cca9095fd915d31a1714ce9676246b8626f164e452ef4
SIZE (xarchiver-0.5.4.tar.bz2) = 1003045
SHA256 (ib-xarchiver-0.5.4.6-bb5fce0_GH0.tar.gz) = 5c9ac0ac4a1bc286a8fa015ef9d6f543f09ae23ea9a944f7c2293a840b35133d
SIZE (ib-xarchiver-0.5.4.6-bb5fce0_GH0.tar.gz) = 983215
81 changes: 7 additions & 74 deletions archivers/xarchiver/files/patch-src_tar.c
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
--- src/tar.c.orig 2014-09-28 20:10:38 UTC
--- src/tar.c.orig 2016-03-09 15:25:48 UTC
+++ src/tar.c
@@ -331,7 +331,7 @@ gboolean xa_tar_extract(XArchive *archiv
@@ -330,7 +330,7 @@ gboolean xa_tar_extract(XArchive *archiv
#else
archive->overwrite ? " --overwrite" : " --keep-old-files",
#endif
Expand All @@ -9,7 +9,7 @@
" -C ",archive->extraction_path," ",names->str,NULL);
}
else
@@ -350,7 +350,7 @@ gboolean xa_tar_extract(XArchive *archiv
@@ -349,7 +349,7 @@ gboolean xa_tar_extract(XArchive *archiv
#else
archive->overwrite ? " --overwrite" : " --keep-old-files",
#endif
Expand All @@ -18,7 +18,7 @@
" -C ",archive->extraction_path," ",names->str,NULL);
}
else
@@ -369,7 +369,7 @@ gboolean xa_tar_extract(XArchive *archiv
@@ -368,7 +368,7 @@ gboolean xa_tar_extract(XArchive *archiv
#else
archive->overwrite ? " --overwrite" : " --keep-old-files",
#endif
Expand All @@ -27,14 +27,7 @@
" -C ",archive->extraction_path," ",names->str,NULL);
}
else
@@ -382,18 +382,18 @@ gboolean xa_tar_extract(XArchive *archiv
case XARCHIVETYPE_TAR_LZMA:
if (archive->full_path || multi_extract)
{
- command = g_strconcat (tar, " --use-compress-program=lzma -xvf " , archive->escaped_path,
+ command = g_strconcat (tar, " --use-compress-program='lzma -d' -xvf " , archive->escaped_path,
#ifdef __FreeBSD__
archive->overwrite ? " " : " -k",
@@ -387,7 +387,7 @@ gboolean xa_tar_extract(XArchive *archiv
#else
archive->overwrite ? " --overwrite" : " --keep-old-files",
#endif
Expand All @@ -43,20 +36,7 @@
" -C ",archive->extraction_path," ",names->str,NULL);
}
else
{
- result = xa_extract_tar_without_directories ( "tar --use-compress-program=lzma -xvf ",archive,names->str);
+ result = xa_extract_tar_without_directories ( "tar --use-compress-program='lzma -d' -xvf ",archive,names->str);
command = NULL;
}
break;
@@ -401,18 +401,18 @@ gboolean xa_tar_extract(XArchive *archiv
case XARCHIVETYPE_TAR_LZOP:
if (archive->full_path || multi_extract)
{
- command = g_strconcat (tar, " --use-compress-program=lzop -xvf " , archive->escaped_path,
+ command = g_strconcat (tar, " --use-compress-program='lzop -d' -xvf " , archive->escaped_path,
#ifdef __FreeBSD__
archive->overwrite ? " " : " -k",
@@ -406,7 +406,7 @@ gboolean xa_tar_extract(XArchive *archiv
#else
archive->overwrite ? " --overwrite" : " --keep-old-files",
#endif
Expand All @@ -65,20 +45,7 @@
" -C ",archive->extraction_path," ",names->str,NULL);
}
else
{
- result = xa_extract_tar_without_directories ( "tar --use-compress-program=lzop -xvf ",archive,names->str);
+ result = xa_extract_tar_without_directories ( "tar --use-compress-program='lzop -d' -xvf ",archive,names->str);
command = NULL;
}
break;
@@ -420,18 +420,18 @@ gboolean xa_tar_extract(XArchive *archiv
case XARCHIVETYPE_TAR_XZ:
if (archive->full_path || multi_extract)
{
- command = g_strconcat (tar, " --use-compress-program=xz -xvf " , archive->escaped_path,
+ command = g_strconcat (tar, " --use-compress-program='xz -d' -xvf " , archive->escaped_path,
#ifdef __FreeBSD__
archive->overwrite ? " " : " -k",
@@ -425,7 +425,7 @@ gboolean xa_tar_extract(XArchive *archiv
#else
archive->overwrite ? " --overwrite" : " --keep-old-files",
#endif
Expand All @@ -87,37 +54,3 @@
" -C ",archive->extraction_path," ",names->str,NULL);
}
else
{
- result = xa_extract_tar_without_directories ( "tar --use-compress-program=xz -xvf ",archive,names->str);
+ result = xa_extract_tar_without_directories ( "tar --use-compress-program='xz -d' -xvf ",archive,names->str);
command = NULL;
}
break;
@@ -567,7 +567,7 @@ gboolean xa_extract_tar_without_director
archive->overwrite ? " --overwrite" : " --keep-old-files",
" --no-wildcards ",
#endif
- archive->tar_touch ? " --touch" : "",
+ archive->tar_touch ? " -m" : "",
"-C ",archive->tmp," ",files_to_extract,NULL);
list = g_slist_append(list,command);
if (strstr(files_to_extract,"/") || strcmp(archive->tmp,archive->extraction_path) != 0)
@@ -618,15 +618,15 @@ void xa_tar_test(XArchive *archive)
break;

case XARCHIVETYPE_TAR_LZMA:
- command = g_strconcat (tar, " --use-compress-program=lzma -tvf ",archive->path, NULL);
+ command = g_strconcat (tar, " --use-compress-program='lzma -d' -tvf ",archive->path, NULL);
break;

case XARCHIVETYPE_TAR_LZOP:
- command = g_strconcat (tar, " --use-compress-program=lzop -tvf ",archive->path, NULL);
+ command = g_strconcat (tar, " --use-compress-program='lzop -d' -tvf ",archive->path, NULL);
break;

case XARCHIVETYPE_TAR_XZ:
- command = g_strconcat (tar, " --use-compress-program=xz -tvf ",archive->path, NULL);
+ command = g_strconcat (tar, " --use-compress-program='xz -d' -tvf ",archive->path, NULL);
break;

case XARCHIVETYPE_LZMA:
2 changes: 1 addition & 1 deletion archivers/xarchiver/pkg-descr
Original file line number Diff line number Diff line change
Expand Up @@ -2,4 +2,4 @@ Xarchiver is a Desktop Environment independent archiver frontend.
All common archive types are supported. RPM and ISO are handled without
rpm or isodump executables.

WWW: http://xarchiver.sourceforge.net/
WWW: https://github.com/ib/xarchiver
85 changes: 49 additions & 36 deletions archivers/xarchiver/pkg-plist
Original file line number Diff line number Diff line change
@@ -1,72 +1,85 @@
bin/xarchiver
libexec/thunar-archive-plugin/xarchiver.tap
share/applications/xarchiver.desktop
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/COPYING
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
%%PORTDOCS%%%%DOCSDIR%%/NEWS
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/TODO
%%PORTDOCS%%%%DOCSDIR%%/html/ch01.html
%%PORTDOCS%%%%DOCSDIR%%/html/ch01s02.html
%%PORTDOCS%%%%DOCSDIR%%/html/ch01s03.html
%%PORTDOCS%%%%DOCSDIR%%/html/ch01s04.html
%%PORTDOCS%%%%DOCSDIR%%/html/ch02.html
%%PORTDOCS%%%%DOCSDIR%%/html/ch02s02.html
%%PORTDOCS%%%%DOCSDIR%%/html/ch02s03.html
%%PORTDOCS%%%%DOCSDIR%%/html/ch03.html
%%PORTDOCS%%%%DOCSDIR%%/html/ch03s02.html
%%PORTDOCS%%%%DOCSDIR%%/html/ch03s03.html
%%PORTDOCS%%%%DOCSDIR%%/html/ch03s04.html
%%PORTDOCS%%%%DOCSDIR%%/html/ch03s05.html
%%PORTDOCS%%%%DOCSDIR%%/html/ch03s06.html
%%PORTDOCS%%%%DOCSDIR%%/html/ch03s07.html
%%PORTDOCS%%%%DOCSDIR%%/html/ch03s08.html
%%PORTDOCS%%%%DOCSDIR%%/html/ch03s09.html
%%PORTDOCS%%%%DOCSDIR%%/html/ch04.html
%%PORTDOCS%%%%DOCSDIR%%/html/ch04s02.html
%%PORTDOCS%%%%DOCSDIR%%/html/ch04s03.html
%%PORTDOCS%%%%DOCSDIR%%/html/ch04s04.html
%%PORTDOCS%%%%DOCSDIR%%/html/ch04s05.html
%%PORTDOCS%%%%DOCSDIR%%/html/ch04s06.html
%%PORTDOCS%%%%DOCSDIR%%/html/images/add_dialog.png
%%PORTDOCS%%%%DOCSDIR%%/html/images/archive_comment_dialog.png
%%PORTDOCS%%%%DOCSDIR%%/html/images/archive_properties.png
%%PORTDOCS%%%%DOCSDIR%%/html/images/extract_dialog.png
%%PORTDOCS%%%%DOCSDIR%%/html/images/multi_extract_dialog.png
%%PORTDOCS%%%%DOCSDIR%%/html/images/new_dialog.png
%%PORTDOCS%%%%DOCSDIR%%/html/images/password_dialog.png
%%PORTDOCS%%%%DOCSDIR%%/html/images/pref_dialog.png
%%PORTDOCS%%%%DOCSDIR%%/html/index.html
%%PORTDOCS%%%%DOCSDIR%%/html/xarchiver.css
%%PORTDOCS%%%%DOCSDIR%%/ch01.html
%%PORTDOCS%%%%DOCSDIR%%/ch01s01.html
%%PORTDOCS%%%%DOCSDIR%%/ch01s02.html
%%PORTDOCS%%%%DOCSDIR%%/ch01s03.html
%%PORTDOCS%%%%DOCSDIR%%/ch02.html
%%PORTDOCS%%%%DOCSDIR%%/ch02s01.html
%%PORTDOCS%%%%DOCSDIR%%/ch02s02.html
%%PORTDOCS%%%%DOCSDIR%%/ch03.html
%%PORTDOCS%%%%DOCSDIR%%/ch03s01.html
%%PORTDOCS%%%%DOCSDIR%%/ch03s02.html
%%PORTDOCS%%%%DOCSDIR%%/ch03s03.html
%%PORTDOCS%%%%DOCSDIR%%/ch03s04.html
%%PORTDOCS%%%%DOCSDIR%%/ch04.html
%%PORTDOCS%%%%DOCSDIR%%/ch04s01.html
%%PORTDOCS%%%%DOCSDIR%%/ch04s02.html
%%PORTDOCS%%%%DOCSDIR%%/ch04s03.html
%%PORTDOCS%%%%DOCSDIR%%/ch04s04.html
%%PORTDOCS%%%%DOCSDIR%%/ch04s05.html
%%PORTDOCS%%%%DOCSDIR%%/ch04s06.html
%%PORTDOCS%%%%DOCSDIR%%/images/add_dialog.png
%%PORTDOCS%%%%DOCSDIR%%/images/archive_comment_dialog.png
%%PORTDOCS%%%%DOCSDIR%%/images/archive_properties.png
%%PORTDOCS%%%%DOCSDIR%%/images/extract_dialog.png
%%PORTDOCS%%%%DOCSDIR%%/images/multi_extract_dialog.png
%%PORTDOCS%%%%DOCSDIR%%/images/new_dialog.png
%%PORTDOCS%%%%DOCSDIR%%/images/password_dialog.png
%%PORTDOCS%%%%DOCSDIR%%/images/pref_dialog.png
%%PORTDOCS%%%%DOCSDIR%%/index.html
%%PORTDOCS%%%%DOCSDIR%%/xarchiver.css
share/icons/hicolor/16x16/apps/xarchiver.png
share/icons/hicolor/24x24/apps/xarchiver.png
share/icons/hicolor/48x48/apps/xarchiver.png
share/icons/hicolor/scalable/apps/xarchiver.svg
%%NLS%%share/locale/ar/LC_MESSAGES/xarchiver.mo
%%NLS%%share/locale/ast/LC_MESSAGES/xarchiver.mo
%%NLS%%share/locale/bg/LC_MESSAGES/xarchiver.mo
%%NLS%%share/locale/ca/LC_MESSAGES/xarchiver.mo
%%NLS%%share/locale/cs/LC_MESSAGES/xarchiver.mo
%%NLS%%share/locale/da/LC_MESSAGES/xarchiver.mo
%%NLS%%share/locale/de/LC_MESSAGES/xarchiver.mo
%%NLS%%share/locale/dz/LC_MESSAGES/xarchiver.mo
%%NLS%%share/locale/el/LC_MESSAGES/xarchiver.mo
%%NLS%%share/locale/en_GB/LC_MESSAGES/xarchiver.mo
%%NLS%%share/locale/es/LC_MESSAGES/xarchiver.mo
%%NLS%%share/locale/eu/LC_MESSAGES/xarchiver.mo
%%NLS%%share/locale/fi/LC_MESSAGES/xarchiver.mo
%%NLS%%share/locale/fr/LC_MESSAGES/xarchiver.mo
%%NLS%%share/locale/gl/LC_MESSAGES/xarchiver.mo
%%NLS%%share/locale/he/LC_MESSAGES/xarchiver.mo
%%NLS%%share/locale/hr/LC_MESSAGES/xarchiver.mo
%%NLS%%share/locale/hu/LC_MESSAGES/xarchiver.mo
%%NLS%%share/locale/id/LC_MESSAGES/xarchiver.mo
%%NLS%%share/locale/it/LC_MESSAGES/xarchiver.mo
%%NLS%%share/locale/ja/LC_MESSAGES/xarchiver.mo
%%NLS%%share/locale/nb_NO/LC_MESSAGES/xarchiver.mo
%%NLS%%share/locale/kk/LC_MESSAGES/xarchiver.mo
%%NLS%%share/locale/ku/LC_MESSAGES/xarchiver.mo
%%NLS%%share/locale/lv/LC_MESSAGES/xarchiver.mo
%%NLS%%share/locale/nb/LC_MESSAGES/xarchiver.mo
%%NLS%%share/locale/nl/LC_MESSAGES/xarchiver.mo
%%NLS%%share/locale/pa/LC_MESSAGES/xarchiver.mo
%%NLS%%share/locale/pl/LC_MESSAGES/xarchiver.mo
%%NLS%%share/locale/pt_BR/LC_MESSAGES/xarchiver.mo
%%NLS%%share/locale/pt_PT/LC_MESSAGES/xarchiver.mo
%%NLS%%share/locale/ro/LC_MESSAGES/xarchiver.mo
%%NLS%%share/locale/ru/LC_MESSAGES/xarchiver.mo
%%NLS%%share/locale/si/LC_MESSAGES/xarchiver.mo
%%NLS%%share/locale/sk/LC_MESSAGES/xarchiver.mo
%%NLS%%share/locale/sq/LC_MESSAGES/xarchiver.mo
%%NLS%%share/locale/sv/LC_MESSAGES/xarchiver.mo
%%NLS%%share/locale/te/LC_MESSAGES/xarchiver.mo
%%NLS%%share/locale/tr/LC_MESSAGES/xarchiver.mo
%%NLS%%share/locale/ug/LC_MESSAGES/xarchiver.mo
%%NLS%%share/locale/uk/LC_MESSAGES/xarchiver.mo
%%NLS%%share/locale/ur/LC_MESSAGES/xarchiver.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/xarchiver.mo
%%NLS%%share/locale/zh_TW/LC_MESSAGES/xarchiver.mo
share/pixmaps/xarchiver/xarchiver-add.png
share/pixmaps/xarchiver/xarchiver-extract.png
share/pixmaps/xarchiver/xarchiver-html.png
17 changes: 8 additions & 9 deletions astro/libkgeomap/Makefile
Original file line number Diff line number Diff line change
@@ -1,23 +1,22 @@
# $FreeBSD$

PORTNAME= libkgeomap
PORTVERSION= ${DIGIKAM_VER}
PORTREVISION= 1
PORTVERSION= ${KDE4_APPLICATIONS_VERSION}
CATEGORIES= astro kde
MASTER_SITES= KDE/${KDE4_APPLICATIONS_BRANCH}/applications/${PORTVERSION}/src
DIST_SUBDIR= KDE/${PORTVERSION}

MAINTAINER= [email protected]
COMMENT= KDE4 library for browsing photos on a map

.include "${.CURDIR}/../../graphics/digikam-kde4/Makefile.common"
LICENSE= GPLv2+ LGPL20+
LICENSE_COMB= multi

BUILD_DEPENDS= ${LOCALBASE}/include/boost/graph/buffer_concepts.hpp:devel/boost-libs

# libkexiv2 is used only for demo application
USE_KDE4+= marble
USE_KDE4= kdelibs kdeprefix automoc4 marble
USES= cmake:outsource pathfix tar:xz
USE_LDCONFIG= yes

post-patch:
${REINPLACE_CMD} -e '/pkgconfig/s|$${LIB_INSTALL_DIR}|libdata|' \
${WRKSRC}/CMakeLists.txt
USE_QT4= network phonon xml moc_build qmake_build rcc_build uic_build

.include <bsd.port.mk>
2 changes: 2 additions & 0 deletions astro/libkgeomap/distinfo
Original file line number Diff line number Diff line change
@@ -0,0 +1,2 @@
SHA256 (KDE/15.04.3/libkgeomap-15.04.3.tar.xz) = b305977b27ebb1da798facf35488beef848f750e70a743ee8a8fab6edb0e1cc0
SIZE (KDE/15.04.3/libkgeomap-15.04.3.tar.xz) = 124160
4 changes: 2 additions & 2 deletions astro/libkgeomap/pkg-plist
Original file line number Diff line number Diff line change
Expand Up @@ -13,8 +13,8 @@ include/kde4/libkgeomap/track_reader.h
include/kde4/libkgeomap/tracks.h
include/kde4/libkgeomap/version.h
lib/libkgeomap.so
lib/libkgeomap.so.1
lib/libkgeomap.so.1.0.0
lib/libkgeomap.so.2
lib/libkgeomap.so.2.1.0
libdata/pkgconfig/libkgeomap.pc
share/apps/cmake/modules/FindKGeoMap.cmake
share/apps/libkgeomap/backend-googlemaps-js.js
Expand Down
14 changes: 4 additions & 10 deletions audio/oss/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -15,11 +15,12 @@ LICENSE= BSD2CLAUSE
BUILD_DEPENDS= gawk:lang/gawk

USES= tar:bzip2 kmod pkgconfig
HAS_CONFIGURE= yes
CONFIGURE_OUTSOURCE= yes
CONFIGURE_ENV= HOSTCC="${CC}"
ALL_TARGET= all install
USE_GNOME= gtk20
USE_RC_SUBR= oss
WRKSRC= ${WRKDIR}/build
PATCH_WRKSRC= ${WRKDIR}/${DISTNAME}
SUB_FILES= pkg-install pkg-deinstall
ONLY_FOR_ARCHS= amd64 i386

Expand All @@ -31,15 +32,13 @@ OSS_CONF_FILES= oss_audigyls oss_audioloop oss_cs461x oss_emu10k1x \
oss_sbpci oss_sbxfi oss_trident oss_usb oss_userdev \
oss_ymf7xx osscore

PROTO_DIR= ${WRKSRC}/prototype
PROTO_DIR= ${INSTALL_WRKSRC}/prototype
PROTO_ETCDIR= ${PROTO_DIR}/etc
PROTO_BINDIR= ${PROTO_DIR}/usr/bin
PROTO_SBINDIR= ${PROTO_DIR}/usr/sbin
PROTO_MANDIR= ${PROTO_DIR}/usr/share/man
PROTO_OSSLIBDIR=${PROTO_DIR}${PREFIX}/lib/oss

CONFIGURE_ENV= CC="${CC}" HOSTCC="${CC}"

OPTIONS_DEFINE= VORBIS
OPTIONS_DEFAULT=VORBIS

Expand All @@ -59,11 +58,6 @@ post-patch:
-name make.local -or -name soundoff -or -name soundon | \
${XARGS} ${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g'

do-configure:
${MKDIR} ${WRKSRC}
(cd ${WRKSRC} && \
${SETENV} ${CONFIGURE_ENV} ${PATCH_WRKSRC}/configure)

do-install:
${INSTALL_PROGRAM} ${PROTO_BINDIR}/* ${STAGEDIR}${PREFIX}/bin/
# @${ECHO_CMD} "OSSLIBDIR=${PREFIX}/lib/oss" > ${PROTO_ETCDIR}/oss.conf
Expand Down
4 changes: 1 addition & 3 deletions audio/praat/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -4,7 +4,7 @@
PORTNAME= praat
PORTVERSION= 5.4.08
DISTVERSIONPREFIX= v
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= audio science

MAINTAINER= [email protected]
Expand All @@ -19,8 +19,6 @@ USE_GNOME= gtk20
MAKEFILE= makefile
PLIST_FILES= bin/praat man/man1/praat.1.gz

LIB_DEPENDS+= libasound.so:audio/alsa-lib

.include <bsd.port.pre.mk>

.if ${OSVERSION} < 1000000
Expand Down
Loading

0 comments on commit 37baa0b

Please sign in to comment.