Skip to content

Commit

Permalink
*/*: sync with upstream
Browse files Browse the repository at this point in the history
Taken from: FreeBSD
  • Loading branch information
fichtner committed Nov 14, 2016
1 parent f3230d0 commit 471d90c
Show file tree
Hide file tree
Showing 309 changed files with 13,187 additions and 11,327 deletions.
5 changes: 3 additions & 2 deletions archivers/innoextract/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -12,8 +12,6 @@ COMMENT= Program to extract Inno Setup files
LICENSE= ZLIB
LICENSE_FILE= ${WRKSRC}/LICENSE

BROKEN_powerpc64= Does not build

LIB_DEPENDS= libboost_iostreams.so:devel/boost-libs \
libboost_filesystem.so:devel/boost-libs \
libboost_system.so:devel/boost-libs \
Expand All @@ -25,4 +23,7 @@ CMAKE_ARGS= -DCMAKE_INSTALL_MANDIR=man
PLIST_FILES= bin/innoextract \
man/man1/innoextract.1.gz

BROKEN_powerpc64= Does not build
BROKEN_sparc64= Does not build: undefined reference to std::ctype<char>::_M_widen_init()

.include <bsd.port.mk>
2 changes: 2 additions & 0 deletions archivers/libcabinet/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -12,6 +12,8 @@ COMMENT= Portable library and utility to use Microsoft cabinet files (.cab)

USE_LDCONFIG= yes

BROKEN_aarch64= Fails to link: linker command failed with exit code 1

USES= uidfix
SRCFILE= ${WRKSRC}/listcab.cpp
PROGFILE= ${SRCFILE:S/.cpp$//}
Expand Down
2 changes: 2 additions & 0 deletions archivers/tclmkziplib/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -11,6 +11,8 @@ DISTNAME= mkZiplib${PORTVERSION:S/.//}
MAINTAINER= [email protected]
COMMENT= GZIP and ZIP support for TCL; dynamically loadable

BROKEN_aarch64= Fails to build: error: operand of type va_list where arithmetic or pointer type is required

USES+= tcl zip

WRKSRC= ${WRKDIR}/mkZiplib${PORTVERSION}
Expand Down
2 changes: 2 additions & 0 deletions astro/cfitsio/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -35,6 +35,8 @@ PORTDOCS= *
SHLIB_MAJOR_VER=5
SHLIB_MINOR_VER=${PORTVERSION:S|0$||}

BROKEN_sparc64= Fails to compile: malloc.h has been replaced by stdlib.h

do-install:
cd ${WRKSRC}/ && ${INSTALL_DATA} drvrsmem.h fitsio.h fitsio2.h longnam.h ${STAGEDIR}${PREFIX}/include/
cd ${WRKSRC}/ && ${INSTALL_DATA} libcfitsio.a ${STAGEDIR}${PREFIX}/lib/
Expand Down
10 changes: 6 additions & 4 deletions audio/festival/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -7,6 +7,7 @@ CATEGORIES= audio accessibility
MASTER_SITES= FESTIVAL
DISTFILES= ${DISTNAME}-release.tar.gz \
speech_tools-${PORTVERSION}-release.tar.gz
DIST_SUBDIR= festival

PATCHFILES= src_modules_diphone_diphone.h.diff?id=b58a836:debian \
src_modules_diphone_di_io.cc.diff?id=b58a836:debian \
Expand All @@ -24,12 +25,15 @@ PATCH_SITES= ftp://ftp.netbsd.org/pub/pkgsrc/current/pkgsrc/audio/festival/patch
MAINTAINER= [email protected]
COMMENT= Multi-lingual speech synthesis system

BROKEN_aarch64= XXX
BROKEN_armv6= Fails to link: cc.mak: No such file or directory
BROKEN_mips64= Fails to link: cc.mak: No such file or directory
BROKEN_powerpc64= Does not build

OPTIONS_DEFINE= NAS ESD
OPTIONS_DEFAULT=NAS ESD
ESD_DESC= ${ESOUND_DESC}

DIST_SUBDIR= festival

CXXFLAGS+= -DFTLIBDIR=${LOCALBASE}/share/festival/lib
CONFIGURE_WRKSRC= ${WRKDIR}/festival
USES= gmake
Expand All @@ -43,8 +47,6 @@ WRKSRC= ${WRKDIR}
SPT_PATCHES= include_ling__class_EST__FeatureFunctionPackage.h \
include_unix_EST__socket__unix.h

BROKEN_powerpc64= Does not build

do-build:
.for d in speech_tools festival
${MAKE_CMD} -C ${WRKDIR}/$d ${MAKE_FLAGS} Makefile ${MAKE_ARGS}
Expand Down
2 changes: 1 addition & 1 deletion audio/festival/pkg-descr
Original file line number Diff line number Diff line change
Expand Up @@ -15,6 +15,6 @@ manual.

If you need the OGI extensions, install ports/audio/festival+OGI instead.

WWW: http://www.cstr.ed.ac.uk/projects/festival/
WWW: http://www.cstr.ed.ac.uk/projects/festival/

Trevor Johnson
1 change: 1 addition & 0 deletions audio/gnuspeechsa/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -13,6 +13,7 @@ LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING

BROKEN_FreeBSD_9= does not build
BROKEN_aarch64= Does not build: the clang compiler does not support -march=native
BROKEN_powerpc64= Does not build

USES= cmake compiler:c++11-lib
Expand Down
2 changes: 2 additions & 0 deletions audio/musescore/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -26,6 +26,8 @@ ALL_TARGET= lrelease manpages all

DATADIR= ${PREFIX}/share/mscore-${PORTVERSION:R}

BROKEN_aarch64= Fails to compile: error: constant expression evaluates to -1

OPTIONS_DEFINE= ALSA JACK PORTAUDIO PULSEAUDIO
OPTIONS_DEFAULT= PORTAUDIO

Expand Down
2 changes: 2 additions & 0 deletions audio/vsound/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -19,6 +19,8 @@ RUN_DEPENDS= sox:audio/sox
USES= alias libtool
GNU_CONFIGURE= yes

BROKEN_aarch64= Fails to build: error: Cannot determine endian-ness of processor

OPTIONS_DEFINE= DOCS

post-install:
Expand Down
3 changes: 3 additions & 0 deletions audio/xmcd/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -22,6 +22,9 @@ PKGMESSAGE= ${WRKDIR}/pkg-message

LIBBINDIR= ${STAGEDIR}${PREFIX}/lib/X11/xmcd/bin-${OPSYS}_${OSREL:R:R}-${ARCH}

BROKEN_aarch64= Fails to compile: many undefined symbols in xorg.cf
BROKEN_armv6= Fails to compile: many undefined symbols in xorg.cf
BROKEN_mips64= Fails to compile: many undefined symbols in xorg.cf
BROKEN_powerpc64= Does not build on powerpc64

pre-patch:
Expand Down
32 changes: 19 additions & 13 deletions cad/astk-serveur/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -2,7 +2,7 @@
# $FreeBSD$

PORTNAME= astk
DISTVERSION= 1.13.5-1
DISTVERSION= 1.13.8-2
CATEGORIES= cad
.if !defined(CLIENT_SEUL)
PKGNAMESUFFIX= -serveur
Expand Down Expand Up @@ -40,15 +40,15 @@ REINPLACE_ARGS= -i ""

EXTRACT_WRKSRC= ${WRKDIR}/aster-${DISTVERSIONPREFIX}${ASTER_DISTVERSION:S/-/./:R}/SRC

NO_ARCH= yes
SUB_FILES= pkg-message
SUB_LIST= inst_dir=${inst_dir} tools_dir=${tools_dir}
PKGMESSAGE= ${WRKDIR}/pkg-message
LINSTDIR= aster/ASTK
inst_dir= ${PREFIX}/${LINSTDIR}
aster_dir= ${LOCALBASE}/aster/${vaster}
S_SCRIPTS= bin/as_run bin/parallel_cp asrun/installation.py \
share/codeaster/asrun/data/mpirun_template \
etc/profile.csh
share/codeaster/asrun/data/mpirun_template
S_PYLIBS= share/codeaster/asrun/examples/alamain.py \
unittest/datafiles/config_serveurs unittest/010_misc.py \
unittest/015_package.py unittest/run_test.py
Expand All @@ -58,13 +58,14 @@ conf_dir= ${WRKSRC}/etc/astkrc

.include <bsd.port.pre.mk>

WRKCONF= ${WRKDIR}/${PORTNAME}-${PORTVERSION:R}/configuration
.if !defined(CLIENT_SEUL)
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:R}/ASTK_SERV
PATCHDIR= ${MASTERDIR}/files
PLIST_SUB= ASTKDIR=${LINSTDIR}/ASTK_SERV SERV="" CLIENT="@comment " \
PLIST_SUB= ASTKDIR=${LINSTDIR}/ASTK_SERV SERV="" CLIENT="@comment "\
vaster=${vaster}
PATCH2RM= bin/as_run bin/parallel_cp etc/asrun etc/profile.csh etc/profile.sh \
asrun/config.py asrun/installation.py asrun/system.py \
PATCH2RM= bin/as_run bin/parallel_cp etc/asrun etc/profile.sh \
asrun/config.py asrun/installation.py asrun/system.py \
asrun/common/sysutils.py asrun/system_command.py
. if exists(${LOCALBASE}/sbin/pbs_server)
WITH_PBS= yes
Expand Down Expand Up @@ -121,6 +122,9 @@ SHIA= zsh
.endif
SHIADEP= ${SHIA}
BASH2RC= asrun/calcul.py share/codeaster/asrun/data/mpirun_template
BASH2RC2= lib/tkselecteur.tcl
BASH2RC3= deprecated_outils.sh extract_info.py deprecated_client.sh \
deprecated_server.sh

.if !defined(WITH_ED)
. if exists(${LOCALBASE}/bin/nedit)
Expand All @@ -132,9 +136,6 @@ RUN_DEPENDS+= ${LOCALBASE}/bin/gvim:editors/vim
. elif exists(${LOCALBASE}/bin/emacs)
WITH_ED= emacs
RUN_DEPENDS+= ${LOCALBASE}/bin/emacs:editors/emacs
. elif exists(${LOCALBASE}/bin/xemacs)
WITH_ED= xemacs
RUN_DEPENDS+= ${LOCALBASE}/bin/xemacs:editors/xemacs
. elif exists(${LOCALBASE}/bin/gedit)
WITH_ED= gedit
RUN_DEPENDS+= ${LOCALBASE}/bin/gedit:editors/gedit
Expand Down Expand Up @@ -197,16 +198,14 @@ do-configure:
-e "s|LOCALBASE|${LOCALBASE}|" \
${WRKSRC}/etc/${sc}
. endfor
. for sh in sh csh
${REINPLACE_CMD} -e "s|?ASTER_ROOT?|${LOCALBASE}/aster|" \
-e 's|?HOME_PYTHON?|${PYTHONBASE}|' \
-e 's|?ASRUN_SITE_PKG?|${PREFIX}/${LINSTDIR}/ASTK_SERV|' \
-e 's|?PYTHON_EXE?|${PYTHON_CMD}|' \
-e 's|?HOME_MED?|${LOCALBASE}|' \
-e 's|?HOME_HDF?|${LOCALBASE}|' \
-e "s|?WISH_EXE?|${WISH}|" \
${WRKSRC}/etc/profile.${sh}
. endfor
-e "s|?WISH_EXE?|${WISH}|" \
${WRKSRC}/etc/profile.sh
. for libs in ${S_PYLIBS}
${REINPLACE_CMD} -e "s|/opt/aster/NEW9|${aster_dir}|" \
-e "s|/opt/aster/NEW10|${aster_dir}|" \
Expand Down Expand Up @@ -262,7 +261,13 @@ do-configure:
${WRKSRC}/lib/tkselecteur.tcl
${REINPLACE_CMD} -e "s|%%unamesm%%|${unamesm}|" \
${WRKSRC}/lib/init.tcl
. for sh in ${BASH2RC2}
${REINPLACE_CMD} -e 's|/bin/bash|${SHELL_INSTALL_ASTER}|' ${WRKSRC}/${sh}
. endfor
.endif
.for sh in ${BASH2RC3}
${REINPLACE_CMD} -e 's|/bin/bash|${SHELL_INSTALL_ASTER}|' ${WRKCONF}/${sh}
.endfor

do-install:
${MKDIR} ${STAGEDIR}${inst_dir}
Expand All @@ -278,6 +283,7 @@ do-install:
(cd ${STAGEDIR}${PREFIX} \
&& ${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py \
-d ${PREFIX} -f aster)
${MV} ${STAGEDIR}${ETCDIR}/profile.sh ${STAGEDIR}${ETCDIR}/profile_astk.sh
. if defined(WITH_MPI)
${ECHO_CMD} "localhost" > ${STAGEDIR}${PREFIX}/aster/aster-mpihosts
. endif
Expand Down
11 changes: 5 additions & 6 deletions cad/astk-serveur/files.client/patch-bin_astk
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- bin/astk.orig 2011-12-20 13:33:00.000000000 +0100
+++ bin/astk 2012-05-08 12:31:09.000000000 +0200
--- bin/astk.orig 2015-08-05 15:37:44 UTC
+++ bin/astk
@@ -17,15 +17,9 @@
# 1 AVENUE DU GENERAL DE GAULLE, 92141 CLAMART CEDEX, FRANCE.
# ==============================================================================
Expand All @@ -9,19 +9,18 @@
- local bin=`dirname $this`
- prefix=`dirname $bin`
-}
-
-set_prefix $0
+prefix=%%inst_dir%%/ASTK_CLIENT

-set_prefix $0
-
-ASTER_ROOT=$prefix
+ASTER_ROOT=?ASTER_ROOT?
ASTER_ETC=$ASTER_ROOT/etc
if [ "$ASTER_ROOT" = "/usr" ]; then
ASTER_ETC=/etc
@@ -43,5 +37,5 @@
@@ -43,4 +37,4 @@ if [ -z "$WISHEXECUTABLE" ]; then
WISHEXECUTABLE=wish
fi

-$WISHEXECUTABLE $ASTER_ROOT/lib/astk/astk.tcl -- $* &
+$WISHEXECUTABLE $prefix/lib/astk.tcl -- $* &

14 changes: 0 additions & 14 deletions cad/astk-serveur/files/patch-etc_profile.csh

This file was deleted.

25 changes: 22 additions & 3 deletions cad/astk-serveur/pkg-plist
Original file line number Diff line number Diff line change
Expand Up @@ -372,6 +372,9 @@
%%SERV%%%%ASTKDIR%%/asrun/plugins/default.py
%%SERV%%%%ASTKDIR%%/asrun/plugins/default.pyc
%%SERV%%%%ASTKDIR%%/asrun/plugins/default.pyo
%%SERV%%%%ASTKDIR%%/asrun/plugins/generic_func.py
%%SERV%%%%ASTKDIR%%/asrun/plugins/generic_func.pyc
%%SERV%%%%ASTKDIR%%/asrun/plugins/generic_func.pyo
%%SERV%%%%ASTKDIR%%/asrun/plugins/rsh_server.py
%%SERV%%%%ASTKDIR%%/asrun/plugins/rsh_server.pyc
%%SERV%%%%ASTKDIR%%/asrun/plugins/rsh_server.pyo
Expand All @@ -381,6 +384,9 @@
%%SERV%%%%ASTKDIR%%/asrun/plugins/sftp_server.py
%%SERV%%%%ASTKDIR%%/asrun/plugins/sftp_server.pyc
%%SERV%%%%ASTKDIR%%/asrun/plugins/sftp_server.pyo
%%SERV%%%%ASTKDIR%%/asrun/plugins/webdav_server.py
%%SERV%%%%ASTKDIR%%/asrun/plugins/webdav_server.pyc
%%SERV%%%%ASTKDIR%%/asrun/plugins/webdav_server.pyo
%%SERV%%%%ASTKDIR%%/asrun/profil.py
%%SERV%%%%ASTKDIR%%/asrun/profil.pyc
%%SERV%%%%ASTKDIR%%/asrun/profil.pyo
Expand All @@ -399,6 +405,9 @@
%%SERV%%%%ASTKDIR%%/asrun/run.py
%%SERV%%%%ASTKDIR%%/asrun/run.pyc
%%SERV%%%%ASTKDIR%%/asrun/run.pyo
%%SERV%%%%ASTKDIR%%/asrun/runner.py
%%SERV%%%%ASTKDIR%%/asrun/runner.pyc
%%SERV%%%%ASTKDIR%%/asrun/runner.pyo
%%SERV%%%%ASTKDIR%%/asrun/schema.py
%%SERV%%%%ASTKDIR%%/asrun/schema.pyc
%%SERV%%%%ASTKDIR%%/asrun/schema.pyo
Expand Down Expand Up @@ -448,13 +457,18 @@
%%SERV%%%%ASTKDIR%%/etc/plugins/aster5.py
%%SERV%%%%ASTKDIR%%/etc/plugins/aster5.pyc
%%SERV%%%%ASTKDIR%%/etc/plugins/aster5.pyo
%%SERV%%%%ASTKDIR%%/etc/plugins/athosdev.py
%%SERV%%%%ASTKDIR%%/etc/plugins/athosdev.pyc
%%SERV%%%%ASTKDIR%%/etc/plugins/athosdev.pyo
%%SERV%%%%ASTKDIR%%/etc/plugins/ivanoe.py
%%SERV%%%%ASTKDIR%%/etc/plugins/ivanoe.pyc
%%SERV%%%%ASTKDIR%%/etc/plugins/ivanoe.pyo
%%SERV%%%%ASTKDIR%%/etc/plugins/sge_pe.py
%%SERV%%%%ASTKDIR%%/etc/plugins/sge_pe.pyc
%%SERV%%%%ASTKDIR%%/etc/plugins/sge_pe.pyo
%%SERV%%%%ASTKDIR%%/etc/profile.csh
%%SERV%%%%ASTKDIR%%/etc/plugins/tail_slurm.py
%%SERV%%%%ASTKDIR%%/etc/plugins/tail_slurm.pyc
%%SERV%%%%ASTKDIR%%/etc/plugins/tail_slurm.pyo
%%SERV%%%%ASTKDIR%%/etc/profile.sh
%%SERV%%%%ASTKDIR%%/i18n/Makefile
%%SERV%%%%ASTKDIR%%/i18n/asrun.fr.mo
Expand Down Expand Up @@ -579,11 +593,16 @@
%%SERV%%%%ETCDIR%%/plugins/aster5.py
%%SERV%%%%ETCDIR%%/plugins/aster5.pyc
%%SERV%%%%ETCDIR%%/plugins/aster5.pyo
%%SERV%%%%ETCDIR%%/plugins/athosdev.py
%%SERV%%%%ETCDIR%%/plugins/athosdev.pyc
%%SERV%%%%ETCDIR%%/plugins/athosdev.pyo
%%SERV%%%%ETCDIR%%/plugins/ivanoe.py
%%SERV%%%%ETCDIR%%/plugins/ivanoe.pyc
%%SERV%%%%ETCDIR%%/plugins/ivanoe.pyo
%%SERV%%%%ETCDIR%%/plugins/sge_pe.py
%%SERV%%%%ETCDIR%%/plugins/sge_pe.pyc
%%SERV%%%%ETCDIR%%/plugins/sge_pe.pyo
%%SERV%%%%ETCDIR%%/profile.csh
%%SERV%%%%ETCDIR%%/profile.sh
%%SERV%%%%ETCDIR%%/plugins/tail_slurm.py
%%SERV%%%%ETCDIR%%/plugins/tail_slurm.pyc
%%SERV%%%%ETCDIR%%/plugins/tail_slurm.pyo
%%SERV%%%%ETCDIR%%/profile_astk.sh
2 changes: 2 additions & 0 deletions cad/irsim/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -31,6 +31,8 @@ GNU_CONFIGURE= yes
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib

BROKEN_aarch64= Fails to link: missing sbrk

.include <bsd.port.options.mk>

.if ${PORT_OPTIONS:MTCL}
Expand Down
2 changes: 2 additions & 0 deletions comms/linrad/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -32,6 +32,8 @@ LINRAD_DOCFILES= z_APM.txt z_BUFFERS.txt z_CALIBRATE.txt \
z_PARALLEL_PORT.txt z_SETTINGS.txt \
z_USERS_EXTRA.txt z_USERS_HWARE.txt

BROKEN_sparc64= Fails to compile: implicit declaration of function outb

.include <bsd.port.pre.mk>
.if ${ARCH} == "i386"
BINFILE= xlinrad
Expand Down
3 changes: 3 additions & 0 deletions comms/mgetty+sendfax/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -26,6 +26,9 @@ CFLAGS+= -DAUTO_PPP

MAKE_JOBS_UNSAFE= yes

BROKEN_aarch64= Fails to compile: error: initializer element is not a compile-time constant
BROKEN_mips64= Fails to compile: error: initializer element is not a compile-time constant

OPTIONS_DEFINE= FIDO
FIDO_DESC= Enable FIDO EMSI support
FIDO_CFLAGS= -DFIDO
Expand Down
2 changes: 2 additions & 0 deletions comms/xnec2c/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -21,6 +21,8 @@ USE_GNOME= gtk20 intltool
OPTIONS_DEFINE= DOCS
OPTIONS_SUB= yes

BROKEN_sparc64= Fails to link: relocation truncated to fit: R_SPARC_GOT13 against symbol input_fp

post-extract:
${CP} ${PATCHDIR}/clog.c ${WRKSRC}/src
${TOUCH} ${WRKSRC}/src/cexp.c
Expand Down
Loading

0 comments on commit 471d90c

Please sign in to comment.