Skip to content

Commit

Permalink
*/*: sync with upstream
Browse files Browse the repository at this point in the history
Taken from: FreeBSD
  • Loading branch information
fichtner committed Dec 25, 2015
1 parent 0928a5a commit 4cd9a1d
Show file tree
Hide file tree
Showing 238 changed files with 4,058 additions and 1,286 deletions.
7 changes: 5 additions & 2 deletions audio/audacity/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -36,7 +36,7 @@ PORTDOCS= README.txt
INSTALL_TARGET= install-strip
DOS2UNIX_GLOB= Makefile.* *.c* *.h

OPTIONS_DEFINE= NLS DEBUG DOCS FLAC ID3TAG LADSPA LAME MAD MIDI \
OPTIONS_DEFINE= NLS DEBUG DOCS FFMPEG FLAC ID3TAG LADSPA LAME MAD MIDI \
SBSMS SOUNDTOUCH TWOLAME VAMP VORBIS VST
OPTIONS_DEFAULT= FLAC ID3TAG LADSPA MAD MIDI \
SBSMS SOUNDTOUCH TWOLAME VAMP VORBIS VST
Expand All @@ -59,7 +59,7 @@ VST_DESC= VST plug-in support

CONFIGURE_ENV+= WX_CONFIG="${WX_CONFIG}"

CONFIGURE_ARGS+= --with-lib-preference="local system" --without-lv2 --without-ffmpeg \
CONFIGURE_ARGS+= --with-lib-preference="local system" --without-lv2 \
--enable-portaudio --enable-unicode --with-libsoxr

CONFIGURE_SHELL?=${LOCALBASE}/bin/bash
Expand All @@ -69,6 +69,9 @@ DEBUG_CONFIGURE_WITH= debug
DOCS_BUILD_DEPENDS= docbook-to-man:${PORTSDIR}/textproc/docbook-to-man \
docbook2man:${PORTSDIR}/textproc/docbook-utils

FFMPEG_CONFIGURE_WITH= ffmpeg=system
FFMPEG_LIB_DEPENDS= libavcodec.so:${PORTSDIR}/multimedia/ffmpeg

FLAC_CONFIGURE_WITH= libflac
FLAC_LIB_DEPENDS= libFLAC.so:${PORTSDIR}/audio/flac

Expand Down
8 changes: 6 additions & 2 deletions audio/opus/Makefile
Original file line number Diff line number Diff line change
@@ -1,8 +1,7 @@
# $FreeBSD$

PORTNAME= opus
PORTVERSION= 1.1
PORTREVISION= 2
PORTVERSION= 1.1.1
CATEGORIES= audio
MASTER_SITES= http://downloads.xiph.org/releases/opus/ \
MOZILLA/opus
Expand All @@ -26,6 +25,11 @@ TEST_TARGET= check

.include <bsd.port.options.mk>

# i386: needs cpuid instruction; arm: only floating point
.if ${ARCH} == "amd64"
CONFIGURE_ARGS+=--enable-intrinsics
.endif

.if ${ARCH} == "arm"
CONFIGURE_ARGS+=--enable-fixed-point
.endif
Expand Down
4 changes: 2 additions & 2 deletions audio/opus/distinfo
Original file line number Diff line number Diff line change
@@ -1,2 +1,2 @@
SHA256 (opus-1.1.tar.gz) = b9727015a58affcf3db527322bf8c4d2fcf39f5f6b8f15dbceca20206cbe1d95
SIZE (opus-1.1.tar.gz) = 850208
SHA256 (opus-1.1.1.tar.gz) = 9b84ff56bd7720d5554103c557664efac2b8b18acc4bbcc234cb881ab9a3371e
SIZE (opus-1.1.1.tar.gz) = 957948
25 changes: 8 additions & 17 deletions audio/opus/files/patch-configure
Original file line number Diff line number Diff line change
@@ -1,20 +1,11 @@
--- configure.orig 2013-12-17 16:51:41.000000000 +0100
+++ configure 2013-12-17 16:52:02.000000000 +0100
@@ -12807,7 +12807,7 @@ else
CPU_ARM_FALSE=
fi
--- configure.orig 2015-11-25 20:46:28 UTC
+++ configure
@@ -13229,7 +13229,7 @@ $as_echo "$as_me: WARNING: Compiler does

- if test x"${inline_optimization:0:3}" = x"ARM"; then
+ if expr x"${inline_optimization}" : x"ARM" >/dev/null; then
OPUS_ARM_INLINE_ASM_TRUE=
OPUS_ARM_INLINE_ASM_FALSE='#'
else
@@ -12815,7 +12815,7 @@ else
OPUS_ARM_INLINE_ASM_FALSE=
fi
;; #(
- i?86|x86_64) :
+ i?86|x86_64|amd64) :


- if test x"${asm_optimization:0:3}" = x"ARM"; then
+ if expr x"${asm_optimization}" : x"ARM" >/dev/null; then
OPUS_ARM_EXTERNAL_ASM_TRUE=
OPUS_ARM_EXTERNAL_ASM_FALSE='#'
else
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking if compiler supports SSE intrinsics" >&5
2 changes: 1 addition & 1 deletion audio/opus/pkg-plist
Original file line number Diff line number Diff line change
Expand Up @@ -6,6 +6,6 @@ include/opus/opus_types.h
lib/libopus.a
lib/libopus.so
lib/libopus.so.0
lib/libopus.so.0.5.0
lib/libopus.so.0.5.1
libdata/pkgconfig/opus.pc
share/aclocal/opus.m4
20 changes: 12 additions & 8 deletions biology/bcftools/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -2,7 +2,7 @@
# $FreeBSD$

PORTNAME= bcftools
PORTVERSION= 1.2
PORTVERSION= 1.3
CATEGORIES= biology

MAINTAINER= [email protected]
Expand All @@ -11,15 +11,17 @@ COMMENT= Tools for manipulating next-generation sequencing data
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE

BUILD_DEPENDS= htslib>=1.2:${PORTSDIR}/biology/htslib
BUILD_DEPENDS= htslib>=1.3:${PORTSDIR}/biology/htslib
LIB_DEPENDS= libhts.so:${PORTSDIR}/biology/htslib
TEST_DEPENDS= bash:${PORTSDIR}/shells/bash

USE_GITHUB= yes
GH_ACCOUNT= samtools

USES= gmake shebangfix
USES= gmake perl5 shebangfix
USE_PERL5= test
SUB_FILES= pkg-message
SHEBANG_FILES= vcfutils.pl
SHEBANG_FILES= vcfutils.pl plot-vcfstats plugins/color-chrs.pl test/test.pl

OPTIONS_DEFINE= GPL
GPL_DESC= Enable modules that rely on GPL code
Expand All @@ -33,10 +35,10 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib

MAKE_ENV= INSTALL_LIB="${INSTALL_LIB}" \
INSTALL_DATA="${INSTALL_DATA}" \
INSTALL_PROGRAM="${INSTALL_PROGRAM}" \
INSTALL_SCRIPT="${INSTALL_SCRIPT}" \
INSTALL_DIR="${MKDIR}"
INSTALL_DATA="${INSTALL_DATA}" \
INSTALL_PROGRAM="${INSTALL_PROGRAM}" \
INSTALL_SCRIPT="${INSTALL_SCRIPT}" \
INSTALL_DIR="${MKDIR}"

.if ${PORT_OPTIONS:MGPL}
MAKE_ENV+= USE_GPL=1
Expand All @@ -45,4 +47,6 @@ LICENSE= GPLv3

PLIST_SUB= PORTVERSION="${PORTVERSION}"

TEST_TARGET= test

.include <bsd.port.mk>
4 changes: 2 additions & 2 deletions biology/bcftools/distinfo
Original file line number Diff line number Diff line change
@@ -1,2 +1,2 @@
SHA256 (samtools-bcftools-1.2_GH0.tar.gz) = 90ccd7dccfb0b2848b71f32fff073c420260e857b7feeb89c1fb4bfaba49bfba
SIZE (samtools-bcftools-1.2_GH0.tar.gz) = 511625
SHA256 (samtools-bcftools-1.3_GH0.tar.gz) = 3f4d4bf68637070cb7dbb5d5619ece7e3315727e651eab751d849085439b11d8
SIZE (samtools-bcftools-1.3_GH0.tar.gz) = 943041
86 changes: 40 additions & 46 deletions biology/bcftools/files/patch-Makefile
Original file line number Diff line number Diff line change
@@ -1,84 +1,78 @@
--- Makefile.orig 2015-02-02 15:40:17 UTC
--- Makefile.orig 2015-12-15 21:42:34 UTC
+++ Makefile
@@ -29,14 +29,13 @@ TEST_PROG= test/test-rbuf
@@ -29,16 +29,15 @@ TEST_PROG= test/test-rbuf
all: $(PROG) $(TEST_PROG)

# Adjust $(HTSDIR) to point to your top-level htslib directory
-HTSDIR = ../htslib
-include $(HTSDIR)/htslib.mk
-HTSLIB = $(HTSDIR)/libhts.a
-BGZIP = $(HTSDIR)/bgzip
-TABIX = $(HTSDIR)/tabix
+HTSDIR = $(prefix)/include
+HTSLIB = -lhts
BGZIP = $(HTSDIR)/bgzip
TABIX = $(HTSDIR)/tabix
+BGZIP = $(HTSDIR)/../bin/bgzip
+TABIX = $(HTSDIR)/../bin/tabix

-CC = gcc
-CPPFLAGS =
-CFLAGS = -g -Wall -Wc++-compat -O2
+CC ?= cc
+CFLAGS += -Wall
DFLAGS =
-LDFLAGS =
+CC ?= cc
+CPPFLAGS +=
+CFLAGS += -Wall
+LDFLAGS +=
LIBS =

OBJS = main.o vcfindex.o tabix.o \
vcfstats.o vcfisec.o vcfmerge.o vcfquery.o vcffilter.o filter.o vcfsom.o \
@@ -52,22 +51,15 @@ INCLUDES = -I. -I$(HTSDIR)
@@ -57,26 +56,20 @@ GSL_LIBS =
ifdef USE_GPL
CFLAGS += -DUSE_GPL
OBJS += polysomy.o
- LDLIBS = -lgsl -lcblas
+ LDLIBS += -lgsl -lgslcblas
EXTRA_CPPFLAGS += -DUSE_GPL
OBJS += polysomy.o peakfit.o
- GSL_LIBS = -lgsl -lcblas
+ GSL_LIBS = -lgsl -lgslcblas
endif

-prefix = /usr/local
+prefix = ${STAGEDIR}${PREFIX}
exec_prefix = $(prefix)
bindir = $(exec_prefix)/bin
libdir = $(exec_prefix)/lib
libexecdir = $(exec_prefix)/libexec
-mandir = $(prefix)/share/man
+mandir = $(prefix)/man
man1dir = $(mandir)/man1

plugindir = $(libexecdir)/bcftools
pluginpath = $(plugindir)

-MKDIR_P = mkdir -p
-INSTALL = install -p
-INSTALL_PROGRAM = $(INSTALL)
-INSTALL_DATA = $(INSTALL) -m 644
-INSTALL_DIR = $(MKDIR_P) -m 755
-
-
all:$(PROG) plugins

# See htslib/Makefile
@@ -102,8 +94,8 @@ PLUGINC = $(foreach dir, plugins, $(wild
PLUGINS = $(PLUGINC:.c=.so)
PLUGINM = $(PLUGINC:.c=.mk)
MISC_PROGRAMS = plot-vcfstats vcfutils.pl plugins/color-chrs.pl

-%.so: %.c version.h version.c $(HTSDIR)/libhts.so
- $(CC) $(CFLAGS) $(INCLUDES) -fPIC -shared -o $@ version.c $< -L$(HTSDIR) -lhts
+%.so: %.c version.h version.c
+ $(CC) $(CFLAGS) $(LDFLAGS) $(INCLUDES) -fPIC -shared -o $@ version.c $< -lhts

-include $(PLUGINM)

@@ -156,10 +148,10 @@ version.o: version.h version.c
test/test-rbuf.o: test/test-rbuf.c rbuf.h

test/test-rbuf: test/test-rbuf.o
- $(CC) $(CFLAGS) -o $@ -lm -ldl $<
+ $(CC) $(CFLAGS) -o $@ -lm $<
all:$(PROG) plugins
@@ -181,7 +174,7 @@ test/test-rbuf: test/test-rbuf.o
$(CC) $(LDFLAGS) -o $@ $^ -lm $(LIBS)

-bcftools: $(HTSLIB) $(OBJS)
- $(CC) $(CFLAGS) -o $@ $(OBJS) $(HTSLIB) -lpthread -lz -lm -ldl $(LDLIBS)
+bcftools: $(OBJS)
+ $(CC) -pthread $(CFLAGS) $(LDFLAGS) -o $@ $(OBJS) $(HTSLIB) -lz -lm $(LDLIBS)
bcftools: $(HTSLIB) $(OBJS)
- $(CC) -rdynamic $(LDFLAGS) -o $@ $(OBJS) $(HTSLIB) -lpthread -lz -lm -ldl $(GSL_LIBS) $(LIBS)
+ $(CC) -rdynamic $(LDFLAGS) -o $@ $(OBJS) $(HTSLIB) -pthread -lz -lm $(GSL_LIBS) $(LIBS)

doc/bcftools.1: doc/bcftools.txt
cd doc && a2x -adate="$(DOC_DATE)" -aversion=$(DOC_VERSION) --doctype manpage --format manpage bcftools.txt
@@ -170,8 +162,9 @@ doc/bcftools.html: doc/bcftools.txt
docs: doc/bcftools.1 doc/bcftools.html

install: $(PROG) doc/bcftools.1
- $(INSTALL_DIR) $(DESTDIR)$(bindir) $(DESTDIR)$(man1dir)
- $(INSTALL_PROGRAM) $(PROG) plot-vcfstats vcfutils.pl $(DESTDIR)$(bindir)
+ $(INSTALL_DIR) $(DESTDIR)$(bindir) $(DESTDIR)$(bindir)/samtools_misc $(DESTDIR)$(man1dir)
@@ -198,8 +191,9 @@ docs: doc/bcftools.1 doc/bcftools.html
# Since there is no make dependency, bcftools.1 can be out-of-date and
# make docs can be run to update if asciidoc is available
install: $(PROG)
- $(INSTALL_DIR) $(DESTDIR)$(bindir) $(DESTDIR)$(man1dir) $(DESTDIR)$(plugindir)
- $(INSTALL_PROGRAM) $(PROG) $(MISC_PROGRAMS) $(DESTDIR)$(bindir)
+ $(INSTALL_DIR) $(DESTDIR)$(bindir) $(DESTDIR)$(bindir)/samtools_misc $(DESTDIR)$(man1dir) $(DESTDIR)$(plugindir)
+ $(INSTALL_PROGRAM) $(PROG) $(DESTDIR)$(bindir)
+ $(INSTALL_SCRIPT) plot-vcfstats vcfutils.pl $(DESTDIR)$(bindir)/samtools_misc
+ $(INSTALL_SCRIPT) $(MISC_PROGRAMS) $(DESTDIR)$(bindir)/samtools_misc
$(INSTALL_DATA) doc/bcftools.1 $(DESTDIR)$(man1dir)
$(INSTALL_PROGRAM) plugins/*.so $(DESTDIR)$(plugindir)

clean: testclean clean-plugins
7 changes: 0 additions & 7 deletions biology/bcftools/files/patch-plugins_fixploidy.mk

This file was deleted.

7 changes: 0 additions & 7 deletions biology/bcftools/files/patch-plugins_vcf2sex.mk

This file was deleted.

12 changes: 5 additions & 7 deletions biology/bcftools/files/patch-prob1.c
Original file line number Diff line number Diff line change
@@ -1,15 +1,13 @@
--- prob1.c.orig 2015-04-28 01:28:23 UTC
--- prob1.c.orig 2015-12-15 21:42:34 UTC
+++ prob1.c
@@ -33,6 +33,14 @@ THE SOFTWARE. */
@@ -33,6 +33,12 @@ THE SOFTWARE. */
#include <zlib.h>
#include "prob1.h"

+#include <sys/param.h>
+#ifdef __FreeBSD__
+# if __FreeBSD_version < 1000034
+# define logl(x) log(x)
+# define expl(x) exp(x)
+# endif
+#if defined(__FreeBSD__) && (__FreeBSD_version < 1000034)
+# define logl(x) log(x)
+# define expl(x) exp(x)
+#endif
+
// #include "kstring.h"
Expand Down
29 changes: 29 additions & 0 deletions biology/bcftools/files/patch-test_test.pl
Original file line number Diff line number Diff line change
@@ -0,0 +1,29 @@
--- test/test.pl.orig 2015-12-22 22:45:13 UTC
+++ test/test.pl
@@ -290,7 +290,7 @@ sub _cmd
else
{
# child
- exec('/bin/bash', '-o','pipefail','-c', $cmd) or error("Cannot execute the command [/bin/sh -o pipefail -c $cmd]: $!");
+ exec('/usr/local/bin/bash', '-o','pipefail','-c', $cmd) or error("Cannot execute the command [/usr/local/bin/sh -o pipefail -c $cmd]: $!");
}
return ($? >> 8, join('',@out));
}
@@ -657,7 +657,7 @@ sub test_usage
my $command = $args{cmd};
my $commandpath = $$opts{bin}."/".$command;
my ($ret,$out) = _cmd("$commandpath $args{redirection} 2>&1");
- if ( $out =~ m/\/bin\/bash.*no.*such/i ) { failed($opts,$test,"could not run $commandpath: $out"); return; }
+ if ( $out =~ m/\/usr\/local\/bin\/bash.*no.*such/i ) { failed($opts,$test,"could not run $commandpath: $out"); return; }

my @sections = ($out =~ m/(^[A-Za-z]+.*?)(?:(?=^[A-Za-z]+:)|\z)/msg);

@@ -708,7 +708,7 @@ sub test_usage_subcommand
my $subcommand = $args{subcmd};
my $commandpath = $$opts{bin}."/".$command;
my ($ret,$out) = _cmd("$commandpath $subcommand $args{redirection} 2>&1");
- if ( $out =~ m/\/bin\/bash.*no.*such/i ) { failed($opts,$test,"could not run $commandpath $subcommand: $out"); return; }
+ if ( $out =~ m/\/usr\/local\/bin\/bash.*no.*such/i ) { failed($opts,$test,"could not run $commandpath $subcommand: $out"); return; }

my @sections = ($out =~ m/(^[A-Za-z]+.*?)(?:(?=^[A-Za-z]+:)|\z)/msg);

7 changes: 6 additions & 1 deletion biology/bcftools/files/pkg-message.in
Original file line number Diff line number Diff line change
@@ -1,2 +1,7 @@
The miscellaneous tools included with Bcftools have been installed to
%%PREFIX%%/bin/samtools_misc

Add %%PREFIX%%/bin/samtools_misc to your path to use miscellaneous tools.
Add that directory to your path if you want to use these tools.

Some of these tools depend on Perl5, and it will need to be installed to
use them.
14 changes: 14 additions & 0 deletions biology/bcftools/pkg-plist
Original file line number Diff line number Diff line change
@@ -1,4 +1,18 @@
bin/bcftools
bin/samtools_misc/color-chrs.pl
bin/samtools_misc/plot-vcfstats
bin/samtools_misc/vcfutils.pl
libexec/bcftools/color-chrs.so
libexec/bcftools/counts.so
libexec/bcftools/dosage.so
libexec/bcftools/fill-AN-AC.so
libexec/bcftools/fill-tags.so
libexec/bcftools/fixploidy.so
libexec/bcftools/frameshifts.so
libexec/bcftools/impute-info.so
libexec/bcftools/mendelian.so
libexec/bcftools/missing2ref.so
libexec/bcftools/setGT.so
libexec/bcftools/tag2tag.so
libexec/bcftools/vcf2sex.so
man/man1/bcftools.1.gz
Loading

0 comments on commit 4cd9a1d

Please sign in to comment.