Skip to content

Commit

Permalink
*/*: sync with upstream
Browse files Browse the repository at this point in the history
Taken from: FreeBSD
  • Loading branch information
fichtner committed Jun 18, 2016
1 parent 2c91c94 commit 5460a99
Show file tree
Hide file tree
Showing 542 changed files with 3,789 additions and 4,368 deletions.
21 changes: 11 additions & 10 deletions astro/xplanet/files/patch-libprojections_stdiofix
Original file line number Diff line number Diff line change
@@ -1,30 +1,31 @@
--- src/libprojection/ProjectionBonne.cpp.orig Wed Dec 8 14:56:51 2004
+++ src/libprojection/ProjectionBonne.cpp Wed Dec 8 14:57:11 2004
--- src/libprojection/ProjectionBonne.cpp.orig 2006-03-26 05:03:20 UTC
+++ src/libprojection/ProjectionBonne.cpp
@@ -7,6 +7,8 @@
http://www.atnf.csiro.au/~mcalabre/WCS
*/

+#include <stdio.h>
+
#include <cmath>
#include <cstdio>
#include <sstream>
#include <vector>
--- src/libprojection/ProjectionGnomonic.cpp.orig Wed Dec 8 14:57:44 2004
+++ src/libprojection/ProjectionGnomonic.cpp Wed Dec 8 14:57:58 2004
--- src/libprojection/ProjectionGnomonic.cpp.orig 2006-03-26 05:03:20 UTC
+++ src/libprojection/ProjectionGnomonic.cpp
@@ -7,6 +7,8 @@
http://www.atnf.csiro.au/~mcalabre/WCS
*/

+#include <stdio.h>
+
#include <cmath>
#include <cstdio>
#include <sstream>
using namespace std;
--- src/libprojection/ProjectionMercator.cpp.orig Wed Dec 8 14:58:26 2004
+++ src/libprojection/ProjectionMercator.cpp Wed Dec 8 14:58:46 2004
@@ -1,3 +1,5 @@
--- src/libprojection/ProjectionMercator.cpp.orig 2006-03-26 05:03:20 UTC
+++ src/libprojection/ProjectionMercator.cpp
@@ -1,4 +1,6 @@
#include <cmath>
+#include <stdio.h>
+
#include <cmath>
#include <cstdio>
#include <sstream>
using namespace std;
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
--- src/libprojection/ProjectionIcosagnomonic.cpp.orig Tue Jun 14 22:10:36 2005
+++ src/libprojection/ProjectionIcosagnomonic.cpp Wed Jun 29 20:11:58 2005
@@ -26,6 +26,19 @@
--- src/libprojection/ProjectionIcosagnomonic.cpp.orig 2009-04-16 15:10:08 UTC
+++ src/libprojection/ProjectionIcosagnomonic.cpp
@@ -26,6 +26,19 @@ using namespace std;
#define THIGH 3
#define RATIO (((THIGH)*sqrt(3.0)/2)/(TWIDE))

Expand Down
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
--- src/readConfig.cpp.orig Mon May 24 09:11:26 2004
+++ src/readConfig.cpp Mon May 24 09:11:45 2004
@@ -2,6 +2,7 @@
--- src/readConfig.cpp.orig 2012-03-03 03:20:05 UTC
+++ src/readConfig.cpp
@@ -4,6 +4,7 @@
#include <fstream>
#include <sstream>
#include <string>
Expand Down
8 changes: 3 additions & 5 deletions benchmarks/iozone/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -2,19 +2,17 @@
# $FreeBSD$

PORTNAME= iozone
PORTVERSION= 3.420
DISTVERSION= 3_434
CATEGORIES= benchmarks
MASTER_SITES= http://www.iozone.org/src/current/
DISTNAME= ${PORTNAME}${PORTVERSION:S/./_/}
EXTRACT_SUFX= .tar
DISTNAME= ${PORTNAME}${DISTVERSION}

MAINTAINER= [email protected]
COMMENT= Performance Test of Sequential File I/O

CONFLICTS= iozone-2.* iozone21-*

WRKSRC= ${WRKDIR}/${DISTNAME}/src/current

USES= tar
MAKEFILE= makefile
MAKE_ARGS= ${MAKE_ENV}
ALL_TARGET= freebsd
Expand Down
5 changes: 3 additions & 2 deletions benchmarks/iozone/distinfo
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
SHA256 (iozone3_420.tar) = f793cc68e86aea5c93fb3010f4088653138a610c3b14047b2314ab6a1f8d5b8e
SIZE (iozone3_420.tar) = 1832960
TIMESTAMP = 1466168535
SHA256 (iozone3_434.tar) = 2c388d9db393a5505b31eca38951883744c69745f687f3c7df5185b4681d462a
SIZE (iozone3_434.tar) = 1843200
27 changes: 27 additions & 0 deletions benchmarks/iozone/files/patch-iozone.c
Original file line number Diff line number Diff line change
@@ -0,0 +1,27 @@
--- iozone.c.orig 2015-10-20 14:12:13 UTC
+++ iozone.c
@@ -360,6 +360,7 @@ typedef off_t off64_t;
#ifndef SCO_Unixware_gcc
#ifndef UWIN
#ifndef __DragonFly__
+#ifndef __FreeBSD__
typedef long long off64_t;
#endif
#endif
@@ -369,6 +370,7 @@ typedef long long off64_t;
#endif
#endif
#endif
+#endif

#ifdef __AIX__
#include <fcntl.h>
@@ -23009,7 +23011,7 @@ char *shell;
#ifdef _HPUX_SOURCE
strcpy(shell,"remsh");
#else
- strcpy(shell,"rsh");
+ strcpy(shell,"ssh");
#endif
return;
}
38 changes: 27 additions & 11 deletions benchmarks/iozone/files/patch-libasync.c
Original file line number Diff line number Diff line change
@@ -1,20 +1,36 @@
--- libasync.c 2012-05-14 23:13:13.000000000 -0700
+++ libasync.c 2012-05-14 23:14:27.000000000 -0700
@@ -109,7 +109,7 @@
#include <sys/fs/vx_ioctl.h>
#endif
--- libasync.c.orig 2015-10-20 14:12:13 UTC
+++ libasync.c
@@ -96,13 +96,13 @@

-#if defined(OSFV5) || defined(linux)
+#if defined(OSFV5) || defined(linux) || defined(__FreeBSD__)
#include <string.h>
#include <sys/types.h>
#include <aio.h>
-#if defined(solaris) || defined(linux) || defined(SCO_Unixware_gcc) || defined(__NetBSD__)
+#if defined(solaris) || defined(linux) || defined(SCO_Unixware_gcc) || defined(__NetBSD__) || defined(__FreeBSD__)
#else
#include <sys/timers.h>
#endif

#include <sys/errno.h>
#include <unistd.h>
-#ifndef bsd4_4
+#if !defined(bsd4_4) && !defined(__FreeBSD__)
#include <malloc.h>
#endif
#ifdef VXFS
@@ -119,7 +119,7 @@
#include <stdlib.h>
#endif

-#if (defined(solaris) && defined(__LP64__)) || defined(__s390x__) || defined(FreeBSD)
+#if (defined(solaris) && defined(__LP64__)) || defined(__s390x__) || defined(__FreeBSD__)
-#if (defined(solaris) && defined(__LP64__)) || defined(__s390x__) || defined(FreeBSD) || defined(__NetBSD__)
+#if (defined(solaris) && defined(__LP64__)) || defined(__s390x__) || defined(__FreeBSD__) || defined(__NetBSD__)
/* If we are building for 64-bit Solaris, all functions that return pointers
* must be declared before they are used; otherwise the compiler will assume
* that they return ints and the top 32 bits of the pointer will be lost,
@@ -135,7 +135,7 @@
void mbcopy(char *source, char *dest, size_t len);


-#if !defined(solaris) && !defined(off64_t) && !defined(_OFF64_T) && !defined(__off64_t_defined) && !defined(SCO_Unixware_gcc)
+#if !defined(solaris) && !defined(off64_t) && !defined(_OFF64_T) && !defined(__off64_t_defined) && !defined(SCO_Unixware_gcc) && !defined(__FreeBSD__)
typedef long long off64_t;
#endif
#if defined(OSFV5)
11 changes: 0 additions & 11 deletions benchmarks/iozone/files/patch-libbif.c

This file was deleted.

7 changes: 4 additions & 3 deletions benchmarks/unixbench/files/patch-Makefile
Original file line number Diff line number Diff line change
@@ -1,6 +1,7 @@
--- Makefile.orig Sun Dec 19 01:29:33 2004
+++ Makefile Sun Dec 19 01:32:06 2004
@@ -30,8 +30,6 @@
--- Makefile.orig 1999-07-28 22:05:02 UTC
+++ Makefile
@@ -30,9 +30,7 @@
##############################################################################
ID="@(#)Makefile:3.9 -- 5/15/91 19:30:15";
SHELL = /bin/sh
-#HZ = ???? #(read from environment)
Expand Down
14 changes: 7 additions & 7 deletions benchmarks/unixbench/files/patch-Run
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
--- Run.orig Sun Dec 19 01:34:20 2004
+++ Run Sun Dec 19 01:39:54 2004
@@ -88,11 +88,11 @@
--- Run.orig 1999-07-28 22:04:47 UTC
+++ Run
@@ -88,11 +88,11 @@ else
fi

# check that the required files are in the proper places
Expand All @@ -17,7 +17,7 @@


# establish full paths to directories
@@ -114,7 +114,7 @@
@@ -114,7 +114,7 @@ cd $SCRPDIR
SCRPDIR=`pwd`
cd $_WD

Expand All @@ -26,7 +26,7 @@
cd $TMPDIR
TMPDIR=`pwd`
cd $_WD
@@ -367,10 +367,11 @@
@@ -367,10 +367,11 @@ do # line argument processing
C)
logmsg="C Compiler Throughput"
prog="looper ${looper-60} ${CC} cctest.c"
Expand All @@ -39,7 +39,7 @@
;;

arithoh)
@@ -385,8 +386,8 @@
@@ -385,8 +386,8 @@ do # line argument processing

dc)
logmsg="Dc: sqrt(2) to 99 decimal places"
Expand All @@ -50,7 +50,7 @@
stdout=/dev/null
cleanopt="-m $TMPTIMES"
;;
@@ -508,7 +509,7 @@
@@ -508,7 +509,7 @@ do # line argument processing
########### some specific cleanup routines ##############
case $bench in
C)
Expand Down
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
--- pgms/cleanup.sh.orig Sun Dec 19 01:42:45 2004
+++ pgms/cleanup.sh Sun Dec 19 01:43:00 2004
@@ -107,8 +107,8 @@
--- pgms/cleanup.sh.orig 1997-09-13 02:01:19 UTC
+++ pgms/cleanup.sh
@@ -107,8 +107,8 @@ do
;;

-r) # reason for failure
Expand Down
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- pgms/multi.sh.orig Sun Dec 19 01:44:14 2004
+++ pgms/multi.sh Sun Dec 19 01:44:24 2004
--- pgms/multi.sh.orig 1995-11-28 00:19:10 UTC
+++ pgms/multi.sh
@@ -14,6 +14,7 @@
#
###############################################################################
Expand Down
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- pgms/tst.sh.orig Sun Dec 19 01:41:24 2004
+++ pgms/tst.sh Sun Dec 19 01:41:49 2004
--- pgms/tst.sh.orig 1995-11-27 17:07:03 UTC
+++ pgms/tst.sh
@@ -14,7 +14,7 @@
#
###############################################################################
Expand Down
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- src/dhry_1.c.orig Sun Dec 19 01:45:10 2004
+++ src/dhry_1.c Sun Dec 19 01:45:59 2004
--- src/dhry_1.c.orig 1999-07-28 21:43:08 UTC
+++ src/dhry_1.c
@@ -34,6 +34,7 @@
***************************************************************************/
char SCCSid[] = "@(#) @(#)dhry_1.c:3.4 -- 5/15/91 19:30:21";
Expand All @@ -8,7 +8,7 @@
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
@@ -81,7 +82,7 @@
@@ -81,7 +82,7 @@ extern int times ();
/* Measurements should last at least about 2 seconds */
#endif
#ifdef TIME
Expand Down
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
--- src/execl.c.orig Wed Jul 28 23:46:58 1999
+++ src/execl.c Fri Mar 23 09:20:36 2007
@@ -88,7 +88,7 @@
--- src/execl.c.orig 1999-07-28 21:46:58 UTC
+++ src/execl.c
@@ -88,7 +88,7 @@ char *argv[];
fprintf(stderr, "%lu loops\n", iter);
exit(0);
}
Expand Down
2 changes: 1 addition & 1 deletion biology/diamond/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -2,7 +2,7 @@
# $FreeBSD$

PORTNAME= diamond
PORTVERSION= 0.8.5
PORTVERSION= 0.8.6
DISTVERSIONPREFIX= v
CATEGORIES= biology

Expand Down
6 changes: 3 additions & 3 deletions biology/diamond/distinfo
Original file line number Diff line number Diff line change
@@ -1,3 +1,3 @@
TIMESTAMP = 1464949238
SHA256 (bbuchfink-diamond-v0.8.5_GH0.tar.gz) = 8ba092647af7c980ddd83acc6686acd2ba18744774c669027859dbaec644fda3
SIZE (bbuchfink-diamond-v0.8.5_GH0.tar.gz) = 203133
TIMESTAMP = 1466172154
SHA256 (bbuchfink-diamond-v0.8.6_GH0.tar.gz) = 94b755f5536fd2c8a009904efc2271aac7bfd9a44a74490fe12944b05c1cba64
SIZE (bbuchfink-diamond-v0.8.6_GH0.tar.gz) = 206973
8 changes: 2 additions & 6 deletions deskutils/charmap/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -5,19 +5,15 @@ PORTNAME= charmap
PORTVERSION= 0.2
PORTREVISION= 5
CATEGORIES= deskutils gnustep
MASTER_SITES= SAVANNAH
MASTER_SITES= http://www.sourcefiles.org/Utilities/GUI/

MAINTAINER= [email protected]
COMMENT= Character map for GNUstep

BROKEN= unfetchable
DEPRECATED= Broken for more than 6 months
EXPIRATION_DATE= 2016-07-04

LICENSE= GPLv2

USES= gnustep
USE_GNUSTEP= back build
USE_GNUSTEP= back base build gui

post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/GNUstep/System/Applications/Charmap.app/Charmap
Expand Down
1 change: 1 addition & 0 deletions devel/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -4205,6 +4205,7 @@
SUBDIR += py-lock_file
SUBDIR += py-lockfile
SUBDIR += py-log4py
SUBDIR += py-logbook
SUBDIR += py-logan
SUBDIR += py-logilab-common
SUBDIR += py-lxml
Expand Down
17 changes: 6 additions & 11 deletions devel/directfb/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -2,20 +2,16 @@
# $FreeBSD$

PORTNAME= directfb
PORTVERSION= 1.4.13
PORTREVISION= 7
PORTVERSION= 1.4.17
CATEGORIES= devel
MASTER_SITES= http://www.directfb.org/downloads/Core/${DISTNAME:R}/
MASTER_SITES= http://sources.buildroot.net/
DISTNAME= DirectFB-${PORTVERSION}

MAINTAINER= [email protected]
COMMENT= Graphic development lightweight API

LICENSE= LGPL21

BROKEN= Does not fetch
DEPRECATED= Broken for more than 6 months
EXPIRATION_DATE= 2016-07-04
LIB_DEPENDS= libpng.so:graphics/png

OPTIONS_DEFINE= FREETYPE X11 SDL UNIQUE TEST DOCS
Expand All @@ -31,10 +27,9 @@ USES= cpe gmake jpeg libtool ncurses pathfix perl5 pkgconfig
USE_LDCONFIG= yes
USE_PERL5= build
PORTDOCS= *
EXTRA_PATCHES= ${FILESDIR}/extra-libpng15:-p1

DIRECTFB_SHLIB= 5.0.8 # LT_BINARY.LT_AGE.LT_REVISION
DIRECTFB_BIN= 5 # LT_BINARY
DIRECTFB_SHLIB= 6.0.11 # LT_BINARY.LT_AGE.LT_REVISION
DIRECTFB_BIN= ${DIRECTFB_SHLIB:R:R} # LT_BINARY
PLIST_SUB+= DIRECTFB_VERSION="${PORTVERSION}" \
DIRECTFB_RELEASE="${PORTVERSION:R}" \
DIRECTFB_SHLIB="${DIRECTFB_SHLIB}" \
Expand All @@ -55,7 +50,7 @@ DOCS_BUILD_DEPENDS= man2html:textproc/man2html
FREETYPE_LIB_DEPENDS= libfreetype.so:print/freetype2
FREETYPE_CONFIGURE_ENABLE= freetype
X11_USE= XORG=x11,xext,xproto
X11_CONFIGURE_ENABLE= --x11
X11_CONFIGURE_ENABLE= x11
SDL_USE= sdl
SDL_CONFIGURE_ENABLE= sdl
UNIQUE_CONFIGURE_ENABLE= unique
Expand Down Expand Up @@ -83,7 +78,7 @@ post-patch:
@${GREP} -lr alloca\.h ${WRKSRC} | ${XARGS} \
${REINPLACE_CMD} -e 's|<alloca\.h>|<stdlib.h>|g'

post-install:
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}/html
.for f in AUTHORS ChangeLog NEWS README TODO fb.modes docs/README.screenshots docs/*.html
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
Expand Down
4 changes: 2 additions & 2 deletions devel/directfb/distinfo
Original file line number Diff line number Diff line change
@@ -1,2 +1,2 @@
SHA256 (DirectFB-1.4.13.tar.gz) = ff85ed00ce76c9f6ca7833534c1cbf00358c9a5450dc1649ce3bc283056ab9b5
SIZE (DirectFB-1.4.13.tar.gz) = 3113159
SHA256 (DirectFB-1.4.17.tar.gz) = 065a8e3a655b7e633eb1c2cdf55956496a29e0b8bd8ca700f0a5507909c864de
SIZE (DirectFB-1.4.17.tar.gz) = 3346983
Loading

0 comments on commit 5460a99

Please sign in to comment.