Skip to content

Commit

Permalink
*/*: sync with upstream
Browse files Browse the repository at this point in the history
Taken from: FreeBSD
  • Loading branch information
fichtner committed Jun 12, 2015
1 parent 6f1f7b9 commit 5d07420
Show file tree
Hide file tree
Showing 263 changed files with 6,730 additions and 813 deletions.
9 changes: 2 additions & 7 deletions archivers/dpkg/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -2,8 +2,7 @@
# $FreeBSD$

PORTNAME= dpkg
PORTVERSION= 1.18.0
PORTREVISION= 1
PORTVERSION= 1.18.1
CATEGORIES= archivers sysutils
MASTER_SITES= DEBIAN_POOL
DISTNAME= dpkg_${PORTVERSION}
Expand All @@ -29,7 +28,7 @@ SUB_FILES= pkg-install pkg-deinstall
SUB_LIST+= DPKGDIR=${DPKGDIR}

CONFIGURE_ARGS+=--with-admindir=${DPKGDIR} --libdir=${PREFIX}/libexec \
--program-transform-name="" --with-libintl-prefix=${LOCALBASE} \
--with-libintl-prefix=${LOCALBASE} \
--with-logdir=/var/log
CONFIGURE_ENV+= PERL_LIBDIR="${PREFIX}/${SITE_PERL_REL}"

Expand All @@ -39,10 +38,6 @@ OPTIONS_SUB= yes
NLS_CONFIGURE_ENABLE= nls
NLS_USES= gettext

post-patch:
@${REINPLACE_CMD} '/^LDFLAGS/ s|$$| -lmd|' \
${WRKSRC}/lib/dpkg/Makefile.in

post-install:
(cd ${STAGEDIR}${DPKGDIR} && ${MKDIR} available diversions \
statoverride status)
Expand Down
4 changes: 2 additions & 2 deletions archivers/dpkg/distinfo
Original file line number Diff line number Diff line change
@@ -1,2 +1,2 @@
SHA256 (dpkg_1.18.0.tar.xz) = 7b156fbeed5bbfb8aa546a18badb46e471b65fa00777ccd8d7e3bbce002f225a
SIZE (dpkg_1.18.0.tar.xz) = 4330304
SHA256 (dpkg_1.18.1.tar.xz) = cb26a97ca21c970cbe63a762125fe21f7437663badf6ce686589fe62650399da
SIZE (dpkg_1.18.1.tar.xz) = 4340240
2 changes: 1 addition & 1 deletion archivers/dpkg/files/patch-lib_compat_gettext.h
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
--- lib/compat/gettext.h.orig 2015-05-07 18:40:12 UTC
--- lib/compat/gettext.h.orig 2015-05-03 14:52:33 UTC
+++ lib/compat/gettext.h
@@ -53,7 +53,6 @@
<libintl.h>, which chokes if dcgettext is defined as a macro. So include
Expand Down
11 changes: 11 additions & 0 deletions archivers/dpkg/files/patch-scripts_Dpkg_Compression.pm
Original file line number Diff line number Diff line change
@@ -0,0 +1,11 @@
--- scripts/Dpkg/Compression.pm.orig 2015-06-11 20:28:56 UTC
+++ scripts/Dpkg/Compression.pm
@@ -55,7 +55,7 @@ interact with the set of supported compr
my $COMP = {
gzip => {
file_ext => 'gz',
- comp_prog => [ 'gzip', '--no-name', '--rsyncable' ],
+ comp_prog => [ 'gzip', '--no-name' ],
decomp_prog => [ 'gunzip' ],
default_level => 9,
},
1 change: 1 addition & 0 deletions audio/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -433,6 +433,7 @@
SUBDIR += linux-laudio
SUBDIR += linux-mbrola
SUBDIR += linux-neroaaccodec
SUBDIR += linux-skype_oss_wrapper
SUBDIR += linuxsampler
SUBDIR += listener
SUBDIR += lmms
Expand Down
4 changes: 2 additions & 2 deletions audio/boodler/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,7 @@

PORTNAME= boodler
PORTVERSION= 1.5.3
PORTREVISION= 4
PORTREVISION= 5
CATEGORIES= audio
MASTER_SITES= http://www.eblong.com/zarf/boodler/
DISTFILES= boodler-153.tar.gz boodler-snd-021902.tar.gz
Expand All @@ -23,7 +23,7 @@ CONFIGURE_SCRIPT= configure.py
CONFIGURE_ARGS= --include ${LOCALBASE}/include --lib ${LOCALBASE}/lib
WRKSRC= ${WRKDIR}/${PORTNAME}

SHEBANG_FILES= ${CONFIGURE_SCRIPT}
SHEBANG_FILES= ${CONFIGURE_SCRIPT} boodler.py
python_CMD= ${PYTHON_CMD}
SUB_FILES= boodler-wrapper
SUB_LIST= PYTHON_CMD=${PYTHON_CMD}
Expand Down
17 changes: 17 additions & 0 deletions audio/last.fm/files/patch-src_src.pro
Original file line number Diff line number Diff line change
@@ -0,0 +1,17 @@
--- src/src.pro.orig 2010-10-11 17:11:16 UTC
+++ src/src.pro
@@ -4,13 +4,7 @@ QT += gui network xml sql

INCLUDEPATH += lib libFingerprint/recommendation-commons

-PRECOMPILED_HEADER = precompiled.h
-CONFIG += precompile_header
-
-unix {
- # precompiled headers breaks icecream builds for some reason :(
- system( test `ps aux | grep iceccd | wc -l` -gt 1 ): CONFIG -= precompile_header
-}
+CONFIG -= precompile_header

#universal binaries cannot be built from precompiled headers
mac:release:CONFIG -= precompile_header
19 changes: 13 additions & 6 deletions audio/libgpod/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,7 @@

PORTNAME= libgpod
PORTVERSION= 0.8.3
PORTREVISION= 3
PORTREVISION= 4
CATEGORIES= audio
MASTER_SITES= SF/gtkpod/${PORTNAME}/${PORTNAME}-${PORTVERSION:R}

Expand All @@ -25,16 +25,24 @@ CONFIGURE_ARGS= --disable-udev --without-hal \
USE_CSTD= gnu89
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes

OPTIONS_DEFINE= DOCS IMOBILE MONO PYTHON
OPTIONS_DEFINE= DOCS IMOBILE PYTHON # MONO
OPTIONS_DEFAULT=IMOBILE
OPTIONS_SUB= yes

IMOBILE_DESC= Apple iPhone/iPod Touch support

IMOBILE_LIB_DEPENDS= libimobiledevice.so:${PORTSDIR}/comms/libimobiledevice
IMOBILE_CONFIGURE_ENV= LIBUSB_CFLAGS=" " LIBUSB_LIBS="-lusb"
IMOBILE_CONFIGURE_WITH= libimobiledevice

# Mono 4+ doesn't seem to be supported.
MONO_USE= GNOME=gtksharp20
MONO_CONFIGURE_WITH= mono
CONFIGURE_ARGS+= --without-mono
PLIST_SUB+= MONO="@comment "

PYTHON_BUILD_DEPENDS= swig2.0:${PORTSDIR}/devel/swig20 \
${PYTHON_SITELIBDIR}/mutagen/__init__.py:${PORTSDIR}/audio/py-mutagen
Expand All @@ -50,10 +58,6 @@ PORTDOCS= ChangeLog NEWS README*

.if ${PORT_OPTIONS:MIMOBILE}
COMMENT:= ${COMMENT:S,iPod,&/iPhone,}
LIB_DEPENDS+= libimobiledevice.so:${PORTSDIR}/comms/libimobiledevice
CONFIGURE_ENV+= LIBUSB_CFLAGS=" " LIBUSB_LIBS="-lusb"
.else
CONFIGURE_ARGS+=--without-libimobiledevice
.endif

post-patch:
Expand All @@ -62,6 +66,9 @@ post-patch:
${WRKSRC}/tools/Makefile.in

post-install:
.if ! ${PORT_OPTIONS:MMONO}
@${RM} ${STAGEDIR}${PREFIX}/libdata/pkgconfig/libgpod-sharp.pc
.endif
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}

.include <bsd.port.mk>
2 changes: 1 addition & 1 deletion audio/libgpod/pkg-descr
Original file line number Diff line number Diff line change
Expand Up @@ -11,4 +11,4 @@ libgpod supports playlists, smart playlists, playcounts, ratings,
podcasts, cover art, audio and video. Photo support is implemented as
well. Python and Mono bindings are optionally available too.

WWW: http://www.gtkpod.org/libgpod.html
WWW: http://www.gtkpod.org/wiki/Libgpod
2 changes: 1 addition & 1 deletion audio/linux-c6-pulseaudio-libs/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -11,7 +11,7 @@ COMMENT= Libraries for PulseAudio clients (Linux CentOS ${LINUX_DIST_VER})

USE_LINUX= c6
USE_LINUX_RPM= yes
USE_LINUX_APPS= dbuslibs libasyncns libsndfile xorglibs
USE_LINUX_APPS= dbuslibs libasyncns libsndfile tcp_wrappers-libs xorglibs

RPMVERSION= 17.el6
USE_LDCONFIG= yes
Expand Down
41 changes: 41 additions & 0 deletions audio/linux-skype_oss_wrapper/Makefile
Original file line number Diff line number Diff line change
@@ -0,0 +1,41 @@
# Created by: Andriy Voskoboinyk <[email protected]>
# $FreeBSD$

PORTNAME= skype_oss_wrapper
PORTVERSION= 0.1.1
CATEGORIES= audio linux
PKGNAMEPREFIX= linux-

MAINTAINER= [email protected]
COMMENT= Partial PulseAudio API implementation using OSS backend

LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE

BUILD_DEPENDS= ${LINUXBASE}/usr/bin/gcc:${PORTSDIR}/devel/linux-c6-devtools

USE_GITHUB= yes
GH_ACCOUNT= s3erios
GH_TAGNAME= v${PORTVERSION}

USE_LINUX= yes
USE_LINUX_PREFIX= yes
# do not define USE_LDCONFIG, it's not for global use

ONLY_FOR_ARCHS= i386 amd64
PLIST_FILES= lib/skype_oss_wrapper/libpulse.so.0

LIB_DIR= ${PREFIX}/lib/${PORTNAME}

# hardcode compiler path
post-patch:
@${REINPLACE_CMD} -e 's|?= cc| = ${LINUXBASE}/usr/bin/gcc|' \
-e 's|$${CC}|${LINUXBASE}/usr/bin/gcc|' \
${WRKSRC}/Makefile

post-install:
@${RM} ${STAGEDIR}${PREFIX}/bin/skype_oss
@${RMDIR} ${STAGEDIR}${PREFIX}/bin
@${BRANDELF} -t Linux ${STAGEDIR}${LIB_DIR}/libpulse.so.0

.include <bsd.port.mk>
2 changes: 2 additions & 0 deletions audio/linux-skype_oss_wrapper/distinfo
Original file line number Diff line number Diff line change
@@ -0,0 +1,2 @@
SHA256 (s3erios-skype_oss_wrapper-0.1.1-v0.1.1_GH0.tar.gz) = 0106c7962eb39e68204f266e310eebb03e351aefe6cc1c7befe1a01fc43aeb92
SIZE (s3erios-skype_oss_wrapper-0.1.1-v0.1.1_GH0.tar.gz) = 12401
3 changes: 3 additions & 0 deletions audio/linux-skype_oss_wrapper/pkg-descr
Original file line number Diff line number Diff line change
@@ -0,0 +1,3 @@
A fake libpulse.so library that mimics pulseaudio behavior for skype

WWW: https://github.com/waterlaz/skype_oss_wrapper
4 changes: 3 additions & 1 deletion biology/lagan/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -3,6 +3,7 @@

PORTNAME= lagan
PORTVERSION= 2.0
PORTREVISION= 1
CATEGORIES= biology
MASTER_SITES= http://lagan.stanford.edu/lagan_web/
DISTNAME= ${PORTNAME}${PORTVERSION:S/.//}
Expand All @@ -12,8 +13,9 @@ COMMENT= Efficient tools for large-scale multiple alignments of genomic DNA

LICENSE= GPLv2

USES= perl5
USES= perl5 shebangfix
USE_PERL5= run
SHEBANG_FILES= slagan.pl
MAKE_JOBS_UNSAFE=yes

SUB_FILES= pkg-message
Expand Down
2 changes: 2 additions & 0 deletions cad/leocad/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -26,6 +26,8 @@ USE_QT4= moc_build rcc_build uic_build iconengines_run imageformats_run \
USE_GL= glut
USE_GNOME= gtk20

CXXFLAGS+= -include ${WRKSRC}/common/lc_global.h

PORTDOCS= CREDITS.txt README.txt
OPTIONS_DEFINE= DOCS

Expand Down
12 changes: 12 additions & 0 deletions cad/leocad/files/patch-leocad.pro
Original file line number Diff line number Diff line change
@@ -0,0 +1,12 @@
--- leocad.pro.orig 2014-01-30 23:26:55 UTC
+++ leocad.pro
@@ -7,8 +7,7 @@ greaterThan(QT_MAJOR_VERSION, 4) {
}

INCLUDEPATH += qt common
-CONFIG += precompile_header incremental
-PRECOMPILED_HEADER = common/lc_global.h
+CONFIG += incremental
win32 {
QMAKE_CXXFLAGS_WARN_ON += -wd4100
DEFINES += _CRT_SECURE_NO_WARNINGS _CRT_SECURE_NO_DEPRECATE=1 _CRT_NONSTDC_NO_WARNINGS=1
1 change: 1 addition & 0 deletions cad/leocad/pkg-plist
Original file line number Diff line number Diff line change
Expand Up @@ -20,3 +20,4 @@ share/icons/hicolor/scalable/mimetypes/application-vnd.leocad.svg
%%DATADIR%%/library.bin
share/mime/packages/leocad.xml
share/pixmaps/leocad.png
@comment @dir share/icons/hicolor/scalable/apps
4 changes: 2 additions & 2 deletions comms/libimobiledevice/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
# $FreeBSD$

PORTNAME= libimobiledevice
PORTVERSION= 1.1.6
PORTVERSION= 1.2.0
PORTREVISION?= 0
CATEGORIES?= comms
MASTER_SITES= http://www.${PORTNAME}.org/downloads/
Expand Down Expand Up @@ -38,7 +38,7 @@ OPTIONS_DEFINE= DOCS

post-patch:
@${REINPLACE_CMD} -e 's, *@ssl_requires@,,' \
${WRKSRC}/${PORTNAME}*.pc.in
${WRKSRC}/src/${PORTNAME}*.pc.in

post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
Expand Down
4 changes: 2 additions & 2 deletions comms/libimobiledevice/distinfo
Original file line number Diff line number Diff line change
@@ -1,2 +1,2 @@
SHA256 (libimobiledevice-1.1.6.tar.bz2) = 1fcd56489a27181617507b1d8aaf122f66d9860c0fe5af4c78f9e0ed129e33e0
SIZE (libimobiledevice-1.1.6.tar.bz2) = 619429
SHA256 (libimobiledevice-1.2.0.tar.bz2) = 786b0de0875053bf61b5531a86ae8119e320edab724fc62fe2150cc931f11037
SIZE (libimobiledevice-1.2.0.tar.bz2) = 631495
10 changes: 8 additions & 2 deletions comms/libimobiledevice/pkg-plist
Original file line number Diff line number Diff line change
Expand Up @@ -3,17 +3,20 @@ bin/idevicebackup
bin/idevicebackup2
bin/idevicecrashreport
bin/idevicedate
bin/idevicedebug
bin/idevicedebugserverproxy
bin/idevicediagnostics
bin/ideviceenterrecovery
bin/ideviceimagemounter
bin/ideviceinfo
bin/idevicename
bin/idevicenotificationproxy
bin/idevicepair
bin/ideviceprovision
bin/idevicescreenshot
bin/idevicesyslog
include/libimobiledevice/afc.h
include/libimobiledevice/debugserver.h
include/libimobiledevice/diagnostics_relay.h
include/libimobiledevice/file_relay.h
include/libimobiledevice/heartbeat.h
Expand All @@ -27,6 +30,7 @@ include/libimobiledevice/mobilebackup.h
include/libimobiledevice/mobilebackup2.h
include/libimobiledevice/mobilesync.h
include/libimobiledevice/notification_proxy.h
include/libimobiledevice/property_list_service.h
include/libimobiledevice/restore.h
include/libimobiledevice/sbservices.h
include/libimobiledevice/screenshotr.h
Expand All @@ -35,20 +39,22 @@ include/libimobiledevice/syslog_relay.h
include/libimobiledevice/webinspector.h
lib/libimobiledevice.a
lib/libimobiledevice.so
lib/libimobiledevice.so.4
lib/libimobiledevice.so.4.0.1
lib/libimobiledevice.so.6
lib/libimobiledevice.so.6.0.0
libdata/pkgconfig/libimobiledevice-1.0.pc
man/man1/idevice_id.1.gz
man/man1/idevicebackup.1.gz
man/man1/idevicebackup2.1.gz
man/man1/idevicecrashreport.1.gz
man/man1/idevicedate.1.gz
man/man1/idevicedebug.1.gz
man/man1/idevicedebugserverproxy.1.gz
man/man1/idevicediagnostics.1.gz
man/man1/ideviceenterrecovery.1.gz
man/man1/ideviceimagemounter.1.gz
man/man1/ideviceinfo.1.gz
man/man1/idevicename.1.gz
man/man1/idevicenotificationproxy.1.gz
man/man1/idevicepair.1.gz
man/man1/ideviceprovision.1.gz
man/man1/idevicescreenshot.1.gz
Expand Down
2 changes: 1 addition & 1 deletion comms/libusbmuxd/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
# $FreeBSD$

PORTNAME= libusbmuxd
PORTVERSION= 1.0.9
PORTVERSION= 1.0.10
CATEGORIES= comms
MASTER_SITES= http://www.libimobiledevice.org/downloads/

Expand Down
4 changes: 2 additions & 2 deletions comms/libusbmuxd/distinfo
Original file line number Diff line number Diff line change
@@ -1,2 +1,2 @@
SHA256 (libusbmuxd-1.0.9.tar.bz2) = 2e3f708a3df30ad7832d2d2389eeb29f68f4e4488a42a20149cc99f4f9223dfc
SIZE (libusbmuxd-1.0.9.tar.bz2) = 265940
SHA256 (libusbmuxd-1.0.10.tar.bz2) = 1aa21391265d2284ac3ccb7cf278126d10d354878589905b35e8102104fec9f2
SIZE (libusbmuxd-1.0.10.tar.bz2) = 292649
2 changes: 1 addition & 1 deletion comms/libusbmuxd/pkg-descr
Original file line number Diff line number Diff line change
Expand Up @@ -6,4 +6,4 @@ listening localhost socket on the device.

This package contains the usbmuxd communication interface library.

WWW: http://marcansoft.com/blog/iphonelinux/usbmuxd
WWW: http://www.libimobiledevice.org
4 changes: 2 additions & 2 deletions comms/libusbmuxd/pkg-plist
Original file line number Diff line number Diff line change
Expand Up @@ -3,6 +3,6 @@ include/usbmuxd-proto.h
include/usbmuxd.h
lib/libusbmuxd.a
lib/libusbmuxd.so
lib/libusbmuxd.so.2
lib/libusbmuxd.so.2.1.0
lib/libusbmuxd.so.4
lib/libusbmuxd.so.4.0.0
libdata/pkgconfig/libusbmuxd.pc
Loading

0 comments on commit 5d07420

Please sign in to comment.