Skip to content

Commit

Permalink
*/*: sync with upstream
Browse files Browse the repository at this point in the history
Taken from: FreeBSD
  • Loading branch information
fichtner committed Jul 27, 2015
1 parent 83ce16f commit 989b7d0
Show file tree
Hide file tree
Showing 431 changed files with 11,829 additions and 9,037 deletions.
4 changes: 4 additions & 0 deletions archivers/py-attic/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -31,6 +31,10 @@ BUILD_DEPENDS+= openssl>=1.0:${PORTSDIR}/security/openssl
RUN_DEPENDS+= openssl>=1.0:${PORTSDIR}/security/openssl
.endif

.if defined(PACKAGE_BUILDING) && ${PYTHON_VER} != ${PYTHON_DEFAULT}
IGNORE= you have python ${PYTHON_DEFAULT} set as the default, and this needs ${PYTHON_VER}
.endif

regression-test: build
${SETENV} PYTHONPATH="${PYDISTUTILS_BUILDPATH}:${PYTHONPATH}" \
${PYTHON_CMD} -m attic.testsuite.run
Expand Down
2 changes: 1 addition & 1 deletion audio/aubio/files/patch-wscript
Original file line number Diff line number Diff line change
Expand Up @@ -25,7 +25,7 @@

# build documentation from source files using doxygen
- if bld.env['DOXYGEN']:
+ if bld.env['DOXYGEN'] and not ctx.options.disable_doxygen:
+ if bld.env['DOXYGEN'] and not bld.options.disable_doxygen:
bld( name = 'doxygen', rule = 'doxygen ${SRC} > /dev/null',
source = 'doc/web.cfg',
cwd = 'doc')
Expand Down
2 changes: 1 addition & 1 deletion benchmarks/rubygem-benchmark-ips/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -2,7 +2,7 @@
# $FreeBSD$

PORTNAME= benchmark-ips
PORTVERSION= 2.2.0
PORTVERSION= 2.3.0
CATEGORIES= benchmarks rubygems
MASTER_SITES= RG

Expand Down
4 changes: 2 additions & 2 deletions benchmarks/rubygem-benchmark-ips/distinfo
Original file line number Diff line number Diff line change
@@ -1,2 +1,2 @@
SHA256 (rubygem/benchmark-ips-2.2.0.gem) = 293d5c718c357ba48470868fb9222e610ccb55f3d53d1a61501e276fd8bce631
SIZE (rubygem/benchmark-ips-2.2.0.gem) = 14848
SHA256 (rubygem/benchmark-ips-2.3.0.gem) = 12443aa327d3129aa965244f79d7d5cb0f692f0f92ba7db76fba61526a40062e
SIZE (rubygem/benchmark-ips-2.3.0.gem) = 15360
4 changes: 2 additions & 2 deletions biology/phylip/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Created by: [email protected]
# Created by: David A. Bader <[email protected]>
# $FreeBSD$

PORTNAME= phylip
Expand All @@ -11,7 +11,7 @@ MAINTAINER= [email protected]
COMMENT= Phylogeny Inference Package

LICENSE= BSD2CLAUSE
LICENSE_FILES= ${WRKSRC}/COPYRIGHT
LICENSE_FILE= ${WRKSRC}/COPYRIGHT

BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash

Expand Down
29 changes: 9 additions & 20 deletions comms/gnuradio/Makefile
Original file line number Diff line number Diff line change
@@ -1,8 +1,7 @@
# $FreeBSD$

PORTNAME= gnuradio
PORTVERSION= 3.7.4
PORTREVISION= 3
PORTVERSION= 3.7.7.1
CATEGORIES= comms astro hamradio
MASTER_SITES= http://gnuradio.org/releases/gnuradio/ \
LOCAL/db
Expand All @@ -19,7 +18,6 @@ BUILD_DEPENDS= sdl-config:${PORTSDIR}/devel/sdl12 \
${PYTHON_PKGNAMEPREFIX}qt4>0:${PORTSDIR}/devel/py-qt4 \
xdg-open:${PORTSDIR}/devel/xdg-utils \
guile:${PORTSDIR}/lang/guile \
icebox:${PORTSDIR}/devel/ice \
aconnect:${PORTSDIR}/audio/alsa-utils \
git:${PORTSDIR}/devel/git \
${PYNUMPY} \
Expand All @@ -35,25 +33,25 @@ LIB_DEPENDS= libcppunit.so:${PORTSDIR}/devel/cppunit \
libgsl.so:${PORTSDIR}/math/gsl
RUN_DEPENDS:= ${BUILD_DEPENDS}

BROKEN_FreeBSD_9= does not build on FreeBSD 9.x

USES= iconv cmake:outsource perl5 python:2.7 shebangfix
USES= cmake:outsource iconv perl5 python:2.7 shebangfix
SHEBANG_FILES= grc/freedesktop/grc_setup_freedesktop.in
CMAKE_ENV+= LD_PRELOAD="${GCC_LIBS}/libstdc++.so:${GCC_LIBS}/libgcc_s.so.1"
CMAKE_ENV+= LD_PRELOAD="${GCC_LIBS}/libstdc++.so:${GCC_LIBS}/libgcc_s.so.1"
CMAKE_ARGS+= -DSWIG_EXECUTABLE:STRING="${LOCALBASE}/bin/swig2.0"
CMAKE_ARGS+= -DICONV_PREFIX:STRING="${ICONV_PREFIX}" \
-DICONV_LIB:STRING="X${ICONV_LIB}" \
-DICE_CONFIG_INCLUDE_DIR="${LOCALBASE}/include/"
# for detailed debugging uncomment the next line
-DENABLE_GR_CTRLPORT="YES"
# for detailed debugging uncomment the next two lines as needed
#CMAKE_ARGS+= --debug-output --trace
DOCSDIR= share/doc/${PORTNAME}-${PORTVERSION}
MAJOR_SUB_VER= 3.7.7
DOCSDIR= share/doc/${PORTNAME}-${MAJOR_SUB_VER}
USE_GNOME= pygtk2
USE_GCC= yes
USE_WX= 3.0+
USE_QT4= gui xml qmake moc rcc uic
WX_COMPS= wx wx:build wx:run python:build python:run
USE_LDCONFIG= yes
PLIST_SUB+= MAJOR_VERSION="3"
PORTDOCS= *
PLIST_SUB+= MAJOR_SUB_VER="${MAJOR_SUB_VER}"

OPTIONS_DEFINE= USRP TESTING
# Unfortunately building docs on i386 fails
Expand All @@ -70,15 +68,6 @@ GCC_LIBS= ${LOCALBASE}/lib/gcc${VP}

.include <bsd.port.pre.mk>

# Only use port clang34 on 10 if not RELEASE. I think this should do it.
.if ${OSVERSION} <= 1000510 && ${OSVERSION} > 1000000
# Debug hack
#.if ${OSVERSION} <= 1200000
BUILD_DEPENDS+= clang34:${PORTSDIR}/lang/clang34
CC= clang34
CXX= clang++34
.endif

.if ${PORT_OPTIONS:MDOCS}
BUILD_DEPENDS+= doxygen:${PORTSDIR}/devel/doxygen \
${LOCALBASE}/bin/sphinx-apidoc:${PORTSDIR}/textproc/py-sphinx \
Expand Down
4 changes: 2 additions & 2 deletions comms/gnuradio/distinfo
Original file line number Diff line number Diff line change
@@ -1,2 +1,2 @@
SHA256 (gnuradio-3.7.4.tar.gz) = 681da0e8694cc88be2dc168756418f21fef3666231d7b21bcfd6cbddd9a9406d
SIZE (gnuradio-3.7.4.tar.gz) = 3461336
SHA256 (gnuradio-3.7.7.1.tar.gz) = 2b27b13fc734ab5882e42c1661d433c0c097fd8b55b682f00626fa96c356584e
SIZE (gnuradio-3.7.7.1.tar.gz) = 3845988
22 changes: 17 additions & 5 deletions comms/gnuradio/files/patch-CMakeLists.txt
Original file line number Diff line number Diff line change
@@ -1,6 +1,18 @@
--- CMakeLists.txt.orig 2014-07-08 17:32:11.000000000 -0400
+++ CMakeLists.txt 2014-07-29 18:41:58.000000000 -0400
@@ -139,6 +139,14 @@
--- CMakeLists.txt.orig 2015-05-12 09:39:44 UTC
+++ CMakeLists.txt
@@ -29,6 +29,11 @@ cmake_minimum_required(VERSION 2.6)
project(gnuradio CXX C)
enable_testing()

+cmake_policy(SET CMP0026 OLD)
+cmake_policy(SET CMP0043 OLD)
+cmake_policy(SET CMP0045 OLD)
+cmake_policy(SET CMP0046 OLD)
+
#make sure our local CMake Modules path comes first
list(INSERT CMAKE_MODULE_PATH 0 ${CMAKE_SOURCE_DIR}/cmake/Modules)

@@ -144,6 +149,14 @@ string(REPLACE "\n" " \\n" COMPILER_INFO
########################################################################
include(GrPlatform) #define LIB_SUFFIX
set(GR_RUNTIME_DIR bin)
Expand All @@ -15,7 +27,7 @@
set(GR_LIBRARY_DIR lib${LIB_SUFFIX})
set(GR_INCLUDE_DIR include)
set(GR_DATA_DIR share)
@@ -199,6 +207,42 @@
@@ -228,6 +241,42 @@ add_custom_target(uninstall
include(GrBoost)

########################################################################
Expand Down Expand Up @@ -58,7 +70,7 @@
# Enable python component
########################################################################
find_package(PythonLibs 2)
@@ -283,11 +327,13 @@
@@ -353,11 +402,13 @@ GR_LOGGING()
########################################################################
# Distribute the README file
########################################################################
Expand Down
82 changes: 51 additions & 31 deletions comms/gnuradio/files/patch-cmake_Modules_FindUSB.cmake
Original file line number Diff line number Diff line change
@@ -1,46 +1,66 @@
--- cmake/Modules/FindUSB.cmake.orig 2012-04-09 10:38:58.000000000 -0500
+++ cmake/Modules/FindUSB.cmake 2014-03-02 20:19:39.000000000 -0500
@@ -1,20 +1,38 @@
--- cmake/Modules/FindUSB.cmake.orig 2015-05-12 09:39:44 UTC
+++ cmake/Modules/FindUSB.cmake
@@ -1,20 +1,30 @@
if(NOT LIBUSB_FOUND)
- pkg_check_modules (LIBUSB_PKG libusb-1.0)
- find_path(LIBUSB_INCLUDE_DIR NAMES libusb.h
+ pkg_check_modules (LIBUSB_PKG libusb-1.0)
+
+ find_path(LIBUSB_INCLUDE_DIR NAMES libusb.h
PATHS
${LIBUSB_PKG_INCLUDE_DIRS}
/usr/include/libusb-1.0
/usr/include
- PATHS
- ${LIBUSB_PKG_INCLUDE_DIRS}
- /usr/include/libusb-1.0
- /usr/include
- /usr/local/include
)
+ message(status "--- LIBUSB_INCLUDE_DIR ${LIBUSB_INCLUDE_DIR}")
+
- )
-
- find_library(LIBUSB_LIBRARIES NAMES usb-1.0 usb
- PATHS
- ${LIBUSB_PKG_LIBRARY_DIRS}
- /usr/lib
- /usr/local/lib
- )
+ if(CMAKE_SYSTEM_NAME STREQUAL "FreeBSD")
+ message(status "--- Looking for FreeBSD usb")
+ find_library(LIBUSB_LIBRARIES NAMES usb
+ PATHS
+ ${LIBUSB_PKG_LIBRARY_DIRS}
+ /usr/lib
+ )
+
+ message(status "--- LIBUSB_LIBRARIES ${LIBUSB_LIBRARIES}")
+ else()
+ message(status "--- LIBUSB_LIBRARIES ${LIBUSB_LIBRARIES}")
+ pkg_check_modules (LIBUSB_PKG libusb-1.0)
+ find_path(LIBUSB_INCLUDE_DIR NAMES libusb.h
+ PATHS
+ ${LIBUSB_PKG_INCLUDE_DIRS}
+ /usr/include/libusb-1.0
+ /usr/include
+ /usr/local/include
+ )

- find_library(LIBUSB_LIBRARIES NAMES usb-1.0
+ CHECK_LIBRARY_EXISTS(${LIBUSB_LIBRARIES} "libusb_get_string_descriptor"
+ "/usr/lib" HAVE_LIBUSB_GET_STRING_DESCRIPTOR)
+ if (HAVE_LIBUSB_GET_STRING_DESCRIPTOR)
+ add_definitions( -DHAVE_LIBUSB_GET_STRING_DESCRIPTOR=${HAVE_LIBUSB_GET_STRING_DESCRIPTOR})
+ endif()
+ message(status "--- HAVE_LIBUSB_GET_STRING_DESCRIPTOR ${HAVE_LIBUSB_STRING_DESCRIPTOR}")
+ endif(CMAKE_SYSTEM_NAME STREQUAL "FreeBSD")
+
+ find_library(LIBUSB_LIBRARIES NAMES usb
PATHS
${LIBUSB_PKG_LIBRARY_DIRS}
/usr/lib
/usr/local/lib
)
-
+ find_library(LIBUSB_LIBRARIES NAMES usb-1.0 usb
+ PATHS
+ ${LIBUSB_PKG_LIBRARY_DIRS}
+ /usr/lib
+ /usr/local/lib
+ )
+ endif()
+
if(LIBUSB_INCLUDE_DIR AND LIBUSB_LIBRARIES)
set(LIBUSB_FOUND TRUE CACHE INTERNAL "libusb-1.0 found")
message(STATUS "Found libusb-1.0: ${LIBUSB_INCLUDE_DIR}, ${LIBUSB_LIBRARIES}")
@@ -23,6 +33,17 @@ else(LIBUSB_INCLUDE_DIR AND LIBUSB_LIBRA
message(STATUS "libusb-1.0 not found.")
endif(LIBUSB_INCLUDE_DIR AND LIBUSB_LIBRARIES)

+message(status "--- Checking for libusb_get_string_descriptor")
+set(CMAKE_REQUIRED_LIBRARIES ${LIBUSB_LIBRARIES})
+CHECK_FUNCTION_EXISTS(libusb_get_string_descriptor HAVE_LIBUSB_GET_STRING_DESCRIPTOR)
+
+if (HAVE_LIBUSB_GET_STRING_DESCRIPTOR)
+ add_definitions( -DHAVE_LIBUSB_GET_STRING_DESCRIPTOR)
+ message(status "--- Found libusb_get_string_descriptor")
+else()
+ message(status "--- libusb_get_string_descriptor Not Found")
+endif()
+
mark_as_advanced(LIBUSB_INCLUDE_DIR LIBUSB_LIBRARIES)

endif(NOT LIBUSB_FOUND)
6 changes: 3 additions & 3 deletions comms/gnuradio/files/patch-cmake_Modules_GrBoost.cmake
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
--- cmake/Modules/GrBoost.cmake.orig 2014-03-06 20:24:23.000000000 -0500
+++ cmake/Modules/GrBoost.cmake 2014-03-06 20:25:07.000000000 -0500
@@ -53,6 +53,8 @@
--- cmake/Modules/GrBoost.cmake.orig 2015-05-12 09:39:44 UTC
+++ cmake/Modules/GrBoost.cmake
@@ -53,6 +53,8 @@ if(MSVC)
endif(MSVC)

find_package(Boost "1.35" COMPONENTS ${BOOST_REQUIRED_COMPONENTS})
Expand Down
10 changes: 5 additions & 5 deletions comms/gnuradio/files/patch-cmake_Modules_GrMiscUtils.cmake
Original file line number Diff line number Diff line change
@@ -1,11 +1,11 @@
--- cmake/Modules/GrMiscUtils.cmake.orig 2014-07-07 17:29:01.000000000 -0400
+++ cmake/Modules/GrMiscUtils.cmake 2014-07-29 18:42:23.000000000 -0400
@@ -142,7 +142,31 @@
--- cmake/Modules/GrMiscUtils.cmake.orig 2015-05-12 09:39:44 UTC
+++ cmake/Modules/GrMiscUtils.cmake
@@ -148,7 +148,31 @@ function(GR_LIBRARY_FOO target)
ARCHIVE DESTINATION ${GR_LIBRARY_DIR} COMPONENT ${GR_LIBRARY_DEVEL_COMPONENT} # .lib file
RUNTIME DESTINATION ${GR_RUNTIME_DIR} COMPONENT ${GR_LIBRARY_RUNTIME_COMPONENT} # .dll file
)
+
+
+ if(CMAKE_SYSTEM_NAME STREQUAL "FreeBSD")
+ #create .la file
+ GR_LIBTOOL(TARGET ${target} DESTINATION ${GR_LIBRARY_DIR})
Expand All @@ -20,7 +20,7 @@
+ COMMAND ${CMAKE_COMMAND} -E create_symlink ${target_name} "${CMAKE_CURRENT_BINARY_DIR}/lib${target}.so.${MAJOR_VERSION}"
+ COMMAND ${CMAKE_COMMAND} -E touch ${target_name} #so the symlinks point to something valid so cmake 2.6 will install
+ )
+
+ #and install the extra symlinks
+ install(
+ FILES
Expand Down
8 changes: 4 additions & 4 deletions comms/gnuradio/files/patch-docs_doxygen_Doxyfile.in
Original file line number Diff line number Diff line change
@@ -1,11 +1,11 @@
--- docs/doxygen/Doxyfile.in.orig 2014-03-31 11:52:54.000000000 -0400
+++ docs/doxygen/Doxyfile.in 2014-07-29 18:42:29.000000000 -0400
@@ -1839,7 +1839,7 @@
--- docs/doxygen/Doxyfile.in.orig 2015-05-12 09:39:44 UTC
+++ docs/doxygen/Doxyfile.in
@@ -1864,7 +1864,7 @@ DOT_FONTSIZE = 10
# If you specify a different font using DOT_FONTNAME you can use DOT_FONTPATH to
# set the path where dot can find it.

-DOT_FONTPATH =
+DOT_FONTPATH = %%PREFIX%%/share/fonts/freefont-ttf
+DOT_FONTPATH = /usr/local/share/fonts/freefont-ttf

# If the CLASS_GRAPH and HAVE_DOT tags are set to YES then doxygen
# will generate a graph for each documented class showing the direct and
44 changes: 3 additions & 41 deletions comms/gnuradio/files/patch-gnuradio-runtime_CMakeLists.txt
Original file line number Diff line number Diff line change
@@ -1,44 +1,6 @@
--- gnuradio-runtime/CMakeLists.txt.orig 2014-07-02 21:09:41.000000000 -0400
+++ gnuradio-runtime/CMakeLists.txt 2014-07-29 18:42:32.000000000 -0400
@@ -141,18 +141,37 @@
${CMAKE_CURRENT_BINARY_DIR}/gnuradio-runtime.conf
@ONLY)

+if(CMAKE_SYSTEM_NAME STREQUAL "FreeBSD")
+ install(
+ FILES ${CMAKE_CURRENT_BINARY_DIR}/gnuradio-runtime.conf
+ DESTINATION ${GR_PREFSDIR}
+ RENAME "gnuradio-runtime.conf.sample"
+ COMPONENT "runtime_runtime"
+ )
+else()
install(
FILES ${CMAKE_CURRENT_BINARY_DIR}/gnuradio-runtime.conf
DESTINATION ${GR_PREFSDIR}
COMPONENT "runtime_runtime"
)
+endif()

if(ENABLE_GR_LOG AND HAVE_LOG4CPP)
+if(CMAKE_SYSTEM_NAME STREQUAL "FreeBSD")
install(FILES
${CMAKE_CURRENT_SOURCE_DIR}/gr_log_default.conf
DESTINATION ${GR_CONF_DIR}/gnuradio
+ RENAME "gr_log_default.conf.sample"
COMPONENT "runtime_runtime"
)
+else()
+install(FILES
+ ${CMAKE_CURRENT_SOURCE_DIR}/gr_log_default.conf
+ DESTINATION ${GR_CONF_DIR}/gnuradio
+ COMPONENT "runtime_runtime"
+)
+endif()
+
endif(ENABLE_GR_LOG AND HAVE_LOG4CPP)

########################################################################
@@ -179,7 +198,7 @@
--- gnuradio-runtime/CMakeLists.txt.orig 2015-05-12 09:39:44 UTC
+++ gnuradio-runtime/CMakeLists.txt
@@ -165,7 +165,7 @@ configure_file(

install(
FILES ${CMAKE_CURRENT_BINARY_DIR}/gnuradio-runtime.pc
Expand Down
12 changes: 6 additions & 6 deletions comms/gnuradio/files/patch-gnuradio-runtime_lib_thread_thread.cc
Original file line number Diff line number Diff line change
@@ -1,30 +1,30 @@
--- gnuradio-runtime/lib/thread/thread.cc.orig 2014-07-08 16:55:12.000000000 -0400
+++ gnuradio-runtime/lib/thread/thread.cc 2014-07-29 18:42:37.000000000 -0400
@@ -276,6 +276,7 @@
--- gnuradio-runtime/lib/thread/thread.cc.orig 2015-05-12 09:39:44 UTC
+++ gnuradio-runtime/lib/thread/thread.cc
@@ -276,6 +276,7 @@ namespace gr {
void
thread_bind_to_processor(gr_thread_t thread, const std::vector<int> &mask)
{
+#ifdef _GNU_SOURCE
cpu_set_t set;
size_t len = sizeof(cpu_set_t);
std::vector<int> _mask = mask;
@@ -291,6 +292,7 @@
@@ -291,6 +292,7 @@ namespace gr {
s << "thread_bind_to_processor failed with error: " << ret << std::endl;
throw std::runtime_error(s.str());
}
+#endif
}

void
@@ -302,6 +304,7 @@
@@ -302,6 +304,7 @@ namespace gr {
void
thread_unbind(gr_thread_t thread)
{
+#ifdef _GNU_SOURCE
cpu_set_t set;
size_t len = sizeof(cpu_set_t);

@@ -317,6 +320,7 @@
@@ -317,6 +320,7 @@ namespace gr {
s << "thread_unbind failed with error: " << ret << std::endl;
throw std::runtime_error(s.str());
}
Expand Down
Loading

0 comments on commit 989b7d0

Please sign in to comment.