forked from opnsense/ports
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Taken from: FreeBSD
- Loading branch information
Showing
431 changed files
with
11,829 additions
and
9,037 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,2 @@ | ||
SHA256 (rubygem/benchmark-ips-2.2.0.gem) = 293d5c718c357ba48470868fb9222e610ccb55f3d53d1a61501e276fd8bce631 | ||
SIZE (rubygem/benchmark-ips-2.2.0.gem) = 14848 | ||
SHA256 (rubygem/benchmark-ips-2.3.0.gem) = 12443aa327d3129aa965244f79d7d5cb0f692f0f92ba7db76fba61526a40062e | ||
SIZE (rubygem/benchmark-ips-2.3.0.gem) = 15360 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,4 +1,4 @@ | ||
# Created by: [email protected] | ||
# Created by: David A. Bader <[email protected]> | ||
# $FreeBSD$ | ||
|
||
PORTNAME= phylip | ||
|
@@ -11,7 +11,7 @@ MAINTAINER= [email protected] | |
COMMENT= Phylogeny Inference Package | ||
|
||
LICENSE= BSD2CLAUSE | ||
LICENSE_FILES= ${WRKSRC}/COPYRIGHT | ||
LICENSE_FILE= ${WRKSRC}/COPYRIGHT | ||
|
||
BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash | ||
|
||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,2 @@ | ||
SHA256 (gnuradio-3.7.4.tar.gz) = 681da0e8694cc88be2dc168756418f21fef3666231d7b21bcfd6cbddd9a9406d | ||
SIZE (gnuradio-3.7.4.tar.gz) = 3461336 | ||
SHA256 (gnuradio-3.7.7.1.tar.gz) = 2b27b13fc734ab5882e42c1661d433c0c097fd8b55b682f00626fa96c356584e | ||
SIZE (gnuradio-3.7.7.1.tar.gz) = 3845988 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,46 +1,66 @@ | ||
--- cmake/Modules/FindUSB.cmake.orig 2012-04-09 10:38:58.000000000 -0500 | ||
+++ cmake/Modules/FindUSB.cmake 2014-03-02 20:19:39.000000000 -0500 | ||
@@ -1,20 +1,38 @@ | ||
--- cmake/Modules/FindUSB.cmake.orig 2015-05-12 09:39:44 UTC | ||
+++ cmake/Modules/FindUSB.cmake | ||
@@ -1,20 +1,30 @@ | ||
if(NOT LIBUSB_FOUND) | ||
- pkg_check_modules (LIBUSB_PKG libusb-1.0) | ||
- find_path(LIBUSB_INCLUDE_DIR NAMES libusb.h | ||
+ pkg_check_modules (LIBUSB_PKG libusb-1.0) | ||
+ | ||
+ find_path(LIBUSB_INCLUDE_DIR NAMES libusb.h | ||
PATHS | ||
${LIBUSB_PKG_INCLUDE_DIRS} | ||
/usr/include/libusb-1.0 | ||
/usr/include | ||
- PATHS | ||
- ${LIBUSB_PKG_INCLUDE_DIRS} | ||
- /usr/include/libusb-1.0 | ||
- /usr/include | ||
- /usr/local/include | ||
) | ||
+ message(status "--- LIBUSB_INCLUDE_DIR ${LIBUSB_INCLUDE_DIR}") | ||
+ | ||
- ) | ||
- | ||
- find_library(LIBUSB_LIBRARIES NAMES usb-1.0 usb | ||
- PATHS | ||
- ${LIBUSB_PKG_LIBRARY_DIRS} | ||
- /usr/lib | ||
- /usr/local/lib | ||
- ) | ||
+ if(CMAKE_SYSTEM_NAME STREQUAL "FreeBSD") | ||
+ message(status "--- Looking for FreeBSD usb") | ||
+ find_library(LIBUSB_LIBRARIES NAMES usb | ||
+ PATHS | ||
+ ${LIBUSB_PKG_LIBRARY_DIRS} | ||
+ /usr/lib | ||
+ ) | ||
+ | ||
+ message(status "--- LIBUSB_LIBRARIES ${LIBUSB_LIBRARIES}") | ||
+ else() | ||
+ message(status "--- LIBUSB_LIBRARIES ${LIBUSB_LIBRARIES}") | ||
+ pkg_check_modules (LIBUSB_PKG libusb-1.0) | ||
+ find_path(LIBUSB_INCLUDE_DIR NAMES libusb.h | ||
+ PATHS | ||
+ ${LIBUSB_PKG_INCLUDE_DIRS} | ||
+ /usr/include/libusb-1.0 | ||
+ /usr/include | ||
+ /usr/local/include | ||
+ ) | ||
|
||
- find_library(LIBUSB_LIBRARIES NAMES usb-1.0 | ||
+ CHECK_LIBRARY_EXISTS(${LIBUSB_LIBRARIES} "libusb_get_string_descriptor" | ||
+ "/usr/lib" HAVE_LIBUSB_GET_STRING_DESCRIPTOR) | ||
+ if (HAVE_LIBUSB_GET_STRING_DESCRIPTOR) | ||
+ add_definitions( -DHAVE_LIBUSB_GET_STRING_DESCRIPTOR=${HAVE_LIBUSB_GET_STRING_DESCRIPTOR}) | ||
+ endif() | ||
+ message(status "--- HAVE_LIBUSB_GET_STRING_DESCRIPTOR ${HAVE_LIBUSB_STRING_DESCRIPTOR}") | ||
+ endif(CMAKE_SYSTEM_NAME STREQUAL "FreeBSD") | ||
+ | ||
+ find_library(LIBUSB_LIBRARIES NAMES usb | ||
PATHS | ||
${LIBUSB_PKG_LIBRARY_DIRS} | ||
/usr/lib | ||
/usr/local/lib | ||
) | ||
- | ||
+ find_library(LIBUSB_LIBRARIES NAMES usb-1.0 usb | ||
+ PATHS | ||
+ ${LIBUSB_PKG_LIBRARY_DIRS} | ||
+ /usr/lib | ||
+ /usr/local/lib | ||
+ ) | ||
+ endif() | ||
+ | ||
if(LIBUSB_INCLUDE_DIR AND LIBUSB_LIBRARIES) | ||
set(LIBUSB_FOUND TRUE CACHE INTERNAL "libusb-1.0 found") | ||
message(STATUS "Found libusb-1.0: ${LIBUSB_INCLUDE_DIR}, ${LIBUSB_LIBRARIES}") | ||
@@ -23,6 +33,17 @@ else(LIBUSB_INCLUDE_DIR AND LIBUSB_LIBRA | ||
message(STATUS "libusb-1.0 not found.") | ||
endif(LIBUSB_INCLUDE_DIR AND LIBUSB_LIBRARIES) | ||
|
||
+message(status "--- Checking for libusb_get_string_descriptor") | ||
+set(CMAKE_REQUIRED_LIBRARIES ${LIBUSB_LIBRARIES}) | ||
+CHECK_FUNCTION_EXISTS(libusb_get_string_descriptor HAVE_LIBUSB_GET_STRING_DESCRIPTOR) | ||
+ | ||
+if (HAVE_LIBUSB_GET_STRING_DESCRIPTOR) | ||
+ add_definitions( -DHAVE_LIBUSB_GET_STRING_DESCRIPTOR) | ||
+ message(status "--- Found libusb_get_string_descriptor") | ||
+else() | ||
+ message(status "--- libusb_get_string_descriptor Not Found") | ||
+endif() | ||
+ | ||
mark_as_advanced(LIBUSB_INCLUDE_DIR LIBUSB_LIBRARIES) | ||
|
||
endif(NOT LIBUSB_FOUND) |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,11 +1,11 @@ | ||
--- docs/doxygen/Doxyfile.in.orig 2014-03-31 11:52:54.000000000 -0400 | ||
+++ docs/doxygen/Doxyfile.in 2014-07-29 18:42:29.000000000 -0400 | ||
@@ -1839,7 +1839,7 @@ | ||
--- docs/doxygen/Doxyfile.in.orig 2015-05-12 09:39:44 UTC | ||
+++ docs/doxygen/Doxyfile.in | ||
@@ -1864,7 +1864,7 @@ DOT_FONTSIZE = 10 | ||
# If you specify a different font using DOT_FONTNAME you can use DOT_FONTPATH to | ||
# set the path where dot can find it. | ||
|
||
-DOT_FONTPATH = | ||
+DOT_FONTPATH = %%PREFIX%%/share/fonts/freefont-ttf | ||
+DOT_FONTPATH = /usr/local/share/fonts/freefont-ttf | ||
|
||
# If the CLASS_GRAPH and HAVE_DOT tags are set to YES then doxygen | ||
# will generate a graph for each documented class showing the direct and |
44 changes: 3 additions & 41 deletions
44
comms/gnuradio/files/patch-gnuradio-runtime_CMakeLists.txt
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
12 changes: 6 additions & 6 deletions
12
comms/gnuradio/files/patch-gnuradio-runtime_lib_thread_thread.cc
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Oops, something went wrong.