Skip to content

Commit

Permalink
*/*: sync with upstream
Browse files Browse the repository at this point in the history
Taken from: FreeBSD
  • Loading branch information
fichtner committed Apr 21, 2017
1 parent 169864c commit ada43ef
Show file tree
Hide file tree
Showing 246 changed files with 2,412 additions and 2,865 deletions.
5 changes: 3 additions & 2 deletions audio/jack_mixer/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,7 @@

PORTNAME= jack_mixer
PORTVERSION= 10
PORTREVISION= 2
PORTREVISION= 3
CATEGORIES= audio
MASTER_SITES= http://download.gna.org/${PORTNAME:S/_//}/

Expand All @@ -18,7 +18,8 @@ BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/fpconst.py:math/py-fpconst \
${LOCALBASE}/include/pygtk-2.0/pygtk/pygtk.h:x11-toolkits/py-gtk2
RUN_DEPENDS:= ${BUILD_DEPENDS}

USES= libtool pkgconfig python
USES= libtool pkgconfig python shebangfix
SHEBANG_FILES= jack_mixer.py
USE_GNOME= gconf2
GCONF_SCHEMAS= jack_mixer.schemas
INSTALLS_ICONS= yes
Expand Down
3 changes: 2 additions & 1 deletion audio/libsamplerate/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -12,8 +12,9 @@ COMMENT= Secret Rabbit Code: a Sample Rate Converter for audio
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYING

USES= libtool pathfix pkgconfig
USES= cpe libtool pathfix pkgconfig
USE_LDCONFIG= yes
CPE_VENDOR= ${CPE_PRODUCT}_project
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip

Expand Down
3 changes: 2 additions & 1 deletion audio/libsndfile/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -11,7 +11,8 @@ COMMENT= Reading and writing files containing sampled sound (like WAV or AIFF)

LICENSE= LGPL21

USES= gmake libtool localbase pkgconfig
USES= cpe gmake libtool localbase pkgconfig
CPE_VENDOR= ${CPE_PRODUCT}_project
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-gcc-pipe \
--disable-sqlite \
Expand Down
2 changes: 1 addition & 1 deletion benchmarks/stress-ng/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
# $FreeBSD$

PORTNAME= stress-ng
PORTVERSION= 0.07.28
PORTVERSION= 0.07.29
CATEGORIES= benchmarks
MASTER_SITES= http://kernel.ubuntu.com/~cking/tarballs/stress-ng/

Expand Down
6 changes: 3 additions & 3 deletions benchmarks/stress-ng/distinfo
Original file line number Diff line number Diff line change
@@ -1,3 +1,3 @@
TIMESTAMP = 1491220473
SHA256 (stress-ng-0.07.28.tar.gz) = e699f90ec1260eb5815fdaf7b7c410c7aa32f8802adad1eaa7a27260a97d7581
SIZE (stress-ng-0.07.28.tar.gz) = 373194
TIMESTAMP = 1492594338
SHA256 (stress-ng-0.07.29.tar.gz) = 71a9555d1d9ee0a4a9bca9ee14294289ee77e998a951c7071df6cc8e153d8410
SIZE (stress-ng-0.07.29.tar.gz) = 374341
10 changes: 5 additions & 5 deletions cad/pythoncad/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -11,16 +11,16 @@ DISTNAME= PythonCAD-DS1-R${PORTVERSION}
MAINTAINER= [email protected]
COMMENT= Open-source CAD package built designed around Python

LICENSE= GPLv2
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING

RUN_DEPENDS= ${PYTHON_SITELIBDIR}/gtk-2.0/gtk/__init__.py:x11-toolkits/py-gtk2

USES= python shebangfix
USE_PYTHON= distutils
USES= python shebangfix
USE_PYTHON= distutils
PYDISTUTILS_PKGNAME= PythonCAD
PYDISTUTILS_PKGVERSION= DS1-R${PORTVERSION}
NO_ARCH= yes
NO_ARCH= yes
SHEBANG_FILES= gtkpycad.py

post-patch:
Expand All @@ -31,7 +31,7 @@ post-patch:
post-install:
${INSTALL_SCRIPT} ${WRKSRC}/gtkpycad.py ${STAGEDIR}${PREFIX}/bin/gtkpycad
${INSTALL_DATA} ${WRKSRC}/gtkpycad.png ${STAGEDIR}${PREFIX}/share/pixmaps
${MKDIR} ${STAGEDIR}${PREFIX}/etc/pythoncad
@${MKDIR} ${STAGEDIR}${PREFIX}/etc/pythoncad
${INSTALL_DATA} ${WRKSRC}/prefs.py ${STAGEDIR}${PREFIX}/etc/pythoncad/prefs.py.sample

.include <bsd.port.mk>
2 changes: 1 addition & 1 deletion converters/osm2pgsql/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -2,7 +2,7 @@
# $FreeBSD$

PORTNAME= osm2pgsql
PORTVERSION= 0.92.0
PORTVERSION= 0.92.1
CATEGORIES= converters geography

MAINTAINER= [email protected]
Expand Down
6 changes: 3 additions & 3 deletions converters/osm2pgsql/distinfo
Original file line number Diff line number Diff line change
@@ -1,3 +1,3 @@
TIMESTAMP = 1486403531
SHA256 (openstreetmap-osm2pgsql-0.92.0_GH0.tar.gz) = b741cfdf6489fd5def721f75a9558b8cda53165dda7ca9548fcc5b43e163ee77
SIZE (openstreetmap-osm2pgsql-0.92.0_GH0.tar.gz) = 1364481
TIMESTAMP = 1492513697
SHA256 (openstreetmap-osm2pgsql-0.92.1_GH0.tar.gz) = 0912a344aaa38ed4b78f6dcab1a873975adb434dcc31cdd6fec3ec6a30025390
SIZE (openstreetmap-osm2pgsql-0.92.1_GH0.tar.gz) = 1364504
6 changes: 3 additions & 3 deletions converters/osm2pgsql/files/patch-CMakeLists.txt
Original file line number Diff line number Diff line change
@@ -1,9 +1,9 @@
--- CMakeLists.txt.orig 2016-07-17 02:30:16 UTC
--- CMakeLists.txt.orig 2017-04-13 20:58:25 UTC
+++ CMakeLists.txt
@@ -257,5 +257,5 @@ endif()
@@ -252,5 +252,5 @@ endif()
#############################################################

install(TARGETS osm2pgsql DESTINATION bin)
-install(FILES docs/osm2pgsql.1 DESTINATION share/man/man1)
+install(FILES docs/osm2pgsql.1 DESTINATION man/man1)
install(FILES default.style empty.style 900913.sql DESTINATION share/osm2pgsql)
install(FILES default.style empty.style DESTINATION share/osm2pgsql)
2 changes: 1 addition & 1 deletion converters/osm2pgsql/files/patch-cmake_FindOsmium.cmake
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
--- cmake/FindOsmium.cmake.orig 2016-07-17 02:30:16 UTC
--- cmake/FindOsmium.cmake.orig 2017-04-13 20:58:25 UTC
+++ cmake/FindOsmium.cmake
@@ -151,8 +151,8 @@ list(APPEND OSMIUM_LIBRARIES
#----------------------------------------------------------------------
Expand Down
1 change: 1 addition & 0 deletions databases/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -858,6 +858,7 @@
SUBDIR += ruby-qdbm
SUBDIR += ruby-tokyocabinet
SUBDIR += ruby-xapian
SUBDIR += rubygem-active_record_query_trace
SUBDIR += rubygem-activemodel4
SUBDIR += rubygem-activemodel5
SUBDIR += rubygem-activerecord-import
Expand Down
18 changes: 18 additions & 0 deletions databases/rubygem-active_record_query_trace/Makefile
Original file line number Diff line number Diff line change
@@ -0,0 +1,18 @@
# $FreeBSD$

PORTNAME= active_record_query_trace
PORTVERSION= 1.5.4
CATEGORIES= databases rubygems
MASTER_SITES= RG

MAINTAINER= [email protected]
COMMENT= Print stack trace of all queries to the Rails log

LICENSE= MIT

NO_ARCH= yes

USE_RUBY= yes
USES= gem

.include <bsd.port.mk>
3 changes: 3 additions & 0 deletions databases/rubygem-active_record_query_trace/distinfo
Original file line number Diff line number Diff line change
@@ -0,0 +1,3 @@
TIMESTAMP = 1492685193
SHA256 (rubygem/active_record_query_trace-1.5.4.gem) = b0c5cbc0d48a4d0755472a0e6211e7d46e16cb6c22829936bda031177ccd0aaa
SIZE (rubygem/active_record_query_trace-1.5.4.gem) = 5632
4 changes: 4 additions & 0 deletions databases/rubygem-active_record_query_trace/pkg-descr
Original file line number Diff line number Diff line change
@@ -0,0 +1,4 @@
This gem logs the execution source of all queries to the Rails log. Tracking
down the source is often useful for performance optimization.

WWW: https://github.com/ruckus/active-record-query-trace/
7 changes: 3 additions & 4 deletions databases/rubygem-pghero/Makefile
Original file line number Diff line number Diff line change
@@ -1,20 +1,19 @@
# $FreeBSD$

PORTNAME= pghero
PORTVERSION= 1.6.4
PORTVERSION= 1.6.5
CATEGORIES= databases rubygems
MASTER_SITES= RG

MAINTAINER= [email protected]
COMMENT= A performance dashboard for Postgres
COMMENT= Performance dashboard for Postgres

LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.txt

RUN_DEPENDS= rubygem-activerecord4>:databases/rubygem-activerecord4
RUN_DEPENDS= rubygem-activerecord4>=0:databases/rubygem-activerecord4

NO_ARCH= yes

USE_RUBY= yes
USES= gem

Expand Down
6 changes: 3 additions & 3 deletions databases/rubygem-pghero/distinfo
Original file line number Diff line number Diff line change
@@ -1,3 +1,3 @@
TIMESTAMP = 1491855254
SHA256 (rubygem/pghero-1.6.4.gem) = dd95168617489e45bdb057c648a89100ef2d9afbbfb2756d0bb62401c075b6b6
SIZE (rubygem/pghero-1.6.4.gem) = 245248
TIMESTAMP = 1492694914
SHA256 (rubygem/pghero-1.6.5.gem) = 1949e13bad031dda1179df4a3a80baa88c9b8970f1082f602a8b3bcfbaf80d86
SIZE (rubygem/pghero-1.6.5.gem) = 245248
2 changes: 1 addition & 1 deletion databases/rubygem-pghero/pkg-descr
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
PgHere is a performance dashboard for Postgres. It includes health checks,
suggested indexes, and more.

WWW: https://github.com/ankane/pghero/
WWW: https://github.com/ankane/pghero
3 changes: 3 additions & 0 deletions deskutils/openproj/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -8,6 +8,9 @@ MASTER_SITES= SF/${PORTNAME}/OpenProj%20Binaries/${PORTVERSION}
MAINTAINER= [email protected]
COMMENT= Free, open source Project Manager

DEPRECATED= Development ceased, superseded by deskutils/projectlibre
EXPIRATION_DATE= 2017-05-19

USE_JAVA= yes
JAVA_VERSION= 1.6+
NO_BUILD= yes
Expand Down
2 changes: 1 addition & 1 deletion deskutils/projectlibre/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,7 @@

PORTNAME= projectlibre
PORTVERSION= 1.7.0
CATEGORIES= deskutils java
CATEGORIES= deskutils editors java
MASTER_SITES= SF/${PORTNAME}/ProjectLibre/${PORTVERSION:S/.0$//} \
LOCAL/cpm/projectlibre/:icons
DISTFILES= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX} \
Expand Down
5 changes: 2 additions & 3 deletions devel/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -99,6 +99,7 @@
SUBDIR += apr2
SUBDIR += arcanist
SUBDIR += arduino
SUBDIR += arduino-avrdude
SUBDIR += arduino-builder
SUBDIR += arduino-core
SUBDIR += arduino-ctags
Expand All @@ -107,7 +108,7 @@
SUBDIR += arduino-mk
SUBDIR += arduino-sevseg
SUBDIR += arduino-tools
SUBDIR += arduino16
SUBDIR += arduino18
SUBDIR += arduinoOTA
SUBDIR += argdata
SUBDIR += argouml
Expand Down Expand Up @@ -624,7 +625,6 @@
SUBDIR += fpc-zlib
SUBDIR += fpp
SUBDIR += frama-c
SUBDIR += freeocl
SUBDIR += frink
SUBDIR += fstrm
SUBDIR += ftjam
Expand Down Expand Up @@ -4241,7 +4241,6 @@
SUBDIR += py-django-rq
SUBDIR += py-django-rq-dashboard
SUBDIR += py-django-tastypie-mongoengine
SUBDIR += py-django16-tastypie-mongoengine
SUBDIR += py-docker-py
SUBDIR += py-dockerpty
SUBDIR += py-docopt
Expand Down
42 changes: 42 additions & 0 deletions devel/arduino-avrdude/Makefile
Original file line number Diff line number Diff line change
@@ -0,0 +1,42 @@
# $FreeBSD$

PORTNAME= avrdude
PORTVERSION= 6.3
CATEGORIES= devel
MASTER_SITES= SAVANNAH/avrdude
PKGNAMEPREFIX= arduino-

MAINTAINER= [email protected]
COMMENT= Program for programming the on-chip memory of Atmel AVR Arduino CPUs

LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING

LIB_DEPENDS= libftdi1.so:devel/libftdi1

GNU_CONFIGURE= yes
USES= libtool localbase readline
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
MAKE_JOBS_UNSAFE= yes

MAKE_ENV+= PKGNAMEPREFIX=${PKGNAMEPREFIX}

CONFIGURE_ARGS+= --disable-shared --disable-static

PLIST_FILES= bin/arduino-avrdude \
etc/arduino-avrdude.conf \
man/man1/arduino-avrdude.1.gz

post-patch:
@${REINPLACE_CMD} -e 's|-lusb-1.0|-lusb|g' ${WRKSRC}/configure

post-configure:
@${MV} ${WRKSRC}/${PORTNAME}.1 ${WRKSRC}/${PKGNAMEPREFIX}${PORTNAME}.1
@${MV} ${WRKSRC}/${PORTNAME}.conf ${WRKSRC}/${PKGNAMEPREFIX}${PORTNAME}.conf

post-install:
@${RM} ${STAGEDIR}${PREFIX}/include/lib${PORTNAME}.h
@${RM} ${STAGEDIR}${PREFIX}/lib/lib${PORTNAME}.a

.include <bsd.port.mk>
3 changes: 3 additions & 0 deletions devel/arduino-avrdude/distinfo
Original file line number Diff line number Diff line change
@@ -0,0 +1,3 @@
TIMESTAMP = 1490880510
SHA256 (avrdude-6.3.tar.gz) = 0f9f731b6394ca7795b88359689a7fa1fba818c6e1d962513eb28da670e0a196
SIZE (avrdude-6.3.tar.gz) = 909744
62 changes: 62 additions & 0 deletions devel/arduino-avrdude/files/patch-Makefile.in
Original file line number Diff line number Diff line change
@@ -0,0 +1,62 @@
--- Makefile.in.orig 2017-03-30 13:30:41 UTC
+++ Makefile.in
@@ -115,7 +115,7 @@ POST_UNINSTALL = :
build_triplet = @build@
host_triplet = @host@
target_triplet = @target@
-bin_PROGRAMS = avrdude$(EXEEXT)
+bin_PROGRAMS = $(PKGNAMEPREFIX)avrdude$(EXEEXT)
subdir = .
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
am__aclocal_m4_deps = $(top_srcdir)/m4/libtool.m4 \
@@ -540,7 +540,7 @@ EXTRA_DIST = \
ChangeLog-2011 \
ChangeLog-2012 \
ChangeLog-2013 \
- avrdude.1 \
+ $(PKGNAMEPREFIX)avrdude.1 \
avrdude.spec \
bootstrap

@@ -664,8 +664,8 @@ avrdude_SOURCES = \
term.c \
term.h

-man_MANS = avrdude.1
-sysconf_DATA = avrdude.conf
+man_MANS = $(PKGNAMEPREFIX)avrdude.1
+sysconf_DATA = $(PKGNAMEPREFIX)avrdude.conf
ACLOCAL_AMFLAGS = -I m4
all: $(BUILT_SOURCES) ac_cfg.h
$(MAKE) $(AM_MAKEFLAGS) all-recursive
@@ -823,8 +823,8 @@ clean-binPROGRAMS:
echo " rm -f" $$list; \
rm -f $$list

-avrdude$(EXEEXT): $(avrdude_OBJECTS) $(avrdude_DEPENDENCIES) $(EXTRA_avrdude_DEPENDENCIES)
- @rm -f avrdude$(EXEEXT)
+$(PKGNAMEPREFIX)avrdude$(EXEEXT): $(avrdude_OBJECTS) $(avrdude_DEPENDENCIES) $(EXTRA_avrdude_DEPENDENCIES)
+ @rm -f $(PKGNAMEPREFIX)avrdude$(EXEEXT)
$(AM_V_CCLD)$(avrdude_LINK) $(avrdude_OBJECTS) $(avrdude_LDADD) $(LIBS)

mostlyclean-compile:
@@ -2490,14 +2490,14 @@ dist-hook:
install-exec-local: backup-avrdude-conf

distclean-local:
- rm -f avrdude.conf
+ rm -f $(PKGNAMEPREFIX)avrdude.conf

# This will get run before the config file is installed.
backup-avrdude-conf:
- @echo "Backing up avrdude.conf in ${DESTDIR}${sysconfdir}"
- @if test -e ${DESTDIR}${sysconfdir}/avrdude.conf; then \
- cp -pR ${DESTDIR}${sysconfdir}/avrdude.conf \
- ${DESTDIR}${sysconfdir}/avrdude.conf.bak; \
+ @echo "Backing up ${PKGNAMEPREFIX}avrdude.conf in ${DESTDIR}${sysconfdir}"
+ @if test -e ${DESTDIR}${sysconfdir}/$(PKGNAMEPREFIX)avrdude.conf; then \
+ cp -pR ${DESTDIR}${sysconfdir}/$(PKGNAMEPREFIX)avrdude.conf \
+ ${DESTDIR}${sysconfdir}/$(PKGNAMEPREFIX)avrdude.conf.bak; \
fi

# Tell versions [3.59,3.63) of GNU make to not export all variables.
Loading

0 comments on commit ada43ef

Please sign in to comment.