forked from opnsense/ports
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Taken from: FreeBSD
- Loading branch information
Showing
1,234 changed files
with
16,834 additions
and
6,638 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -3,14 +3,25 @@ | |
|
||
PORTNAME= libitl | ||
PORTVERSION= 0.7.0 | ||
PORTREVISION= 1 | ||
CATEGORIES= arabic | ||
MASTER_SITES= SF/arabeyes/ITL%20Library%20%28${PORTNAME}%29/${PORTNAME}-${PORTVERSION} | ||
|
||
MAINTAINER= [email protected] | ||
COMMENT= API abstraction to common Islamic calculations | ||
|
||
LICENSE= LGPL21 | ||
LICENSE_FILE= ${WRKSRC}/COPYING | ||
|
||
GNU_CONFIGURE= yes | ||
USE_LDCONFIG= ${PREFIX}/lib/itl | ||
MAKE_JOBS_UNSAFE= yes | ||
|
||
post-install: | ||
.for f in libitl.so libitl.so.0 | ||
${RM} -f ${STAGEDIR}${PREFIX}/lib/itl/$f | ||
${LN} -s libitl.so.0.0.7 ${STAGEDIR}${PREFIX}/lib/itl/$f | ||
.endfor | ||
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/itl/libitl.so | ||
|
||
.include <bsd.port.mk> |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file was deleted.
Oops, something went wrong.
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,21 @@ | ||
--- programs/Makefile.orig 2015-05-07 11:23:39 UTC | ||
+++ programs/Makefile | ||
@@ -150,7 +150,7 @@ test-all: test test32 | ||
test-travis: $(TRAVIS_TARGET) | ||
|
||
test-lz4-sparse: lz4 datagen | ||
- @echo ---- test sparse file support ---- | ||
+ @echo "\n ---- test sparse file support ----" | ||
./datagen -g5M -P100 > tmpSrc | ||
./lz4 -B4D tmpSrc | ./lz4 -dv --sparse > tmpB4 | ||
diff -s tmpSrc tmpB4 | ||
@@ -167,6 +167,9 @@ test-lz4-sparse: lz4 datagen | ||
./datagen -s1 -g1200007 -P100 | diff -s - tmpOdd | ||
ls -ls tmpOdd | ||
@rm tmp* | ||
+ @echo "\n Compatibility with Console :" | ||
+ ./lz4 COPYING | ./lz4 -d -c | ||
+ ./lz4 COPYING | ./lz4 -d | cat | ||
|
||
test-lz4-contentSize: lz4 datagen | ||
@echo ---- test original size support ---- |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,11 @@ | ||
--- programs/lz4cli.c.orig 2015-05-07 11:23:39 UTC | ||
+++ programs/lz4cli.c | ||
@@ -473,7 +473,7 @@ int main(int argc, char** argv) | ||
if (multiple_inputs) input_filename = inFileNames[0], output_filename = (const char*)(inFileNames[0]); | ||
if(!input_filename) { input_filename=stdinmark; } | ||
|
||
- /* Check if input or output are defined as console; trigger an error in this case */ | ||
+ /* Check if input is defined as console; trigger an error in this case */ | ||
if (!strcmp(input_filename, stdinmark) && IS_CONSOLE(stdin) ) badusage(); | ||
|
||
/* Check if benchmark is selected */ |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,61 @@ | ||
--- programs/lz4io.c.orig 2015-05-07 11:23:39 UTC | ||
+++ programs/lz4io.c | ||
@@ -303,6 +303,12 @@ static int LZ4IO_getFiles(const char* in | ||
|
||
if ( *pfoutput==0) EXM_THROW(13, "Pb opening %s", output_filename); | ||
|
||
+ if (g_sparseFileSupport) | ||
+ { | ||
+ long int ftr = ftell(*pfoutput); | ||
+ if (ftr==-1) g_sparseFileSupport = 0; | ||
+ } | ||
+ | ||
return 0; | ||
} | ||
|
||
@@ -639,7 +645,7 @@ static unsigned LZ4IO_fwriteSparse(FILE* | ||
if (!g_sparseFileSupport) /* normal write */ | ||
{ | ||
size_t sizeCheck = fwrite(buffer, 1, bufferSize, file); | ||
- if (sizeCheck != bufferSize) EXM_THROW(68, "Write error : cannot write decoded block"); | ||
+ if (sizeCheck != bufferSize) EXM_THROW(70, "Write error : cannot write decoded block"); | ||
return 0; | ||
} | ||
|
||
@@ -647,7 +653,7 @@ static unsigned LZ4IO_fwriteSparse(FILE* | ||
if (storedSkips > 1 GB) | ||
{ | ||
int seekResult = fseek(file, 1 GB, SEEK_CUR); | ||
- if (seekResult != 0) EXM_THROW(68, "1 GB skip error (sparse file support)"); | ||
+ if (seekResult != 0) EXM_THROW(71, "1 GB skip error (sparse file support)"); | ||
storedSkips -= 1 GB; | ||
} | ||
|
||
@@ -667,12 +673,12 @@ static unsigned LZ4IO_fwriteSparse(FILE* | ||
{ | ||
size_t sizeCheck; | ||
seekResult = fseek(file, storedSkips, SEEK_CUR); | ||
- if (seekResult) EXM_THROW(68, "Skip error (sparse file)"); | ||
+ if (seekResult) EXM_THROW(72, "Skip error (sparse file)"); | ||
storedSkips = 0; | ||
seg0SizeT -= nb0T; | ||
ptrT += nb0T; | ||
sizeCheck = fwrite(ptrT, sizeT, seg0SizeT, file); | ||
- if (sizeCheck != seg0SizeT) EXM_THROW(68, "Write error : cannot write decoded block"); | ||
+ if (sizeCheck != seg0SizeT) EXM_THROW(73, "Write error : cannot write decoded block"); | ||
} | ||
ptrT += seg0SizeT; | ||
} | ||
@@ -689,10 +695,10 @@ static unsigned LZ4IO_fwriteSparse(FILE* | ||
{ | ||
size_t sizeCheck; | ||
int seekResult = fseek(file, storedSkips, SEEK_CUR); | ||
- if (seekResult) EXM_THROW(68, "Skip error (end of block)"); | ||
+ if (seekResult) EXM_THROW(74, "Skip error (end of block)"); | ||
storedSkips = 0; | ||
sizeCheck = fwrite(restPtr, 1, restEnd - restPtr, file); | ||
- if (sizeCheck != (size_t)(restEnd - restPtr)) EXM_THROW(68, "Write error : cannot write decoded end of block"); | ||
+ if (sizeCheck != (size_t)(restEnd - restPtr)) EXM_THROW(75, "Write error : cannot write decoded end of block"); | ||
} | ||
} | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,2 @@ | ||
SHA256 (glebius-gpxloggerd-0.2.2_GH0.tar.gz) = 66a849fa653967bc514887d1a0c553467ba24f97b8bc7ca67738dc76750e1d62 | ||
SIZE (glebius-gpxloggerd-0.2.2_GH0.tar.gz) = 7484 | ||
SHA256 (glebius-gpxloggerd-0.2.3_GH0.tar.gz) = de87f5a754c4c9bf386bfbf01df4cf50df1269b5339d7f415387826f418fd4e9 | ||
SIZE (glebius-gpxloggerd-0.2.3_GH0.tar.gz) = 7504 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,2 @@ | ||
SHA256 (splitter-r412.tar.gz) = 8f67fbe72d77bb1384dd2d4d6c9a52f1d8c4893336fe84620e176ef2a19c51e4 | ||
SIZE (splitter-r412.tar.gz) = 1546258 | ||
SHA256 (splitter-r423.tar.gz) = a7d1adfe5238fe2a02eaec281b2960dec9a7e3fcf9a37acfe69af658dc6119f2 | ||
SIZE (splitter-r423.tar.gz) = 1547994 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,2 @@ | ||
SHA256 (mkgmap-r3336.tar.gz) = 83ebb618c427cefd5f8a38bf98face685337697f5ec3c0528ea51b55459eb3da | ||
SIZE (mkgmap-r3336.tar.gz) = 3099320 | ||
SHA256 (mkgmap-r3598.tar.gz) = 5464b25f08e61916f73d7021a310baf0b98e2d6d9a9148dc925d85c4f4410a14 | ||
SIZE (mkgmap-r3598.tar.gz) = 3126931 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,2 @@ | ||
SHA256 (Astro-SpaceTrack-0.091.tar.gz) = c413ba2df4566d408b339787473fa76aa7cf11a8ff3418de8f607fba79749772 | ||
SIZE (Astro-SpaceTrack-0.091.tar.gz) = 154385 | ||
SHA256 (Astro-SpaceTrack-0.092.tar.gz) = d7823ac4809d35fad7493b74ab0fcf34238aa3ac9bd56ac4dab6cdd6ed2fe1a7 | ||
SIZE (Astro-SpaceTrack-0.092.tar.gz) = 155017 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -3,21 +3,19 @@ | |
|
||
PORTNAME= audiere | ||
PORTVERSION= 1.9.4 | ||
PORTREVISION= 5 | ||
PORTREVISION= 6 | ||
CATEGORIES= audio | ||
MASTER_SITES= SF | ||
|
||
MAINTAINER= [email protected] | ||
COMMENT= High-level audio API | ||
|
||
GNU_CONFIGURE= yes | ||
USES= gmake libtool | ||
USES= autoreconf gmake libtool | ||
WANT_WX= yes | ||
USE_AUTOTOOLS= autoconf | ||
INSTALL_TARGET= install-strip | ||
USE_LDCONFIG= yes | ||
|
||
CONFIGURE_ENV= PTHREAD_LIBS="-pthread" | ||
CONFIGURE_ENV= PTHREAD_LIBS="-lpthread" | ||
CPPFLAGS+= -I${LOCALBASE}/include/speex -I${LOCALBASE}/include | ||
LDFLAGS+= -L${LOCALBASE}/lib | ||
|
||
|
@@ -75,6 +73,7 @@ post-patch: | |
${WRKSRC}/configure.in | ||
|
||
post-install: | ||
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libaudiere.so | ||
${MKDIR} ${STAGEDIR}${DOCSDIR} | ||
.for f in ${PORTDOCS} | ||
${INSTALL_DATA} ${WRKSRC}/doc/${f} ${STAGEDIR}${DOCSDIR} | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -3,7 +3,7 @@ | |
|
||
PORTNAME= cdparanoia | ||
PORTVERSION= 3.9.8 | ||
PORTREVISION= 9 | ||
PORTREVISION= 10 | ||
CATEGORIES= audio sysutils | ||
MASTER_SITES= http://www.xiph.org/paranoia/download/ | ||
DISTNAME= ${PORTNAME}-${PORTVERSION:C/^3\./III-alpha/} | ||
|
@@ -13,6 +13,7 @@ MAINTAINER= [email protected] | |
COMMENT= CDDA extraction tool (also known as ripper) | ||
|
||
LICENSE= GPLv2 | ||
LICENSE_FILE= ${WRKSRC}/GPL | ||
|
||
GNU_CONFIGURE= yes | ||
USES= gmake | ||
|
@@ -23,6 +24,6 @@ post-patch: | |
${WRKSRC}/interface/utils.h | ||
|
||
post-install: | ||
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libcdda_* | ||
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libcdda_*.so | ||
|
||
.include <bsd.port.mk> |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -9,6 +9,9 @@ MASTER_SITES= SF/clunk | |
MAINTAINER= [email protected] | ||
COMMENT= Real-time 3D sound generation library | ||
|
||
LICENSE= LGPL21 | ||
LICENSE_FILE= ${WRKSRC}/LICENSE | ||
|
||
USES= tar:bzip2 cmake | ||
USE_SDL= sdl | ||
USE_LDCONFIG= yes | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,2 @@ | ||
SHA256 (mpg123-1.22.1.tar.bz2) = a0eb598e5bd72cee4c1b7603fa227b7bd54575aa84b7b94a35ca05dd3536cdba | ||
SIZE (mpg123-1.22.1.tar.bz2) = 854802 | ||
SHA256 (mpg123-1.22.2.tar.bz2) = 6d1e2487777114ba8a73c543f355cacfa2055646724000fc195ac9e64c843744 | ||
SIZE (mpg123-1.22.2.tar.bz2) = 870063 |
Oops, something went wrong.