Skip to content

Commit

Permalink
*/*: sync with upstream
Browse files Browse the repository at this point in the history
Taken from: FreeBSD
  • Loading branch information
fichtner committed Dec 28, 2015
1 parent 21f63df commit fc2bb2f
Show file tree
Hide file tree
Showing 159 changed files with 3,734 additions and 1,274 deletions.
2 changes: 1 addition & 1 deletion astro/josm/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -2,7 +2,7 @@
# $FreeBSD$

PORTNAME= josm
PORTVERSION= 8964
PORTVERSION= 9060
CATEGORIES= astro java
MASTER_SITES= http://josm.openstreetmap.de/download/ \
http://mirror.amdmi3.ru/distfiles/
Expand Down
4 changes: 2 additions & 2 deletions astro/josm/distinfo
Original file line number Diff line number Diff line change
@@ -1,2 +1,2 @@
SHA256 (josm-snapshot-8964.jar) = 8f105b9370a6f7e831427491a24769237dc7ed7b60854ce0ec6a08676d0ec7a0
SIZE (josm-snapshot-8964.jar) = 10347301
SHA256 (josm-snapshot-9060.jar) = 4202856102b40adbd551d22d384ba424daeddbbdb68bb2eae749863ef4023830
SIZE (josm-snapshot-9060.jar) = 10396174
12 changes: 8 additions & 4 deletions audio/gramofile/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -19,11 +19,13 @@ LIB_DEPENDS= libfftw.so:${PORTSDIR}/math/fftw
ALL_TARGET= gramofile
USES= gmake perl5
USE_CSTD= gnu89
MAKE_ARGS+= CC="${CC}"
MAKE_ARGS+= CXX="${CXX}"
MAKE_ARGS= CC="${CC}" \
CXX="${CXX}" \
PERLCOREDIR=${PERLCOREDIR}

PERLCOREDIR= ${LOCALBASE}/lib/perl5/${PERL_VER}/${PERL_ARCH}/CORE
MAKE_ARGS+= PERLCOREDIR=${PERLCOREDIR}

OPTIONS_DEFINE= DOCS

post-patch:
${RM} ${WRKSRC}/debian/20-warning-fixes.dpatch
Expand All @@ -42,8 +44,10 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/gramofile ${WRKSRC}/bplay_gramo \
${STAGEDIR}${PREFIX}/bin
${LN} -s bplay_gramo ${STAGEDIR}${PREFIX}/bin/brec_gramo

do-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
${LN} -s bplay_gramo ${STAGEDIR}${PREFIX}/bin/brec_gramo

.include <bsd.port.mk>
2 changes: 1 addition & 1 deletion audio/gramofile/pkg-plist
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
bin/gramofile
bin/bplay_gramo
bin/brec_gramo
%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/README
3 changes: 3 additions & 0 deletions databases/cassandra/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -16,6 +16,9 @@ LICENSE= APACHE20

RUN_DEPENDS= ${JAVALIBDIR}/snappy-java.jar:${PORTSDIR}/archivers/snappy-java

DEPRECATED= 1.2.x has reached EOL, upgrade to a supported version of Cassandra
EXPIRATION_DATE= 2016-03-27

JAVA_VERSION= 1.7
JAVA_VENDOR= openjdk
REINPLACE_ARGS= -i ''
Expand Down
66 changes: 21 additions & 45 deletions databases/mysql57-client/files/patch-scripts_CMakeLists.txt
Original file line number Diff line number Diff line change
Expand Up @@ -24,23 +24,15 @@
IF(UNIX)
FILE(WRITE ${CMAKE_CURRENT_BINARY_DIR}/make_binary_distribution
"cd ${CMAKE_BINARY_DIR} && '${CMAKE_CPACK_COMMAND}' -G TGZ --config CPackConfig.cmake\n" )
@@ -152,6 +155,7 @@ IF(UNIX)
@@ -150,6 +153,7 @@ IF(UNIX)
COMMAND chmod +x ${CMAKE_CURRENT_BINARY_DIR}/make_binary_distribution
)
ENDIF()
+ENDIF()

IF(NOT WITHOUT_SERVER)
+IF(FALSE)
INSTALL(FILES
${CMAKE_CURRENT_SOURCE_DIR}/mysql_system_tables.sql
${CMAKE_CURRENT_SOURCE_DIR}/mysql_system_tables_data.sql
@@ -282,6 +286,7 @@ SET(HOSTNAME "hostname")
SET(MYSQLD_USER "mysql")

ENDIF(UNIX)
+ENDIF()

SET(bindir ${prefix}/${INSTALL_BINDIR})
SET(sbindir ${prefix}/${INSTALL_SBINDIR})
@@ -347,6 +352,8 @@ MACRO(EXTRACT_LINK_LIBRARIES target var)
@@ -347,6 +351,8 @@ MACRO(EXTRACT_LINK_LIBRARIES target var)
GET_FILENAME_COMPONENT(lib "${lib}" NAME_WE)
STRING(REGEX REPLACE "^lib" "" lib "${lib}")
SET(${var} "${${var}}-l${lib} " )
Expand All @@ -49,40 +41,24 @@
ELSE()
SET(${var} "${${var}}-l${lib} " )
ENDIF()
@@ -433,14 +440,10 @@ ELSE()
IF(WITH_SYSTEMD)
SET(BIN_SCRIPTS
mysql_config
@@ -430,19 +436,7 @@ ELSE()
# On Unix, most of the files end up in the bin directory
SET(mysql_config_COMPONENT COMPONENT Development)

- IF(WITH_SYSTEMD)
- SET(BIN_SCRIPTS
- mysql_config
- mysqldumpslow
)
ELSE()
SET(BIN_SCRIPTS
mysql_config
- )
- ELSE()
- SET(BIN_SCRIPTS
- mysql_config
- mysqldumpslow
- mysqld_multi
- mysqld_safe
)
ENDIF()

@@ -510,11 +513,13 @@ ELSE()
CONFIGURE_FILE(systemd/mysqld.tmpfiles.d.in
${CMAKE_CURRENT_BINARY_DIR}/mysql.conf ESCAPE_QUOTES @ONLY)

+IF(FALSE)
INSTALL_SCRIPT(
${CMAKE_CURRENT_BINARY_DIR}/mysqld_pre_systemd
DESTINATION ${INSTALL_BINDIR}
COMPONENT Server
)
+ENDIF()

IF(INSTALL_LAYOUT MATCHES "STANDALONE")
SET(SYSTEMD_INSTALL_PREFIX "${CMAKE_INSTALL_PREFIX}/")
@@ -532,6 +537,7 @@ ELSE()
)
ENDIF()
ENDIF()
+ENDIF()
- )
- ENDIF()
+ SET(BIN_SCRIPTS mysql_config)

# Install libgcc as mylibgcc.a
IF(CMAKE_COMPILER_IS_GNUCXX AND CMAKE_CXX_FLAGS MATCHES "-static")
SET(PKGCONFIG_FILE ${LIBMYSQL_OS_OUTPUT_NAME}.pc)
STRING(REGEX REPLACE "/mysql$" "" PKGCONFIG_DIR "${INSTALL_LIBDIR}")
2 changes: 2 additions & 0 deletions databases/mysql57-client/pkg-plist
Original file line number Diff line number Diff line change
@@ -1,4 +1,5 @@
bin/mysql
bin/mysql_config
bin/mysql_config_editor
bin/mysql_ssl_rsa_setup
bin/mysqladmin
Expand Down Expand Up @@ -115,6 +116,7 @@ lib/mysql/libmysqlclient.a
lib/mysql/libmysqlclient.so
lib/mysql/libmysqlclient.so.20
lib/mysql/libmysqlservices.a
libdata/pkgconfig/mysqlclient.pc
man/man1/comp_err.1.gz
man/man1/mysql.1.gz
man/man1/mysql_config.1.gz
Expand Down
1 change: 1 addition & 0 deletions databases/postgis-jdbc/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -17,6 +17,7 @@ RUN_DEPENDS= ${JAVALIBDIR}/postgresql.jar:${PORTSDIR}/databases/postgresql-jdbc
USE_JAVA= yes
JAVA_VERSION= 1.6+
NO_BUILD= yes
NO_ARCH= yes

PLIST_FILES= %%JAVAJARDIR%%/postgis_1.4.0.jar

Expand Down
1 change: 1 addition & 0 deletions devel/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -4376,6 +4376,7 @@
SUBDIR += py-tw.forms
SUBDIR += py-twiggy
SUBDIR += py-twisted
SUBDIR += py-twisted152
SUBDIR += py-twistedCore
SUBDIR += py-twistedFlow
SUBDIR += py-twistedRunner
Expand Down
2 changes: 1 addition & 1 deletion devel/epm/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -2,7 +2,7 @@
# $FreeBSD$

PORTNAME= epm
PORTVERSION= 4.2
PORTVERSION= 4.3
CATEGORIES= devel
MASTER_SITES= http://www.msweet.org/files/project2/
EXTRACT_SUFX= -source.tar.bz2
Expand Down
4 changes: 2 additions & 2 deletions devel/epm/distinfo
Original file line number Diff line number Diff line change
@@ -1,2 +1,2 @@
SHA256 (epm-4.2-source.tar.bz2) = 66c689fae292d4e390d5c52a4bcbd4b231d20dd51d309a7cb9a73d172a7d358e
SIZE (epm-4.2-source.tar.bz2) = 458362
SHA256 (epm-4.3-source.tar.bz2) = 03d2eafd509e224484ce6d03ff45d9ca8ff751c01868a09f0113b409b353f010
SIZE (epm-4.3-source.tar.bz2) = 442672
20 changes: 6 additions & 14 deletions devel/ice/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -2,8 +2,7 @@
# $FreeBSD$

PORTNAME= Ice
PORTVERSION= 3.6.0
PORTREVISION= 1
PORTVERSION= 3.6.1
DISTVERSIONPREFIX= v
CATEGORIES= devel

Expand All @@ -24,15 +23,13 @@ LIB_DEPENDS+= libIce.so.${LIB_VRS}:${PORTSDIR}/devel/ice
PLIST_SUB+= LIB_VERSION="${PORTVERSION}" LIB_VRS="${LIB_VRS}"
.endif

OPTIONS_DEFINE?= DEBUG TESTS
OPTIONS_DEFAULT?= TESTS
TESTS_DESC?= Build and run tests (requires lang/python)
OPTIONS_DEFINE?= DEBUG TEST

.include <bsd.port.options.mk>

USES+= iconv gmake

.if ${PORT_OPTIONS:MTESTS} && ${SLAVE_PORT} == "no"
.if ${PORT_OPTIONS:MTEST} && ${SLAVE_PORT} == "no"
USES+= python:build
BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}passlib>0:${PORTSDIR}/security/py-passlib
.endif
Expand Down Expand Up @@ -62,7 +59,7 @@ BROKEN_sparc64= Does not compile on ${ARCH}
MAKE_ENV+= LP64=yes
.endif

.if !${PORT_OPTIONS:MTESTS}
.if !${PORT_OPTIONS:MTEST}
MAKE_ENV+= NOTESTS=yes
.endif

Expand Down Expand Up @@ -135,13 +132,8 @@ post-patch:
s|%%PREFIX%%|${PREFIX}|g; \
s|%%LOCALBASE%%|${LOCALBASE}|g;' ${WRKSRC}/php/config/Make.rules.php

.if ${PORT_OPTIONS:MTESTS}
TEST_CMD= @cd ${BUILD_WRKSRC} && ${PYTHON_CMD} ./allTests.py
check regression-test test: build
${TEST_CMD}

pre-install: regression-test
.endif
do-test-TEST-on:
@cd ${BUILD_WRKSRC} && ${PYTHON_CMD} ./allTests.py

.if ${SLAVE_PORT} == "no"
post-install:
Expand Down
4 changes: 2 additions & 2 deletions devel/ice/distinfo
Original file line number Diff line number Diff line change
@@ -1,2 +1,2 @@
SHA256 (zeroc-ice-Ice-v3.6.0_GH0.tar.gz) = 77933580cdc7fade0ebfce517935819e9eef5fc6b9e3f4143b07404daf54e25e
SIZE (zeroc-ice-Ice-v3.6.0_GH0.tar.gz) = 5300956
SHA256 (zeroc-ice-Ice-v3.6.1_GH0.tar.gz) = 454d81cb72986c1f04e297a81bca7563e3449a216ad63de8630122d34545ae78
SIZE (zeroc-ice-Ice-v3.6.1_GH0.tar.gz) = 5338954
152 changes: 0 additions & 152 deletions devel/ice/files/patch-cpp-test-Glacier2-override-Client.cpp

This file was deleted.

Loading

0 comments on commit fc2bb2f

Please sign in to comment.