Skip to content

Commit

Permalink
busybox: update to version 1.34.0
Browse files Browse the repository at this point in the history
Update busybox to version 1.34.0

* Remove upstreamed patches (205, 530, 540)

* Remove one old patch that does not apply any more. (203)
  That was originally introduced in 2008 with 563d234,
  but does not apply after busybox restructuring with
  https://git.busybox.net/busybox/commit/networking/udhcp/dhcpc.c?h=1_34_stable&id=e6007c4911c3ea26925f9473b9f156a692585f30
  and
  https://git.busybox.net/busybox/commit/networking/udhcp/dhcpc.c?h=1_34_stable&id=1c7253726fcbab09917f143f0b703efbd2df55c3

* Refresh config and patches.

* Backport upstream fixes for
   - MIPS compilation breakage and
   - process substitution regression

Config refresh:

Refresh commands, run after busybox is first built once:

cd utils/busybox/
cd config/
../convert_menuconfig.pl ../../../../build_dir/target-aarch64_cortex-a53_musl/busybox-default/busybox-1.34.0
cd ..
./convert_defaults.pl < ../../../build_dir/target-aarch64_cortex-a53_musl/busybox-default/busybox-1.34.0/.config > Config-defaults.in

Manual edits needed afterward:

* Config-defaults.in:  OpenWrt config symbol IPV6 logic applied to
  BUSYBOX_DEFAULT_FEATURE_IPV6
* Config-defaults.in:  OpenWrt configTARGET_bcm53xx logic applied to
  BUSYBOX_DEFAULT_TRUNCATE (commit 547f1ec)
* Config-defaults.in:  OpenWrt logic applied to
  BUSYBOX_DEFAULT_LOGIN_SESSION_AS_CHILD (commit dc92917)
  BUSYBOX_DEFAULT_UDHCPC_DEFAULT_INTERFACE (just "")
* config/editors/Config.in: Add USE_GLIBC dependency to
  BUSYBOX_CONFIG_FEATURE_VI_REGEX_SEARCH (commit f141090)
* config/shell/Config.in : change at "Options common to all shells"  the symbol
  SHELL_ASH  -->  BUSYBOX_CONFIG_SHELL_ASH
   (discussion in http://lists.openwrt.org/pipermail/openwrt-devel/2021-January/033140.html
     Apparently our script does not see the hidden option while
     prepending config options with "BUSYBOX_CONFIG_" which leads to a
     missed dependency when the options are later evaluated.)
* Edit Config.in files by adding quotes to sourced items in
  config/Config.in, config/networking/Config.in and config/util-linux/Config.in (commit 1da014f)

Signed-off-by: Hannu Nyman <[email protected]>
  • Loading branch information
hnyman authored and dedeckeh committed Sep 4, 2021
1 parent 43f0e38 commit b6cbbbb
Show file tree
Hide file tree
Showing 17 changed files with 223 additions and 203 deletions.
33 changes: 27 additions & 6 deletions package/utils/busybox/Config-defaults.in
Original file line number Diff line number Diff line change
Expand Up @@ -381,7 +381,7 @@ config BUSYBOX_DEFAULT_BZIP2_SMALL
default 0
config BUSYBOX_DEFAULT_FEATURE_BZIP2_DECOMPRESS
bool
default y
default n
config BUSYBOX_DEFAULT_CPIO
bool
default n
Expand Down Expand Up @@ -514,6 +514,9 @@ config BUSYBOX_DEFAULT_CHROOT
config BUSYBOX_DEFAULT_CKSUM
bool
default n
config BUSYBOX_DEFAULT_CRC32
bool
default n
config BUSYBOX_DEFAULT_COMM
bool
default n
Expand All @@ -529,6 +532,9 @@ config BUSYBOX_DEFAULT_FEATURE_CP_REFLINK
config BUSYBOX_DEFAULT_CUT
bool
default y
config BUSYBOX_DEFAULT_FEATURE_CUT_REGEX
bool
default n
config BUSYBOX_DEFAULT_DATE
bool
default y
Expand Down Expand Up @@ -829,9 +835,6 @@ config BUSYBOX_DEFAULT_TIMEOUT
config BUSYBOX_DEFAULT_TOUCH
bool
default y
config BUSYBOX_DEFAULT_FEATURE_TOUCH_NODEREF
bool
default n
config BUSYBOX_DEFAULT_FEATURE_TOUCH_SUSV3
bool
default y
Expand Down Expand Up @@ -1058,6 +1061,9 @@ config BUSYBOX_DEFAULT_FEATURE_VI_8BIT
config BUSYBOX_DEFAULT_FEATURE_VI_COLON
bool
default y
config BUSYBOX_DEFAULT_FEATURE_VI_COLON_EXPAND
bool
default n
config BUSYBOX_DEFAULT_FEATURE_VI_YANKMARK
bool
default y
Expand Down Expand Up @@ -1097,6 +1103,9 @@ config BUSYBOX_DEFAULT_FEATURE_VI_UNDO_QUEUE
config BUSYBOX_DEFAULT_FEATURE_VI_UNDO_QUEUE_MAX
int
default 0
config BUSYBOX_DEFAULT_FEATURE_VI_VERBOSE_STATUS
bool
default n
config BUSYBOX_DEFAULT_FEATURE_ALLOW_EXEC
bool
default y
Expand Down Expand Up @@ -1895,6 +1904,9 @@ config BUSYBOX_DEFAULT_FEATURE_VOLUMEID_XFS
config BUSYBOX_DEFAULT_ADJTIMEX
bool
default n
config BUSYBOX_DEFAULT_ASCII
bool
default n
config BUSYBOX_DEFAULT_BBCONFIG
bool
default n
Expand Down Expand Up @@ -2183,6 +2195,9 @@ config BUSYBOX_DEFAULT_VOLNAME
config BUSYBOX_DEFAULT_WATCHDOG
bool
default n
config BUSYBOX_DEFAULT_FEATURE_WATCHDOG_OPEN_TWICE
bool
default n
config BUSYBOX_DEFAULT_FEATURE_IPV6
bool
default y if IPV6
Expand Down Expand Up @@ -2589,6 +2604,9 @@ config BUSYBOX_DEFAULT_FEATURE_WGET_LONG_OPTIONS
config BUSYBOX_DEFAULT_FEATURE_WGET_STATUSBAR
bool
default n
config BUSYBOX_DEFAULT_FEATURE_WGET_FTP
bool
default n
config BUSYBOX_DEFAULT_FEATURE_WGET_AUTHENTICATION
bool
default n
Expand Down Expand Up @@ -2652,6 +2670,9 @@ config BUSYBOX_DEFAULT_FEATURE_UDHCPC6_RFC4833
config BUSYBOX_DEFAULT_FEATURE_UDHCPC6_RFC5970
bool
default n
config BUSYBOX_DEFAULT_UDHCPC_DEFAULT_INTERFACE
string
default ""
config BUSYBOX_DEFAULT_FEATURE_UDHCP_PORT
bool
default n
Expand Down Expand Up @@ -2985,10 +3006,10 @@ config BUSYBOX_DEFAULT_HUSH_BASH_COMPAT
config BUSYBOX_DEFAULT_HUSH_BRACE_EXPANSION
bool
default n
config BUSYBOX_DEFAULT_HUSH_LINENO_VAR
config BUSYBOX_DEFAULT_HUSH_BASH_SOURCE_CURDIR
bool
default n
config BUSYBOX_DEFAULT_HUSH_BASH_SOURCE_CURDIR
config BUSYBOX_DEFAULT_HUSH_LINENO_VAR
bool
default n
config BUSYBOX_DEFAULT_HUSH_INTERACTIVE
Expand Down
4 changes: 2 additions & 2 deletions package/utils/busybox/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -5,14 +5,14 @@
include $(TOPDIR)/rules.mk

PKG_NAME:=busybox
PKG_VERSION:=1.33.1
PKG_VERSION:=1.34.0
PKG_RELEASE:=$(AUTORELEASE)
PKG_FLAGS:=essential

PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://www.busybox.net/downloads \
http://sources.buildroot.net
PKG_HASH:=12cec6bd2b16d8a9446dd16130f2b92982f1819f6e1c5f5887b6db03f5660d28
PKG_HASH:=ec8d1615edb045b83b81966604759c4d4ac921434ab4011da604f629c06074ce

PKG_BUILD_DEPENDS:=BUSYBOX_CONFIG_PAM:libpam
PKG_BUILD_PARALLEL:=1
Expand Down
23 changes: 12 additions & 11 deletions package/utils/busybox/config/coreutils/Config.in
Original file line number Diff line number Diff line change
Expand Up @@ -63,8 +63,10 @@ config BUSYBOX_CONFIG_CHROOT
config BUSYBOX_CONFIG_CKSUM
bool "cksum (4.1 kb)"
default BUSYBOX_DEFAULT_CKSUM
help
cksum is used to calculate the CRC32 checksum of a file.

config BUSYBOX_CONFIG_CRC32
bool "crc32 (4.1 kb)"
default BUSYBOX_DEFAULT_CRC32
config BUSYBOX_CONFIG_COMM
bool "comm (4.2 kb)"
default BUSYBOX_DEFAULT_COMM
Expand Down Expand Up @@ -95,6 +97,13 @@ config BUSYBOX_CONFIG_CUT
help
cut is used to print selected parts of lines from
each file to stdout.

config BUSYBOX_CONFIG_FEATURE_CUT_REGEX
bool "cut -F"
default BUSYBOX_DEFAULT_FEATURE_CUT_REGEX
depends on BUSYBOX_CONFIG_CUT
help
Allow regex based delimiters.
config BUSYBOX_CONFIG_DATE
bool "date (7 kb)"
default BUSYBOX_DEFAULT_DATE
Expand Down Expand Up @@ -739,16 +748,8 @@ config BUSYBOX_CONFIG_TOUCH
touch is used to create or change the access and/or
modification timestamp of specified files.

config BUSYBOX_CONFIG_FEATURE_TOUCH_NODEREF
bool "Add support for -h"
default BUSYBOX_DEFAULT_FEATURE_TOUCH_NODEREF
depends on BUSYBOX_CONFIG_TOUCH
help
Enable touch to have the -h option.
This requires libc support for lutimes() function.

config BUSYBOX_CONFIG_FEATURE_TOUCH_SUSV3
bool "Add support for SUSV3 features (-d -t -r)"
bool "Add support for SUSV3 features (-a -d -m -t -r)"
default BUSYBOX_DEFAULT_FEATURE_TOUCH_SUSV3
depends on BUSYBOX_CONFIG_TOUCH
help
Expand Down
18 changes: 17 additions & 1 deletion package/utils/busybox/config/editors/Config.in
Original file line number Diff line number Diff line change
Expand Up @@ -110,6 +110,14 @@ config BUSYBOX_CONFIG_FEATURE_VI_COLON
Enable a limited set of colon commands. This does not
provide an "ex" mode.

config BUSYBOX_CONFIG_FEATURE_VI_COLON_EXPAND
bool "Expand \"%\" and \"#\" in colon commands"
default BUSYBOX_DEFAULT_FEATURE_VI_COLON_EXPAND
depends on BUSYBOX_CONFIG_FEATURE_VI_COLON
help
Expand the special characters \"%\" (current filename)
and \"#\" (alternate filename) in colon commands.

config BUSYBOX_CONFIG_FEATURE_VI_YANKMARK
bool "Enable yank/put commands and mark cmds"
default BUSYBOX_DEFAULT_FEATURE_VI_YANKMARK
Expand All @@ -126,7 +134,7 @@ config BUSYBOX_CONFIG_FEATURE_VI_SEARCH

config BUSYBOX_CONFIG_FEATURE_VI_REGEX_SEARCH
bool "Enable regex in search and replace"
default BUSYBOX_DEFAULT_FEATURE_VI_REGEX_SEARCH
default BUSYBOX_DEFAULT_FEATURE_VI_REGEX_SEARCH # Uses GNU regex, which may be unavailable. FIXME
depends on BUSYBOX_CONFIG_FEATURE_VI_SEARCH
depends on USE_GLIBC
help
Expand Down Expand Up @@ -218,6 +226,14 @@ config BUSYBOX_CONFIG_FEATURE_VI_UNDO_QUEUE_MAX
Unless you want more (or less) frequent "undo points" while typing,
you should probably leave this unchanged.

config BUSYBOX_CONFIG_FEATURE_VI_VERBOSE_STATUS
bool "Enable verbose status reporting"
default BUSYBOX_DEFAULT_FEATURE_VI_VERBOSE_STATUS
depends on BUSYBOX_CONFIG_VI
help
Enable more verbose reporting of the results of yank, change,
delete, undo and substitution commands.

config BUSYBOX_CONFIG_FEATURE_ALLOW_EXEC
bool "Allow vi and awk to execute shell commands"
default BUSYBOX_DEFAULT_FEATURE_ALLOW_EXEC
Expand Down
2 changes: 1 addition & 1 deletion package/utils/busybox/config/klibc-utils/Config.in
Original file line number Diff line number Diff line change
Expand Up @@ -13,7 +13,7 @@ config BUSYBOX_CONFIG_MINIPS
Alias to "ps".
config BUSYBOX_CONFIG_NUKE
bool "nuke (2.9 kb)"
default BUSYBOX_DEFAULT_NUKE
default BUSYBOX_DEFAULT_NUKE # off by default: too "accidentally destructive"
help
Alias to "rm -rf".
config BUSYBOX_CONFIG_RESUME
Expand Down
21 changes: 21 additions & 0 deletions package/utils/busybox/config/miscutils/Config.in
Original file line number Diff line number Diff line change
Expand Up @@ -12,6 +12,12 @@ config BUSYBOX_CONFIG_ADJTIMEX
help
Adjtimex reads and optionally sets adjustment parameters for
the Linux clock adjustment algorithm.
config BUSYBOX_CONFIG_ASCII
bool "ascii"
default BUSYBOX_DEFAULT_ASCII
help
Print ascii table.

config BUSYBOX_CONFIG_BBCONFIG
bool "bbconfig (9.7 kb)"
default BUSYBOX_DEFAULT_BBCONFIG
Expand Down Expand Up @@ -788,4 +794,19 @@ config BUSYBOX_CONFIG_WATCHDOG
certain amount of time, the watchdog device assumes the system has
hung, and will cause the hardware to reboot.

config BUSYBOX_CONFIG_FEATURE_WATCHDOG_OPEN_TWICE
bool "Open watchdog device twice, closing it gracefully in between"
depends on BUSYBOX_CONFIG_WATCHDOG
default BUSYBOX_DEFAULT_FEATURE_WATCHDOG_OPEN_TWICE # this behavior was essentially a hack for a broken driver
help
When enabled, the watchdog device is opened and then immediately
magic-closed, before being opened a second time. This may be necessary
for some watchdog devices, but can cause spurious warnings in the
kernel log if the nowayout feature is enabled. If this workaround
is really needed for you machine to work properly, consider whether
it should be fixed in the kernel driver instead. Even when disabled,
the behaviour is easily emulated with a "printf 'V' > /dev/watchdog"
immediately before starting the busybox watchdog daemon. Say n unless
you know that you absolutely need this.

endmenu
8 changes: 8 additions & 0 deletions package/utils/busybox/config/networking/Config.in
Original file line number Diff line number Diff line change
Expand Up @@ -1092,6 +1092,13 @@ config BUSYBOX_CONFIG_FEATURE_WGET_STATUSBAR
default BUSYBOX_DEFAULT_FEATURE_WGET_STATUSBAR
depends on BUSYBOX_CONFIG_WGET

config BUSYBOX_CONFIG_FEATURE_WGET_FTP
bool "Enable FTP protocol (+1k)"
default BUSYBOX_DEFAULT_FEATURE_WGET_FTP
depends on BUSYBOX_CONFIG_WGET
help
To support FTPS, enable FEATURE_WGET_HTTPS as well.

config BUSYBOX_CONFIG_FEATURE_WGET_AUTHENTICATION
bool "Enable HTTP authentication"
default BUSYBOX_DEFAULT_FEATURE_WGET_AUTHENTICATION
Expand Down Expand Up @@ -1120,6 +1127,7 @@ config BUSYBOX_CONFIG_FEATURE_WGET_HTTPS
select BUSYBOX_CONFIG_TLS
help
wget will use internal TLS code to connect to https:// URLs.
It also enables FTPS support, but it's not well tested yet.
Note:
On NOMMU machines, ssl_helper applet should be available
in the $PATH for this to work. Make sure to select that applet.
Expand Down
8 changes: 8 additions & 0 deletions package/utils/busybox/config/networking/udhcp/Config.in
Original file line number Diff line number Diff line change
Expand Up @@ -142,6 +142,14 @@ config BUSYBOX_CONFIG_FEATURE_UDHCPC6_RFC5970
comment "Common options for DHCP applets"
depends on BUSYBOX_CONFIG_UDHCPD || BUSYBOX_CONFIG_UDHCPC || BUSYBOX_CONFIG_UDHCPC6 || BUSYBOX_CONFIG_DHCPRELAY

config BUSYBOX_CONFIG_UDHCPC_DEFAULT_INTERFACE
string "Default interface name"
default BUSYBOX_DEFAULT_UDHCPC_DEFAULT_INTERFACE
depends on BUSYBOX_CONFIG_UDHCPC || BUSYBOX_CONFIG_UDHCPC6
help
The interface that will be used if no other interface is
specified on the commandline.

config BUSYBOX_CONFIG_FEATURE_UDHCP_PORT
bool "Enable '-P port' option for udhcpd and udhcpc"
default BUSYBOX_DEFAULT_FEATURE_UDHCP_PORT
Expand Down
10 changes: 5 additions & 5 deletions package/utils/busybox/config/shell/Config.in
Original file line number Diff line number Diff line change
Expand Up @@ -299,18 +299,18 @@ config BUSYBOX_CONFIG_HUSH_BRACE_EXPANSION
help
Enable {abc,def} extension.

config BUSYBOX_CONFIG_HUSH_LINENO_VAR
bool "$LINENO variable"
default BUSYBOX_DEFAULT_HUSH_LINENO_VAR
depends on BUSYBOX_CONFIG_HUSH_BASH_COMPAT

config BUSYBOX_CONFIG_HUSH_BASH_SOURCE_CURDIR
bool "'source' and '.' builtins search current directory after $PATH"
default BUSYBOX_DEFAULT_HUSH_BASH_SOURCE_CURDIR # do not encourage non-standard behavior
depends on BUSYBOX_CONFIG_HUSH_BASH_COMPAT
help
This is not compliant with standards. Avoid if possible.

config BUSYBOX_CONFIG_HUSH_LINENO_VAR
bool "$LINENO variable (bashism)"
default BUSYBOX_DEFAULT_HUSH_LINENO_VAR
depends on BUSYBOX_CONFIG_SHELL_HUSH

config BUSYBOX_CONFIG_HUSH_INTERACTIVE
bool "Interactive mode"
default BUSYBOX_DEFAULT_HUSH_INTERACTIVE
Expand Down
Original file line number Diff line number Diff line change
@@ -0,0 +1,37 @@
From 00adcdb64a5487f0ea6b400d912dcf7c58637696 Mon Sep 17 00:00:00 2001
From: Denys Vlasenko <[email protected]>
Date: Fri, 20 Aug 2021 13:33:50 +0200
Subject: udhcp: fix build breakage on MIPS

Signed-off-by: Denys Vlasenko <[email protected]>
---
networking/udhcp/common.h | 12 ------------
1 file changed, 12 deletions(-)

diff --git a/networking/udhcp/common.h b/networking/udhcp/common.h
index 8c678dd32..ca778dab8 100644
--- a/networking/udhcp/common.h
+++ b/networking/udhcp/common.h
@@ -304,18 +304,6 @@ void udhcp_dump_packet(struct dhcp_packet *packet) FAST_FUNC;
# define log3s(msg) ((void)0)
#endif

-#if defined(__mips__)
-/*
- * The 'simple' message functions have a negative impact on the size of the
- * DHCP code when compiled for MIPS, so don't use them in this case.
- */
-#define bb_simple_info_msg bb_info_msg
-#define bb_simple_error_msg bb_error_msg
-#define bb_simple_perror_msg_and_die bb_perror_msg_and_die
-#undef log1s
-#define log1s log1
-#endif
-
/*** Other shared functions ***/

/* 2nd param is "uint32_t*" */
--
cgit v1.2.3


Loading

0 comments on commit b6cbbbb

Please sign in to comment.