forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-portage/java-ebuilder: bump to 0.2 to support gatk.
Package-Manager: portage-2.3.3
- Loading branch information
Showing
2 changed files
with
66 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST java-ebuilder-0.1.tar.gz 22291 SHA256 0c4dd0f76c0b36c7d736ed2f02ed06244ef7645be45bf7ca83ed27aaafe8787e SHA512 bc058b03da53bab03d7a48b2971f34da812bfd03aff7cc64ee4a3209245f4855bf8095d12c5c506f49b896db69fba09f06814f4c35e13a25c4e8f381d6416637 WHIRLPOOL 9ccacb782eedd8e56a5508f1379098579cd12bd86dac727df4577e218c295fa908cbcab49772934508e3f302607d5f075373948bfec93d214ad08b001b600b4f | ||
DIST java-ebuilder-0.2.tar.gz 22998 SHA256 849e09768daf9bad42373e743fd851e0302caa90dbda8166e2c67f618433128b SHA512 c76b15d4a81413e05359202c7b73b84baa3b277faddb7aa5f904290e5e47ed2bc6d80638c7b5417acc4224d067e4f48f1687972b7e36c363da8e9a89ea7f2766 WHIRLPOOL 85a41a31f2567c488f05930616082bfe75c0975cef3c5ba476eb8152dacd8e437b5bf8cf330ed66bb3332408bb0f0ec37ab53550b3f07a05be6d66210f031643 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,65 @@ | ||
# Copyright 2016-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI="6" | ||
|
||
if [[ ${PV} == 9999 ]]; then | ||
ECLASS="git-r3" | ||
EGIT_REPO_URI="https://github.com/heroxbd/${PN}.git" | ||
else | ||
SRC_URI="https://github.com/gentoo/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz" | ||
KEYWORDS="~amd64" | ||
fi | ||
|
||
inherit java-pkg-2 java-pkg-simple prefix ${ECLASS} | ||
|
||
DESCRIPTION="Java team tool for semi-automatic creation of ebuilds from pom.xml" | ||
HOMEPAGE="https://github.com/gentoo/java-ebuilder" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
|
||
DEPEND=">=virtual/jdk-1.8" | ||
RDEPEND=">=virtual/jre-1.8 | ||
sys-process/parallel | ||
>=dev-java/maven-bin-3" | ||
|
||
S="${WORKDIR}/${P}" | ||
|
||
JAVA_SRC_DIR="src/main/java" | ||
JAVA_ADDRES_DIRS="src/main/resources" | ||
|
||
MAIN_CLASS="org.gentoo.java.ebuilder.Main" | ||
|
||
java_prepare() { | ||
eapply_user | ||
local base_dir="target/classes/" | ||
[[ ! -d "${base_dir}" ]] &&mkdir -p "${base_dir}META-INF" | ||
echo "Manifest-Version: 1.0 | ||
Main-Class: ${MAIN_CLASS}" \ | ||
>> "${base_dir}META-INF/MANIFEST.MF" | ||
} | ||
|
||
src_prepare() { | ||
eapply_user | ||
hprefixify scripts/{{tree,meta}.sh,movl} java-ebuilder.conf | ||
} | ||
|
||
src_install() { | ||
java-pkg-simple_src_install | ||
java-pkg_dolauncher ${PN} --main ${MAIN_CLASS} | ||
|
||
insinto /var/lib/${PN} | ||
doins -r maven | ||
dodir /var/lib/${PN}/{poms,cache} | ||
|
||
dodoc README maven.conf | ||
|
||
exeinto /usr/lib/${PN} | ||
doexe scripts/{tree,meta}.sh | ||
|
||
dobin scripts/movl | ||
|
||
insinto /etc | ||
doins java-ebuilder.conf | ||
} |