forked from openwrt/packages
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Signed-off-by: Lucian Cristian <[email protected]>
- Loading branch information
Showing
13 changed files
with
28 additions
and
3,013 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -7,16 +7,16 @@ | |
|
||
include $(TOPDIR)/rules.mk | ||
PKG_NAME:=frr | ||
PKG_VERSION:=7.5.1 | ||
PKG_RELEASE:=2 | ||
PKG_SOURCE_DATE:=2021-08-26 | ||
PKG_VERSION:=8.1.0 | ||
PKG_RELEASE:=1 | ||
PKG_SOURCE_DATE:=2021-11-12 | ||
|
||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_SOURCE_DATE).tar.gz | ||
PKG_SOURCE_VERSION:=4cc14d346bdedc81a52b2981f9f568176513dc3e | ||
PKG_SOURCE_VERSION:=c18235d5b1e33fad9d3181aa29fefa48b8c6ff3f | ||
PKG_SOURCE_URL:=https://codeload.github.com/FRRouting/frr/tar.gz/$(PKG_SOURCE_VERSION)? | ||
|
||
|
||
PKG_HASH:=dd0ec4616b85f5142c9e4ecc4a17b944000a3219bedf9d091484503e8c91e0e7 | ||
PKG_HASH:=95922586d6c39565b3eec362563e031fd4cb2b6d6c0012256e345b364de1ae82 | ||
PKG_MAINTAINER:=Lucian Cristian <[email protected]> | ||
|
||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_SOURCE_VERSION) | ||
|
@@ -35,6 +35,7 @@ PKG_DAEMON_AVAILABLE:= \ | |
nhrpd \ | ||
ospfd \ | ||
ospf6d \ | ||
pathd \ | ||
pbrd \ | ||
pimd \ | ||
ripd \ | ||
|
@@ -59,7 +60,7 @@ PKG_BUILD_PARALLEL:=1 | |
PKG_INSTALL:=1 | ||
|
||
PKG_BUILD_DEPENDS:=frr/host | ||
HOST_BUILD_DEPENDS:=python3/host | ||
HOST_BUILD_DEPENDS:=python3/host elfutils/host | ||
|
||
include $(INCLUDE_DIR)/package.mk | ||
include $(INCLUDE_DIR)/host-build.mk | ||
|
@@ -144,6 +145,8 @@ define BuildDaemon | |
TITLE:= $(1) routing engine | ||
DEPENDS+=frr-libfrr $(2) | ||
endef | ||
# if [ "$(1)" == "bfdd" ]; then \ | ||
# export HAVE_BFDD == 1 ; fi | ||
|
||
define Package/frr-$(1)/install | ||
$(INSTALL_DIR) $$(1)/usr/sbin | ||
|
@@ -170,7 +173,7 @@ define Host/Configure | |
$(SED) 's/$$$$(MAKE) $$$$(AM_MAKEFLAGS) install-am/# $$$$(MAKE) $$$$(AM_MAKEFLAGS) install-am/' $(HOST_BUILD_DIR)/Makefile.in | ||
endef | ||
|
||
#HOST_CPPFLAGS += -I$(STAGING_DIR_HOST)/include/libelf | ||
HOST_CPPFLAGS += -I$(STAGING_DIR_HOST)/include/libelf | ||
HOST_CONFIGURE_ARGS+= \ | ||
--enable-clippy-only | ||
|
||
|
@@ -184,7 +187,6 @@ CONFIGURE_ARGS+= \ | |
--prefix=/usr \ | ||
--enable-shared \ | ||
--disable-static \ | ||
--disable-pathd \ | ||
--enable-user=network \ | ||
--enable-group=network \ | ||
--disable-ospfclient \ | ||
|
@@ -224,6 +226,7 @@ define Package/frr-libfrr/install | |
$(INSTALL_CONF) ./files/{frr.conf,daemons} $(1)/etc/frr/ | ||
endef | ||
|
||
|
||
define Package/frr-pythontools/install | ||
$(INSTALL_DIR) $(1)/usr/lib/frr $(1)/usr/sbin $(1)/etc/frr | ||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/*.py $(1)/usr/lib/frr/ | ||
|
@@ -254,6 +257,7 @@ $(eval $(call BuildDaemon,ldpd,)) | |
$(eval $(call BuildDaemon,nhrpd,+libcares)) | ||
$(eval $(call BuildDaemon,ospfd,)) | ||
$(eval $(call BuildDaemon,ospf6d,@IPV6)) | ||
$(eval $(call BuildDaemon,pathd,)) | ||
$(eval $(call BuildDaemon,pbrd,)) | ||
$(eval $(call BuildDaemon,pimd,)) | ||
$(eval $(call BuildDaemon,ripd,)) | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -13,6 +13,7 @@ nhrpd=no | |
eigrpd=no | ||
babeld=no | ||
sharpd=no | ||
pathd=no | ||
pbrd=no | ||
bfdd=no | ||
fabricd=no | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Oops, something went wrong.