Skip to content

Commit

Permalink
kernel: bump 5.4 to 5.4.161
Browse files Browse the repository at this point in the history
Removed upstreamed:
    ath79/patches-5.4/921-serial-core-add-support-for-boot-console-with-arbitr.patch[1]

Manually rebased:
    layerscape/patches-5.4/804-crypto-0016-MLKU-114-1-crypto-caam-reduce-page-0-regs-access-to-.patch
    octeontx/patches-5.4/0004-PCI-add-quirk-for-Gateworks-PLX-PEX860x-switch-with-.patch

All other patches automatically rebased.

1. Private email exchange with patch author, Hauke Mehrtens

Signed-off-by: John Audia <[email protected]>
  • Loading branch information
graysky2 authored and hauke committed Nov 28, 2021
1 parent 26a7a38 commit bbdc13b
Show file tree
Hide file tree
Showing 31 changed files with 66 additions and 120 deletions.
4 changes: 2 additions & 2 deletions include/kernel-version.mk
Original file line number Diff line number Diff line change
Expand Up @@ -6,10 +6,10 @@ ifdef CONFIG_TESTING_KERNEL
KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
endif

LINUX_VERSION-5.4 = .159
LINUX_VERSION-5.4 = .161
LINUX_VERSION-5.10 = .82

LINUX_KERNEL_HASH-5.4.159 = d718325f4eab325dce4f82b88418f68ba130864118229539541331e0a4478643
LINUX_KERNEL_HASH-5.4.161 = 3149c6b52a3079218a60bd369a80d18275b574d84908ffee32a0a8f9ddf939a7
LINUX_KERNEL_HASH-5.10.82 = d66f7c7eed02f84ae550b3c91a26c70eea13682a6d672432f07bce66ff8ce350

remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -48,7 +48,7 @@ Signed-off-by: Vinod Koul <[email protected]>

#include "xhci.h"
#include "xhci-trace.h"
@@ -65,6 +67,44 @@
@@ -72,6 +74,44 @@
#define PCI_DEVICE_ID_ASMEDIA_2142_XHCI 0x2142
#define PCI_DEVICE_ID_ASMEDIA_3242_XHCI 0x3242

Expand Down Expand Up @@ -93,7 +93,7 @@ Signed-off-by: Vinod Koul <[email protected]>
static const char hcd_name[] = "xhci_hcd";

static struct hc_driver __read_mostly xhci_pci_hc_driver;
@@ -311,6 +351,873 @@ static void xhci_pme_acpi_rtd3_enable(st
@@ -327,6 +367,873 @@ static void xhci_pme_acpi_rtd3_enable(st
static void xhci_pme_acpi_rtd3_enable(struct pci_dev *dev) { }
#endif /* CONFIG_ACPI */

Expand Down Expand Up @@ -967,7 +967,7 @@ Signed-off-by: Vinod Koul <[email protected]>
/* called during probe() after chip reset completes */
static int xhci_pci_setup(struct usb_hcd *hcd)
{
@@ -352,6 +1259,27 @@ static int xhci_pci_probe(struct pci_dev
@@ -368,6 +1275,27 @@ static int xhci_pci_probe(struct pci_dev
struct hc_driver *driver;
struct usb_hcd *hcd;

Expand Down Expand Up @@ -995,7 +995,7 @@ Signed-off-by: Vinod Koul <[email protected]>
driver = (struct hc_driver *)id->driver_data;

/* Prevent runtime suspending between USB-2 and USB-3 initialization */
@@ -413,6 +1341,16 @@ static void xhci_pci_remove(struct pci_d
@@ -429,6 +1357,16 @@ static void xhci_pci_remove(struct pci_d
{
struct xhci_hcd *xhci;

Expand All @@ -1012,7 +1012,7 @@ Signed-off-by: Vinod Koul <[email protected]>
xhci = hcd_to_xhci(pci_get_drvdata(dev));
xhci->xhc_state |= XHCI_STATE_REMOVING;

@@ -552,6 +1490,11 @@ static int xhci_pci_resume(struct usb_hc
@@ -568,6 +1506,11 @@ static int xhci_pci_resume(struct usb_hc
if (pdev->vendor == PCI_VENDOR_ID_INTEL)
usb_enable_intel_xhci_ports(pdev);

Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -13,7 +13,7 @@ produce a noisy warning.

--- a/drivers/usb/host/xhci-pci.c
+++ b/drivers/usb/host/xhci-pci.c
@@ -290,6 +290,7 @@ static void xhci_pci_quirks(struct devic
@@ -297,6 +297,7 @@ static void xhci_pci_quirks(struct devic
pdev->device == 0x0015) {
xhci->quirks |= XHCI_RESET_ON_RESUME;
xhci->quirks |= XHCI_ZERO_64B_REGS;
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -754,7 +754,7 @@
ptr = ip6hoff + sizeof(struct ipv6hdr);
--- a/include/net/neighbour.h
+++ b/include/net/neighbour.h
@@ -274,8 +274,10 @@ static inline bool neigh_key_eq128(const
@@ -275,8 +275,10 @@ static inline bool neigh_key_eq128(const
const u32 *n32 = (const u32 *)n->primary_key;
const u32 *p32 = pkey;

Expand Down

This file was deleted.

Original file line number Diff line number Diff line change
Expand Up @@ -66,7 +66,7 @@ Signed-off-by: David S. Miller <[email protected]>

--- a/net/core/dev.c
+++ b/net/core/dev.c
@@ -5429,8 +5429,7 @@ static inline void skb_gro_reset_offset(
@@ -5432,8 +5432,7 @@ static inline void skb_gro_reset_offset(
NAPI_GRO_CB(skb)->frag0 = NULL;
NAPI_GRO_CB(skb)->frag0_len = 0;

Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -1385,15 +1385,15 @@ Signed-off-by: David S. Miller <[email protected]>
if (ret)
--- a/drivers/net/ethernet/ti/davinci_emac.c
+++ b/drivers/net/ethernet/ti/davinci_emac.c
@@ -1685,7 +1685,6 @@ davinci_emac_of_get_pdata(struct platfor
@@ -1697,7 +1697,6 @@ davinci_emac_of_get_pdata(struct platfor
const struct of_device_id *match;
const struct emac_platform_data *auxdata;
struct emac_platform_data *pdata = NULL;
- const u8 *mac_addr;

if (!IS_ENABLED(CONFIG_OF) || !pdev->dev.of_node)
return dev_get_platdata(&pdev->dev);
@@ -1697,11 +1696,8 @@ davinci_emac_of_get_pdata(struct platfor
@@ -1709,11 +1708,8 @@ davinci_emac_of_get_pdata(struct platfor
np = pdev->dev.of_node;
pdata->version = EMAC_VERSION_2;

Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -14,7 +14,7 @@ Signed-off-by: Felix Fietkau <[email protected]>

--- a/include/net/sch_generic.h
+++ b/include/net/sch_generic.h
@@ -615,12 +615,13 @@ extern struct Qdisc_ops noop_qdisc_ops;
@@ -617,12 +617,13 @@ extern struct Qdisc_ops noop_qdisc_ops;
extern struct Qdisc_ops pfifo_fast_ops;
extern struct Qdisc_ops mq_qdisc_ops;
extern struct Qdisc_ops noqueue_qdisc_ops;
Expand Down
2 changes: 1 addition & 1 deletion target/linux/generic/hack-5.4/721-phy_packets.patch
Original file line number Diff line number Diff line change
Expand Up @@ -101,7 +101,7 @@ Signed-off-by: Felix Fietkau <[email protected]>
help
--- a/net/core/dev.c
+++ b/net/core/dev.c
@@ -3198,10 +3198,20 @@ static int xmit_one(struct sk_buff *skb,
@@ -3200,10 +3200,20 @@ static int xmit_one(struct sk_buff *skb,
if (dev_nit_active(dev))
dev_queue_xmit_nit(skb, dev);

Expand Down
2 changes: 1 addition & 1 deletion target/linux/generic/hack-5.4/904-debloat_dma_buf.patch
Original file line number Diff line number Diff line change
Expand Up @@ -45,7 +45,7 @@ Signed-off-by: Felix Fietkau <[email protected]>
selftest.o \
--- a/drivers/dma-buf/dma-buf.c
+++ b/drivers/dma-buf/dma-buf.c
@@ -1313,4 +1313,5 @@ static void __exit dma_buf_deinit(void)
@@ -1314,4 +1314,5 @@ static void __exit dma_buf_deinit(void)
dma_buf_uninit_debugfs();
kern_unmount(dma_buf_mnt);
}
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -25,7 +25,7 @@ Signed-off-by: Jason A. Donenfeld <[email protected]>

--- a/arch/mips/Kconfig
+++ b/arch/mips/Kconfig
@@ -2039,7 +2039,8 @@ config CPU_MIPS32
@@ -2040,7 +2040,8 @@ config CPU_MIPS32

config CPU_MIPS64
bool
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -19,7 +19,7 @@ Acked-by: Rob Landley <[email protected]>
config CEVT_BCM1480
bool

@@ -3046,6 +3043,18 @@ choice
@@ -3047,6 +3044,18 @@ choice
bool "Extend builtin kernel arguments with bootloader arguments"
endchoice

Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -32,7 +32,7 @@ Signed-off-by: Felix Fietkau <[email protected]>
__u16 tc_index; /* traffic control index */
--- a/net/core/dev.c
+++ b/net/core/dev.c
@@ -5495,6 +5495,9 @@ static enum gro_result dev_gro_receive(s
@@ -5498,6 +5498,9 @@ static enum gro_result dev_gro_receive(s
int same_flow;
int grow;

Expand All @@ -42,7 +42,7 @@ Signed-off-by: Felix Fietkau <[email protected]>
if (netif_elide_gro(skb->dev))
goto normal;

@@ -7297,6 +7300,48 @@ static void __netdev_adjacent_dev_unlink
@@ -7300,6 +7303,48 @@ static void __netdev_adjacent_dev_unlink
&upper_dev->adj_list.lower);
}

Expand Down Expand Up @@ -91,23 +91,23 @@ Signed-off-by: Felix Fietkau <[email protected]>
static int __netdev_upper_dev_link(struct net_device *dev,
struct net_device *upper_dev, bool master,
void *upper_priv, void *upper_info,
@@ -7347,6 +7392,7 @@ static int __netdev_upper_dev_link(struc
@@ -7350,6 +7395,7 @@ static int __netdev_upper_dev_link(struc
if (ret)
return ret;

+ netdev_update_addr_mask(dev);
ret = call_netdevice_notifiers_info(NETDEV_CHANGEUPPER,
&changeupper_info.info);
ret = notifier_to_errno(ret);
@@ -7440,6 +7486,7 @@ void netdev_upper_dev_unlink(struct net_
@@ -7443,6 +7489,7 @@ void netdev_upper_dev_unlink(struct net_

__netdev_adjacent_dev_unlink_neighbour(dev, upper_dev);

+ netdev_update_addr_mask(dev);
call_netdevice_notifiers_info(NETDEV_CHANGEUPPER,
&changeupper_info.info);

@@ -8170,6 +8217,7 @@ int dev_set_mac_address(struct net_devic
@@ -8173,6 +8220,7 @@ int dev_set_mac_address(struct net_devic
if (err)
return err;
dev->addr_assign_type = NET_ADDR_SET;
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -95,7 +95,7 @@ Signed-off-by: Felix Fietkau <[email protected]>

static int netif_rx_internal(struct sk_buff *skb);
static int call_netdevice_notifiers_info(unsigned long val,
@@ -5937,6 +5938,11 @@ void __napi_schedule(struct napi_struct
@@ -5940,6 +5941,11 @@ void __napi_schedule(struct napi_struct
{
unsigned long flags;

Expand All @@ -107,7 +107,7 @@ Signed-off-by: Felix Fietkau <[email protected]>
local_irq_save(flags);
____napi_schedule(this_cpu_ptr(&softnet_data), n);
local_irq_restore(flags);
@@ -5988,6 +5994,10 @@ EXPORT_SYMBOL(napi_schedule_prep);
@@ -5991,6 +5997,10 @@ EXPORT_SYMBOL(napi_schedule_prep);
*/
void __napi_schedule_irqoff(struct napi_struct *n)
{
Expand All @@ -118,7 +118,7 @@ Signed-off-by: Felix Fietkau <[email protected]>
if (!IS_ENABLED(CONFIG_PREEMPT_RT))
____napi_schedule(this_cpu_ptr(&softnet_data), n);
else
@@ -6252,9 +6262,89 @@ static void init_gro_hash(struct napi_st
@@ -6255,9 +6265,89 @@ static void init_gro_hash(struct napi_st
napi->gro_bitmask = 0;
}

Expand Down Expand Up @@ -208,23 +208,23 @@ Signed-off-by: Felix Fietkau <[email protected]>
INIT_LIST_HEAD(&napi->poll_list);
hrtimer_init(&napi->timer, CLOCK_MONOTONIC, HRTIMER_MODE_REL_PINNED);
napi->timer.function = napi_watchdog;
@@ -6271,6 +6361,7 @@ void netif_napi_add(struct net_device *d
@@ -6274,6 +6364,7 @@ void netif_napi_add(struct net_device *d
#ifdef CONFIG_NETPOLL
napi->poll_owner = -1;
#endif
+ INIT_WORK(&napi->work, napi_workfn);
set_bit(NAPI_STATE_SCHED, &napi->state);
set_bit(NAPI_STATE_NPSVC, &napi->state);
list_add_rcu(&napi->dev_list, &dev->napi_list);
@@ -6311,6 +6402,7 @@ static void flush_gro_hash(struct napi_s
@@ -6314,6 +6405,7 @@ static void flush_gro_hash(struct napi_s
void netif_napi_del(struct napi_struct *napi)
{
might_sleep();
+ cancel_work_sync(&napi->work);
if (napi_hash_del(napi))
synchronize_net();
list_del_init(&napi->dev_list);
@@ -6323,50 +6415,18 @@ EXPORT_SYMBOL(netif_napi_del);
@@ -6326,50 +6418,18 @@ EXPORT_SYMBOL(netif_napi_del);

static int napi_poll(struct napi_struct *n, struct list_head *repoll)
{
Expand Down Expand Up @@ -279,7 +279,7 @@ Signed-off-by: Felix Fietkau <[email protected]>

/* Some drivers may have called napi_schedule
* prior to exhausting their budget.
@@ -10346,6 +10406,10 @@ static int __init net_dev_init(void)
@@ -10349,6 +10409,10 @@ static int __init net_dev_init(void)
sd->backlog.weight = weight_p;
}

Expand All @@ -292,7 +292,7 @@ Signed-off-by: Felix Fietkau <[email protected]>
/* The loopback device is special if any other network devices
--- a/net/core/net-sysfs.c
+++ b/net/core/net-sysfs.c
@@ -442,6 +442,52 @@ static ssize_t proto_down_store(struct d
@@ -470,6 +470,52 @@ static ssize_t proto_down_store(struct d
}
NETDEVICE_SHOW_RW(proto_down, fmt_dec);

Expand Down Expand Up @@ -345,7 +345,7 @@ Signed-off-by: Felix Fietkau <[email protected]>
static ssize_t phys_port_id_show(struct device *dev,
struct device_attribute *attr, char *buf)
{
@@ -532,6 +578,7 @@ static struct attribute *net_class_attrs
@@ -581,6 +627,7 @@ static struct attribute *net_class_attrs
&dev_attr_flags.attr,
&dev_attr_tx_queue_len.attr,
&dev_attr_gro_flush_timeout.attr,
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -13,7 +13,7 @@ Reviewed-by: Stuart Yoder <[email protected]>

--- a/arch/arm64/include/asm/pgtable.h
+++ b/arch/arm64/include/asm/pgtable.h
@@ -422,6 +422,9 @@ static inline pmd_t pmd_mkdevmap(pmd_t p
@@ -428,6 +428,9 @@ static inline pmd_t pmd_mkdevmap(pmd_t p
__pgprot_modify(prot, PTE_ATTRINDX_MASK, PTE_ATTRINDX(MT_DEVICE_nGnRnE) | PTE_PXN | PTE_UXN)
#define pgprot_writecombine(prot) \
__pgprot_modify(prot, PTE_ATTRINDX_MASK, PTE_ATTRINDX(MT_NORMAL_NC) | PTE_PXN | PTE_UXN)
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -11,7 +11,7 @@ Signed-off-by: Haiying Wang <[email protected]>

--- a/arch/arm64/include/asm/pgtable.h
+++ b/arch/arm64/include/asm/pgtable.h
@@ -425,6 +425,8 @@ static inline pmd_t pmd_mkdevmap(pmd_t p
@@ -431,6 +431,8 @@ static inline pmd_t pmd_mkdevmap(pmd_t p
#define pgprot_cached(prot) \
__pgprot_modify(prot, PTE_ATTRINDX_MASK, PTE_ATTRINDX(MT_NORMAL) | \
PTE_PXN | PTE_UXN)
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -87,15 +87,15 @@ Signed-off-by: Li Yang <[email protected]>
}

/**
@@ -3873,6 +3889,7 @@ static int cgroup_add_file(struct cgroup
@@ -3896,6 +3912,7 @@ static int cgroup_add_file(struct cgroup
{
char name[CGROUP_FILE_NAME_MAX];
struct kernfs_node *kn;
+ struct kernfs_node *kn_link;
struct lock_class_key *key = NULL;
int ret;

@@ -3903,6 +3920,14 @@ static int cgroup_add_file(struct cgroup
@@ -3926,6 +3943,14 @@ static int cgroup_add_file(struct cgroup
spin_unlock_irq(&cgroup_file_kn_lock);
}

Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -89,15 +89,15 @@ Signed-off-by: Li Yang <[email protected]>
}

/**
@@ -3889,7 +3873,6 @@ static int cgroup_add_file(struct cgroup
@@ -3912,7 +3896,6 @@ static int cgroup_add_file(struct cgroup
{
char name[CGROUP_FILE_NAME_MAX];
struct kernfs_node *kn;
- struct kernfs_node *kn_link;
struct lock_class_key *key = NULL;
int ret;

@@ -3920,14 +3903,6 @@ static int cgroup_add_file(struct cgroup
@@ -3943,14 +3926,6 @@ static int cgroup_add_file(struct cgroup
spin_unlock_irq(&cgroup_file_kn_lock);
}

Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -51,7 +51,7 @@ Signed-off-by: Horia Geantă <[email protected]>
static int caam_get_era_from_hw(struct caam_ctrl __iomem *ctrl)
--- a/drivers/crypto/caam/regs.h
+++ b/drivers/crypto/caam/regs.h
@@ -492,7 +492,8 @@ struct rngtst {
@@ -495,7 +495,8 @@ struct rngtst {

/* RNG4 TRNG test registers */
struct rng4tst {
Expand Down
Loading

0 comments on commit bbdc13b

Please sign in to comment.