Skip to content

Commit

Permalink
Don't order pointer, but check the value intended instead. Bump
Browse files Browse the repository at this point in the history
revision.
  • Loading branch information
jsonn committed Feb 8, 2017
1 parent fc83408 commit de19d19
Show file tree
Hide file tree
Showing 3 changed files with 19 additions and 3 deletions.
4 changes: 2 additions & 2 deletions geography/opencpn-plugin-weather_routing/Makefile
Original file line number Diff line number Diff line change
@@ -1,10 +1,10 @@
# $NetBSD: Makefile,v 1.8 2017/02/06 13:55:24 wiz Exp $
# $NetBSD: Makefile,v 1.9 2017/02/08 00:05:55 joerg Exp $
#

VERSION= 20160716
DISTNAME= weather_routing_pi-${VERSION}
PKGNAME= opencpn-plugin-weather_routing-${VERSION}
PKGREVISION= 2
PKGREVISION= 3
CATEGORIES= geography
MASTER_SITES= ${MASTER_SITE_GITHUB:=seandepagnier/}
GITHUB_PROJECT= weather_routing_pi
Expand Down
3 changes: 2 additions & 1 deletion geography/opencpn-plugin-weather_routing/distinfo
Original file line number Diff line number Diff line change
@@ -1,8 +1,9 @@
$NetBSD: distinfo,v 1.6 2016/07/18 14:23:46 bouyer Exp $
$NetBSD: distinfo,v 1.7 2017/02/08 00:05:55 joerg Exp $

SHA1 (weather_routing_pi-20160716-7a016521e0a1e1ca4e97016dad8d0d16f09da912.tar.gz) = 131045d458326c9febd21605cf784f247bc1e848
RMD160 (weather_routing_pi-20160716-7a016521e0a1e1ca4e97016dad8d0d16f09da912.tar.gz) = c8d0cf451091047ae155e0e7ce08ae47329d09a8
SHA512 (weather_routing_pi-20160716-7a016521e0a1e1ca4e97016dad8d0d16f09da912.tar.gz) = 18ffb602f57f92b41fb152a34a8552e1c2a877eea70228c84602b79bc37809b2152e45afafad054f97b84d9d1c338f3ea92b39fc26eedc392babcd1ee3985b30
Size (weather_routing_pi-20160716-7a016521e0a1e1ca4e97016dad8d0d16f09da912.tar.gz) = 846632 bytes
SHA1 (patch-cmake_PluginConfigure.cmake) = e2873cbba3d776227d72b8538634f687dc04c439
SHA1 (patch-src_Polar.cpp) = fa7af26e0dcba1dda3ae358c35353c6304d4f941
SHA1 (patch-src_RouteMap.cpp) = a733a901f04eeb1699805e590325c0485ce26d1b
Original file line number Diff line number Diff line change
@@ -0,0 +1,15 @@
$NetBSD: patch-src_Polar.cpp,v 1.1 2017/02/08 00:05:55 joerg Exp $

Pointers are not relative to 0, so check correct variable.

--- src/Polar.cpp.orig 2017-01-08 19:55:10.199446917 +0000
+++ src/Polar.cpp
@@ -180,7 +180,7 @@ Polar::Polar()

#define MAX_WINDSPEEDS_IN_TABLE 200
#define MESSAGE(S) (S + wxString(_T("\n")) + wxString::FromUTF8(filename) \
- + (line > 0 ? (_(" line ") + wxString::Format(_T("%d"), linenum)) : _T("")))
+ + (linenum > 0 ? (_(" line ") + wxString::Format(_T("%d"), linenum)) : _T("")))
#define PARSE_WARNING(S) do { if(message.empty()) message = MESSAGE(S); } while (0)
#define PARSE_ERROR(S) if(message.empty()) do { message = _("Boat polar failed") + wxString(_T("\n")) \
+ MESSAGE(S); goto failed; } while (0)

0 comments on commit de19d19

Please sign in to comment.